QCAD Bugtracker

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category QCAD (main)
  • Assigned To
    Andrew
  • Operating System Windows (All)
  • Severity Low
  • Priority Very Low
  • Reported Version 3.26.4
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: QCAD Bugtracker
Opened by Tomas Novak - 10.06.2021
Last edited by Andrew - 10.06.2021

FS#2249 - Can not open this file in 3.26.4, but in 3.22.0.5 I can

This file is produces by .js script which some QCad user wrote for me. The script produce many dxf files which are ok, but this one can not be loaded to 3.26.4. (3.22.0.5 is fine)

Closed by  Andrew
10.06.2021 11:24
Reason for closing:  Not a bug
Admin
Andrew commented on 10.06.2021 11:23

The file is not strictly valid DXF.

However, you can import it using dxflib which is more tolerant than the OpenDesign libraries:
- File > Open
- Choose "Filter: DXF Files [dxflib] (*.dxf)"

Tomas Novak commented on 11.06.2021 06:33

Ok, I understand. But I use qcad bbox tool to get dxf size which fails to load the drawing.
I guess there is something wrong in these script files. I have a drawing edited and saved in 3.26.4, then I use create_blocks.js to create blocks from entities in rectangles and then I use export_blocks.js to create individual dxf files from blocks. With 3.22.0.5 it works fine and with 3.26.4 some exported blocks can not be opened. Would it be possible to review those scripts for some donation?

Admin
Andrew commented on 11.06.2021 06:37

Please move this discussion over to our user forum at:
https://www.qcad.org/rsforum/viewforum.php?f=30

Please provide all relevant files (DXF).

Thanks.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing