QCAD Bugtracker

  • Status Closed
  • Percent Complete
  • Task Type Bug Report
  • Category QCAD (main)
  • Assigned To
  • Operating System Windows 7
  • Severity Medium
  • Priority Very Low
  • Reported Version 3 RC1
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: QCAD Bugtracker
Opened by Ralf Braumann - 09.11.2011
Last edited by Andrew - 14.11.2011

FS#380 - Destroying cross-hatch

By saving a drawing QCAD is destroying the cross-hatches

Closed by  Andrew
14.11.2011 11:02
Reason for closing:  Fixed
Additional comments about closing:  


Andrew commented on 09.11.2011 18:27

- What hatch pattern do you use?
- Do you create the drawing in QCAD or load an existing drawing (in the latter case, please attach or send by e-mail to [email protected])
- Please make sure you are not in draft mode in which hatches are not displayed (View - Draft Mode)

Lothar Marzahn commented on 10.11.2011 15:01

It's the same for MAC Lion, Solid fill is not stored or reloaded

Andrew commented on 10.11.2011 15:24

Lothar Marzahn:
I cannot reproduce the problem here.

Please send drawings for testing if possible.

Otherwise, please explain what shapes you are filling, i.e. how to reproduce the problem. Thanks.

Lothar Marzahn commented on 10.11.2011 21:47

A testfile with a filled rectangle containing a circle and some arcs and lines was stored and reloaded. It worked!! But at the attached file hatch failed but works in QCAD2.
Loading it from QCAD2 the hatch is shown, but store and reload in QCAD3 the hatch is gone.

   test2.dxf (261.8 KiB)
Andrew commented on 12.11.2011 09:36

The hatches in the file have no boundary.

Is the attached file the file you have already saved in QCAD 3?
Do you still have the original file? That would be more helpful, thanks.

Lothar Marzahn commented on 12.11.2011 17:42

I send a set of files. "LM2-test1" is a file created and modified by QCAD2. "LM3-test1" is the same file only viewed by QCAD3 and will so far show the same picture. But if You save it with QCAD3 the hatch is away and even QCAD2 will not find it.
"LM-test2" is a file that works regardless of the QCAD-version! I hope it will help.

Lothar Marzahn commented on 13.11.2011 20:25

I send one more file. For the time being the problem seems to be related to arcs because simple boxes and circles don't create problems. The shape in the attached file worked fine from the beginning with arcs rotating in the same direction. First when I entered the arcs in the red circled region the hatch was no longer stored. In order to verify this I went back to the previos shape. But from this moment already one arc caused the problem! May be, there is also something stored witch is confusing the program.

Andrew commented on 14.11.2011 10:59

Thanks. The problem has been identified (wrong angles with reversed arcs) and fixed for the next release.


Available keyboard shortcuts


Task Details

Task Editing