QCAD Bugtracker

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category QCAD (main)
  • Assigned To
    Andrew
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version 3.3.3
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: QCAD Bugtracker
Opened by Nomen Nescio - 11.10.2013
Last edited by Andrew - 11.10.2013

FS#939 - block hierarchy

The block hierarchy is lost after saving. Only one item appears in the block after reload, and it is doubled outside, too.

attached file:

Tried to put the four patches and the bar in a “Pzeile” block, this works, but after save and open, only the bar is in the block and is doubled to layer “0”.

The attached file is the destroyed version with removed doublette.

   lj3.dxf (18.9 KiB)
Closed by  Andrew
11.10.2013 23:48
Reason for closing:  Not a bug
Admin
Andrew commented on 11.10.2013 19:47

The block 'Pzeile' seems to be correct here as far as I can tell (a horizontal bar and four instances of 'Patch', see attached images).

In the model space, I noticed there are 5 block references, which is probably not intended: 1 block reference to block 'Pzeile' plus four individual block references to 'Patch', exactly on top of the four 'Patch' block references from block 'Pzeile'.

How are these screenshots different on your installation after loading the file? Thanks.

Admin
Andrew commented on 11.10.2013 20:00

Can you also please double-check your QCAD version and indicate what operating system you are on and if you are using QCAD Pro or the free QCAD Community Edition? Thanks.

Husky commented on 11.10.2013 23:34

Andrew - FYI:

QCAD Pro / XP32

After loading the file - recovering the file - and saving as R27 Format instead of R15 everything works as expected. Insert block (Pzeile) a couple times, saved,
closed, reloaded ..... no duplicates, nothing missing ............ just fine!

Nomen Nescio commented on 15.10.2013 16:27

I am using the self-compiled free version under linux.

This problem appears in qcad-3.3.3.0 but seems to be solved in qcad-3.3.4.0 :-)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing