All Projects

IDProjectCategoryTask TypeSeveritySummaryStatusOpened by
2271QCAD BugtrackerQCAD (main)Bug ReportHighUnpredictable Crashing on Mac M1 Arm64AssignedKeith Task Description

I am getting random crashing on my MacBook M1 chipset while using QCAD Pro. There is nothing in particular that you can do to replicate as the crashing is completely inconsistent. Have had it crash when pressing escape while using measurement tool, but have also had it crash while using the app and selecting a tool.

Included crash report, which has also been sent to Apple.

Thanks

693QCAD BugtrackerQCAD (main)Feature RequestMediumSupport for external references (XREF)Likely to be implemented26Andrew Task Description

Support for external references (XREF)

2272QCAD BugtrackerQCAD (main)Feature RequestLowSupport unit "US survey foot"AssignedAnđa Task Description

In the US, it is (unfortunately) still common to use US survey foot. It seems at least some DXF applications/libraries support this unit as a $INSUNITS value, some references:

There are two issues regarding this with QCAD:

  1. If you open a document with $INSUNITS being 21, it’s reset to 0 (unitless/unspecified) when saved again, even when not changing anything.
  2. It is not possible to select these units in the GUI.

I don’t know about standardization of these values, but my hope is that it’s at least possible to preserve the unit in an existing drawing. Given that this unit is supposed to be obsolete in some years, it might seem less important, but due to this transition, it might get even more important to be able to distinguish between units. Thanks!

2266QCAD BugtrackerQCAD (main)Bug ReportLowCrash while creating an angular dimensionAssignedSteve Green Task Description

no task description

2264QCAD BugtrackerQCAD (main)Bug ReportLowHatching segment selection stops at entity - hatch patt...AssignedCVH Task Description

QCAD Professional
Windows7 pro WinInstaller
Version: 3.26.4.5 (3.26.4.5)
Internet: QCAD.org
Build Date: Jul 20 2021
Revision: e596276
Qt Version: 5.13.2
Architecture: i386
Compiler: Unknown

In the example given by ‘turtle’ .. why_is_this_not_closed-v2.dxf
https://www.qcad.org/rsforum/viewtopic.php?f=32&p=34157#p34153

Selecting hatch boundary segments of the horizontal polyline segment at
(1169.933593;274.432562)-(1089.933593;274.432562)

Segment selection stops where the AR-CONC hatch pattern touches the horizontal segment.
Such intersections points where already no longer regarded as snappoints.
See :
 FS#2090 : https://www.qcad.org/bugtracker/index.php?do=details&task_id=2090.
Related topic https://www.qcad.org/rsforum/viewtopic.php?&t=7340&p=28414#p28414

Regards,
CVH

2252QCAD BugtrackerQCAD (main)Bug ReportLowFreeze / crash when selecting clamped splines (not crea...AssignedAndrew Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=33&t=8531

2245QCAD BugtrackerQCAD (main)Bug ReportLowBold fonted text appears regular sized - v 3.26.2AssignedJoe Loiacono Task Description

Text that has been applied to a drawing with the ‘bold’ attribute sometimes appears as regular, un-bolded, text. When increasing the viewing magnification one will see the text adopt the bold attribute, but at smaller sizes the text appears without the bold. This can be confusing causing the draftsman to double-check whether the text had the bold attribute.

Current version: 3.26.2

Previous version: 3.22.1 (note: in this version, bolded text appeared bold at all viewing magnifications.)

2242QCAD BugtrackerQCAD (main)SuggestionLowBill of MaterialsAssigned2Zilmo Task Description

It would be a very interesting feature to add to future versions.

I also use AutoCAD Mechanical 2012 and the BOM is synced with every balloon on the drawing. Making it easy to edit.

The core BOM accepts formula fields and we can easily calculate the mass of a part, with some Ifs and math.

The BOM that is shown in the actual drawing is more simplistic, and has just Part number, Quantity, Mass and the Description. But it’s related to the “core BOM”.

It’s a very interesting thing! It would be great on QCad.

2233QCAD BugtrackerQCAD/CAMFeature RequestLowMore selection options to select sheets for nestingAssignedHusky Task Description

I’m often in the situation that I have to select for nesting 50+ sheets. Currently is only a Shift + left mouse click selection possible. It would be nice if QCAD/CAM could get for the nesting / sheet selection additional a mouse rectangle area selection.

2229QCAD BugtrackerQCAD (main)Feature RequestLowProperty Editor, option format property values as decim...AssignedHusky Task Description

Angle Display is decimal although the decimal display is disabled in Application Preferences.

Format should be 17° 31’ 52” instead of 17.531111.

2227QCAD BugtrackerQCAD (main)Feature RequestLowCAM > CAM Export: post processor for tangential knife c...AssignedAndrew Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=2&t=8342

2216QCAD BugtrackerQCAD (main)SuggestionLowDIM modification cause overlapping textAssigned1Husky Task Description

When I modify partly a DIM with “Stretch” or changing one Extension line position with drag and drop the Value text is updated which is nice working. Unfortunately the previous value stays in place and is overwritten by the actual value. I think for a good readability the previous value should disappear in the moment when the new value is presented.

2213QCAD BugtrackerQCAD/CAMFeature RequestLowAllow editing Spindle Speed separately for each Toolpat...Assigned1Y.LAURENT Task Description

Hello dear CAM developers!

I need to use the same tool at different spindle speed in a single machining file.
I would deeply appreciate if you could add a Spindle Speed edit field in the CAM Profile Toolpath edit window in order that each Toolpath can have its own Spindle Speed value (same as you did for Feed Rate and Plunge Rate)

FYI, the tool on my concern is a laser who’s power is driven by the Spindle Speed PWM signal.
I need to be able to do both engraving and cutting in a single file.
Alas! this laser tool is defined with a fix and unique number (99).
Therefore I cannot define different laser tools with different speeds.

Many thanks
Best regards.

2205QCAD BugtrackerQCAD (main)Bug ReportLowText rendering fails in certain zoom levelWaiting on fix in 3rd party libraryHusky Task Description

Case:
Drawing with text, zoom in and out with one of the common methods, text will disappear in certain zoom level

Same drawing zoomed in and out in 3.20.0.0 doesn’t show this effect - works just fine.

2195QCAD BugtrackerQCAD (main)Feature RequestLowSaved views include memory of blockAssignedRyan Cousins Task Description

When saving a view, it would be great if the view also saved which block (model space, layout block, or any other block) that was active at the time the view was saved and when the view is later re-activated, the corresponding block would re-activate.

2192QCAD BugtrackerQCAD (main)Feature RequestLowAdd "Define angle using mouse cursor" to Move and Rotat...Assigned1Kieran Sturrock Task Description

The “Define annge using mouse cursor” of the Rotate tool would be useful in the Move and Rotate Tool

2191QCAD BugtrackerQCAD (main)Feature RequestLowExtend the functionality of the Reorder toolAssigned3Kieran Sturrock Task Description

Add functions to the Reorder tool, similar to the functions of the counter tool, undo last step and start at any number, allowing corrections and restarting the tool part way through.

See the discussions at https://qcad.org/rsforum/viewtopic.php?f=32&t=8170

2190QCAD BugtrackerQCAD (main)Feature RequestLowOption for unidirectional dimensionsAssigned3Ryan Cousins Task Description

An option for unidirectional dimensions, in addition to the default aligned dimensions.

2189QCAD BugtrackerQCAD (main)Feature RequestLowVertically and/or diagonally stacked fractions option.Assigned2Ryan Cousins Task Description

The option for vertically and diagonally stacked fractions would be helpful for both the text creation tool and as the output of dimensions.

2182QCAD BugtrackerQCAD (main)Feature RequestLowSelect > Select PreviousAssigned3Andrew Task Description

Select the previously selected entities.

2178QCAD BugtrackerQCAD (main)Bug ReportLowStored Color of text dimension changesAssigned1CVH Task Description

QCAD Pro 3.25.2.7 Win7 Wininstaller 32bit
Related Topic:
https://www.qcad.org/rsforum/viewtopic.php?&t=7954

Reported is that black is saved as #00004c (dark blue)
Radek (iMac (Retina 5K, 27-inch, 2017), Catalina 10.15.7 (19H114)

My system/installation saves black as #4c000 (dark red)

When using single primary colors these get reduced to #4c, #7f, #99, #cc & #ff.
The threshold for that are #00, #65, #8b, #b2 & #e5
See: DimColorScale (png & dxf)

8 standard CAD colors fail saving correct
Black (something with #4c)
Dark Red, Dark Green, Dark Blue, Dark Cyan, Dark Magenta, Dark Yellow
(#80 turns #7f)
& Gray
(#adadad instead of #a0a0a4)

As with Gray, when mixing the 3 colors it gets rather fuzzy ...
#505050 & #555555 both turn #5b5b5b
&
#464646 turns #4c4226

A snippet of my investigation is included in the topic
(45 files in a ZIP)

CVH

2177QCAD BugtrackerDocumentationSuggestionLowUpdate class_r_polyline.htmlAssigned1CVH Task Description

Include RPolyline.getLeftRightOutline() method in class_r_polyline.html

In use since 11 Sept 2020

CVH

2174QCAD BugtrackerQCAD (main)Bug ReportLow[SOLVED] Numerous shortcomings when exploding Polylines...Assigned1CVH Task Description

QCAD Professional
Windows 7, Win installer 32bit
Version: 3.25.2.7 (3.25.2.7)
Internet: QCAD.org
Build Date: Dec 16 2020
Revision: e06f230
Qt Version: 5.13.2
Architecture: i386
Compiler: Unknown

Issues most likely unrelated to OS and installations before 3.25.
Related post:
https://qcad.org/rsforum/viewtopic.php?&t=7982

Flaws documented in full in attached dxf.
The dxf has meaningful Layer States.

4 Columns:
- Prior Art
- The test cases
- Actual results
- Results with proposed fix

Tried as many things as I can come up with.
Orange: Flaws
Red: Errors
Green: Good results (or as good as I can get them)

Solution(s) given in attached script explode.js
(I am just a simple guy and wouldn’t know how to file a pull request on GitHub ......)

In section: “explode polyline into line and arc segments”
group: “if (RPolyline.hasProxy() && polyline.hasWidths()) {....}”
All additions, updates & typos are marked with “CVH”, one can textual search for it.
Over-documented for sure.
Any Eaction is to debug in Windows and is obsolete.

Included PreferencesPage.ui is updated for the all Splines from Text fix
Still in consideration: Forcing cubic splines from text to degree 2 ...
... I am rather convinced ...

CVH

2169QCAD BugtrackerQCAD (main)Bug ReportLowMissing G-Code G00 X0 Y0 when placing hole at x0 y0AssignedJürgen Schmidt Task Description

When placing a hole at x0 y0 there is no G00 x0 y0 in the exported G-Code.
So the first cut was made at the current position of the tool, not at x0 y0!

2167QCAD BugtrackerQCAD/CAMBug ReportLowComma format decimal separator fails ZSafety CAM config...Assigned1CVH Task Description

QCAD/CAM
Trial package Win installer 32 bit
Version: 3.25.2.0 (3.25.2)
Internet: QCAD.org
Build Date: Sep 4 2020
Revision: 4a61501
Qt Version: 5.13.2
Architecture: i386
Compiler: Unknown

Local decimal separator is ‘,’ (comma)
In CAM configuration .. Z Levels .. Safety level

Using nn,nnn the output is Nxx G0 Znn
Using nn.nnn the output is Nxx G0 Znn.nnn

Drop down boxes are all in dot format.
Didn’t try anything else yet ;-)

Regards,
CVH

2164QCAD BugtrackerQCAD/CAMFeature RequestLowAdd ability to pan the 3D view with a modifier key and ...Assigned1Steve Green Task Description

With a Mac (and no external mouse) there’s no middle button so it’s not possible to pan the 3D view (that’s what they tell me in the forum). It would be useful if one could use command-drag or control-drag to pan around the 3D view.

2162QCAD BugtrackerQCAD (main)SuggestionLowUpdate the parameter with simplify of RPolylineData & R...Assigned1CVH Task Description

Unrelated to OS, nor version

Reported Jun 23, 2020 in: https://qcad.org/rsforum/viewtopic.php?f=30&t=7372

Status Dec 24, 2020: https://qcad.org/rsforum/viewtopic.php?f=30&t=7372#p30955 Documentation is updated.
The Classes still refer to an ‘angleTolerance’.

Regards,
CVH

2161QCAD BugtrackerQCAD (main)Feature RequestLowMake Polyline from Selection (OC) configurable for simp...Assigned1CVH Task Description

QCAD Professional
Win installer 32bit
Version: 3.25.2.7 (3.25.2.7)
Internet: QCAD.org
Build Date: Dec 16 2020
Revision: e06f230
Qt Version: 5.13.2
Architecture: i386
Compiler: Unknown

Not related to OS, nor version.

The method Polyline from Segments (OC) can be configured for tolerance and simplification in the Options Toolbar.
The method Polyline from Selection (OG) has no UI or none showing.

OG retrieves a tolerance from QCAD.ini, what is initially not set:

    var tolerance = RSettings.getDoubleValue("PolylineFromSelection/Tolerance", 0.001);

The tolerance will be default = 0.001 similar as the default in AppPrefs.
The tolerance setting is included in QCAD.ini after changing the AppPrefs entry.

OG calls PolylineFromSelection.autoJoinSegments with this tolerance:

    var counter = PolylineFromSelection.autoJoinSegments(di, tolerance, this);

PolylineFromSelection.autoJoinSegments calls PolylineFromSegments.createPolylineShape
with simplification hard coded to true. (last parameter)

    // create polyline from line, arc, spline or open polyline entity:
    var polyline = PolylineFromSegments.createPolylineShape(
                    entity, doc, vTolerance, op, undefined,
                    traversed, callBacks, undefined, true);

I would like to see the simplification optional and default = true.

Regards,
CVH

2160QCAD BugtrackerQCAD (main)Bug ReportLowDraw > Polyline > Relocate Start Point: fails on polyli...Assigned1CVH Task Description

QCAD Professional
Win installer 32bit
Version: 3.25.2.7 (3.25.2.7)
Internet: QCAD.org
Build Date: Dec 16 2020
Revision: e06f230
Qt Version: 5.13.2
Architecture: i386
Compiler: Unknown

Origin:
I like to start my CAM paths at low curvature instead starting at high curvature.
Ellipses may explode with the startpoint at the tip. (file Y2)

Documented in 3.25.2.4, reproducible under 3.25.2.7

File included with 4 LayerStates
- Original Ellipses: Y1
- Exploded to polylines (32 segments): Y2
- Direct after XP, OR performs different on the left top one: Y3
- Faulty solutions by OR: Y4 (= saved state)

The results may differ with the saved explosions.

With the file.
Y1
TA
XP
Relocate startpoint with OR to an existing reference (called ‘End’)

Regards,
CVH

2159QCAD BugtrackerQCAD (main)Bug ReportLowDraw > Polyline > Polyline from Selection: may induce N...Assigned1CVH Task Description

QCAD Professional
Win installer 32
Version: 3.25.2.7 (3.25.2.7)
Internet: QCAD.org
Build Date: Dec 16 2020
Revision: e06f230
Qt Version: 5.13.2
Architecture: i386
Compiler: Unknown

Discovered in 3.25.2.4, reproducible under 3.25.2.7

Draw any open or closed chain of line entities.
Select All.
OC to Polyline.
Step through vertices.

No example file provided because these NaN values are not saved to a file.
More pronounced with lines as with arcs.
Less pronounced when recombining after an explosion.
Some methods clear these to value = void.
Some methods clear these to zero (OR).
Can also occur when adding segments to an existing polyline with OC.

Regards,
CVH

2157QCAD BugtrackerQCAD (main)Bug ReportLowControlpoint Spline exploded to polyline may induce NaN...Assigned1CVH Task Description

QCAD Professional
Win installer 32bit
Version: 3.25.2.7 (3.25.2.7)
Internet: QCAD.org
Build Date: Dec 16 2020
Revision: e06f230
Qt Version: 5.13.2
Architecture: i386
Compiler: Unknown

Documented in 3.25.2.4, reproducible under 3.25.2.7
In the attached file:
→ Explode the trial cases and locate NaN Widths.
→ These faulty widths are cleared while saving and reverting.
= work around.

Related Post: https://www.qcad.org/rsforum/viewtopic.php?t=7902#p30902
Related Topic: https://www.qcad.org/rsforum/viewtopic.php?t=7901
Related Commit: https://github.com/qcad/qcad/commit/fcd7929bced7ae328029c1aa2ee2aff2745709c6

Arctic_Eddie reports failing CAM offset at exactly these points !!!
Reported is a faulty arc with radius of over 360,000mm.
- I can not reproduce this under QCAD working further on the Polys with NaNs.
- However the direct offset of such controlpoint Splines is erroneous.
(see file in post 30902)

Arctic_Eddie reports arc radii of over 10,000mm.
- These don’t seem to be faulty.
- I agree that BiArc fitting should be bound to a lower and certainly to an upper limit.
- That should be huge otherwise faint curvature is represented by many
wobbles or too quick by straight lines.
(All this, keeping in mind that QCAD doesn’t return the optimum fitted BiArc, see: https://www.qcad.org/rsforum/viewtopic.php?t=4859)

Regards,
CVH

2145QCAD BugtrackerQCAD (main)Bug ReportLowModify > Trim Both: closed polyline as either entity br...Assigned1CVH Task Description

QCAD Professional

Version: 3.25.2.4 (3.25.2.4)
Internet: QCAD.org
Build Date: Nov 18 2020
Revision: 40f4475
Qt Version: 5.13.2
Architecture: i386
Compiler: Unknown

Use TM by mistake to trim a line to a closed shape.
Topic: https://qcad.org/rsforum/viewtopic.php?f=33&t=7780
File included in the topic.
Y1 Original
Y2 Faulty use of TM
Y3 After ‘Undo’

Husky only ‘could agree on a not proper working undo
The conditional clause of this sentence is ‘the odd choice’.
Blaming this on incompetence.
Insight is the best way to get better ...
... but the rest is more an odd choice of tools for this kind of task ...

Again, the MISTAKE was by accident, not intended, in a flick of the wrist ...
I didn’t change the trimming method, I simply forgot to ... only once.

The ‘undo’ of my incompetent MISTAKE didn’t returned to how the situation was before I erroneous trimmed with TM.
I was simply undoing my erroneous action.

Documented it in 4 quadrants.
For this, 4 times on purpose, and not as a consistent ‘odd choice’.

Regards,
CVH

2140QCAD BugtrackerQCAD (main)SuggestionLowChanging navigation mode for mouse wheel doesn't change...Assigned1Ar ren Task Description

Looks like error, but may be that’s feature request.

CAD software uses typical navigation behavior as:
Wheel = Zoom; Ctrl+Wheel = Scroll up/down; Shift+Wheel = Scroll left/right.

Any other software like browsers, office software (openoffice writer, ms excel and so on), 2d paint software like GIMP (Photoshop and so on) uses other behavior:
Wheel = Scroll up/down; Ctrl+Wheel = Zoom; Shift+Wheel = Scroll left/right.

Users, that intensively use CAD and other software simultaneously prefer to make same behavior in their applications switching CAD scroll to plain mouse wheel.

QCAD’s “Application Preferences”: “Graphics View: Navigation”: “Mouse wheel/ two finger swipe”: “Scroll” allow user to assign scroll up/down to wheel mouse instead of Zoom. But there is mistake Ctrl+Wheel didn’t change to Zoom. Ctrl+Wheel continues to scroll up/down, as the wheel.
Wheel = Scroll up/down; Ctrl+Wheel = Scroll up/down; Shift+Wheel = Scroll left/right. No zoom!

Draw manipulation at this mode like a hell: you need to use wheel in conjunction with Ctrl/Shift to point draw in desired position, than move your hand to +(-) for make desired zoom.

2130QCAD BugtrackerQCAD (main)TaskLowText: Text dialog removes tabsAssignedAndrew Task Description

Text dialog (QTextEdit) strips tabs in toHtml.
If tabs can be retained, text entities could support tabs.

2128QCAD BugtrackerQCAD (main)Feature RequestLow"Create Library Item" "Save As" dialogue doesn't rememb...Assigned2Russell Ault Task Description

This is either a bug or a feature request, depending on perspective; my apologies if I’ve picked the wrong one. Additional discussion can be found here.

Steps to reproduce:
1. Create an entity
2. Run “Create Library Item” [BT]
3. Select Reference Point

Expected outcome:
“Save As” dialogue opens in the directory that the previous library item was saved in

Actual outcome:
“Save As” dialogue opens in ( RSettings.getLaunchPath() + “/libraries” )

Additional Context:
The reason I’ve categorized this as a bug is because, relative to the behaviour of the main “Save As” dialogue (which does remember the last directory used) the behaviour of the “Create Library Item” “Save As” dialogue is unexpected.

Software versions:
QCAD 3.25.2 Pro
Windows 10 Pro

2127QCAD BugtrackerQCAD (main)Feature RequestLowSnap for predicted intersections while using "Restrict ...Assigned2Russell Ault Task Description

I would like to request a new kind of snap: a “Restricted Intersection” snap that appears at the point where an entity would intersect with a line drawn from Relative Zero that fulfills the current EL criteria. “Restricted Intersection” snaps would be similar to other Relative Zero-based snaps (like “Perpendicular” and “Tangential”), but would predict the point of the snap from the EL constraints instead of the characteristics of the entity being snapped to. Naturally a value of 0 for angle or length would result in that constraint being ignored.

Additional operational flexibility could be achieved by allowing the snap to exist regardless of whether EL is actually in use. To be useful this would probably require determining snap locations based on angle OR length as opposed to angle AND length.

Implementing this new snap would allow, for example, for easily drawing a line of unknown (but determinable) length at a specified angle between a given point and a given entity (see discussion here), with the “Restricted Intersection” snap ensuring that the endpoint of the new line forms an intersection with the entity in question. Currently the same goal can be achieved a couple of different ways, but they all involve at least two separate steps.

2125QCAD BugtrackerQCAD (main)Bug ReportLowText disappears when you zoomWaiting on UserPoul Strömberg Task Description

When I zoom, the text disappears in certain zoom levels after updating to the latest version.

2115QCAD BugtrackerQCAD (main)SuggestionLowMove toolbars with negative positions to 0 positions AssignedReinhard Schneider Task Description

As it can be seen in the attached image, QCAD toolbars may dock to a position slightly outside the visible area of the screen. After having docked there, I have not been able to move them any more. Their current position is just in the middle of the screen.

The position of the toolbars remains the same after the deinstallation of QCAD, shutting down, restarting the computer and reinstalling QCAD. I kindly ask for help.

Kind regards
Reinhard

2099QCAD BugtrackerQCAD (main)Bug ReportLowDIM Label, Square Symbol doesn't adopt layer attributesAssignedHusky Task Description

The square symbol offered as symbol in DIM label is the only symbol which doesn’t adopt the layer color.
If I print a drawing in full color it leads to a black symbol in an otherwise colored dimension.

It is also the only symbol which has a solid filling what is confusing when you work with it in Model_Space ...

2092QCAD BugtrackerQCAD (main)Bug ReportLowcrash when changing shortcut in preferencesAssignedreint kamp Task Description

The application crashes when I try to change a shortcut in the preferences. And only after resizing the preferences window.
In the attachement are the cli warnings.
I also tried the 3.24.3.9 snapshot with the same result.

2091QCAD BugtrackerQCAD (main)Feature RequestLowToggle redrawing of hatches Assigned2reint kamp Task Description

Because modifying hatches have lag issues I’d like to propose a toggle that turns of the redrawing/rendering of the hatch. Especially while modifying the hatch.

The hatches always have a boundary that can be worked with right? So when we move or stretch the hatch we can still see the boundary and its handles to perform all the actions.

This could be a new view mode that turns of the view of the interior/pattern of the hatch but leave the boundary of the hatch.
Or the draft mode can be extended to include simplified hatches while modifying.

Also see the discussion

2087QCAD BugtrackerQCAD (main)Feature RequestLowMore options for "Paste along Entity" [PE]Assigned1Husky Task Description

“Paste” has already the options: To current layer, Overwrite layers, Overwrite blocks.

Would be a nice time saver to have the same options for “Paste along Entity” too.

2072QCAD BugtrackerQCAD (main)SuggestionLowInserted and flipped block mirrors text and dimAssignedHusky Task Description

Text and/or DIM used in blocks will be mirrored if inserted with a vertical/horizontal flip option.

Text/DIM which was successfully used in previos QCAD versions are now mirrored if they are loaded in the current version.

Version 3.23.0 doesn’t shows this behavior.

https://www.qcad.org/rsforum/viewtopic.php?f=32&t=7206

2070QCAD BugtrackerQCAD (main)Feature RequestLowcropping imageAssigned2Gabriele Task Description

It may be useful to insert the “image cropping” function both in top / bottom - right / left mode, and with polyline

2063QCAD BugtrackerQCAD (main)Performance IssueLowBad performance while zooming inside layout block with ...Assigned2reint kamp Task Description

Zooming in and out is lagging to the point of unusable. This is happening in a layout block with the cursor pointing inside geometry with hatches. When the cursor is pointing outside the geometry zooming works as expected.
The attached file has a very simplified testcase that shows this problem almost in the same way as a more complex drawing with multiple layers and hatches.

edit: I also attached the more complex drawing because it is a bit unclear to me where the lagging stops. Outside the viewport or outside the paper.

I just noticed the selection box has the same problem!

2060QCAD BugtrackerQCAD (main)Feature RequestLowDialog box for Layer StatusAssigned1Thomas Stoelting Task Description

So far, layer status has only been implemented very rudimentarily.
I wish something like a dialog box in which you can choose for each layer status, which layers belong to it and which not.

2057QCAD BugtrackerQCAD (main)Feature RequestLowMultiline toolAssignedAndrew Task Description

Implement a multiline tool.

2056QCAD BugtrackerQCAD (main)Feature RequestLowOption Duplicate layer (yy) inclusive all sub-layers.AssignedHusky Task Description

If I’ve to duplicate a layer with a bunch of sub-layer it’s a kind of a Sisyphus task to get it done.
Currently I have to duplicate each single layer. Then in an additional step I’ve to address each child layer to the proper parent layer.

Current lack:
Marked parent layer with all sub-layer / Duplicate Layer / only ONE layer will be duplicated.

With other words: If I have to duplicate a layer with 5 sub-layer it requires 11 steps to get a copy of that tree ... :-(

2041QCAD BugtrackerQCAD (main)Bug ReportLowcircletangent2 doesn't solve correctly if the defining ...AssignedDmitry Task Description

In my example I can’t draw a circle with circletangent2 if the defining point is on one of the defining tangents. The tangency is lost when I try to do this.

I attached 4 screenshots: TheExample.png, TryingPoint1.png, TryingPoint2.png and The_Point_Isn’t_On_The_Tangents.png.

2037QCAD BugtrackerQCAD (main)Feature RequestLowSupport alternative angle referenceAssignedAndrew Task Description

E.g. 0 degrees at the top, clock-wise for positive direction, alternative angle units.

Showing tasks 1 - 50 of 429 Page 1 of 91 - 2 - 3 - 4 - 5 - Last >>

Available keyboard shortcuts

Tasklist

Task Details

Task Editing