All Projects

IDProjectCategoryTask TypeSeveritySummaryStatusOpened by
 1369 QCAD BugtrackerQCAD/CAMBug ReportVery Low qcad-bin is trying to access non-existent /home/andrew ClosedJohn Florian Task Description

I experience long start delays. I’ve trace the problem to the fact that I have autofs automounting my home directories. However, an strace of qcad-bin shows the following:

execve("/opt/ribbonsoft/qcad/qcad-3.12.6/qcad-bin", ["/opt/ribbonsoft/qcad/qcad-3.12.6"...], [/* 87 vars */]) = 0
brk(NULL)                               = 0x1eca000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fd6194ad000
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
open("/home/andrew/local/qt/lib/tls/x86_64/libqcadecmaapi.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/andrew/local/qt/lib/tls/x86_64", 0x7fff4722f250) = -1 ENOENT (No such file or directory)
open("/home/andrew/local/qt/lib/tls/libqcadecmaapi.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/andrew/local/qt/lib/tls", 0x7fff4722f250) = -1 ENOENT (No such file or directory)
open("/home/andrew/local/qt/lib/x86_64/libqcadecmaapi.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/andrew/local/qt/lib/x86_64", 0x7fff4722f250) = -1 ENOENT (No such file or directory)
open("/home/andrew/local/qt/lib/libqcadecmaapi.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/andrew/local/qt/lib", 0x7fff4722f250) = -1 ENOENT (No such file or directory)

Since there is no “andrew” user here, I have to wait for automount to timeout which takes about 2m and is rather annoying.

 1668 QCAD BugtrackerQCAD (main)Bug ReportVery Low Text color of command line unreadable with KDE's Breeze ...ClosedJohn Florian Task Description

I prefer the Breeze Dark color scheme as it find it less stressful on my eyes, however it’s unusable with QCAD where the Command Line prompts and responses are rendered as a very light grey on a white background. I believe the proper fix would be one (or both) of:

  • Make the Command Line area background follow the desktop scheme. (It appears that the text already does so, hence the light text, but since the background doesn’t it becomes unusable.)
  • Provide a configuration option for the text and/or background color used in the Command Line area.

Screen shots are attached showing both Breeze and Breeze Dark schemes.

Showing tasks 1 - 2 of 2 Page 1 of 1

Available keyboard shortcuts

Tasklist

Task Details

Task Editing