All Projects

IDProjectCategoryTask TypeSeveritySummaryStatusOpened by
 2172 QCAD BugtrackerQCAD (main)Feature RequestLow Modify > Property Painter: Add alpha property for hatch ...Closed2reint kamp Task Description

The alpha property is a new feature. Now that we are using it it can be added to tools like the “Property Painter”.

 2153 QCAD BugtrackerQCAD (main)Bug ReportLow Freeze program when using text tool Closedreint kamp Task Description

Using version

Add or change text.
Inside the rich tab I try to change the text height.
The program freezes.
Tried with different fonts.

2092QCAD BugtrackerQCAD (main)Bug ReportLowcrash when changing shortcut in preferencesAssignedreint kamp Task Description

The application crashes when I try to change a shortcut in the preferences. And only after resizing the preferences window.
In the attachement are the cli warnings.
I also tried the snapshot with the same result.

2091QCAD BugtrackerQCAD (main)Feature RequestLowToggle redrawing of hatches Assigned2reint kamp Task Description

Because modifying hatches have lag issues I’d like to propose a toggle that turns of the redrawing/rendering of the hatch. Especially while modifying the hatch.

The hatches always have a boundary that can be worked with right? So when we move or stretch the hatch we can still see the boundary and its handles to perform all the actions.

This could be a new view mode that turns of the view of the interior/pattern of the hatch but leave the boundary of the hatch.
Or the draft mode can be extended to include simplified hatches while modifying.

Also see the discussion

2063QCAD BugtrackerQCAD (main)Performance IssueLowBad performance while zooming inside layout block with ...Assigned2reint kamp Task Description

Zooming in and out is lagging to the point of unusable. This is happening in a layout block with the cursor pointing inside geometry with hatches. When the cursor is pointing outside the geometry zooming works as expected.
The attached file has a very simplified testcase that shows this problem almost in the same way as a more complex drawing with multiple layers and hatches.

edit: I also attached the more complex drawing because it is a bit unclear to me where the lagging stops. Outside the viewport or outside the paper.

I just noticed the selection box has the same problem!

 1576 QCAD BugtrackerQCAD (main)Feature RequestLow add option to switch off dialog for modify: rotate tool ...Closed1reint kamp Task Description

To improve the flow of drawing I’d like to switch off the dialog for the rotate tool. Most of the times i use the interactive input and delete the original. So I don’t need to click a popup to acknowledge that.
I allready use the same option for the move/copy tool.

 1575 QCAD BugtrackerQCAD (main)Bug ReportLow There are no shortcut entries in the application prefer ...Closedreint kamp Task Description

Shortcuts do work except G,Y (and maybe other I don’t know of)


Warning:  Script Exception:
 "TypeError: Result of expression 'ShortcutPreferences.kms.getShortcutMap()' [undefined] is not an object."
Warning:  "<anonymous>(false) at :scripts/Pro/Edit/AppPreferences/ShortcutPreferences/ShortcutPreferences.js:473\nexec() at -1\n<anonymous>() at /home/cccplex/qcad/qcad-3.16.7-pro-linux-x86_64/scripts/Edit/AppPreferences/../AbstractPreferences.js:76\n<eval>() at 1\n<native>() at -1\nmain() at scripts/autostart.js:767\n<global>() at scripts/autostart.js:780"
Linux lennie 4.10.11-1-ARCH #1 SMP PREEMPT Tue Apr 18 08:39:42 CEST 2017 x86_64 GNU/Linux
 1573 QCAD BugtrackerQCAD (main)Feature RequestLow add reference point input to copy paste Closedreint kamp Task Description

It woul be really handy if there is an option to set the reference point of the copy selection.
Maybe this can be added to the clipboard widget?

 1571 QCAD BugtrackerQCAD (main)Bug ReportLow character map not showing special characters that have  ...Closedreint kamp Task Description

I use a font that changes the characters of latin and greek to technical symbols. The font is installed and working okee.
But in the text tool → special characters button → others I expect to see this modified character map but instead I see the standard unicode characters.
When I use a gtk tool gucharmap I can see the character map as expected.
Now it is really combersome to enter the special characters.

 1570 QCAD BugtrackerQCAD (main)Feature RequestLow make the stretch tool more flexible in selecting nodes Closed1reint kamp Task Description

Stretching multiple points of an entity is not possible to my knowledge. I
can use the stretch tool but this gives me a rectangular selection box and
this limits my posibilities. For example when entities are over eachother.
I hope that in the future this will become more like blender. With a freedraw
selection tool and/or shift clicking multiple nodes.

 1569 QCAD BugtrackerQCAD (main)Bug ReportLow File > Print Preview: changing offset in drawing prefer ...Closedreint kamp Task Description

In print preview mode I click the button for drawing preferences.
I go to Printing: Page and change the offset for x,y in the viewport.
Then apply but the page has not moved and the autozoom still redirects to the old position.
When I redraw the window through the window manager or quit and reopen the printpreview the page has moved to it spot.

 2212 QCAD BugtrackerQCAD (main)Bug ReportVery Low Cannot change f5 shortcut in preferences. Closedreint kamp Task Description

I’d like to change the f5 shortcut from rotate counter-clockwise to move/copy.

I started with a fresh QCAD3.conf

In the preferences window: general: tool settings

First time I remove f5 from rotate counter-clockwise qcad crashes.
Second run it seems to work.
I add the shortcut f5 to move/copy and restart.
The shortcut doesn’t work. And tool settings has a notice that there are conflicts.
When I change it to f3 it works.

btw the shortcut column don’t show any shortcuts. See screenshot.

2098QCAD BugtrackerQCAD (main)Bug ReportVery LowOffset will pick up hidden blocks while using it in a l...Assigned1reint kamp Task Description

When I’m drawing inside a layout block the offset tool picks up lines from blocks that are hidden.
It is not happening with all the block.

2097QCAD BugtrackerQCAD (main)Bug ReportVery LowVery hard to snap to baseline reference point of dimens...Assignedreint kamp Task Description

With default autosnap settings reference points included I find it very hard to snap to the baseline reference points of a dimension.
I manage to do it by setting snap to reference point only and zoom out till I see the entire dimension element.

2088QCAD BugtrackerQCAD (main)Bug ReportVery Low column headers of the "General: tool settings " resize...Assignedreint kamp Task Description

Open QCAD and the application preferences. In the section “General: tool settings " you can resize the columns: Menu, Shortcuts etc.
The problem is that it is not intuitive. The first divider is not selectable and the second moves the first, only backwards.

 2085 QCAD BugtrackerQCAD (main)Bug ReportVery Low Drag and drop: moving single polyline vertex moves also ...Closedreint kamp Task Description

See the steps to reproduce in the attached drawing.

 1574 QCAD BugtrackerQCAD (main)Bug ReportVery Low Layer > Remove: deleting sublayer switches to layer 0 Closedreint kamp Task Description

I have set the delete layer preference to make the next layer in the list the current. This will not work for sublayers. After deleting a sublayer the 0 layer will become current.

Showing tasks 1 - 17 of 17 Page 1 of 1

Available keyboard shortcuts


Task Details

Task Editing