All Projects

IDProjectCategoryTask TypeSeveritySummaryStatusOpened by
 2179 QCAD BugtrackerQCAD (main)Bug ReportHigh The use of 'Edit Block In-place' corrupts other open fi ...ClosedCVH Task Description

QCAD Professional
Win7 winInstaller 32bit
Version: 3.25.2.7 (3.25.2.7)
Internet: QCAD.org
Build Date: Dec 16 2020
Revision: e06f230
Qt Version: 5.13.2
Architecture: i386
Compiler: Unknown

Include file was open when using ‘Edit Block In-place (BB)’ in an other drawing.
Happend on 5/1/2021 just before 2:56 am
https://qcad.org/rsforum/viewtopic.php?&t=7945#p31055

‘Edit Block In-place (BB)’ is never used in this drawing.
There was never a Block in this file.
I might have switched focus.

Re-installed QCAD a dozen times meanwhile.
Wiped all what remained of QCAD twice.
Cleaned up the windows registry twice.
Lastly left out all kinds of my custom scripts.
Simply a bare install with the msi file.

How to replicate:
- Start QCAD in normal mode
- Load included file
- Set App.Prefs .. Startup .. Restore open files
- Close QCAD
- Start QCAD in debugger mode
(-rescan -enable-script-debugger -always-load-scripts)

Boot fails.
Every successive trial.

When booting in normal mode I see the BB options toolbar blink shortly.

3 Screengrabs in DebuggerModeError.zip in the same topic.
The blink I can’t catch.

I can Boot with no file to retore on open in debugger mode and load the file.
I have several of those files, all were open that day at 2:56 am

CVH

 1758 QCAD BugtrackerQCAD (main)Bug ReportHigh Draw > Polyline > Create from Selected Entities: crash  ...ClosedCVH Task Description

(Re-)combining polys touching at node with ‘create from selected’ leads to application crash.

QCAD 3.20.1 Win7 32bit

In the file example 2.
Regards

 1750 QCAD BugtrackerQCAD (main)Bug ReportMedium trimming polylines ClosedCVH Task Description

Trimming polylines especialy those with a string of small segments should be done at the intersection of those polylines.
Now trimming is done with the seggments that where the nearest when selecting the two polylines.

 1747 QCAD BugtrackerQCAD (main)Bug ReportMedium Scaling w 2 ratios fails to scale polyline arc ClosedCVH Task Description

Scaling without keeping the aspect ratio fails to scale an arc to an ellips when this is part of a polyline.

Discovered while documenting feature request ‘Skewing’

CVH

 2277 QCAD BugtrackerQCAD (main)Performance IssueLow Auto Trim (AX) slower with larger number of text entiti ...ClosedCVH Task Description

QCAD Professional
Win7pro Win-Installer
Version: 3.26.4.5 (3.26.4.5)
Internet: QCAD.org
Build Date: Jul 20 2021
Revision: e596276
Qt Version: 5.13.2
Architecture: i386
Compiler: Unknown

Trimming With AX slows down with many text entities.
Seeing the same lagging with D2 on Circle entities.

Also seen on Windows 10 Pro 3.26.4.0
Forum topic: https://qcad.org/rsforum/viewtopic.php?t=8729

Attached files:
TrimAuto_1.dxf ... 11 entities ... trimming instantaneous
TrimAuto_2.dxf ... 11 entities + 1936 LINES ... rather instantaneous
TrimAuto_3.dxf ... 11 entities + 1936 ARCS ... less than 1 second
TrimAuto_4.dxf ... 11 entities + 121 TEXT ... over 3 or 4 seconds
Slower for larger Arc / Circle

The questions here are:
Should AX trim at text entities?
Can this be optional?

Regards,
CVH

 2275 QCAD BugtrackerQCAD (main)Bug ReportLow Snap > Center: snapping to center of polyline arc segme ...ClosedCVH Task Description

QCAD Professional
Win7Pro WinInstaller
Version: 3.26.4.5 (3.26.4.5)
Internet: QCAD.org
Build Date: Jul 20 2021
Revision: e596276
Qt Version: 5.13.2
Architecture: i386
Compiler: Unknown

See attached file:
- The 9 center snapping points of the 24 bulging segments are all presumed to be incorrect
- For some segments the center snap is outside the arc shape from a bulging segment
- For some segments there are 2 solutions

Regards,
CVH

2264QCAD BugtrackerQCAD (main)Bug ReportLowHatching segment selection stops at entity - hatch patt...AssignedCVH Task Description

QCAD Professional
Windows7 pro WinInstaller
Version: 3.26.4.5 (3.26.4.5)
Internet: QCAD.org
Build Date: Jul 20 2021
Revision: e596276
Qt Version: 5.13.2
Architecture: i386
Compiler: Unknown

In the example given by ‘turtle’ .. why_is_this_not_closed-v2.dxf
https://www.qcad.org/rsforum/viewtopic.php?f=32&p=34157#p34153

Selecting hatch boundary segments of the horizontal polyline segment at
(1169.933593;274.432562)-(1089.933593;274.432562)

Segment selection stops where the AR-CONC hatch pattern touches the horizontal segment.
Such intersections points where already no longer regarded as snappoints.
See :
 FS#2090 : https://www.qcad.org/bugtracker/index.php?do=details&task_id=2090.
Related topic https://www.qcad.org/rsforum/viewtopic.php?&t=7340&p=28414#p28414

Regards,
CVH

 2258 QCAD BugtrackerQCAD (main)Bug ReportLow Selected entities send to an 'Off' layer retain their s ...ClosedCVH Task Description

Andrew,

Seen in al previous versions that I know of.
To recreate and merely as an example:
With:
- A polyline entity on a layer ‘polyline’ (notLocked - notFrozen - Visible)
- A hidden layer ‘exploded’ (notLocked - notFrozen - notVisible)

- Select the polyline .. DP .. XP » duplicated polyline explosion in selection.
- Set the selection its layer to ‘exploded’ by a double click in the Layer List or by Property Editor.
- Hide layer ‘polyline’ by toggling its visibility.
- Unhide layer ‘exploded’ by toggling its visibility.

The explosion is still in a dark red color.
Workaround: TA & TN

Regards,
CVH

 2256 QCAD BugtrackerECMAScriptBug ReportLow Getting the end direction of a zero-length polyline lea ...ClosedCVH Task Description

Andrew,

With an RPolyline shape.
That is trimmed by RPolyline.trimEndPoint(cutPoint1, RVector.invalid, false);
And what is turned into a null-shape having only one single vertex.
Getting the end orientation of such a shape lead to an Application Crach.

RPolyline.getDirection1(); Doesn’t fail and returns 0.0rad.
RPolyline.getDirection2(); Fails critical.

I would have expected 0.0rad or ‘undefined’ for both.

One can circumvent that with simply testing the nature of the RPolyline before getting the end direction, and this each time required.

Regards,
CVH

 2244 QCAD BugtrackerQCAD (main)Feature RequestLow Add poyline segment midpoint to 'Store Positions' Closed1CVH Task Description

Andrew,

Besides that Misc .. Information .. ‘Store Positions’ - stores the startpoint of each polyline
- or stores all nodes of each polyline (With: InfoStorePositions/PolylineNodes = true)
Refering to https://qcad.org/rsforum/viewtopic.php?t=6300

I somethimes require the midpoints of the line and arc segments as spline controlpoints
+ the start and the endpoint when geometrical open.

Could that be made an undocumented preference too?

Regards,
CVH

 2204 QCAD BugtrackerQCAD (main)Bug ReportLow Modify > Break out Manual: point order matters with ope ...ClosedCVH Task Description

QCAD Professional
Win7 32bit wininstaller
Version: 3.25.2.13 (3.25.2.13)
Internet: QCAD.org
Build Date: Feb 12 2021
Revision: cad2d36
Qt Version: 5.13.2
Architecture: i386
Compiler: Unknown

Andrew,

Break out Manual (B2) on Arc and open Polyline results
seems to depend on the breakpoint picking order.

A segment is broken out when the picking order is in the entity orientation.
The intended behavior.

That differs when the picking order is opposite the entity orientation.
One would expect that the picking order matters when removing
a segment between the picked points.

Example file included

Noticed while merging code to PolyLineBreakSymbol.js
https://github.com/qcad/qcad/blob/master/scripts/Misc/MiscDraw/PolyLineBreakSymbol/PolyLineBreakSymbol.js Line 300-312 orders cut points on distance from start.
Otherwise, the results where inconsistent.

Regards,
CVH

 2196 QCAD BugtrackerQCAD (main)Bug ReportLow Leader: Arrow removed on load if arrow only fits first  ...Closed1CVH Task Description

Andrew,
This is bugging me for over a year now.
I filed it as a feature request as it is dismissed twice as a possible bug on the forum.
In both cases the advice is to only use Specific Scale 0 for Leaders.
(... and adapt all other dimensions to that)

I am aware that an arrow head has to fit twice on the first leg of a Leader Entity.

The size is set global in the Drawing Preferences under Dimension Settings: ‘Text Height’.
Under Dimension Settings, there is also a global ‘Size scale factor’.
And every dimension entity has a Specific Property called ‘Scale’ that supersedes this global ‘Size scale factor’.

Proof of concept: Dim size 5 and for any regular dimension.
1) Size scale factor 1, Specific Scale 0 » text height & arrow length = 5 units.
2) Size scale factor 2, Specific Scale 0 » text height & arrow length = 10 units.
3) Size scale factor 2, Specific Scale 1 » text height & arrow length = 5 units.
4) Size scale factor 1, Specific Scale 2 » text height & arrow length = 10 units.
5) Size scale factor 10, Specific Scale 0.5 » text height & arrow length = 2.5 units.
6) Size scale factor 99, Specific Scale 0.1 » text height & arrow length = 0.5 units.
→ Obvious is that the ‘Specific Scale’ supersedes the dimensions ‘Size scale factor’.

Those two last Leader arrows (2.5 & 0.5 long) would definitely fit twice on an 8 units long first Leader leg! And they do perfectly while drawing them.

However, the arrow will be reset when the file is saved & loaded.

For case 5 the first leg has to be (2 times 5×10) 100 units or over so an arrow 2.5 long remains on save (=40 times). In the absurd case 6 that would be (2 times 5×99) 990 units or over for an arrow only 0.5 units long (=1980 times).
Verfied and true.

It seems that on save/load:
The Specific Scale is not taken into consideration while evaluating ‘At least twice’.

Apart from that they render fine when first drew.
And reappear when setting the arrow back on again after load.

Regards,
CVH

2178QCAD BugtrackerQCAD (main)Bug ReportLowStored Color of text dimension changesAssigned1CVH Task Description

QCAD Pro 3.25.2.7 Win7 Wininstaller 32bit
Related Topic:
https://www.qcad.org/rsforum/viewtopic.php?&t=7954

Reported is that black is saved as #00004c (dark blue)
Radek (iMac (Retina 5K, 27-inch, 2017), Catalina 10.15.7 (19H114)

My system/installation saves black as #4c000 (dark red)

When using single primary colors these get reduced to #4c, #7f, #99, #cc & #ff.
The threshold for that are #00, #65, #8b, #b2 & #e5
See: DimColorScale (png & dxf)

8 standard CAD colors fail saving correct
Black (something with #4c)
Dark Red, Dark Green, Dark Blue, Dark Cyan, Dark Magenta, Dark Yellow
(#80 turns #7f)
& Gray
(#adadad instead of #a0a0a4)

As with Gray, when mixing the 3 colors it gets rather fuzzy ...
#505050 & #555555 both turn #5b5b5b
&
#464646 turns #4c4226

A snippet of my investigation is included in the topic
(45 files in a ZIP)

CVH

2177QCAD BugtrackerDocumentationSuggestionLowUpdate class_r_polyline.htmlAssigned1CVH Task Description

Include RPolyline.getLeftRightOutline() method in class_r_polyline.html

In use since 11 Sept 2020

CVH

2174QCAD BugtrackerQCAD (main)Bug ReportLow[SOLVED] Numerous shortcomings when exploding Polylines...Assigned1CVH Task Description

QCAD Professional
Windows 7, Win installer 32bit
Version: 3.25.2.7 (3.25.2.7)
Internet: QCAD.org
Build Date: Dec 16 2020
Revision: e06f230
Qt Version: 5.13.2
Architecture: i386
Compiler: Unknown

Issues most likely unrelated to OS and installations before 3.25.
Related post:
https://qcad.org/rsforum/viewtopic.php?&t=7982

Flaws documented in full in attached dxf.
The dxf has meaningful Layer States.

4 Columns:
- Prior Art
- The test cases
- Actual results
- Results with proposed fix

Tried as many things as I can come up with.
Orange: Flaws
Red: Errors
Green: Good results (or as good as I can get them)

Solution(s) given in attached script explode.js
(I am just a simple guy and wouldn’t know how to file a pull request on GitHub ......)

In section: “explode polyline into line and arc segments”
group: “if (RPolyline.hasProxy() && polyline.hasWidths()) {....}”
All additions, updates & typos are marked with “CVH”, one can textual search for it.
Over-documented for sure.
Any Eaction is to debug in Windows and is obsolete.

Included PreferencesPage.ui is updated for the all Splines from Text fix
Still in consideration: Forcing cubic splines from text to degree 2 ...
... I am rather convinced ...

CVH

 2170 QCAD BugtrackerQCAD (main)Bug ReportLow Draw > Text: Wrong color for formatted text blocks usin ...Closed1CVH Task Description

QCAD Professional
Win installer 32bit
Version: 3.25.2.7 (3.25.2.7)
Internet: QCAD.org
Build Date: Dec 16 2020
Revision: e06f230
Qt Version: 5.13.2
Architecture: i386
Compiler: Unknown

File & picture included
Work around: Chop it up or use a TTF font

Regards,
CVH

 2168 QCAD BugtrackerQCAD (main)Bug ReportLow Explosion of a bulging Polyline with Widths may include ...Closed1CVH Task Description

QCAD Professional
Win installer 32bit
Version: 3.25.2.7 (3.25.2.7)
Internet: QCAD.org
Build Date: Dec 16 2020
Revision: e06f230
Qt Version: 5.13.2
Architecture: i386
Compiler: Unknown

Follow up on: https://www.qcad.org/bugtracker/index.php?do=details&task_id=2023
The zero crossing at 180° turn is fixed.

Found two very minute Line segments where the Width is set zero.
Revision dxf included.

Referring to the grid they are rendered about 0.0002 long.
They are in the order of 5e-15 and less or simply zero long in this case (<1ULP).
Results may vary in length ... and vary after Save/Revert.
Files included: PolyWidthErrLargeArc_v2.csv (a/b)

Not encountered on a Polyline with line segments.

Regards,
CVH

2167QCAD BugtrackerQCAD/CAMBug ReportLowComma format decimal separator fails ZSafety CAM config...Assigned1CVH Task Description

QCAD/CAM
Trial package Win installer 32 bit
Version: 3.25.2.0 (3.25.2)
Internet: QCAD.org
Build Date: Sep 4 2020
Revision: 4a61501
Qt Version: 5.13.2
Architecture: i386
Compiler: Unknown

Local decimal separator is ‘,’ (comma)
In CAM configuration .. Z Levels .. Safety level

Using nn,nnn the output is Nxx G0 Znn
Using nn.nnn the output is Nxx G0 Znn.nnn

Drop down boxes are all in dot format.
Didn’t try anything else yet ;-)

Regards,
CVH

 2165 QCAD BugtrackerQCAD (main)Bug ReportLow Rectangle with Size (RS) doesn't remember Fill, RoundCo ...Closed1CVH Task Description

QCAD Professional
Win installer 32bit
Version: 3.25.2.7 (3.25.2.7)
Internet: QCAD.org
Build Date: Dec 16 2020
Revision: e06f230
Qt Version: 5.13.2
Architecture: i386
Compiler: Unknown

Topic: https://qcad.org/rsforum/viewtopic.php?f=33&t=7900
Report: https://qcad.org/rsforum/viewtopic.php?f=33&t=7900#p30977

Rectangle with Size (RS) doesn’t update the Fill, RoundCorners & Radius settings shared under the [Shape] header in QCAD ini.

Explained as group synchronization while the Polygon methods have more settings in common, although not shared.

In the summary there are more minor issues listed.
All have a bar in the Options Toolbar that disappears after the first is drawn.

I rather would opt for all individual settings ...
... or all grouped.

Regards,
CVH

2162QCAD BugtrackerQCAD (main)SuggestionLowUpdate the parameter with simplify of RPolylineData & R...Assigned1CVH Task Description

Unrelated to OS, nor version

Reported Jun 23, 2020 in: https://qcad.org/rsforum/viewtopic.php?f=30&t=7372

Status Dec 24, 2020: https://qcad.org/rsforum/viewtopic.php?f=30&t=7372#p30955 Documentation is updated.
The Classes still refer to an ‘angleTolerance’.

Regards,
CVH

2161QCAD BugtrackerQCAD (main)Feature RequestLowMake Polyline from Selection (OC) configurable for simp...Assigned1CVH Task Description

QCAD Professional
Win installer 32bit
Version: 3.25.2.7 (3.25.2.7)
Internet: QCAD.org
Build Date: Dec 16 2020
Revision: e06f230
Qt Version: 5.13.2
Architecture: i386
Compiler: Unknown

Not related to OS, nor version.

The method Polyline from Segments (OC) can be configured for tolerance and simplification in the Options Toolbar.
The method Polyline from Selection (OG) has no UI or none showing.

OG retrieves a tolerance from QCAD.ini, what is initially not set:

    var tolerance = RSettings.getDoubleValue("PolylineFromSelection/Tolerance", 0.001);

The tolerance will be default = 0.001 similar as the default in AppPrefs.
The tolerance setting is included in QCAD.ini after changing the AppPrefs entry.

OG calls PolylineFromSelection.autoJoinSegments with this tolerance:

    var counter = PolylineFromSelection.autoJoinSegments(di, tolerance, this);

PolylineFromSelection.autoJoinSegments calls PolylineFromSegments.createPolylineShape
with simplification hard coded to true. (last parameter)

    // create polyline from line, arc, spline or open polyline entity:
    var polyline = PolylineFromSegments.createPolylineShape(
                    entity, doc, vTolerance, op, undefined,
                    traversed, callBacks, undefined, true);

I would like to see the simplification optional and default = true.

Regards,
CVH

2160QCAD BugtrackerQCAD (main)Bug ReportLowDraw > Polyline > Relocate Start Point: fails on polyli...Assigned1CVH Task Description

QCAD Professional
Win installer 32bit
Version: 3.25.2.7 (3.25.2.7)
Internet: QCAD.org
Build Date: Dec 16 2020
Revision: e06f230
Qt Version: 5.13.2
Architecture: i386
Compiler: Unknown

Origin:
I like to start my CAM paths at low curvature instead starting at high curvature.
Ellipses may explode with the startpoint at the tip. (file Y2)

Documented in 3.25.2.4, reproducible under 3.25.2.7

File included with 4 LayerStates
- Original Ellipses: Y1
- Exploded to polylines (32 segments): Y2
- Direct after XP, OR performs different on the left top one: Y3
- Faulty solutions by OR: Y4 (= saved state)

The results may differ with the saved explosions.

With the file.
Y1
TA
XP
Relocate startpoint with OR to an existing reference (called ‘End’)

Regards,
CVH

2159QCAD BugtrackerQCAD (main)Bug ReportLowDraw > Polyline > Polyline from Selection: may induce N...Assigned1CVH Task Description

QCAD Professional
Win installer 32
Version: 3.25.2.7 (3.25.2.7)
Internet: QCAD.org
Build Date: Dec 16 2020
Revision: e06f230
Qt Version: 5.13.2
Architecture: i386
Compiler: Unknown

Discovered in 3.25.2.4, reproducible under 3.25.2.7

Draw any open or closed chain of line entities.
Select All.
OC to Polyline.
Step through vertices.

No example file provided because these NaN values are not saved to a file.
More pronounced with lines as with arcs.
Less pronounced when recombining after an explosion.
Some methods clear these to value = void.
Some methods clear these to zero (OR).
Can also occur when adding segments to an existing polyline with OC.

Regards,
CVH

2157QCAD BugtrackerQCAD (main)Bug ReportLowControlpoint Spline exploded to polyline may induce NaN...Assigned1CVH Task Description

QCAD Professional
Win installer 32bit
Version: 3.25.2.7 (3.25.2.7)
Internet: QCAD.org
Build Date: Dec 16 2020
Revision: e06f230
Qt Version: 5.13.2
Architecture: i386
Compiler: Unknown

Documented in 3.25.2.4, reproducible under 3.25.2.7
In the attached file:
→ Explode the trial cases and locate NaN Widths.
→ These faulty widths are cleared while saving and reverting.
= work around.

Related Post: https://www.qcad.org/rsforum/viewtopic.php?t=7902#p30902
Related Topic: https://www.qcad.org/rsforum/viewtopic.php?t=7901
Related Commit: https://github.com/qcad/qcad/commit/fcd7929bced7ae328029c1aa2ee2aff2745709c6

Arctic_Eddie reports failing CAM offset at exactly these points !!!
Reported is a faulty arc with radius of over 360,000mm.
- I can not reproduce this under QCAD working further on the Polys with NaNs.
- However the direct offset of such controlpoint Splines is erroneous.
(see file in post 30902)

Arctic_Eddie reports arc radii of over 10,000mm.
- These don’t seem to be faulty.
- I agree that BiArc fitting should be bound to a lower and certainly to an upper limit.
- That should be huge otherwise faint curvature is represented by many
wobbles or too quick by straight lines.
(All this, keeping in mind that QCAD doesn’t return the optimum fitted BiArc, see: https://www.qcad.org/rsforum/viewtopic.php?t=4859)

Regards,
CVH

 2156 QCAD BugtrackerQCAD (main)SuggestionLow Add an option to XP preferences to include circles or n ...Closed1CVH Task Description

Andrew,
unrelated to any OS or version.

Circles do explode to polylines with two arc segments.
Discussed earlier and very correct because a full circle bulge would be a mathematical limit situation.

When there is no option to ‘Undo’ anymore or when the file was saved & loaded there is no easy way back.

One of the reasons why I isolate circle entities if I might going to use XP as in the file here:
https://qcad.org/bugtracker/index.php?do=details&task_id=2155
Even knowing it, I still make more mistakes as I would like. ;-)

It would be nice to be able to exclude circle entities from the GUI explosion action XP.
Can be simply implemented in the top of Explode.explodeSelection with an extra preference in AppPrefs, default =true.

On the other hand, the explosions of circles used internally in various methods should remain.

Regards,
CVH

2145QCAD BugtrackerQCAD (main)Bug ReportLowModify > Trim Both: closed polyline as either entity br...Assigned1CVH Task Description

QCAD Professional

Version: 3.25.2.4 (3.25.2.4)
Internet: QCAD.org
Build Date: Nov 18 2020
Revision: 40f4475
Qt Version: 5.13.2
Architecture: i386
Compiler: Unknown

Use TM by mistake to trim a line to a closed shape.
Topic: https://qcad.org/rsforum/viewtopic.php?f=33&t=7780
File included in the topic.
Y1 Original
Y2 Faulty use of TM
Y3 After ‘Undo’

Husky only ‘could agree on a not proper working undo
The conditional clause of this sentence is ‘the odd choice’.
Blaming this on incompetence.
Insight is the best way to get better ...
... but the rest is more an odd choice of tools for this kind of task ...

Again, the MISTAKE was by accident, not intended, in a flick of the wrist ...
I didn’t change the trimming method, I simply forgot to ... only once.

The ‘undo’ of my incompetent MISTAKE didn’t returned to how the situation was before I erroneous trimmed with TM.
I was simply undoing my erroneous action.

Documented it in 4 quadrants.
For this, 4 times on purpose, and not as a consistent ‘odd choice’.

Regards,
CVH

 2141 QCAD BugtrackerECMAScriptSuggestionLow Typo in simple.js ClosedCVH Task Description

Andrew,

Both disableInput() & enableInput() in simple.js
state that input is prevented ...

It is most obvious ;-)

Regards,
CVH

 2108 QCAD BugtrackerECMAScriptReleaseLow FlexPainter update Beta 0.42e ClosedCVH Task Description

https://qcad.org/rsforum/viewtopic.php?f=30&t=6547&p=29307#p29307

FlexPainter is updated.

Should not load while PROTOOLS are absent.

Regards,
CVH

 2078 QCAD BugtrackerQCAD (main)Bug ReportLow Draw > Hatch: Small gap tolerated by QCAD, not by DXF/D ...ClosedCVH Task Description

https://qcad.org/rsforum/viewtopic.php?f=33&t=7254

It seems to be an accuracy problem.
The original hatch boundaries are defined from 732 single entities.
These interconnect with an accuracy better then 1e-10 except for a gap of 0.000814 in two places.

Creating a Hatch of these entities with TA-HA is rather slow but succesfull.
After Save-Close-Open the Hatch may look different or may even be missing (=Null).

Suspected is that:
The recreation off the Hatch on load uses some other accuracy setting.
The outer boundary is not found and only some inner ones are considered as outer.

But that explains not why it looks fine after initial creation.
Nor that the outcome of a retry may vary.

Regards,
CVH

 2059 QCAD BugtrackerQCAD (main)Bug ReportLow Modify > Explode: Error with hatch in block with positi ...ClosedCVH Task Description

See Forum Topic:
https://www.qcad.org/rsforum/viewtopic.php?f=33&t=7093

Isolated in Reply:
https://www.qcad.org/rsforum/viewtopic.php?f=33&t=7093#p27329

Sorry forgot to mention.
Reported by User 2CV375 qcad/cam version 3.24.2.0 (3.24.2) on Windows 10.
Reproduced in Qcad pro 3.24.2 on Windows 7/32.

2016QCAD BugtrackerQCAD (main)Bug ReportLowOffsetting multi selection of polylines halts prematureAssigned1CVH Task Description

See:
https://qcad.org/rsforum/viewtopic.php?&t=6827&p=25992#p25992

Offsetting 32 polys from ellipses fails.
Offsetting 16 polys can be completed with 2 selections for outer and 2 for inner.

For some reason the offset function halts premature.

Regards,
CVH

 1985 QCAD BugtrackerQCAD (main)Bug ReportLow Hatch dots are rendered as lines with fixed length of 0 ...ClosedCVH Task Description

With some unit and scale combinations dots rather look like dashes.
https://qcad.org/rsforum/viewtopic.php?t=6685#p25325

1983QCAD BugtrackerQCAD (main)Feature RequestLowTrim All or Bulk Break outAssigned3CVH Task Description

This is a trim method I am missing in Qcad.

20 years ago it existed in CadKey.
You had a bunch of lines or segments.
You defined a (new) line or segment as cutter.
‘Trim All’.
You pointed at the side of the cutter entity to trim all intersecting at that side.

Pritty the same as in this topic:
https://qcad.org/rsforum/viewtopic.php?t=5221

Only in rare cases I can use Husky’s workaround as pro.
It all depends on what else is in the clipping rectangle that is needed to trim all intended.
If of no use all single crossing entities have to be chosen one by one.

Regards,
CVH

1976QCAD BugtrackerQCAD (main)Feature RequestLowEnvelope at offset to a poly toolAssigned1CVH Task Description

See:
https://www.qcad.org/rsforum/viewtopic.php?t=6650

1928QCAD BugtrackerQCAD (main)Feature RequestLowOptionnally 'Auto clean up' after generation of NaN / N...Assigned1CVH Task Description

Some functions / methods can generate some sort off entity or part with NaN / Null / Null-lenght ... props.
Some explicitly don’t and test their actions with isNull().

As these serve a purpose in some processes, trails of them can be part of the results.
For some users Null / Null-lenght are meaningfull, for other users these produce errors down the line.
In a few cases its a desirable feature eg. controlpoint spline.
(Allthough there are no Null props involved with equal successively controlpoints)

Many problem post on the forum are related to Null - Zero and so on.

In some cases it can’t be undone by re-editing the drawing.
https://qcad.org/bugtracker/index.php?do=details&task_id=1925

If it can’t be undone by Undo/Redo it is a bug.
https://qcad.org/bugtracker/index.php?do=details&task_id=1757

In some cases there is a difference noticed after file save-close-open.

 1925 QCAD BugtrackerQCAD (main)SuggestionLow Poly Ref Points manipulation that generates null-segmen ...ClosedCVH Task Description

Win7pro 32bit Wininstaller Qcadpro 3.23.0

With a polyline.

Select the poly.
Pick any reference point of a vertex.
Place it on any of its neighboring vertex reference points.

A null-segment is created.
The placement can not be undone by re-picking the reference point.
Can be Undone/Redone.
The action can result from editing the vertex coordinates.
When exploding null-entities are created.

This action should delete:
- if the target is next: the picked vertex. (incl. start or end-1)
- if the target is prior: the targetted vertex. (incl. start or end-1)
- if the target is and next and prior: both the prior and the picked vertex.

As the user intentionally places any vertex reference points on:
- any excluding its neighbors:
→ the intented nature is ‘Self-Touching’, ‘Self-Crossing’ or ‘Trace-Back’.
- any of its neighbors:
→ the intention is to delete the segment(s).

Regards

 1924 QCAD BugtrackerQCAD (main)Bug ReportLow SweepAngle = 0 ClosedCVH Task Description

Win7pro 32bit Wininstaller Qcadpro 3.23.0

Draw an arc.
Select the arc.
In Property Editor:
Set start angle to 135
Set end angle to 135

SweepAngle = */-360

edit the end angle and add “+360”, hit enter

SweepAngle = 0

An arc with zero sweep is a point.
A point is not an arc.
With the same start and end parameter an arc should have a sweep of +/-360.
As for entries by points or by angles.

Regards

 1918 QCAD BugtrackerQCAD (main)Bug ReportLow Splines whit control points of order 1 and 4 not select ...ClosedCVH Task Description

Set up a spline with control points let’s say of the order 3.
Clone it 3 times with some offset in x&y.
Edit the degree property and set 1ste to 1, 2nd to 2, aso
Draw select partially from right to left.
Those of the order 1 and 4 aren’t selected.

Regards

 1906 QCAD BugtrackerQCAD (main)Bug ReportLow Draw > Polyline > Polyline from Segments: Converting fu ...ClosedCVH Task Description

Win7/32bit
QCADpro 3.22.1.0

Full 360 degrees Arcs don’t convert correct to polylines with the methods OG and OC.
Both methods create a zero-length open type Polyline and remove the full Arc.
OG creates a Poly with 2 vertexes at the startpoint (= endpoint) and OC one with 0 (zero!) vertexes.
The firts one is selectable, the second one only with ‘Select All’//TA because there are no references.

The OL method with the same start and endpoint doens’t affect the full arc.
Neither a poly is created nor an error is generated that the method failed.

Typical the bulge of the OG method is (-)16331239353195370, the OC method has no references.
The math to calculate the bulge should result in a division by zero or an illegal function as tan(π/2).
Therefore a polyline can’t contain a 360 degrees arc by standard means.

From the OC method is known that it simplify coradial arc strings to a single arc.
This should not result in 360 degrees arcs what would result in zero-length segments.
(With CAM fuzzy things may happen at such positions)

Simplifying coradial arcs strings that would create a 360 degrees arc should result in no less then two coradial Arcs.
The OG method will then creates a open Poly with 3 vertexes, OC a closed one with 2 vertexes.

Found while fiddling around with editing CXF fonts.
CXF uses full Arcs, two half arcs and even polylines with coradial segments that forms circles are supported,
the OC closed polyline with 2 vertexes is recoded as two 180 degree Arcs (90-270&270-90).

Regards
CVH

 1802 QCAD BugtrackerQCAD (main)Bug ReportLow Startpoint indication disapears for some entities while ...ClosedCVH Task Description

Having a multi selection and at least one ‘older’ arc the startpoint indication in red of some entities might disappear.

Entities that suffer from this are:
Other arcs
Polyline
Splines

Only the ‘oldest’ arc in selection will have a startpoit indication.
Multi selection of ‘newer’ entities from the list above will not if an ‘older’ arc is part of the selection.
Deselecting de ‘older’ arcs will reveal the startpoints up to the ‘oldest’ arc.

In the file provided entities where drew in order from left to right.
Select all and start deseleting arcs from the left.

The behaviour is affected by changing the draw order property and a save/close/open.
In the second file the rightmost arc was set to draw order 7, the same as the 4th was.
After save/close/open it is renumbered to 8 and the behaviour is different as in the firts file.

Regards

 1768 QCAD BugtrackerQCAD (main)Bug ReportLow Draw > Polyline > Create From Segments: segments delete ...Closed1CVH Task Description

‘Create From Segments’ ‘OG’ includes and admits selection of segments on locked layers.

A)
-When selecting a segment on a not locked layer it can include segments on locked layers that connect to the string. (Assumed wrong)
-A copy of the segments on the locked layer(s) are included in the polyline. (Assumed wrong)
These segments are not removed from the locked layer(s) because of their locked nature. (Intended behaviour)
eg. ‘OG’ & selecting the arc at point A in the example file. The arc is on a not locked layer.

B)
-When selecting a segment on a locked layer it will fully remove segments that connect to the string on not locked layers. (Assumed very wrong)
-Connecting segments on the locked layer(s) will not be converted to a polyline because of their locked nature. (Intended behaviour)
eg. ‘OG’ & selecting the line at point B in the example file. The cyan lines are on a locked Layer.

Both A & B can be undone.

The example is a part of the ‘Skewing project’.

Regards
CVH

 1763 QCAD BugtrackerQCAD (main)Feature RequestLow Simple Modify Move function ClosedCVH Task Description

Moving things require an extra click on ‘Delete original’ and a click on ‘OK’

A simple Modify Move functionality will reduce mouseclicks for moving by 2 for every move that is made.

Regards

 1761 QCAD BugtrackerQCAD (main)Bug ReportLow Info Polyline area does not find polylines (II) ClosedCVH Task Description

Selecting Info // Polyline area
And hovering over a drawing with all kinds of entities.
Does not find any polyline on the drawing hovering over them.
Nor clicking on them.

Not a locked layer issue.
All are visible.

 1757 QCAD BugtrackerQCAD (main)Bug ReportLow Modify > Auto Trim: on polyline, followed by undo yield ...ClosedCVH Task Description

Breaking up self-intersecting Polys at segments crossing
can’t be done for the second segment.

Divide:
A new node is inserted and made start and end node.
For the second segment no division occurs or can be made.
Expected is that the segment the nearest to the selecting point is addressed.
Eg. the trim command.

Breakout gap:
- 1 Part fully trimmend of
- Can be undone

Auto trim:
(hint: do file-save first to revert)
- 1 Part fully trimmend of
- Undo will wipe the complete poly

In the file example 1.

Work-arround:
- Divide
- Insert node on the second segment not at the crossing
- Divide at that node
- Move new nodes to crossing

QCAD 3.20.1 Win7 32bit
Kind Regards

 1756 QCAD BugtrackerQCAD (main)Bug ReportLow Polyline area wrong if polyline contains arc segments ClosedCVH Task Description

The area of polylines with arcs can be incorrect.
With only line segments it is correct as far as I can check.
See <Poly-line Area.dxf> ; <Poly-arc Area.dxf>

It does not depend on the quadrant their in nor with what point the start point is.
It is related with the oriëntation.
Flipping or mirroring horizontally induce the error.

Modifications like flip, move & copy may induce another error that locks the oriëntation.
It is noticed that the oriëntation property in the editor does not change anymore when reversing.
Although locked the value of the area property switches between good and wrong.

The master poly in question is a part of an arc and a part of an ellipse exploded 1024/full.
These where recombined to one poly with ‘Create from selection’ and are closed.
Closed as per the last vertex does not point to the start point, logically closed I presume.
The purpose is to sum the error surface for the skewing math.
For now I will use my common sence to distinguish what value is the correct one.
Reversing while found faulty is the solution.

Version: 3.20.1.0 (3.20.1)
Internet: QCAD.org
Build Date: Apr 13 2018
Revision: dd51609
Qt Version: 5.5.1
Architecture: i386
Compiler: MSVC++ 10.0 (2010)
Win7 32bit

Regards

1755QCAD BugtrackerQCAD (main)Feature RequestLowSelecting standard rotation angles by mouse click for M...Assigned1CVH Task Description

This would be nice.
It will save a lot mouse - keypad changes for me.

 1752 QCAD BugtrackerQCAD (main)Bug ReportLow Not selecting text with sub/superscript ClosedCVH Task Description

Found a strange behaviour with formatted text.

File attached.
‘Draw’-selecting only the yellow text with a little space arround it
- L>R or R>L ⇒ Yellow text not selected.

‘Draw’-selecting only the yellow text with a little space from R>L but crossing the text half way
- Yellow text Selected ⇒ Expected behaviour.

‘Draw’-selecting just including the mentioned little circles.
- Orange L>R or R>L ⇒ Normal texts selected ⇒ Expected behaviour
- Green L>R Yellow not R>L Yellow selected ⇒ Expected behaviour
- Magenta L>R or R>L ⇒ Yellow text not selected ??
- Red L>R or R>L ⇒ Yellow text not selected ??

Version: 3.20.1.0 (3.20.1)
Internet: QCAD.org
Build Date: Apr 13 2018
Revision: dd51609
Qt Version: 5.5.1
Architecture: i386
Compiler: MSVC++ 10.0 (2010)
Windows 7 32-bit

Kind Regards

 1749 QCAD BugtrackerQCAD (main)Feature RequestLow Add support for non-uniform block scaling Closed1CVH Task Description

Same txt as on the forum.
had a copy because i had to log in 3 times to remark my own post.

Blocks are no solution either.

see pdf
[attachment=0]Block test_1.pdf[/attachment]

Antartica is put in a block as segments.
Added a rounded corner as segments and as poly.
scaled X x0.5 Y x1 origin the center of the magenta circl.

The scaled version is all over the place.
Set them to color red, no use they stay black.

The reference of the block is 2000mm to the left because I tried it out far right of my design.
The cyan circle is about 400mm in diameter.

dxf part included
[attachment=1]Block test.dxf[/attachment]

Version: 3.20.1.0 (3.20.1)
Internet: QCAD.org
Build Date: Apr 13 2018
Revision: dd51609
Qt Version: 5.5.1
Architecture: i386
Compiler: MSVC++ 10.0 (2010)

CVH

 1708 QCAD BugtrackerQCAD (main)Feature RequestLow Layer > Select Layer: add feedback ClosedCVH Task Description

Win 7
Q-CAD 3.19.2

R-Click in Layer list
With a selection, selecting by Layer adds the Items on that Layer to the selection.
With a selection, deselecting by Layer subtracts the Items on that Layer from the selection.
This is not a bug in casu because this can be the intention of the function. Adding or Subtracting.

Intuitively ‘selecting by Layer’ to retrict to that Layer solely has only the desired effect if no selection existed before.
Deselecting by Layer with no previous selection should mention there was none to start with.
Selecting by Layer from an empty Layer should mention that nothing is added.

Faults are prone to make.

Selecting a Layer uniquely would be an interesting additional feature.

Regards

 1648 QCAD BugtrackerQCAD (main)Feature RequestLow Uniform Layer listing in dropdown as in Layer List Widg ...Closed1CVH Task Description

The order layers are listed in dropdown boxes is different as how there are presented in the Layer List Widget.
Uniformity can shorten lookup time drastically with a large number of layers / sublayers.

Showing tasks 1 - 50 of 80 Page 1 of 21 - 2 -

Available keyboard shortcuts

Tasklist

Task Details

Task Editing