All Projects

IDProjectCategoryTask TypeSeveritySummaryStatusOpened by
 904 QCAD BugtrackerQCAD (main)Bug ReportHigh Crash when inserting some blocks from part library Closed-- Task Description

Tested on Linux Mint-64
Inserting some exsisting blocks or newly user created blocks makes QCAD quit!
Permissions were checked and also tested by submitting new blocks to new folder...but problem remains.
See related topic:

 900 QCAD BugtrackerQCAD (main)Bug ReportHigh Using text in 3.1.2 freezes QCAD Closed-- Task Description

Placing text in a drawing using 3.2.1 causes the application to freeze.
Please see topic:

 799 QCAD BugtrackerQCAD (main)Bug ReportHigh Detect duplicates not working properly Closed-- Task Description

Windows 7-64
Detect duplicates tool not working properly.
Selecting this tool causes program to lag endlessly and malfunctions.
To reproduce bug:
1. Select all entities.
2. Select duplicates tool.
3. Nothing happens.
4. Select duplicate tool again and...bug!

 406 QCAD BugtrackerQCAD (main)Bug ReportHigh QCAD Version 3 RC2 .exe does`nt run  Closed-- Task Description

Hi Andrew

I uninstalled QCAD 3 RC1 first then installed V3-RC2 seems to install ok but when I run qcad.exe it complains everytime that qcad.exe has stopped working!

Running on Windows 7 - 64bit



 518 QCAD BugtrackerQCAD (main)Bug ReportMedium Unable to use Library browser properly in RC4 Closed-- Task Description

Hi Andrew

In Ubuntu 11.10 and Windows 7 everything so far is working ok in QCAD apart from the Library browser!

1.In Win 7-64 I can run the browser and make a new folder, but when I try to set the permissions/open the folder - browser crashes.

2.In ubuntu 11.10 I first uninstalled RC2 then installed RC4. QCAD program runs ok but this time when I try to open up the browser (not a new folder)I get an error message stating that I do not have permissions to open the first file (vehicle -I think!)in RC2? If I select OK in the warning window the warning just keeps on repeating the same message for the next and subsequent files until I quit it.

1731QCAD BugtrackerQCAD (main)Feature RequestLowOption to place text to other sideAssigned1-- Task Description

Hi Andrew,

It would be good to have an option to be able to place the text to the left or right,maybe just a simple check box? please see attached screenshot to explain. In this instance (and I have to do this a lot ;)) I had to explode the dimension entity and rearrange the text manually :(

Many thanks


 1730 QCAD BugtrackerQCAD (main)Bug ReportLow Point display in a layout / print preview not correct Closed-- Task Description

Hi Andrew,

When placing a point in a layout it gives an incorrcet display, for example if I place a cross point style I get a rather strange shape in return!

Many thanks


 1727 QCAD BugtrackerQCAD (main)Bug ReportLow Autosave - Error feedback - DXF staed but should be DWG Closed-- Task Description

Hi Andrew,

Just a little thing I noticed recently.

My default is set to save as DWG and indeed it does, however the auto-save feedback tells me that the file is saved to DXF, although it actually does save to DWG - no big deal but is this correct feedback?

Many thanks


1722QCAD BugtrackerQCAD (main)Feature RequestLowOption to insert viewport at either of the rectangle co...Assigned1-- Task Description

Hi Andrew,

Currently the only option to insert a viewport is using the central insertion point, for better placement it would be useful to have an option to insert viewports at any of the four corners in addition to the centre.

Hope that makes sense.

Many thanks


1721QCAD BugtrackerQCAD (main)Feature RequestLowInsert table toolAssigned5-- Task Description

Hi Andrew,

I’m not sure whether this has been added or suggested already. It would be great to have a built in QCAD table tool for producing cutting lists or bill of materials etc. A dedicated table tool would be a real boost to QCAD Pro ;)

Many thanks


1699QCAD BugtrackerQCAD (main)Feature RequestLowDimensioning - add option to insert text in the middle ...Assigned-- Task Description

Dimensioning - add option to insert text in the middle of dimension.

To have an option to have text aligned in the middle of the dimension line, rather than above it.

1698QCAD BugtrackerQCAD (main)Feature RequestLowDimensioning - add option to split dimensionsAssigned-- Task Description

Dimensioning - add option to split dimensions.

To have an option to split the extension lines if they run over other entities.

1697QCAD BugtrackerQCAD (main)Feature RequestLowDimensioning - add option for horizontal text alignmentAssigned-- Task Description

Dimensioning - add option for horizontal text alignment.

Basically an option in drawing preferences to align text horizontally instead of vertically.

 1695 QCAD BugtrackerQCAD (main)Bug ReportLow Context menu: editing tools not working in paper space Closed2-- Task Description

Tools not working from context menu in paper space.

1651QCAD BugtrackerQCAD (main)Feature RequestLowChange thickness of arch tick for dimensioningAssigned-- Task Description

An option in the drawing preferences to change the line thicknesses for arch ticks would be a huge plus, at the moment I am having to insert ‘arch tick’ blocks for this.

 1650 QCAD BugtrackerQCAD (main)Feature RequestLow Option to remember / configure specific folder to save  ...Closed-- Task Description

Option to remember / configure specific folder to save to when creating a library block.

Currently every time I want to create a library item I have to navigate to where I want to save the block - unless this is a bug and not working properly? I set the library path and re-started QCAD, but it doesn’t seem to work for me now!

1647QCAD BugtrackerQCAD (main)Feature RequestLowAdd point / dot option for leaders Assigned-- Task Description

Hi Andrew,

Hopefully you might be able to squeeze this one around your busy schedule.

Would it be possible to add in the property editor an option to change a dimension arrow to a point / filled dot and maybe also a tick?

I see you are working on some viewport stuff, I am very much looking forward to testing some of this out ;).

Many thanks


1632QCAD BugtrackerQCAD (main)Feature RequestLowOption to add bespoke dimension precision + tolerance s...Assigned-- Task Description

Hi Andrew,

1. I cannot find a way of selecting individual dimensions and changing the precision lets say from 0.00 to 0.000 for these particular dimensions only without affecting all the rest of the dimensions in the drawing - could an option be added for doing this in the property editor or not?

2. Would it be possible to add an option in the drawing preferences so that automatically a symbol is added at the correct placement fo all dimensions, in this case a tolerance plus/minus symbol?

Many thanks


 1612 QCAD BugtrackerQCAD (main)Feature RequestLow Multi - Lengthen / Shorten Tool Closed-- Task Description

To have an option added to the lengthen / Shorten tool to be able to select more than one entity and do a ‘multi’ lengthen / shorten operation.

 1611 QCAD BugtrackerQCAD (main)Feature RequestLow Cabinet projection at 30 degree also Closed-- Task Description

Hi Andrew,

Cabinet projections are usually drawn at 45 or 30 degrees, having drawn up many furniture configurations over the years, would it be possible to add options for 45 and 30 degrees at all?



 1603 QCAD BugtrackerQCAD (main)Feature RequestLow Curved leader Lines Closed-- Task Description

Hi Andrew,

I would like to request an additional option in the dimension tool set to have a curved leader line, could be just the spline tool with an arrow on the end?



 1547 QCAD BugtrackerQCAD (main)Bug ReportLow PDF won't print out properly Closed-- Task Description

Hi Andrew

I have attached a file which was drawn in QCAD, but for some reason when exported to PDF from QCAD it doesn’t print out properly,all I get is the dimensions only.

When printed direct from QCAD all is fine?



 1532 QCAD BugtrackerQCAD (main)Bug ReportLow Selection Problem ? Closed-- Task Description

Please attached file. When dragging a selection window across only the cyan lines -I get only one line selected?

1505QCAD BugtrackerQCAD (main)Feature RequestLowNew feature - use info tools with scaleAssigned-- Task Description

When using the info tools, like the point to point measure it would be useful to be able to select a scale as well.

For example, when I scale a drawing say to 1:20, when working on the scaled drawing I can measure accurately with the measure tool in 1:20 also, without having to keep refering to the 1:1 drawing.



 1504 QCAD BugtrackerQCAD (main)Bug ReportLow Dimension - Aligned not working with context menu Closed-- Task Description

Dimension - Aligned, not working with context menu.

1503QCAD BugtrackerQCAD (main)Feature RequestLowDetect duplicates within a given selection -new tool re...Assigned-- Task Description

It would be so useful to have an option to be able to detect duplicates within a given selection.

 1494 QCAD BugtrackerQCAD (main)Bug ReportLow polyline offset fails ? Closed-- Task Description

Hi Andrew

Exploded a spline, then created a single polyline from the segments ... but I cannot offset it, to produce another one ?

Is this a bug ?



1489QCAD BugtrackerQCAD (main)Feature RequestLowEdit > Drawing Preferences > Dimensions: Add option to ...Assigned1-- Task Description

It would be extreamly useful to have an option to either use - or not use leader lines in the standard horizontal/vertical dimension line tools, some of the drawings I’m working on need the ‘standard’ looking dimensions with leader lines and some don’t. its a real pain to have to select - explode and delete all the leaders I don’t need.

Hoping for an option



1488QCAD BugtrackerQCAD (main)Feature RequestLowDimension text positionAssigned7-- Task Description

This one is a really important one for me, as currently I am doing a lot of dimension and annotation drawings.
I would like to request an option to be added to the dimension settings for both drawing and application settings to be able to choose whether the dimension text is to the right or left side or over the top or underneath the dimension line.
This would help tremendously when a lot of dimensions are needed!



1470QCAD BugtrackerQCAD (main)Feature RequestLowDouble line tool requestAssigned3-- Task Description

I would love to have a ‘Double Line’ tool in QCAD.

For me this would be such a time saver when drawing out building floor plans in QCAD.

 1461 QCAD BugtrackerQCAD (main)Bug ReportLow Zoom in / out: not centred under mouse cursor if Retina ...Closed-- Task Description

see topic:

 1455 QCAD BugtrackerQCAD (main)Bug ReportLow Orthographic Projection -Cylindrical, clipping query Closed-- Task Description

Please refer to attached drawing

1.Draw square 80mm x 80mm.
2.Draw circle in the centre 44mm dia.
3.Select circle and project using orthographic projection tool (cylindrical) with clipping enabled onto copy of square to the right.
4.Clipping should do what? is it suppose to clip the edges of the square? if so it doesn’t clip and doesn’t seem to make any difference whether I enable the ‘clipping’ option or not.

 1454 QCAD BugtrackerQCAD (main)Bug ReportLow No HTML field for colours in Ubuntu Linux (Mint) Closed-- Task Description

No HTML field for colours in Ubuntu Linux (Mint).

1452QCAD BugtrackerQCAD (main)Feature RequestLowColour opacity optionAssigned1-- Task Description

Not sure how difficult this would be to implement but just wondered if it is possible to have an option in QCAD to change the opacity of a colour ?

related to topic:

 1451 QCAD BugtrackerQCAD (main)Bug ReportLow Space doesn't move focus to undocked command line (Linu ...Closed-- Task Description

Please see topic:

 1414 QCAD BugtrackerQCAD (main)Bug ReportLow No 'Dark' theme available in Linux Closed-- Task Description

In Linux Mint QCAD offers no ‘Dark’ theme, not sure whether this is a bug or not?

 1383 QCAD BugtrackerQCAD (main)Bug ReportLow Updating to Latest QCAD version - Lost Library items ? Closed-- Task Description

When I updated to the most latest version of QCAD I now have no library items - all gone!

 1374 QCAD BugtrackerQCAD (main)Bug ReportLow Using Filter in Tool Settings fails Closed-- Task Description

Presumably after entering a search filter one would press enter on the keyboard, when I enter for example ‘Line’ and press enter the dialog closes and nothing happens ?

1373QCAD BugtrackerQCAD (main)Feature RequestLowLine From Angle - additional option to select exisitng ...Assigned1-- Task Description

Often I find myself clicking on an existing line to determine the angle from the property editor, then copying and pasting this info into the angle field, it would be so very useful to have an additional option in the ‘Line from Angle’ tool to be able to pick an existing entity which would automatically register and fill in the angle for me,then all I would need to do would enter the length required.

1372QCAD BugtrackerQCAD (main)Feature RequestLowDistance Point to Point - option for 'added' distancesAssigned1-- Task Description

It would be useful to have an additional option to be able to count/add up consecutive distances measured with this tool ;)

1371QCAD BugtrackerQCAD (main)Feature RequestLowMatrix - Modify, missing Flip Horizonatal and Vertical ...Assigned-- Task Description

Matrix - Modify, add Flip Horizonatal and Vertical tools

 1370 QCAD BugtrackerQCAD (main)Bug ReportLow Context Menu suddenly stopped working ? Closed-- Task Description

Context Menu suddenly stopped working ?

Yep, tried everything I know of, can’t get it back.

1368QCAD BugtrackerQCAD (main)SuggestionLowContext Menu - suggestionsAssigned1-- Task Description

I love using the context menu, speeding up my workflow indeed.

I would like to suggest that we have the added option to show only icons if desired and also that maybe an option to save and show commonly used tools!

Maybe the context menu could be configurable to show two columns, one for the normal last used tools and the othjer one for the user saved tools?

What do you think?

 1367 QCAD BugtrackerQCAD (main)Bug ReportLow From Context Menu - Move/Copy not working Closed-- Task Description

From Context Menu - Move/Copy not working

It seems that when selection is required to use a modify tool, right clicking for context deselects - of course!

 1366 QCAD BugtrackerQCAD (main)Bug ReportLow Context Menu: Modify > Break Out Gap not working Closed-- Task Description

Using context Menu - Break Out Gap not working

1364QCAD BugtrackerQCAD (main)Feature RequestLowNew Tool -'Run Parallel with'Assigned2-- Task Description

New Tool request:

When drawing a line it would be good to have a tool/option to ‘run parallel with’.

For example start to draw a line and choose ‘run parallel with’, select appropriate line to draw parallel with!

1363QCAD BugtrackerQCAD (main)Feature RequestLowNew Tool - make lines horizontal or verticalAssigned-- Task Description

New Tool Request:

To have a tool to make any given line which is ‘not’ orthogonal already into an orthogonal line.

For example if I had a line at 30 degrees by using the tool I could change the line to be either horizontal or vertical.

 1360 QCAD BugtrackerQCAD (main)Bug ReportLow Selection Filter - by Colour not working Closed-- Task Description

Selection by colour is not working when using Selection Filter tool.

Draw several lines, circles etc. Change colour to Yellow for example and use selection filter to selet ‘Any’ by colour Yellow - it fails for me.

1356QCAD BugtrackerQCAD (main)Feature RequestLowOption to lengthen/Shorten from both ends of entity at ...Assigned2-- Task Description

It would be helpful to have the added option to lengthen/Shorten from both ends of entity at the same time.

 1351 QCAD BugtrackerQCAD (main)Bug ReportLow Help > Check for Updates: No connection to server Closed-- Task Description

Installed latest release.

Checked for update and no connection found: See attached image.

Showing tasks 1 - 50 of 170 Page 1 of 41 - 2 - 3 - 4 -

Available keyboard shortcuts


Task Details

Task Editing