QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategoryTask Type  descSeveritySummaryStatusProgress
1008QCAD (main)Bug ReportLowDXF (dxflib) compat issuesAssigned
0%
Task Description

Git head as well as 3.4.5 (trial), both with dxflib 3.3.4.0.

Start up QCAD, (with existing or new configuration, doesn’t seem to matter), “Save as” the completely empty drawing, choose “R15 (dxflib)” on Pro (only this one is available on community), save drawing.

Fire up AutoCAD 2000, try to load the empty drawing just saved.

Result:

DXF read error
Error in APPID Table
DXF read error on line 941.
Invalid or incomplete DXF input -- drawing discarded.

Problem not present when a completely empty drawing saved using Teigha in R15 format is opened (ie. it just results in an empty drawing in AutoCAD 2000). Problem is also not present when saving an existing drawing with Pro (trial) with Teigha and opening it in AutoCAD 2000. Problem does present when trying to open a dxflib-saved drawing in AutoCAD 2000.

Empty drawings created with both dxflib 3.3.4.0 in QCAD Pro 3.4.5 trial and Teigha whatever in QCAD Pro trial 3.4.5 are attached. (Community Git 135fd0 is identical to Pro - same dxflib version.)

1087QCAD (main)Bug ReportLowRuler ticks are not corresponding to the grid pointsAssigned
0%
Task Description

Ruler ticks are not corresponding to the grid points,
Ruler will completely disappear at a certain zoom level,

Settings:
Drawing unit: inch,
Grid settings: Grid 1, Meta Grid 12,
Dim Label Format: “Engineering, 0’-0.0”

see topic below:
http://www.qcad.org/rsforum/viewtopic.php?f=32&t=3014

1203dxflibBug ReportLowImages not saved (dxflib)Assigned
0%
Task Description

I am doing a bit of landscaping and using a (big) ortophoto as one of my layers in order to sanity-check on the ground measurements.

The layer contains a point and the image and nothing else.

The image is a 8MB file: “PNG image data, 4200 x 2980, 8-bit/color RGB, non-interlaced” and it is scaled to 210 coordinate units (meter) horizontally in the drawing.

With approx 50% probability the image disappears during Save, as see for instance in this diff of the DXF file:

      @@ -158699,28 +153057,6 @@ AcDbXrecord
        90
       6
         0
      -IMAGEDEF
      -  5
      -A1
      -100
      -AcDbRasterImageDef
      - 90
      -0
      -  1
      -/critter/HTV10/Ortofoto/ortofoto201502f.png
      - 10
      -210.0
      - 20
      -149.0
      - 11
      -1.0
      - 21
      -1.0
      -280
      -1
      -281
      -0
      -  0
       ENDSEC
         0
       EOF

The point in the same layer does not similarly disappear, the bug only seems to affect images.

I have seen this bug from version 3.7.5.0 to git as of yesterday (63e06c778926a803bdfbffdf27b8c24d41511072).

I have not been able to correlate the bug with anything.

Looking closer at the DXF file (attached), there seems to be some residuce of attempts to insert images in protected/invisible layers, so this may be some kind of refcounting issue.

(Any chance of getting FreeBSD into the “Operating System” field ?)

1214QCAD (main)Bug ReportLowArray of blocks -> Clipboard -> "flip pasted entities" ...Assigned
0%
1 Task Description

Case:

Select a block array,
put it with “Copy with reference” or “Cut with reference” into the clipboard,
choose a reference point which isn’t in the center of the array,
use the paste tool / with option “flip pasted entities”

If I flip only in horizontal or vertical direction the preview box will double in size and I can’t place the entities precisely regarding to the reference point.
If I try to flip in both directions at the same time - you can’t see this effect.

1242QCAD (main)Bug ReportLowSVG import DPI box should use localized decimal separat...Assigned
0%
Task Description

I wanted to make it so, that SVG units translate 1:1 into CAD units; I use the German localized QCAD and entered 25,4 into the box with the wrong result, i.e. the same as 25; Entering 25.4 got me what I wanted: The question box needs the point and ignores the comma. Would be nice if it could use the localized separator.

1339QCAD (main)Bug ReportLowLibrary Browser unstoppableAssigned
0%
Task Description

Hi,

Even with the Application Preference, Library Browser, NO Update on Start up,
the Libray Browser scans the directory, a proces that can’t be stopped or closed.

1427QCAD (main)Bug ReportLowInfo Tool / Polylinie Area (II)/ Preview brokenAssigned
0%
Task Description

Print “Command Line” and as “Add measurement to drawing” works as expected.

1445QCAD (main)Bug ReportLowSwitching off grid scaling can break rulersAssigned
0%
Task Description

See also:
http://www.qcad.org/rsforum/viewtopic.php?f=32&t=4314

1462QCAD (main)Bug ReportLowMac Trackpad zoom gesture not working as expectedAssigned
0%
1 Task Description

Hi,

I am using mac version and I have annoying issue with trackpad.
I use qcad primary with my trackpad and under application preferences (Graphics View/Navigation), my setting is as follows.
Mouse wheel / two finger swipe: Scroll (Trackpad...
Enable pan gesture : unticked (found that enabling this often goes into pan mode when I am just moving my pointer around)
Limit zoom and scroll to prevent overflows : ticked (hoping that this would prevent weird zooming issue. I will describe what I am experiencing later this page)
Reverse mouse wheel direction for zoom :unticked
Mouse wheel zoom factor: 1.02

Things work as expected:

  • panning with two finger swipe
  • and the rest

Issue I am experiencing:

Often, when I am zooming in and out with two finger gestures, the view suddenly sets to some weird state and my drawing goes off the ruler.
The mouse point remains where it is.

Workaround:
Reset viewpoint with autozoom and navigate around.

Expected zoom behaviour:
I expect viewpoint to zoom in / out at where my mouse pointer is or at least the centre of current view point.

1843QCAD/CAMBug ReportLowCreating ToolPath StallsAssigned
0%
Task Description

Hi Andrew,

Still working with and on CAM HPGL for the HP7580 pen plotter.

I have added a penplotter test drawing, that might be used for testing en callibrating plotter and pens. You may add it to the Examples-directory.

QCAD has a lot of trouble creating toolpaths and exports. Much too often it shuts itself down, or gets stalled. Why? I am not sure.

1847QCAD/CAMBug ReportLowBUG MEMORYAssigned
0%
Task Description

Hi Andrew,

Still working on creating HPGL.PLT toolpaths for the HP7580 pen plotter. QCAD has some trouble creating toolpaths. Too often it shuts itself down, or the PC gets stalled.

Recreating the same error however is possible

1912QCAD/CAMBug ReportLowTool Description ErrorAssigned
0%
Task Description

Hallo Andrew,

Testing the drill toolpath I find it hard to select the correct tool by a small bug

1913QCAD/CAMBug ReportLow3D Simulation Behaves oddAssigned
0%
Task Description

Hallo Andrew,

testing the drill toolpath I used single point markers.

In 3D simulation the tool drills the toolpath AND uses the drill as a mill.

Cam Export and generated G-code is not effected.

1916QCAD (main)Bug ReportLowMoving an object in an angled viewport with mouse does ...Assigned
0%
Task Description

To reproduce

1. Select a new view-port in model-space
2. Select the appropriate paper-space
3. When the paper space opens change the angle of the viewport to 90 degrees
4. Place view-port in paper space
5. Select the view-port in paper-space by clicking it
6. Try to move the object itself in the view-port (by clicking the “top” dot) to the right by moving the mouse to the right while holding the left mouse-button.

Actual

The object in the viewport moves down vertically NOT to the right

Expected

The object moves to the right

(It seems mouse movement does not compensate for the rotated angle of the viewport)

Workaround

None, except compensate for the angle in your head and moving the mouse the “wrong” way when correcting the placement of objects in the view-port

1924QCAD (main)Bug ReportLowSweepAngle = 0Assigned
0%
Task Description

Win7pro 32bit Wininstaller Qcadpro 3.23.0

Draw an arc.
Select the arc.
In Property Editor:
Set start angle to 135
Set end angle to 135

SweepAngle = */-360

edit the end angle and add “+360”, hit enter

SweepAngle = 0

An arc with zero sweep is a point.
A point is not an arc.
With the same start and end parameter an arc should have a sweep of +/-360.
As for entries by points or by angles.

Regards

1971QCAD/CAMBug ReportLowCAD/CAM 3D SimulatorAssigned
0%
Task Description

Hallo Andrew,

Found a bug in the 3D Simulator execution

1972QCAD (main)Bug ReportLowHatch import fails for boundaries with many very small ...Assigned
0%
Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=33&t=6648

1997QCAD/CAMBug ReportLowCan't export gcode, intermittentlyAssigned
0%
Task Description

When I create a simple drawing, I cannot export the gcode until I restart qcad.

general steps to reproduce the issue:
1. open a new drawing
2. Add a letter “D” near the origin in Arial font, about 7mm tall.
3. explode it
4. save the drawing
5. Fill in in the “cam configuration” 6. Select the drawing and generate the tool paths.
7. Hit the “export button” or the menu item.
8. Observe that you see the “camexport” command appears in the command section, but there is no file generated for the gcode.

If you restart qcad, then the gcode will export as expected. Also, it appears to work for more complicated drawings. I had the same issue, when I tried to generate the same thing, but using the string “November 2019” at 5mm height. I am using up to date MX Linux with kernel version 4.19.0. I also observed this behavior under Windows 10 professional.

1443QCAD (main)Bug ReportVery LowView > Status Bar remains uncheckedAssigned
0%
Task Description

Status Bar menu remains unchecked even it is toggled on or off

1691QCAD (main)Bug ReportVery LowIssue with Layouts after "File-Revert"Assigned
0%
Task Description

QCad 3.19.2 Professional, 64bit, Liux Mint

Case:
1. Open some saved drawing with viewport entities on layout block (paper space). Print Preview mode is “On” automatically.
2. After “File-Revert” drawing is reopened on layout block (paper space), but now Print Previw mode is “Off” .

For example can try on “flange.dxf”

1719QCAD (main)Bug ReportVery LowUndo on converted drawing leads to wrong label position...Assigned
0%
Task Description

Drawing converted from inch to mm - undo leads to wrong dim label position. I can fix that with “Reset Label position” but it would be nice if QCAD could to that in first place.

1760QCAD (main)Bug ReportVery LowSelf-crossing polylines can't be cut twice at segment c...Assigned
0%
Task Description

Re-entering dividing problem from  FS#1757 

Divide the poly selecting near segment 1 at the segment crossing.
> A new node is inserted on the crossing and made start and end node.
Divide the poly again selecting near segment 2 at the segment crossing.
> no division appears to be done.

One can’t divide the second segment at the crossing

Presumed intended behaviour like  FS#1750 

Regards

1765QCAD (main)Bug ReportVery LowErrors with polyline offsetAssigned
0%
1 Task Description

Win 7 32 bit QCAD 3.20.1

Ofsset of a base-line with arcs results in massive ammount of errors.
Most of them occur as a cluster of very tiny segments and are part of the offset. (zoom far in at the red circles)
Mostly they occur where the offsetted arcs should merely be trimmend pairwise.
Some occur as detached entities or as detached strings of entities very near the offset (strings not documented).
Spooks occur at opposite site when base-line is not closed.
360° curls can occur with R = Offset.
Null-entities may occur (not documented, hard to find and not able to copy).

The base-line is checked and sound and has mixed tangentially or not tangentially connected arcs.
Offsetting the mother base-line of the base in the file has similar effect but not all and/or different ones.
Also encountered with offseting polys from fonts.
Used to define pocket paths for CNC.
Detected because the CNC driver will not accept Self-crossers, Null-entities or open ends depending on the settings.

Work arround is to explode and select small entities but this does not solves the issues.
1) Choosing the tolerance large enough will detect small segments that should stay.
2) Recombining will generate new ones at the place where the main segments remain crossed.
Cleaning up the paths is a daunting process with some thousand segments for several offsets.

I assume this has an infuence on the CAM part of QCAD too unless the offset method is different.

1900QCAD (main)Bug ReportVery LowRemote shares initially not accessible.Assigned
0%
Task Description

My data files are stored on network shares (synology) with a GB link. QCAD Pro is run in Admin mode.

While in my Windows browser all remote shares are accessible (Green), in the QCAD file open menu they are initially shown as not accessible (Red). By accessing a specific drawing file in a remote share, the share will open and turn green.

Same behavior using ‘Open recent’. Always the message is given that the requested file does not exist, and the file is wiped from the ‘Recent Open’ list. Only if the share is first accessed through ‘Open’ with a random file, it will turn and a ‘recent open’ file for that share will open.

Drag and Drop from a remote share will never work.

1905QCAD (main)Bug ReportVery LowView > Property Editor: Changing attribute of block cha...Assigned
0%
Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=33&t=6367#p23947

1919QCAD (main)Bug ReportVery LowWrong order XY(Z) for Ordinate Dimension in property ed...Assigned
0%
Task Description

Win7pro Qcad Pro 3.22.1.2

In property editor
properties of an Ordinate Dimension

Without Show Z
DefPoint is displayed in order YX?

With Show Z
Origin is displayed in order XZY?
DefPoint is displayed in order YZX?
LeaderEndPoint is displayed in order ZXY?

Regards

1923QCAD (main)Bug ReportVery LowFaulty rendering Polylines with Global/Local Widths and...Assigned
0%
Task Description

Win7pro 32bit Qcad 3.23.0

Andrew,
The Arc segments of Polylines with Global or any Local Width render faulty where Global Z or any of the arc’s local Z is not zero.

In the attached drawing setting the Global Z of the inner poly to 5,10,...

The setting of Z to not zero affects the radius of the projected arc and not the bulging of the poly.
It also affects the projected widths of the line inversely, but not by changing the widths properties.

Pritty rare combination! True.
Qcad is 2D native! True.

Flatten will resolve this.

It is not a purely visual rendering fault, the poly will explode as such.

Maybe similar flaw as with uneven scaling blocks with arcs.
https://qcad.org/rsforum/viewtopic.php?f=8&t=5566#p20703

Regards

1974QCAD (main)Bug ReportVery LowFile > Print Preview: Cannot move paper in new drawingUnconfirmed
0%
Task Description

Yesterday I set up a Windows 64 bit install of QCAD Pro which shows the same bug I have been seeing for a while in the Community linux git repo.

Create a new drawing and then go to “Print preview”. Enable “Move paper postion”, the cursor changes to the hand icon, but the paper position is unable to be moved. Only by saving the drawing, exiting the program, restarting and reopening the drawing, will the “Move paper postion” function correctly.

Affected versions tested:

Windows 64bit installer download, as of yesterday.
Linux 64bit build from git, about 20minutes ago.

For what it’s worth, this bug is not present in this previous git checkout:

Version:
3.21.1.0 (3.21.1)
Internet:
QCAD.org
Build Date:
Jul 2 2018
Revision:

Qt Version:
5.7.0
Architecture:
x86_64
Compiler:
gcc 6.3.1

Thanks for a great product.

Showing tasks 351 - 378 of 378 Page 8 of 8<<First - 4 - 5 - 6 - 7 - 8

Available keyboard shortcuts

Tasklist

Task Details

Task Editing