QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategoryTask TypeSeveritySummaryStatusProgress  desc
1902QCAD/CAMFeature RequestLowCAM G-Block ToolpathAssigned
0%
Task Description

Hallo Andrew,

Still busy on the never ending G-code story. Urgently needed the very handy G-code Block Toolpath. This ‘toolpath’ also solves a lot of “editing requests”.

1903QCAD (main)Feature RequestLowSaving layer settings, e.g. visibility status, associat...Assigned
0%
Task Description

In a medium complex drawing it may be too much details to have all layers in a drawing visible at once.

Instead a number of views would be created that saves not only zoom level and position but also what layers are visible and not (as appropriate for the purpose of that particular view). This is very cumbersome (to the extent it is not really realistic) to achieve today and requires a lot of duplication of both model and layers.

The advantage of adding this is the ability to have only one model (with multiple views) and avoid duplication of work and the risk of inconsistency inherent with many copies of the model.

As a further (and natural extension to this) would be the ability to used this functionality with view-ports to be able to create (possibly many) paper-spaces from a single model. This would however require view-ports to be aware of what view they are a window into. A single change in the model would then propagate to all defined view-ports and paper-spaces.

1905QCAD (main)Bug ReportVery LowView > Property Editor: Changing attribute of block cha...Assigned
0%
Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=33&t=6367#p23947

1911QCAD/CAMFeature RequestLowDrill ToolpathAssigned
0%
Task Description

Hallo Andrew

It would be more than conveniant, defining the drilling locations of the drill toolpath, by selecting a circle’s center point.

1913QCAD/CAMBug ReportLow3D Simulation Behaves oddAssigned
0%
Task Description

Hallo Andrew,

testing the drill toolpath I used single point markers.

In 3D simulation the tool drills the toolpath AND uses the drill as a mill.

Cam Export and generated G-code is not effected.

1915QCAD (main)SuggestionLowViewport does not rotate view-port when changed in pape...Assigned
0%
Task Description

To reproduce

1. Select a new view-port in model-space
2. Select the appropriate paper-space
3. When the paper space opens change the angle of the viewport.

Actual

The object in the viewport changes but the viewport itself remains unchanged

Expected

That both the view-port and the object changes angle as the angle is updated

Motivation

If you abort the placement (but keep the angle) and go back to model-space and then redo the operation the view-port is rotated along the angle. It seems that the viewport only picks up the initial angle once the paper-space is open and ignores any changes thereafter

Workaround

1. Select the view-port per normal in model-space
2. Open the paper-space and set the wanted angle but do not place the view-port in paper space
3. Abort the placement on paper-space and redo the whole operation

Once the paper space is opened again the view-port will have the chosen angle

1916QCAD (main)Bug ReportLowMoving an object in an angled viewport with mouse does ...Assigned
0%
Task Description

To reproduce

1. Select a new view-port in model-space
2. Select the appropriate paper-space
3. When the paper space opens change the angle of the viewport to 90 degrees
4. Place view-port in paper space
5. Select the view-port in paper-space by clicking it
6. Try to move the object itself in the view-port (by clicking the “top” dot) to the right by moving the mouse to the right while holding the left mouse-button.

Actual

The object in the viewport moves down vertically NOT to the right

Expected

The object moves to the right

(It seems mouse movement does not compensate for the rotated angle of the viewport)

Workaround

None, except compensate for the angle in your head and moving the mouse the “wrong” way when correcting the placement of objects in the view-port

1917QCAD (main)Feature RequestLowAutomatic labels with static information of the drawingAssigned
0%
Task Description

I would like static information of the drawing (like scale, creation-date, modified-date, revision etc) to be available as automatic labels to be placed in the drawing (with selectable style, font etc)

This would greatly simplify the creatin of title sections in the drawing and making sure it is consistent with the actual drawing and not requiring manual “synchronization”.

1919QCAD (main)Bug ReportVery LowWrong order XY(Z) for Ordinate Dimension in property ed...Assigned
0%
Task Description

Win7pro Qcad Pro 3.22.1.2

In property editor
properties of an Ordinate Dimension

Without Show Z
DefPoint is displayed in order YX?

With Show Z
Origin is displayed in order XZY?
DefPoint is displayed in order YZX?
LeaderEndPoint is displayed in order ZXY?

Regards

1920QCAD (main)Feature RequestVery LowEdit > Application Preferences: Add preference to disab...Assigned
0%
Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=89&t=6447

1922dwg2bmpFeature RequestVery LowAdd error message when requesting raster for a non-exis...Assigned
0%
Task Description

It would be nice if QCAD spit some kind of warning message when trying to render a layer with a name that doesn’t exist (and perhaps render nothing), rather than silently rendering an empty image. :D

See https://qcad.org/rsforum/viewtopic.php?f=33&t=6453

1923QCAD (main)Bug ReportVery LowFaulty rendering Polylines with Global/Local Widths and...Assigned
0%
Task Description

Win7pro 32bit Qcad 3.23.0

Andrew,
The Arc segments of Polylines with Global or any Local Width render faulty where Global Z or any of the arc’s local Z is not zero.

In the attached drawing setting the Global Z of the inner poly to 5,10,...

The setting of Z to not zero affects the radius of the projected arc and not the bulging of the poly.
It also affects the projected widths of the line inversely, but not by changing the widths properties.

Pritty rare combination! True.
Qcad is 2D native! True.

Flatten will resolve this.

It is not a purely visual rendering fault, the poly will explode as such.

Maybe similar flaw as with uneven scaling blocks with arcs.
https://qcad.org/rsforum/viewtopic.php?f=8&t=5566#p20703

Regards

1930QCAD (main)Feature RequestLowOption disable "Auto Zoom on load" for saved "Layout Vi...Assigned
0%
Task Description

Hi,

my setting for “Auto Zoom on load” is checked to on. That works perfect for me for most of my drawings.

But if I save a drawing with Layout Viewports then I have to adjust every Viewport again after loading.

Would it be possible to have an option below Application Preferences / Graphics View / Appearance / Auto Zoom on load / ON which excludes drawings saved with Layout Viewports?

1934QCAD (main)Feature RequestLowDiametric text - overlaidAssigned
0%
Task Description

Diametric text is always placed above a horizontal measurement.

I often want to indicate both the inside and outside diameter of an object e.g. a wheel using diametric text. The text is overlaid and illegible.

To avoid text overlapping, I use Horizontal Aligned because I can control the position of the text to avoid illegible text.

A better method would be to alternate the placement of diametric text (alternatively) above and below a measurement so that in the majority of cases an overlap would be avoided.

Similarly for a vertical measurement, the text is overlaid and illegible.

When the angle is almost vertical, the angle controls the side the text appears however it also reverses the direction of the text (which is logical but not attractive).

Kind regards
Simon

1954QCAD/CAMReleaseLowRevised PWM Post ProcessorAssigned
0%
Task Description

Hallo Andrew,

I have revised the PWM Post Processor to Revision D.

1971QCAD/CAMBug ReportLowCAD/CAM 3D SimulatorAssigned
0%
Task Description

Hallo Andrew,

Found a bug in the 3D Simulator execution

1972QCAD (main)Bug ReportLowHatch import fails for boundaries with many very small ...Assigned
0%
Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=33&t=6648

1974QCAD (main)Bug ReportVery LowFile > Print Preview: Cannot move paper in new drawingUnconfirmed
0%
Task Description

Yesterday I set up a Windows 64 bit install of QCAD Pro which shows the same bug I have been seeing for a while in the Community linux git repo.

Create a new drawing and then go to “Print preview”. Enable “Move paper postion”, the cursor changes to the hand icon, but the paper position is unable to be moved. Only by saving the drawing, exiting the program, restarting and reopening the drawing, will the “Move paper postion” function correctly.

Affected versions tested:

Windows 64bit installer download, as of yesterday.
Linux 64bit build from git, about 20minutes ago.

For what it’s worth, this bug is not present in this previous git checkout:

Version:
3.21.1.0 (3.21.1)
Internet:
QCAD.org
Build Date:
Jul 2 2018
Revision:

Qt Version:
5.7.0
Architecture:
x86_64
Compiler:
gcc 6.3.1

Thanks for a great product.

1976QCAD (main)Feature RequestLowEnvelope at offset to a poly toolAssigned
0%
Task Description

See:
https://www.qcad.org/rsforum/viewtopic.php?t=6650

1977QCAD (main)Feature RequestLowCorresponding coordinate format Assigned
0%
Task Description

Hi,

It would be less confusing to read messages in the command line protocol if it would use the same coordinate separators like the settings below Application Preferences / General / Coordinate Format.

This example shows the “Absolute Cartesian Coordinate” but of course all corresponding format settings should be used within messages.

Absolute Cartesian Coordinate: Setting = semicolon (;) but the message will use division (/).

1982QCAD (main)Feature RequestLowmeasure DIN 1356Assigned
0%
Task Description

To measure in the format DIN 1356 , Architect
It is hard work to do this manual input with meta characters.

2011QCAD Community EditionSuggestionVery LowUpdate QCAD CE SpatialIndex module to latest versionAssigned
0%
Task Description

Building with the bundled version, 1.8.5, works fine.

When I try to build using the system version, which for Mageia Cauldron is 1.9.3, the build fails.

https://raw.githubusercontent.com/kekePower/mmbl/master/qcad/2019/12/11/20%3A13%3A48/log.qcad

Here is the current spec file for version 3.23.0.4.
https://svnweb.mageia.org/packages/cauldron/qcad/current/SPECS/qcad.spec?revision=1465894&view=markup

It looks like qcad is incompatible with versions above 1.8.5.

Are there plans to port to the new version?

Thanks in advance.

2014QCAD (main)Bug ReportLowFocus on Options Toolbar failsAssigned
0%
Task Description

Scenario: e.g. Tools Move/Copy and Rotate switched to “use without dialog.

Launch within a drawing Move/Copy, use the Keyboard keys CTRL + Space to focus on the Option Bar - the field for Numbers is Highlighted and I can change it. Further navigation with keys on the keyboard depends on remembered option (copy yes/no etc what make a navigation possible or not. It looks like the navigation with the Arrow keys is focused on the canvas and sooner or later the courser will jump to the Command Line or Property editor. Same behavior with the Rotation tool.

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=32&t=6828

2016QCAD (main)Bug ReportLowOffsetting multi selection of polylines halts prematureAssigned
0%
Task Description

See:
https://qcad.org/rsforum/viewtopic.php?&t=6827&p=25992#p25992

Offsetting 32 polys from ellipses fails.
Offsetting 16 polys can be completed with 2 selections for outer and 2 for inner.

For some reason the offset function halts premature.

Regards,
CVH

2021QCAD (main)Performance IssueVery LowCannot work with big dwg filesAssigned
0%
Task Description

Openning a big file or doing any action in it, takes minutes to load.
Even dragging the scrollbar slightly left or right, takes mintues to redraw the canvas again, which makes QCAD un-usable for professional use.
Is there a way to make QCAD usable, after loading completed:
- Like suppressing edit until user says so,
- or taking snapshots of rendered canvases to another file and use it, as windows uses thumb.db ( for negative latency :P )

PS: I wish I could help a bit, but my hand are tied. I am just a java freak, I am opt to any idea of porting it to java, if she is still alive.

Tu─čalsan Karabacak
EEE, MSc Mobile Comp & App, IWE

2031QCAD (main)Bug ReportLowOrdinate Dimensions don't act as expectedAssigned
0%
Task Description

Hi Andrew

I wasn’t sure if this was a bug or feature request, when I’m drawing part sets that only change in lengths I dimension them
to save time then I stretch and save as whatever filename... I was surprised when Qcad reacted the way it did when stretching ordinate
dimensions on a part, the 1st thing I did was window select over the dimensions which didn’t work ( this is the typical way for
stretching ordinate dimensions in AutoCAD,IntelliCad,Draftsight etc )... anyway Husky and I had a fairly long debate and he told me
I had to select the object and only parts of the ordinate dimensions which when stretched leaves a bit of tidying up to do..
Please let me know if I’m going about this the wrong way.. do i really have to do multiple stretches and move all the jogged dimensions?

See Topic https://www.qcad.org/rsforum/viewtopic.php?f=32&t=6901&start=15 It started off with negative values for ordinate dimensions then turned into problems stretching ordinate dimensions..
I also posted dropbox links to quite a few videos..

Attached is a zip file containing some screenshots plus the original dxf file..

Best Regards
John Hyslop

2033QCAD/CAMBug ReportLowRepeated warning message while updating toolpathAssigned
0%
Task Description

While updating or regenerating toolpath on the attached dxf file I repeatedly get the warning message in the attached jpg file. If I keep clicking OK then the toolpath is successfully generated. This did not happen in version 3.23.0 with the same file.

2034QCAD (main)Feature RequestLowPaint Properties to include modifying linetype scales w...Assigned
0%
Task Description

Previous Feature Request #1285, dated 2015, incorporated in QCADPro 3.24. I regularly adjust linetype scales on hidden, centreline and phantom lines to achieve the best appearance on the drawing when printed. I note the Paint Properties feature copies all the attributes of the chosen line but does not copy the scale. I have to change the scale of each line, even after ‘painting’. This copying all Properties is something AutoCAD does. I know I could change the line to Hidden2 etc. and tick the ‘scale lines’ box in Drawing Properties but that is not always successful- copying properties is a quick and useful way of achieving the required result.
QCAD Pro 3.24 Windows10.

2037QCAD (main)Feature RequestLowSupport alternative angle referenceAssigned
0%
Task Description

E.g. 0 degrees at the top, clock-wise for positive direction, alternative angle units.

2041QCAD (main)Bug ReportLowcircletangent2 doesn't solve correctly if the defining ...Assigned
0%
Task Description

In my example I can’t draw a circle with circletangent2 if the defining point is on one of the defining tangents. The tangency is lost when I try to do this.

I attached 4 screenshots: TheExample.png, TryingPoint1.png, TryingPoint2.png and The_Point_Isn’t_On_The_Tangents.png.

2047QCAD (main)Bug ReportLowQCAD quits when inserting a library item, Ubuntu 19.10 ...Assigned
0%
Task Description

Description:
QCAD quits when trying to insert a library item (PC_1kW.dxf) from the library browser. Both by dragging it or clicking on insert.
Joined a copy of the terminal and dmesg (Linux) and what I found on the windows logs.

- Tested with other libraries elements of the same origin with the same result.
- The file opens normally in QCAD. When you create a block from it, you can re-insert it and it works as expected, try with PC_1kWblock.dxf...
- If you re-create a library item from the file with another name it fails also to insert.
- Tested with a new empty file or with a file containing same blocks...

Now the strange part:

-On a brand new HP Zbook 14u G6 it works flawlessly on Windows but fails on Linux... That was the first computer I tried (with Windows) when I decided that it will replace Draftsight... I was lucky...
-On a 4 years old Lenovo Yoga 14 it fails both on Linux & Windows... This computer has only 8Gb of RAM, but dedicated graphics...
-On a customer’s HP Pavillon 17’’ it fails... He bought a licence & Book of QCAD because of me...
-On my Dell 7720 it fails both on Windows and Linux. This workstation has everything to run any CAD software (64Gb RAM, Xeon 1535M v6, Quadro P5000)
-Reinstallation of the software doesn’t solve the problem. 2 independent sources tested (my download and my customer’s download)

These blocks have a lot of attributes on different layers, needed for the intended usage. I’m developping a script to extract them to a CSV file based on a template file... As on Draftsight.

Looks a lot like  FS#1938 ... But now you have files to test...

I made further testings and this bug is definitely related to the fact that the attributes definitions are on different layers...

If the layer definition exists before the library items is inserted, it works as expected.

If one layer existing in the item definition is missing from the layer list before the item is inserted it fails.

If you create a block from an instance of the library item, and create a new library item with the block, then it can be inserted without problems and the layers are created... But you must explode it first to access the attributes which is not the idea behind the block attributes that should be editable when a block with attributes is inserted.

So at the moment the only way to work is to start with a template document with all the possible layers on which attributes definitions are defined...

Can’t go further in debugging as block attributes are one of the feature of the ‘professional’ version I paid for and are not open source...

Ready and willing to sign a NDA to get access to the sources and make this work if nobody else takes care of this.

2048QCAD (main)Bug ReportVery LowMove / Copy to current layer fails when reference point...Assigned
0%
Task Description

QCAD 3.24.2 / macOS x86_64 10.14.6

Starting with empty doc:
1. Draw any object (e.g. a rectangle) on layer 0.
2. Create new layer (”1”) with color, say yellow.
3. Select new layer
4. Select new object
5. Modify → Move / Copy
6. Click reference point
7. Click target point same as reference point
8. In “Move / Copy Options” dialog, select “Delete Original” and check “Use current layer and attributes.” Click OK.

The moved object stays on the layer it was previously on. Using “Move / Copy” as a quick way to move a selection between layers is not useful even though it appears to be the recommended way in a Google search.

Note: if “Keep Original” is selected instead, the copied object is placed on the current layer and the original object remains on its layer, as expected.

Note: if the target point is different from the reference point, the moved object is placed on the current layer as expected.

There are other workarounds too, cut / paste with “To current layer” checked seems to work, as does chaging the layer in the Properties Editor.

2050QCAD Community EditionBug ReportVery LowFlexPainter dosen't workAssigned
0%
Task Description

FlexPainter works in the Pro version of QCad but not in the Comunity one.
If it’s not supposed to works in the latter, maybe, it would be better to remove it from the menu (Misc > Script Examples > Mathematics).

2056QCAD (main)Feature RequestLowOption Duplicate layer (yy) inclusive all sub-layers.Assigned
0%
Task Description

If I’ve to duplicate a layer with a bunch of sub-layer it’s a kind of a Sisyphus task to get it done.
Currently I have to duplicate each single layer. Then in an additional step I’ve to address each child layer to the proper parent layer.

Current lack:
Marked parent layer with all sub-layer / Duplicate Layer / only ONE layer will be duplicated.

With other words: If I have to duplicate a layer with 5 sub-layer it requires 11 steps to get a copy of that tree ... :-(

2057QCAD (main)Feature RequestLowMultiline toolAssigned
0%
Task Description

Implement a multiline tool.

2060QCAD (main)Feature RequestLowDialog box for Layer StatusAssigned
0%
Task Description

So far, layer status has only been implemented very rudimentarily.
I wish something like a dialog box in which you can choose for each layer status, which layers belong to it and which not.

2063QCAD (main)Performance IssueLowBad performance while zooming inside layout block with ...Assigned
0%
Task Description

Zooming in and out is lagging to the point of unusable. This is happening in a layout block with the cursor pointing inside geometry with hatches. When the cursor is pointing outside the geometry zooming works as expected.
The attached file has a very simplified testcase that shows this problem almost in the same way as a more complex drawing with multiple layers and hatches.

edit: I also attached the more complex drawing because it is a bit unclear to me where the lagging stops. Outside the viewport or outside the paper.

I just noticed the selection box has the same problem!

2068QCAD Community EditionBug ReportVery LowNon-english text in upper/lower index becomes UTF codeAssigned
0%
Task Description

How to reproduce.

1. Create a text field with some non-english words in the upper index. (see attached pic1.png)
2. Save the project and close QCAD.
3. Run QCAD and open same project.
4. Now upper/lower indexed text becomes not human readable UTF codes. (see attached pic2.png)

Tried different fonts - doesn’t help.

Linux ntb-kirill 3.10.0-1062.12.1.el7.x86_64 #1 SMP Tue Feb 4 23:02:59 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
CentOS Linux release 7.7.1908 (Core)

2070QCAD (main)Feature RequestLowcropping imageAssigned
0%
Task Description

It may be useful to insert the “image cropping” function both in top / bottom - right / left mode, and with polyline

2072QCAD (main)SuggestionLowInserted and flipped block mirrors text and dimAssigned
0%
Task Description

Text and/or DIM used in blocks will be mirrored if inserted with a vertical/horizontal flip option.

Text/DIM which was successfully used in previos QCAD versions are now mirrored if they are loaded in the current version.

Version 3.23.0 doesn’t shows this behavior.

https://www.qcad.org/rsforum/viewtopic.php?f=32&t=7206

2075QCAD (main)SuggestionLowDraw order bug after insert bit mapAssigned
0%
Task Description

First post, so please excuse if I missed some forum rules etc...

I insert bit maps and trace over them to create DXF files for laser cutting burnout templates. If the edge of the bit map is coincident with a line I have drawn, it is not possible to select the line for offsetting, trimming etc. This is regardless of the draw order or handle number. It seems to happen most if the edge of the image and line are coincident with the X or Y origin. I also use fairly fat lines to make it easy to see. My default line width is 1mm. Not sure if that affects selection or not, but fatter lines don’t help the issue at hand.

Steps to reproduce...
insert bitmap at 0,0
draw horizontal and vertical lines starting at 0,0. (my lines are usually longer than the edges of the bitmap.
try to select one of the lines for offsetting. (Select the line in the area of the bitmap. There is no problem selecting the line where it extends past the edge of the bitmap.)

It does not matter if I insert the bitmap first and then draw lines, or draw lines first, insert bitmap and then change the draw order so the lines are on top. It is also not consistent on which axis is affected. It is usually both X & Y, but sometimes just one or the other.

Workaround is select the bitmap, then move it by 0.001 in any direction. Now the edges are no longer coincident and you can select your lines. The alternate workaround is to insert the image on another layer and then turn that layer off when you need to select a line on the edge of the bitmap.

2078QCAD (main)Bug ReportLowDraw > Hatch: Small gap tolerated by QCAD, not by DXF/D...Assigned
0%
Task Description

https://qcad.org/rsforum/viewtopic.php?f=33&t=7254

It seems to be an accuracy problem.
The original hatch boundaries are defined from 732 single entities.
These interconnect with an accuracy better then 1e-10 except for a gap of 0.000814 in two places.

Creating a Hatch of these entities with TA-HA is rather slow but succesfull.
After Save-Close-Open the Hatch may look different or may even be missing (=Null).

Suspected is that:
The recreation off the Hatch on load uses some other accuracy setting.
The outer boundary is not found and only some inner ones are considered as outer.

But that explains not why it looks fine after initial creation.
Nor that the outcome of a retry may vary.

Regards,
CVH

2079QCAD/CAMBug ReportLowFull screen mode (F11) - Menu / drop down menus not wor...Assigned
0%
Task Description

https://www.qcad.org/rsforum/viewtopic.php?f=33&t=7269

Showing tasks 351 - 393 of 393 Page 8 of 8<<First - 4 - 5 - 6 - 7 - 8

Available keyboard shortcuts

Tasklist

Task Details

Task Editing