QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategoryTask TypeSeveritySummaryStatusProgress  desc
1826QCAD (main)Feature RequestLowguide lines when extending lines Assigned
Task Description

When using the SHIFT key while dragging the end point a perpendicular guide line is displayed (see attached screenshot).
It would be very helpful if other guide lines with x=const. and y= const. are displayed when pressing SHIFT + ALT key together while dragging.

1772QCAD (main)Feature RequestLowGo back on right-click on shaded Tool buttonAssigned
Task Description

Right-click on the tools on the left-hand side of the screen brings you back in the hierarchy.

However, that does not work if you right-click while hovering above a button that that is shaded (inactive).

601QCAD (main)Feature RequestLowFür Berechnungen neu zu erstellende Elemente Werte von ...Assigned
Task Description

Es wäre schön wenn ich Werte wie zum Beispiel Längen von Linien direkt abgreifen könnte um diese weiter in Berechnungen verwenden zu können.

Ich habe eine Linie konstruiert wobei sich eine Länge y ergeben hat.

Nun möchte ich eine Linie zeichnen die 5 mal y sein soll.

Linientool → Wert 5* eingeben und y durch Auswahl mit der Maus von dem vorhandenen Elements übernehmen.

Natürlich könnte ich die Geometrie Info benutzen um den Wert abzulesen oder auch über die Zwischenablage zu benutzen. Ein abgreifen mit der Maus wäre aber schneller, direkter und wahrscheinlich auch mit weniger Fehlern (Human error) verbunden. Wahrscheinlich auch genauer da QCad, denke ich, mit mehr Nachkommastellen rechnet, oder?

2252QCAD (main)Bug ReportLowFreeze / crash when selecting clamped splines (not crea...Assigned
Task Description

See also:

2014QCAD (main)Bug ReportLowFocus on Options Toolbar failsAssigned
Task Description

Scenario: e.g. Tools Move/Copy and Rotate switched to “use without dialog.

Launch within a drawing Move/Copy, use the Keyboard keys CTRL + Space to focus on the Option Bar - the field for Numbers is Highlighted and I can change it. Further navigation with keys on the keyboard depends on remembered option (copy yes/no etc what make a navigation possible or not. It looks like the navigation with the Arrow keys is focused on the canvas and sooner or later the courser will jump to the Command Line or Property editor. Same behavior with the Rotation tool.

See also:

1067QCAD (main)Feature RequestLowFilling an area with a bitmapAssigned
Task Description

Being able to fill an area with a bitmap would be a nice addition to the already impressive feature list of QCAD.

586QCAD (main)Feature RequestLowFile open dialog with previewAssigned
Task Description

Since this is not supported by Qt anymore, this would likely have to be implemented from scratch.

1332QCAD (main)Feature RequestLowFile > SVG Export: export DXF entity handles to SVGAssigned
Task Description

Add handle attribute to exported SVG tags to identify exported DXF entities.

1974QCAD (main)Bug ReportVery LowFile > Print Preview: Cannot move paper in new drawingUnconfirmed
Task Description

Yesterday I set up a Windows 64 bit install of QCAD Pro which shows the same bug I have been seeing for a while in the Community linux git repo.

Create a new drawing and then go to “Print preview”. Enable “Move paper postion”, the cursor changes to the hand icon, but the paper position is unable to be moved. Only by saving the drawing, exiting the program, restarting and reopening the drawing, will the “Move paper postion” function correctly.

Affected versions tested:

Windows 64bit installer download, as of yesterday.
Linux 64bit build from git, about 20minutes ago.

For what it’s worth, this bug is not present in this previous git checkout:

Version: (3.21.1)
Build Date:
Jul 2 2018

Qt Version:
gcc 6.3.1

Thanks for a great product.

1230QCAD (main)Feature RequestLowFile > PDF Export / SVG Export: export layersAssigned
Task Description

Dear Andrew, just in case you should ever run out of ideas for enhancements; As an advisor I sometimes get PDF files and recently, some CAD drawings contained layers, which is kind of nifty to reduce the clutter.

Sadly though, qprinter/qpainter seem to be unaware of OCG (Optional Content Groups, the PDF jargon for layers) at the moment, so my plea is for the back burner now. Probably in SVG though it can be done? Yet that is of a little less use, maybe…

2297QCAD (main)SuggestionVery LowFew UI inconsistencies Assigned
Task Description

1) Line with command prompt in Command Line widget is missing padding/margin - letter C is glued to frame.
2) In the “Selection Filter” widget there is an “whitespace” character before colon “:” symbol on multiple places, it doesn’t seem repeat anywhere else

951QCAD (main)Feature RequestLowExtra Option for Block attributes ...Assigned
Task Description

It would be nice to have the possibility to control the automatic Text orientation in Block attributes.
Something what would work like the DIM restriction: I can read the text horizontal and/or from the right side of the drawing sheet.

Right now I have the feeling that the Text orientation is dependent on the tool what I even use.
Different tools = different outcomes.

173QCAD (main)Feature RequestLowexplode text to lettersAssigned
Task Description


2287QCAD (main)Feature RequestVery LowEvaluate draw order for preference "Prevent white-on-wh...Assigned
Task Description

The Application Preference setting “Graphics View - Appearance - Prevent white-on-white/black-on-black display” seems to be a global setting that doesn’t take the draw order into account. For example: With the setting enabled, it prevents creating a white hatch of a higher draw order on top of a larger, colored hatch with lower draw order (background). The preference does not seem to evaluate if the object is truly drawn as “white-on-white”.

With the preference enabled, setting the object color as “white” will set the “white” color label, but the object color actually stays black. Its hard to determine why it happens in that case.

Is it possible to let the global preference setting be applied to objects after evaluation of the draw order, and determine if the object actually is a true case of white-on-white?

My workaround: Disable the preference setting (I think it is default = on), and only enable it for ad-hoc checks of hidden and overlooked objects.

1316QCAD (main)Feature RequestLowEdit > Drawing Preferences: add global linear factorAssigned
Task Description

See also:

1586QCAD (main)Feature RequestLowEdit > Application Preferences: Use different color for...Assigned
Task Description

Add preference to use a single, configurable color for all locked layers.

See also:

1920QCAD (main)Feature RequestVery LowEdit > Application Preferences: Add preference to disab...Assigned
Task Description

See also:

747QCAD (main)Feature RequestLowDXF import: dimension labelAssigned
Task Description

Add support for custom dimension labels created in 3rd party applications. Such labels may contain text that is stripped by QCAD.

976dxflibBug ReportLowDXF import errors related to hatches, textsAssigned
Task Description


1008QCAD (main)Bug ReportLowDXF (dxflib) compat issuesAssigned
Task Description

Git head as well as 3.4.5 (trial), both with dxflib

Start up QCAD, (with existing or new configuration, doesn’t seem to matter), “Save as” the completely empty drawing, choose “R15 (dxflib)” on Pro (only this one is available on community), save drawing.

Fire up AutoCAD 2000, try to load the empty drawing just saved.


DXF read error
Error in APPID Table
DXF read error on line 941.
Invalid or incomplete DXF input -- drawing discarded.

Problem not present when a completely empty drawing saved using Teigha in R15 format is opened (ie. it just results in an empty drawing in AutoCAD 2000). Problem is also not present when saving an existing drawing with Pro (trial) with Teigha and opening it in AutoCAD 2000. Problem does present when trying to open a dxflib-saved drawing in AutoCAD 2000.

Empty drawings created with both dxflib in QCAD Pro 3.4.5 trial and Teigha whatever in QCAD Pro trial 3.4.5 are attached. (Community Git 135fd0 is identical to Pro - same dxflib version.)

1542dwg2svgFeature RequestLowdwg2svg: add switch to show only given layer(s)Assigned
Task Description

Implement a command line switch to only show a list of given layers for dwg2* command line tools.

1700dwg2pdfFeature RequestLowdwg2pdf: output multiple layoutsAssigned
Task Description

Add support to specify multiple blocks (layouts) to output (one per page).

1824dwg2pdfFeature RequestLowdwg2pdf does not obey frozen layers in paper-space view...Assigned
Task Description

We currently have a paper-space using two viewports with different layers from the model-space frozen. Unfortunately in the pdf output the layers which are frozen show up.
dwg2pdf should obey the specific frozen layer for each viewport

1911QCAD/CAMFeature RequestLowDrill ToolpathAssigned
Task Description

Hallo Andrew

It would be more than conveniant, defining the drilling locations of the drill toolpath, by selecting a circle’s center point.

1298QCAD (main)Feature RequestLowDrawing Preference; File formatAssigned
Task Description

Hi, I get anoyed everytime saving a drawing;

 File Format not recommended.......          [Yes]   ; I know. it's suppose to be in that format!
 Saving to file......                        [OK]    ; I already told you
 Black entities ......bla bla                [OK]    ; I already told you
 Custom colors ...... bla bla                [OK]    ; I already told you

Therefore, Drawing Preferences should start with the file format choice field;

 File Format: R.......

Drawing should be opened and saved in that format without any question. Please.

2312QCAD Community EditionBug ReportLowDraw from CSV can not create Layers with NewLayerAssigned
Task Description

NewLayer always complains about a missing parent layer.

I could not figure out how to create Layers from a CSV file,
I tried DrawCSV_Layer_test.csv which is a reference test from the qcad repo but NewLayer always returns “Parent layer doesn’t exist.”

Reading from file: /home/zem/DrawCSV_Layer_test.csv
Switched to semicolon/comma CSV style.
Layer doesn't exist, ignored. Text line 20 layer: 0 Entity Colors
Not a correct layer name. Text line 24 name: Invalid=`name`
Add/Update layer ignored.
Not a correct color. Text line 25 color: ByBlock
Add/Update layer ignored.
Not a correct Lineweight. Text line 26 weight: 999
Add/Update layer ignored.
Not a correct Linetype. Text line 27 type: Orange line
Add/Update layer ignored.
Parent layer doesn't exist. Text line 31 layer: MyLayerInvalid paren
Add/Update layer ignored.
Can not hide layer, ignored. Text line 34 layer: Invalid Hide
Can not freeze layer, ignored. Text line 35 layer: Invalid FreezeInvalid SUB
Can not lock layer, ignored. Text line 36 layer: Invalid Lock
Can not lock layer, ignored. Text line 37 layer: Invalid=`name`
Can not allow layer, ignored. Text line 38 layer: Invalid Allow
Can not switch to layer, ignored. Text line 39 layer: Invalid layer switch
Can not switch to layer, ignored. Text line 40 layer: Invalid=`name`
Parent layer doesn't exist. Text line 43 layer: 01 Gree
Add/Update layer ignored.
Parent layer doesn't exist. Text line 44 layer: 02 Parent
Add/Update layer ignored.
Parent layer doesn't exist. Text line 45 layer: 02 Parent1Sub
Add/Update layer ignored.
Parent layer doesn't exist. Text line 46 layer: 02 Parent1Sub1SubSub1 
Add/Update layer ignored.
Parent layer doesn't exist. Text line 47 layer: 03 Parent
Add/Update layer ignored.
Parent layer doesn't exist. Text line 48 layer: 03 Parent2Sub
Add/Update layer ignored.
Parent layer doesn't exist. Text line 49 layer: 03 Parent2Sub2SubSub
Add/Update layer ignored.
Parent layer doesn't exist. Text line 50 layer: 04 Parent
Add/Update layer ignored.
Parent layer doesn't exist. Text line 51 layer: 04 Parent3Sub
Add/Update layer ignored.
Parent layer doesn't exist. Text line 52 layer: 04 Parent3Sub3SubSub
Add/Update layer ignored.
Parent layer doesn't exist. Text line 53 layer: Last New &Curren
Add/Update layer ignored.
Can not hide layer, ignored. Text line 56 layer: 03 Parent2
Can not freeze layer, ignored. Text line 57 layer: 03 Parent2Sub2
Can not lock layer, ignored. Text line 58 layer: 03 Parent2Sub2SubSub2
Can not hide layer, ignored. Text line 60 layer: 04 Parent3
Can not freeze layer, ignored. Text line 61 layer: 04 Parent3
Can not lock layer, ignored. Text line 62 layer: 04 Parent3
Can not hide layer, ignored. Text line 63 layer: 04 Parent3Sub3
Can not freeze layer, ignored. Text line 64 layer: 04 Parent3Sub3
Can not lock layer, ignored. Text line 65 layer: 04 Parent3Sub3
Can not hide layer, ignored. Text line 66 layer: 04 Parent3Sub3SubSub3
Can not freeze layer, ignored. Text line 67 layer: 04 Parent3Sub3SubSub3
Can not lock layer, ignored. Text line 68 layer: 04 Parent3Sub3SubSub3
Can not allow layer, ignored. Text line 70 layer: 04 Parent3
Can not switch to layer, ignored. Text line 76 layer: 02 Parent1Sub1SubSub1 %
Layer doesn't exist, ignored. Text line 82 layer: 02 Parent1
Can not switch to layer, ignored. Text line 85 layer: 02 Parent1Sub1SubSub1 %
Casted entries : 4 with 90 text lines
Importing CSV complete. Command ended.

No layers are added in the resulting drawing.

OS here is fedora 34 and qcad is either from fedora or rpmfusion.

1666QCAD (main)Feature RequestLowDraw > Line > Relative Angle / Orthogonal: define lengt...Assigned
Task Description

Add option to define length (end point) using mouse pointer.

If reference point is “Middle”, extend line from middle in both directions to mouse cursor (?).

See also:

936QCAD (main)Feature RequestLowDisproportional scaling of block referencesAssigned
Task Description


... doesn’t works proper at circles and ellipses.

Circles: the scale works only proportional even though I have the options for x and y.
Ellipses: The same but if I play around with the x, y fields it will freeze the scale possibility.

622QCAD (main)Feature RequestLowDisproportianal scaling of arcs, ellipsesAssigned
Task Description

Support disproportional scaling also for arcs, ellipses, other entities, not only lines and polylines with only line segments.

1510QCAD (main)Feature RequestLowdimensioning, rounded valuesAssigned
Task Description

Approximation value for dimensioning, i.e. for example:
approximate to .5
measured valure 11.3456 > displayed value 11.5

1698QCAD (main)Feature RequestLowDimensioning - add option to split dimensionsAssigned
Task Description

Dimensioning - add option to split dimensions.

To have an option to split the extension lines if they run over other entities.

1699QCAD (main)Feature RequestLowDimensioning - add option to insert text in the middle ...Assigned
Task Description

Dimensioning - add option to insert text in the middle of dimension.

To have an option to have text aligned in the middle of the dimension line, rather than above it.

1697QCAD (main)Feature RequestLowDimensioning - add option for horizontal text alignmentAssigned
Task Description

Dimensioning - add option for horizontal text alignment.

Basically an option in drawing preferences to align text horizontally instead of vertically.

901QCAD (main)Feature RequestLowDimension text stylesAssigned
Task Description

Support custom dimension text styles for imported DXF / DWG files.

790QCAD (main)Feature RequestLowDimension Setting - Extension Line - total length setti...Assigned
Task Description

It would be nice to have the option for a “Short” Extension Line.
This is often used in Architectural drawings.
Yes, I know that I can explode a dimension and change it to that what I’m asking for - but that is really a Sisyphus task and destructs the function of a dynamic Dimension in QCAD.

757QCAD (main)Feature RequestLowDim: Architectural tick and Leader Arrow size independe...Assigned
Task Description

Leader Arrow size and the Architectural tick size are controlled by one and the same value.

It would be nice to get the possibility to adjust them independently from each other ...

2099QCAD (main)Bug ReportLowDIM Label, Square Symbol doesn't adopt layer attributesAssigned
Task Description

The square symbol offered as symbol in DIM label is the only symbol which doesn’t adopt the layer color.
If I print a drawing in full color it leads to a black symbol in an otherwise colored dimension.

It is also the only symbol which has a solid filling what is confusing when you work with it in Model_Space ...

1934QCAD (main)Feature RequestLowDiametric text - overlaidAssigned
Task Description

Diametric text is always placed above a horizontal measurement.

I often want to indicate both the inside and outside diameter of an object e.g. a wheel using diametric text. The text is overlaid and illegible.

To avoid text overlapping, I use Horizontal Aligned because I can control the position of the text to avoid illegible text.

A better method would be to alternate the placement of diametric text (alternatively) above and below a measurement so that in the majority of cases an overlap would be avoided.

Similarly for a vertical measurement, the text is overlaid and illegible.

When the angle is almost vertical, the angle controls the side the text appears however it also reverses the direction of the text (which is logical but not attractive).

Kind regards

1503QCAD (main)Feature RequestLowDetect duplicates within a given selection -new tool re...Assigned
Task Description

It would be so useful to have an option to be able to detect duplicates within a given selection.

2295QCAD (main)Feature RequestLowDeselect all with Escape keyAssigned
Task Description

I’m used to have persistant selection while drawing (Application Preferences > Graphics View:Appearance > Selection), but I’m missing deselection of all objects with ESC key. I have seen the option to deselect with right key, but it’s nice to have right key for context menu.

Currently ESC key cancels current active command, but would be nice if there is no command active to also deselect all features by default.

990QCAD (main)Feature RequestLowDefault Names for Custom Property ...Assigned
Task Description

Property Editor - Geometry - Custom - Add Custom Property

It would be nice to have in “Application preferences” the possibility to predefine a couple Custom Property Names.
Right now I use the Custom Property function to add a DIN and the Material info to every Block. This project has a lot of DIN parts and I have to type again and again the names DIN ... Material ... DIN ... Material ... DIN ... Material ... DIN ... Material ... DIN ... Material ... you got my point ;-)

If I have predefined Names - I have just to fill out the value :-)

2296QCAD (main)Feature RequestLowCustom font type and size for command line widgetAssigned
Task Description

Would be nice to change default font type and size for command line widget.

1843QCAD/CAMBug ReportLowCreating ToolPath StallsAssigned
Task Description

Hi Andrew,

Still working with and on CAM HPGL for the HP7580 pen plotter.

I have added a penplotter test drawing, that might be used for testing en callibrating plotter and pens. You may add it to the Examples-directory.

QCAD has a lot of trouble creating toolpaths and exports. Much too often it shuts itself down, or gets stalled. Why? I am not sure.

805QCAD (main)Feature RequestLowCreate tool radius compensation / tool path generationAssigned
Task Description

This is how I would implement this:

This would be a modification tool. Parts are selected, a toolpath is generated, and a dialog pops up to allow putting the tool path into an existing layer, a new layer, or replace all drawings in an existing layer.

This is how the toolpath is generated:

We iterate through all elements and explode everything but text into line segments. Then we connect the line segments into chains wherever the line endpoints are less than some tolerance away from each other. The chains can be very chaotic, but at least we have separate entities for now.

For every chain, we need to find the largest complete loop. A good drawing would only contain non-overlapping loops, but we can’t expect that. Everything that is not on this loop can not be defined as a part or as a hole, so we will merely create a tool path segment that is equivalent to the line segment. Every segment that *IS* on a loop is either an outside edge (part outline), or an inside edge (hole outline), (or overlapping, in which case it is neither, and we have an operator problem).

In a perfect world, we need to find exactly which shape is inside which other shape, and then create alternating tool offsets from the outmost loop (part edge) to the second outmost (hole), to the next (part) etc. .

In a simplified world, we can used the bounding box of the loop instead. This works OK for rectangular shapes, but a circle next to an “L” shape could be seen as inside the L’s bounding box, hence inside the L, wrongly accused of being a hole, not a part.

Now all that is left to do is to create a new loop, offset by the tool radius. Oh, and since we have the connections from line segment to line segment in the correct order already, we can use the opportunity to order all cutting loops from inner to outer, or from small to large, and order non-loop edges by travel distance.

The new drawing in the new layer can now be exported without further hassle to create a nice laser cut file.

PS: of course, a user could create multiple layers for marking, cutting, enraging, etc. . Additional Layer attributes for cutting speed and laser power (and a few more) would be needed.

2266QCAD (main)Bug ReportLowCrash while creating an angular dimensionAssigned
Task Description

no task description

2092QCAD (main)Bug ReportLowcrash when changing shortcut in preferencesAssigned
Task Description

The application crashes when I try to change a shortcut in the preferences. And only after resizing the preferences window.
In the attachement are the cli warnings.
I also tried the snapshot with the same result.

2315QCAD Community EditionBug ReportLowCrash after ~10-th times move Spline nodesAssigned
Task Description

1. Create spline
2. Move spline nodes. After ~10 times move qcad is crashed with backtrace:
Thread 9 “Thread (pooled)” received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fff56dc9640 (LWP 8224)]
0x00007ffff66fabf2 in QList<QSharedPointer<RShape> >::node_copy (this=<optimized out>, src=0x55537c59e758, to=0x555557f66408, from=0x55537cfdc848) at /usr/include/qt5/QtCore/qlist.h:492
492 current→v = new T(*reinterpret_cast<T*>(src→v));
(gdb) bt
#0 0x00007ffff66fabf2 in QList<QSharedPointer<RShape> >::node_copy (this=<optimized out>, src=0x55537c59e758, to=0x555557f66408, from=0x55537cfdc848)

  at /usr/include/qt5/QtCore/qlist.h:492

#1 QList<QSharedPointer<RShape> >::detach_helper (alloc=<optimized out>, this=0×555557311620) at /usr/include/qt5/QtCore/qlist.h:835
#2 QList<QSharedPointer<RShape> >::detach_helper (this=0×555557311620) at /usr/include/qt5/QtCore/qlist.h:849
#3 QList<QSharedPointer<RShape> >::detach (this=0×555557311620) at /usr/include/qt5/QtCore/qlist.h:178
#4 QList<QSharedPointer<RShape> >::detach (this=0×555557311620) at /usr/include/qt5/QtCore/qlist.h:178
#5 0x00007ffff686182a in QList<QSharedPointer<RShape> >::end (this=<optimized out>, this=<optimized out>) at /usr/include/qt5/QtCore/qlist.h:342
#6 QList<QSharedPointer<RShape> >::last (this=0×555557311620) at /usr/include/qt5/QtCore/qlist.h:364
#7 RSpline::appendToExploded (this=0×555557311510, line=...) at math/RSpline.cpp:964
#8 0x00007ffff6867059 in RSpline::getExploded (this=0×555557311510, segments=1457293328) at math/RSpline.cpp:919
#9 0x00007ffff686682a in RSpline::getLength ([email protected]=0×555557311510) at math/RSpline.cpp:1026
#10 0x00007ffff6c11490 in RSplineData::getLength (this=<optimized out>, this=<optimized out>) at /usr/src/debug/qcad-
#11 RSplineEntity::getProperty (this=0x5555573114a0, propertyTypeId=..., humanReadable=<optimized out>, noAttributes=<optimized out>,

  showOnRequest=<optimized out>) at /usr/src/debug/qcad-

#12 0x00007ffff67cc214 in RPropertyEditor::computePropertyValue (ccProp=...) at /usr/src/debug/qcad-
#13 0x00007ffff67d298f in QtConcurrent::FunctionWrapper1<void, RProperty&>::operator() (u=..., this=0x555557757f18)

  at /usr/include/qt5/QtConcurrent/qtconcurrentfunctionwrappers.h:80

#14 QtConcurrent::MapKernel<QList<RProperty>::iterator, QtConcurrent::FunctionWrapper1<void, RProperty&> >::runIteration (it=..., this=0x555557757ee0)

  at /usr/include/qt5/QtConcurrent/qtconcurrentmapkernel.h:68

#15 QtConcurrent::MapKernel<QList<RProperty>::iterator, QtConcurrent::FunctionWrapper1<void, RProperty&> >::runIterations (this=0x555557757ee0,

  sequenceBeginIterator=..., beginIndex=<optimized out>, endIndex=15) at /usr/include/qt5/QtConcurrent/qtconcurrentmapkernel.h:77

#16 0x00007ffff67d2c9d in QtConcurrent::IterateKernel<QList<RProperty>::iterator, void>::forThreadFunction (this=0x555557757ee0)

  at /usr/include/qt5/QtConcurrent/qtconcurrentiteratekernel.h:255

#17 0x00007ffff44b5b2d in QtConcurrent::ThreadEngineBase::run (this=0x555557757f20) at qtconcurrentthreadengine.cpp:302
#18 0x00007ffff59c8d52 in QThreadPoolThread::run (this=0x555556198b10) at thread/qthreadpool.cpp:100
#19 0x00007ffff59c5a61 in QThreadPrivate::start (arg=0x555556198b10) at thread/qthread_unix.cpp:329
#20 0x00007ffff546c717 in start_thread (arg=<optimized out>) at pthread_create.c:435
#21 0x00007ffff54f018c in clone3 () from /lib64/libc.so.6

1977QCAD (main)Feature RequestLowCorresponding coordinate format Assigned
Task Description


It would be less confusing to read messages in the command line protocol if it would use the same coordinate separators like the settings below Application Preferences / General / Coordinate Format.

This example shows the “Absolute Cartesian Coordinate” but of course all corresponding format settings should be used within messages.

Absolute Cartesian Coordinate: Setting = semicolon (;) but the message will use division (/).

503QCAD (main)Feature RequestLowConvert entities to points with a fixed distanceAssigned
Task Description

Select lines, arcs, ... and convert them to points along the lines, arcs, ... with a fixed distance.

See also forum at:

670QCAD (main)Feature RequestLowConfigurable rendering options for stacked textAssigned
Task Description

Customer wishes that stacked text used as subscript is rendered differently (i.e. increased text size, lower position for subscript).
This may also apply to superscripts.

Showing tasks 351 - 400 of 452 Page 8 of 10<<First - 6 - 7 - 8 - 9 - 10 -

Available keyboard shortcuts


Task Details

Task Editing