QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategoryTask Type  descSeveritySummaryStatusProgress
948QCAD (main)Bug ReportLowmainwindow example segfaultsAssigned
0%
Task Description

As far as I can tell, it never worked.

#0  0x0000000000490527 in QFormInternal::domPropertyToVariant ()
No symbol table info available.
#1  0x000000000042aea9 in QFormInternal::QAbstractFormBuilder::toVariant ()
No symbol table info available.
#2  0x00000000004498a6 in QFormInternal::QFormBuilder::applyProperties ()
No symbol table info available.
#3  0x000000000042475f in QFormInternal::FormBuilderPrivate::applyProperties ()
No symbol table info available.
#4  0x000000000042e83b in QFormInternal::QAbstractFormBuilder::create ()
No symbol table info available.
#5  0x00000000004493c0 in QFormInternal::QFormBuilder::create ()
No symbol table info available.
#6  0x000000000042182e in QFormInternal::FormBuilderPrivate::create ()
No symbol table info available.
#7  0x000000000042fa37 in QFormInternal::QAbstractFormBuilder::create ()
No symbol table info available.
#8  0x00000000004225a2 in QFormInternal::FormBuilderPrivate::create ()
No symbol table info available.
#9  0x0000000815eed3d7 in QFormInternal::QAbstractFormBuilder::load ()
   from /usr/home/ice/w/qcad/qcad/plugins/script/libqtscript_uitools.so.1.0.0
No symbol table info available.
#10 0x0000000815ededad in QUiLoader::load () from /usr/home/ice/w/qcad/qcad/plugins/script/libqtscript_uitools.so.1.0.0
No symbol table info available.
#11 0x0000000815eda326 in qtscript_QUiLoader_prototype_call (context=0x813262240)
    at ../../generated_cpp/com_trolltech_qt_uitools/qtscript_QUiLoader.cpp:282
        _q_arg0 = (QIODevice *) 0x813fe5610
        _q_arg1 = (QWidget *) 0x813ffdcd0
        _q_result = (QWidget *) 0x8006e2c00
        _id = <value optimized out>
        _q_self = (QUiLoader *) 0x813f08d40
#12 0x0000000805fc9f78 in QScript::FunctionWrapper::proxyCall () from /usr/local/lib/qt4/libQtScript.so.4
No symbol table info available.
#13 0x0000000805ee418f in QTJSC::NativeFuncWrapper::operator() () from /usr/local/lib/qt4/libQtScript.so.4
No symbol table info available.
#14 0x0000000805eb93ee in QTJSC::Interpreter::privateExecute () from /usr/local/lib/qt4/libQtScript.so.4
No symbol table info available.
#15 0x0000000805ec1ccd in QTJSC::Interpreter::execute () from /usr/local/lib/qt4/libQtScript.so.4
No symbol table info available.
#16 0x0000000805ec1ff9 in QTJSC::Interpreter::execute () from /usr/local/lib/qt4/libQtScript.so.4
No symbol table info available.
#17 0x0000000805fa9743 in QScriptEnginePrivate::evaluateHelper () from /usr/local/lib/qt4/libQtScript.so.4
No symbol table info available.
#18 0x0000000805faabc6 in QScriptEngine::evaluate () from /usr/local/lib/qt4/libQtScript.so.4
No symbol table info available.
#19 0x0000000800ac5aae in RScriptHandlerEcma::eval (this=0x811f435e0, script=<value optimized out>, 
    fileName=<value optimized out>) at RScriptHandlerEcma.cpp:855
        err = {d_ptr = {d = 0x7fffffffcf50}}
#20 0x0000000800ac65c5 in RScriptHandlerEcma::doScript (this=0x811f435e0, [email protected], 
    arguments=<value optimized out>) at RScriptHandlerEcma.cpp:851
        fi = {d_ptr = {d = 0x813f94700}}
        globalObject = {d_ptr = {d = 0x813ff1240}}
        contents = {static null = {<No data fields>}, static shared_null = {ref = {_q_value = 3936}, alloc = 0, size = 0, 
    data = 0x809bb387a, clean = 0, simpletext = 0, righttoleft = 0, asciiCache = 0, capacity = 0, reserved = 0, array = {0}}, 
  static shared_empty = {ref = {_q_value = 19}, alloc = 0, size = 0, data = 0x809bb389a, clean = 0, simpletext = 0, 
    righttoleft = 0, asciiCache = 0, capacity = 0, reserved = 0, array = {0}}, d = 0x811c11800, static codecForCStrings = 0x0}
#21 0x0000000000417d13 in MainWindow (this=0x7fffffffd4b0, parent=<value optimized out>) at MainWindow.cpp:99
No locals.
#22 0x0000000000416ad9 in main (argc=1, argv=<value optimized out>) at main.cpp:35
        app = <value optimized out>
        window = {<QMainWindow> = {<QWidget> = {<QObject> = {_vptr$QObject = 0x4992b0, static staticMetaObject = {d = {
            superdata = 0x0, stringdata = 0x809933ae0 "QObject", data = 0x809933b80, extradata = 0x809ba94c0}}, 
        static staticMetaObjectExtraData = {objects = 0x0, 
          static_metacall = 0x80985cd80 <QObject::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)>}, d_ptr = {
          d = 0x811d28600}, static staticQtMetaObject = {d = {superdata = 0x0, stringdata = 0x80993cc40 "Qt", 
            data = 0x809940560, extradata = 0x0}}}, <QPaintDevice> = {_vptr$QPaintDevice = 0x499478, painters = 0}, 
      static staticMetaObject = {d = {superdata = 0x809ba94e0, stringdata = 0x808e66be0 "QWidget", data = 0x808e670c0, 
          extradata = 0x809282360}}, static staticMetaObjectExtraData = {objects = 0x0, 
        static_metacall = 0x8087899a0 <QWidget::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)>}, 
      data = 0x811d28748}, static staticMetaObject = {d = {superdata = 0x809282380, stringdata = 0x808ec04c0 "QMainWindow", 
        data = 0x808ec0660, extradata = 0x8092abc60}}, static staticMetaObjectExtraData = {objects = 0x8092d1880, 
      static_metacall = 0x808e5aaf0 <QMainWindow::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)>}}, 
  documentInterface = 0x811d31600}
        ret = <value optimized out>
976dxflibBug ReportLowDXF import errors related to hatches, textsAssigned
0%
Task Description

See:
http://www.qcad.org/rsforum/posting.php?mode=reply&f=30&t=2677

980QCAD (main)Bug ReportLowIsometric Projection / blocks / wrong layer are used in...Assigned
0%
Task Description

Isometric Projection used on a selection which contains blocks will mix up the layer affiliations.
No blocks - no problems ;-)

1008QCAD (main)Bug ReportLowDXF (dxflib) compat issuesAssigned
0%
Task Description

Git head as well as 3.4.5 (trial), both with dxflib 3.3.4.0.

Start up QCAD, (with existing or new configuration, doesn’t seem to matter), “Save as” the completely empty drawing, choose “R15 (dxflib)” on Pro (only this one is available on community), save drawing.

Fire up AutoCAD 2000, try to load the empty drawing just saved.

Result:

DXF read error
Error in APPID Table
DXF read error on line 941.
Invalid or incomplete DXF input -- drawing discarded.

Problem not present when a completely empty drawing saved using Teigha in R15 format is opened (ie. it just results in an empty drawing in AutoCAD 2000). Problem is also not present when saving an existing drawing with Pro (trial) with Teigha and opening it in AutoCAD 2000. Problem does present when trying to open a dxflib-saved drawing in AutoCAD 2000.

Empty drawings created with both dxflib 3.3.4.0 in QCAD Pro 3.4.5 trial and Teigha whatever in QCAD Pro trial 3.4.5 are attached. (Community Git 135fd0 is identical to Pro - same dxflib version.)

1087QCAD (main)Bug ReportLowRuler ticks are not corresponding to the grid pointsAssigned
0%
Task Description

Ruler ticks are not corresponding to the grid points,
Ruler will completely disappear at a certain zoom level,

Settings:
Drawing unit: inch,
Grid settings: Grid 1, Meta Grid 12,
Dim Label Format: “Engineering, 0’-0.0”

see topic below:
http://www.qcad.org/rsforum/viewtopic.php?f=32&t=3014

1203dxflibBug ReportLowImages not saved (dxflib)Assigned
0%
Task Description

I am doing a bit of landscaping and using a (big) ortophoto as one of my layers in order to sanity-check on the ground measurements.

The layer contains a point and the image and nothing else.

The image is a 8MB file: “PNG image data, 4200 x 2980, 8-bit/color RGB, non-interlaced” and it is scaled to 210 coordinate units (meter) horizontally in the drawing.

With approx 50% probability the image disappears during Save, as see for instance in this diff of the DXF file:

      @@ -158699,28 +153057,6 @@ AcDbXrecord
        90
       6
         0
      -IMAGEDEF
      -  5
      -A1
      -100
      -AcDbRasterImageDef
      - 90
      -0
      -  1
      -/critter/HTV10/Ortofoto/ortofoto201502f.png
      - 10
      -210.0
      - 20
      -149.0
      - 11
      -1.0
      - 21
      -1.0
      -280
      -1
      -281
      -0
      -  0
       ENDSEC
         0
       EOF

The point in the same layer does not similarly disappear, the bug only seems to affect images.

I have seen this bug from version 3.7.5.0 to git as of yesterday (63e06c778926a803bdfbffdf27b8c24d41511072).

I have not been able to correlate the bug with anything.

Looking closer at the DXF file (attached), there seems to be some residuce of attempts to insert images in protected/invisible layers, so this may be some kind of refcounting issue.

(Any chance of getting FreeBSD into the “Operating System” field ?)

1242QCAD (main)Bug ReportLowSVG import DPI box should use localized decimal separat...Assigned
0%
Task Description

I wanted to make it so, that SVG units translate 1:1 into CAD units; I use the German localized QCAD and entered 25,4 into the box with the wrong result, i.e. the same as 25; Entering 25.4 got me what I wanted: The question box needs the point and ignores the comma. Would be nice if it could use the localized separator.

1339QCAD (main)Bug ReportLowLibrary Browser unstoppableAssigned
0%
Task Description

Hi,

Even with the Application Preference, Library Browser, NO Update on Start up,
the Libray Browser scans the directory, a proces that can’t be stopped or closed.

1427QCAD (main)Bug ReportLowInfo Tool / Polylinie Area (II)/ Preview brokenAssigned
0%
Task Description

Print “Command Line” and as “Add measurement to drawing” works as expected.

1443QCAD (main)Bug ReportVery LowView > Status Bar remains uncheckedAssigned
0%
Task Description

Status Bar menu remains unchecked even it is toggled on or off

1445QCAD (main)Bug ReportLowSwitching off grid scaling can break rulersAssigned
0%
Task Description

See also:
http://www.qcad.org/rsforum/viewtopic.php?f=32&t=4314

1691QCAD (main)Bug ReportVery LowIssue with Layouts after "File-Revert"Assigned
0%
Task Description

QCad 3.19.2 Professional, 64bit, Liux Mint

Case:
1. Open some saved drawing with viewport entities on layout block (paper space). Print Preview mode is “On” automatically.
2. After “File-Revert” drawing is reopened on layout block (paper space), but now Print Previw mode is “Off” .

For example can try on “flange.dxf”

1719QCAD (main)Bug ReportVery LowUndo on converted drawing leads to wrong label position...Assigned
0%
Task Description

Drawing converted from inch to mm - undo leads to wrong dim label position. I can fix that with “Reset Label position” but it would be nice if QCAD could to that in first place.

1760QCAD (main)Bug ReportVery LowSelf-crossing polylines can't be cut twice at segment c...Assigned
0%
Task Description

Re-entering dividing problem from  FS#1757 

Divide the poly selecting near segment 1 at the segment crossing.
> A new node is inserted on the crossing and made start and end node.
Divide the poly again selecting near segment 2 at the segment crossing.
> no division appears to be done.

One can’t divide the second segment at the crossing

Presumed intended behaviour like  FS#1750 

Regards

1843QCAD/CAMBug ReportLowCreating ToolPath StallsAssigned
0%
Task Description

Hi Andrew,

Still working with and on CAM HPGL for the HP7580 pen plotter.

I have added a penplotter test drawing, that might be used for testing en callibrating plotter and pens. You may add it to the Examples-directory.

QCAD has a lot of trouble creating toolpaths and exports. Much too often it shuts itself down, or gets stalled. Why? I am not sure.

1847QCAD/CAMBug ReportLowBUG MEMORYAssigned
0%
Task Description

Hi Andrew,

Still working on creating HPGL.PLT toolpaths for the HP7580 pen plotter. QCAD has some trouble creating toolpaths. Too often it shuts itself down, or the PC gets stalled.

Recreating the same error however is possible

1900QCAD (main)Bug ReportVery LowRemote shares initially not accessible.Assigned
0%
Task Description

My data files are stored on network shares (synology) with a GB link. QCAD Pro is run in Admin mode.

While in my Windows browser all remote shares are accessible (Green), in the QCAD file open menu they are initially shown as not accessible (Red). By accessing a specific drawing file in a remote share, the share will open and turn green.

Same behavior using ‘Open recent’. Always the message is given that the requested file does not exist, and the file is wiped from the ‘Recent Open’ list. Only if the share is first accessed through ‘Open’ with a random file, it will turn and a ‘recent open’ file for that share will open.

Drag and Drop from a remote share will never work.

1905QCAD (main)Bug ReportVery LowView > Property Editor: Changing attribute of block cha...Assigned
0%
Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=33&t=6367#p23947

1912QCAD/CAMBug ReportLowTool Description ErrorAssigned
0%
Task Description

Hallo Andrew,

Testing the drill toolpath I find it hard to select the correct tool by a small bug

1913QCAD/CAMBug ReportLow3D Simulation Behaves oddAssigned
0%
Task Description

Hallo Andrew,

testing the drill toolpath I used single point markers.

In 3D simulation the tool drills the toolpath AND uses the drill as a mill.

Cam Export and generated G-code is not effected.

1916QCAD (main)Bug ReportLowMoving an object in an angled viewport with mouse does ...Assigned
0%
Task Description

To reproduce

1. Select a new view-port in model-space
2. Select the appropriate paper-space
3. When the paper space opens change the angle of the viewport to 90 degrees
4. Place view-port in paper space
5. Select the view-port in paper-space by clicking it
6. Try to move the object itself in the view-port (by clicking the “top” dot) to the right by moving the mouse to the right while holding the left mouse-button.

Actual

The object in the viewport moves down vertically NOT to the right

Expected

The object moves to the right

(It seems mouse movement does not compensate for the rotated angle of the viewport)

Workaround

None, except compensate for the angle in your head and moving the mouse the “wrong” way when correcting the placement of objects in the view-port

1919QCAD (main)Bug ReportVery LowWrong order XY(Z) for Ordinate Dimension in property ed...Assigned
0%
Task Description

Win7pro Qcad Pro 3.22.1.2

In property editor
properties of an Ordinate Dimension

Without Show Z
DefPoint is displayed in order YX?

With Show Z
Origin is displayed in order XZY?
DefPoint is displayed in order YZX?
LeaderEndPoint is displayed in order ZXY?

Regards

1923QCAD (main)Bug ReportVery LowFaulty rendering Polylines with Global/Local Widths and...Assigned
0%
Task Description

Win7pro 32bit Qcad 3.23.0

Andrew,
The Arc segments of Polylines with Global or any Local Width render faulty where Global Z or any of the arc’s local Z is not zero.

In the attached drawing setting the Global Z of the inner poly to 5,10,...

The setting of Z to not zero affects the radius of the projected arc and not the bulging of the poly.
It also affects the projected widths of the line inversely, but not by changing the widths properties.

Pritty rare combination! True.
Qcad is 2D native! True.

Flatten will resolve this.

It is not a purely visual rendering fault, the poly will explode as such.

Maybe similar flaw as with uneven scaling blocks with arcs.
https://qcad.org/rsforum/viewtopic.php?f=8&t=5566#p20703

Regards

1924QCAD (main)Bug ReportLowSweepAngle = 0Assigned
0%
Task Description

Win7pro 32bit Wininstaller Qcadpro 3.23.0

Draw an arc.
Select the arc.
In Property Editor:
Set start angle to 135
Set end angle to 135

SweepAngle = */-360

edit the end angle and add “+360”, hit enter

SweepAngle = 0

An arc with zero sweep is a point.
A point is not an arc.
With the same start and end parameter an arc should have a sweep of +/-360.
As for entries by points or by angles.

Regards

1933QCAD (main)Bug ReportLowAdvanced SVG export file overwrite check doesn't use up...Assigned
0%
Task Description

In the Advance SVG Export dialog, when I edit the filename to be different than the default file that already exists and then clear the checkbox for “Overwrite existing file without asking” just to make sure that I haven’t already created a file with the modified name as well, then I get a popup warning that the export would overwrite the default filename, not the name as edited. In other words, the overwrite check ignored the fact that I edited the filename.

Observed on MacOS Mojave (10.14), but probably applies to all.

1936QCAD (main)Bug ReportLowver 3.23 not saving font informationAssigned
0%
Task Description

The attached file is not saving font preference.
All fonts on the online layer are reported as the standard font. If I highlight one or all of the text entities and change the font to something like Yu gothic light, the property page reports yu gothic light and the screen reflects the changed font.
If I save, close and reload, the fonts for all text is again “standard”.

So then I try to enter new text via the “A” draw text command icon. I select “Broadway.ttf” as the main font in the text entry dialog.
One word “Broadway” is entered as the text. it appears on the upper left of the screen as expected and the font name is Broadway in the property editor. If I look at the dxf file source there is a whole bunch of text styles.
I save and close the file, and then open it again. Now the word Broadway has changed to font name “standard” in the property editor and is very definitely not the Broadway.ttf font.

I am not the originator of the file, I am just trying to change the font. If I start a new file and enter new text the font saves just fine, so I am thinking it is a setting somewhere, but I am unable to find it.

We (me and my customers) use these files for engraving so exact font is critical.

1960dwg2pdfBug ReportLowdwg2pdf command failAssigned
0%
Task Description

Good afternoon, I found a bug.

Source file: B5.dwg.

Command line: .\dwg2pdf.bat -f -a -recompute-dim -ltscale=1 -font-substitution Standard GBK path

After I used the command, the message “Warning: standard font not found” occured. And B5.pdf is not found.
Convert is fail.

1961dwg2pdfBug ReportLowToo many drawings are missingAssigned
0%
Task Description

Hello, I found a bug.

Original file: 006–【武汉会展中心店】一层合用前室.dwg

Converted file: 006–【武汉会展中心店】一层合用前室.pdf

Command line: .\dwg2pdf.bat -f -a -recompute-dim -ltscale=1 -block=布局1 path

Bug description file: problem8.png

As you see. I use dwg2pdf to export the block named “布局1”. There are too many drawings missing.

1971QCAD/CAMBug ReportLowCAD/CAM 3D SimulatorAssigned
0%
Task Description

Hallo Andrew,

Found a bug in the 3D Simulator execution

1972QCAD (main)Bug ReportLowHatch import fails for boundaries with many very small ...Assigned
0%
Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=33&t=6648

1974QCAD (main)Bug ReportVery LowFile > Print Preview: Cannot move paper in new drawingUnconfirmed
0%
Task Description

Yesterday I set up a Windows 64 bit install of QCAD Pro which shows the same bug I have been seeing for a while in the Community linux git repo.

Create a new drawing and then go to “Print preview”. Enable “Move paper postion”, the cursor changes to the hand icon, but the paper position is unable to be moved. Only by saving the drawing, exiting the program, restarting and reopening the drawing, will the “Move paper postion” function correctly.

Affected versions tested:

Windows 64bit installer download, as of yesterday.
Linux 64bit build from git, about 20minutes ago.

For what it’s worth, this bug is not present in this previous git checkout:

Version:
3.21.1.0 (3.21.1)
Internet:
QCAD.org
Build Date:
Jul 2 2018
Revision:

Qt Version:
5.7.0
Architecture:
x86_64
Compiler:
gcc 6.3.1

Thanks for a great product.

Showing tasks 351 - 381 of 381 Page 8 of 8<<First - 4 - 5 - 6 - 7 - 8

Available keyboard shortcuts

Tasklist

Task Details

Task Editing