QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategoryTask TypeSeveritySummaryStatusProgress  desc
1691QCAD (main)Bug ReportVery LowIssue with Layouts after "File-Revert"Assigned
0%
Task Description

QCad 3.19.2 Professional, 64bit, Liux Mint

Case:
1. Open some saved drawing with viewport entities on layout block (paper space). Print Preview mode is “On” automatically.
2. After “File-Revert” drawing is reopened on layout block (paper space), but now Print Previw mode is “Off” .

For example can try on “flange.dxf”

1719QCAD (main)Bug ReportVery LowUndo on converted drawing leads to wrong label position...Assigned
0%
Task Description

Drawing converted from inch to mm - undo leads to wrong dim label position. I can fix that with “Reset Label position” but it would be nice if QCAD could to that in first place.

1843QCAD/CAMBug ReportLowCreating ToolPath StallsAssigned
0%
Task Description

Hi Andrew,

Still working with and on CAM HPGL for the HP7580 pen plotter.

I have added a penplotter test drawing, that might be used for testing en callibrating plotter and pens. You may add it to the Examples-directory.

QCAD has a lot of trouble creating toolpaths and exports. Much too often it shuts itself down, or gets stalled. Why? I am not sure.

1847QCAD/CAMBug ReportLowBUG MEMORYAssigned
0%
Task Description

Hi Andrew,

Still working on creating HPGL.PLT toolpaths for the HP7580 pen plotter. QCAD has some trouble creating toolpaths. Too often it shuts itself down, or the PC gets stalled.

Recreating the same error however is possible

1900QCAD (main)Bug ReportVery LowRemote shares initially not accessible.Assigned
0%
Task Description

My data files are stored on network shares (synology) with a GB link. QCAD Pro is run in Admin mode.

While in my Windows browser all remote shares are accessible (Green), in the QCAD file open menu they are initially shown as not accessible (Red). By accessing a specific drawing file in a remote share, the share will open and turn green.

Same behavior using ‘Open recent’. Always the message is given that the requested file does not exist, and the file is wiped from the ‘Recent Open’ list. Only if the share is first accessed through ‘Open’ with a random file, it will turn and a ‘recent open’ file for that share will open.

Drag and Drop from a remote share will never work.

1905QCAD (main)Bug ReportVery LowView > Property Editor: Changing attribute of block cha...Assigned
0%
Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=33&t=6367#p23947

1913QCAD/CAMBug ReportLow3D Simulation Behaves oddAssigned
0%
Task Description

Hallo Andrew,

testing the drill toolpath I used single point markers.

In 3D simulation the tool drills the toolpath AND uses the drill as a mill.

Cam Export and generated G-code is not effected.

1916QCAD (main)Bug ReportLowMoving an object in an angled viewport with mouse does ...Assigned
0%
Task Description

To reproduce

1. Select a new view-port in model-space
2. Select the appropriate paper-space
3. When the paper space opens change the angle of the viewport to 90 degrees
4. Place view-port in paper space
5. Select the view-port in paper-space by clicking it
6. Try to move the object itself in the view-port (by clicking the “top” dot) to the right by moving the mouse to the right while holding the left mouse-button.

Actual

The object in the viewport moves down vertically NOT to the right

Expected

The object moves to the right

(It seems mouse movement does not compensate for the rotated angle of the viewport)

Workaround

None, except compensate for the angle in your head and moving the mouse the “wrong” way when correcting the placement of objects in the view-port

1971QCAD/CAMBug ReportLowCAD/CAM 3D SimulatorAssigned
0%
Task Description

Hallo Andrew,

Found a bug in the 3D Simulator execution

1972QCAD (main)Bug ReportLowHatch import fails for boundaries with many very small ...Assigned
0%
Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=33&t=6648

1974QCAD (main)Bug ReportVery LowFile > Print Preview: Cannot move paper in new drawingUnconfirmed
0%
Task Description

Yesterday I set up a Windows 64 bit install of QCAD Pro which shows the same bug I have been seeing for a while in the Community linux git repo.

Create a new drawing and then go to “Print preview”. Enable “Move paper postion”, the cursor changes to the hand icon, but the paper position is unable to be moved. Only by saving the drawing, exiting the program, restarting and reopening the drawing, will the “Move paper postion” function correctly.

Affected versions tested:

Windows 64bit installer download, as of yesterday.
Linux 64bit build from git, about 20minutes ago.

For what it’s worth, this bug is not present in this previous git checkout:

Version:
3.21.1.0 (3.21.1)
Internet:
QCAD.org
Build Date:
Jul 2 2018
Revision:

Qt Version:
5.7.0
Architecture:
x86_64
Compiler:
gcc 6.3.1

Thanks for a great product.

2014QCAD (main)Bug ReportLowFocus on Options Toolbar failsAssigned
0%
Task Description

Scenario: e.g. Tools Move/Copy and Rotate switched to “use without dialog.

Launch within a drawing Move/Copy, use the Keyboard keys CTRL + Space to focus on the Option Bar - the field for Numbers is Highlighted and I can change it. Further navigation with keys on the keyboard depends on remembered option (copy yes/no etc what make a navigation possible or not. It looks like the navigation with the Arrow keys is focused on the canvas and sooner or later the courser will jump to the Command Line or Property editor. Same behavior with the Rotation tool.

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=32&t=6828

2041QCAD (main)Bug ReportLowcircletangent2 doesn't solve correctly if the defining ...Assigned
0%
Task Description

In my example I can’t draw a circle with circletangent2 if the defining point is on one of the defining tangents. The tangency is lost when I try to do this.

I attached 4 screenshots: TheExample.png, TryingPoint1.png, TryingPoint2.png and The_Point_Isn’t_On_The_Tangents.png.

2048QCAD (main)Bug ReportVery LowMove / Copy to current layer fails when reference point...Assigned
0%
Task Description

QCAD 3.24.2 / macOS x86_64 10.14.6

Starting with empty doc:
1. Draw any object (e.g. a rectangle) on layer 0.
2. Create new layer (”1”) with color, say yellow.
3. Select new layer
4. Select new object
5. Modify → Move / Copy
6. Click reference point
7. Click target point same as reference point
8. In “Move / Copy Options” dialog, select “Delete Original” and check “Use current layer and attributes.” Click OK.

The moved object stays on the layer it was previously on. Using “Move / Copy” as a quick way to move a selection between layers is not useful even though it appears to be the recommended way in a Google search.

Note: if “Keep Original” is selected instead, the copied object is placed on the current layer and the original object remains on its layer, as expected.

Note: if the target point is different from the reference point, the moved object is placed on the current layer as expected.

There are other workarounds too, cut / paste with “To current layer” checked seems to work, as does chaging the layer in the Properties Editor.

2068QCAD Community EditionBug ReportVery LowNon-english text in upper/lower index becomes UTF codeAssigned
0%
Task Description

How to reproduce.

1. Create a text field with some non-english words in the upper index. (see attached pic1.png)
2. Save the project and close QCAD.
3. Run QCAD and open same project.
4. Now upper/lower indexed text becomes not human readable UTF codes. (see attached pic2.png)

Tried different fonts - doesn’t help.

Linux ntb-kirill 3.10.0-1062.12.1.el7.x86_64 #1 SMP Tue Feb 4 23:02:59 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
CentOS Linux release 7.7.1908 (Core)

2088QCAD (main)Bug ReportVery Low column headers of the "General: tool settings " resize...Assigned
0%
Task Description

Open QCAD and the application preferences. In the section “General: tool settings " you can resize the columns: Menu, Shortcuts etc.
The problem is that it is not intuitive. The first divider is not selectable and the second moves the first, only backwards.

2092QCAD (main)Bug ReportLowcrash when changing shortcut in preferencesAssigned
0%
Task Description

The application crashes when I try to change a shortcut in the preferences. And only after resizing the preferences window.
In the attachement are the cli warnings.
I also tried the 3.24.3.9 snapshot with the same result.

2097QCAD (main)Bug ReportVery LowVery hard to snap to baseline reference point of dimens...Assigned
0%
Task Description

With default autosnap settings reference points included I find it very hard to snap to the baseline reference points of a dimension.
I manage to do it by setting snap to reference point only and zoom out till I see the entire dimension element.

2099QCAD (main)Bug ReportLowDIM Label, Square Symbol doesn't adopt layer attributesAssigned
0%
Task Description

The square symbol offered as symbol in DIM label is the only symbol which doesn’t adopt the layer color.
If I print a drawing in full color it leads to a black symbol in an otherwise colored dimension.

It is also the only symbol which has a solid filling what is confusing when you work with it in Model_Space ...

2125QCAD (main)Bug ReportLowText disappears when you zoomWaiting on User
0%
Task Description

When I zoom, the text disappears in certain zoom levels after updating to the latest version.

2169QCAD (main)Bug ReportLowMissing G-Code G00 X0 Y0 when placing hole at x0 y0Assigned
0%
Task Description

When placing a hole at x0 y0 there is no G00 x0 y0 in the exported G-Code.
So the first cut was made at the current position of the tool, not at x0 y0!

2198QCAD (main)Bug ReportLowInternational characters change when saving and reloadi...Waiting on fix in 3rd party library
0%
Task Description

Text font changes when saving and reloading the file.
Original text before saving:
ľščťžýáíé ôúäň
Text after reopening the file:
¾šèžýáíé ôúäò
See also attachments.

2205QCAD (main)Bug ReportLowText rendering fails in certain zoom levelWaiting on fix in 3rd party library
0%
Task Description

Case:
Drawing with text, zoom in and out with one of the common methods, text will disappear in certain zoom level

Same drawing zoomed in and out in 3.20.0.0 doesn’t show this effect - works just fine.

2228QCAD (main)Bug ReportLowInvalid Symbol Table name.Assigned
0%
Task Description

During saving file I’m getting information “Invalid Symbol Table name error”. Problem is already known so i tried to follow the instructions given to other users by you. I’ve tried to change spaces to _ symbol in the layers names or deleting polish specific letters but there was no change. I was able to find out that the problem is related only to four layers named: A_ciany... When I delete these layers I’m able to save file without error message. Can you tell me what’s wrong in these layers? I’ve tried to change names of these layers but problem still exists. Best regards.

Showing tasks 401 - 424 of 424 Page 9 of 9<<First - 5 - 6 - 7 - 8 - 9

Available keyboard shortcuts

Tasklist

Task Details

Task Editing