QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategory  ascTask TypeSeveritySummaryStatusProgress
 1872 QCAD Community EditionSuggestionLow inconsistent color of the active layer icon for dark th ...Closed
100%
Task Description

Hello

So, I think .. that when the dark scheme has been chosen
the eye color for the active layers should be white
(similar to the list of blocks).

Best regards
Jacek

 1939 QCAD Community EditionBug ReportLow Right click not working in QCAD Community Edition Closed
100%
Task Description

After I remove the .dll files from the pro trial version, right click stop working on Windows 10.
I went a little further to try identifying which of the 5 files specifically causes right click to stop working, and I found that it is qcadproscripts.dll. The presence or absence of the other 4 dll files that make up the pro version has no influence on this behavior.

 998 QCAD/CAMBug ReportVery Low Grounded 0 recursive block references in blocks: Closed
100%
Task Description

I open anyting file dxf, the message pop-up : Grounded 0 recursive block references in blocks:

 1324 QCAD/CAMSuggestionVery Low Confusing Copy / Move option Closed
100%
Task Description

Hi,

Using the Copy and Move command the [ ] Use current layer and attributes’ is confusing.

Perhaps [ ] change copy /moved set to current layers and attributes. is more suitable.

 1369 QCAD/CAMBug ReportVery Low qcad-bin is trying to access non-existent /home/andrew Closed
100%
Task Description

I experience long start delays. I’ve trace the problem to the fact that I have autofs automounting my home directories. However, an strace of qcad-bin shows the following:

execve("/opt/ribbonsoft/qcad/qcad-3.12.6/qcad-bin", ["/opt/ribbonsoft/qcad/qcad-3.12.6"...], [/* 87 vars */]) = 0
brk(NULL)                               = 0x1eca000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fd6194ad000
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
open("/home/andrew/local/qt/lib/tls/x86_64/libqcadecmaapi.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/andrew/local/qt/lib/tls/x86_64", 0x7fff4722f250) = -1 ENOENT (No such file or directory)
open("/home/andrew/local/qt/lib/tls/libqcadecmaapi.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/andrew/local/qt/lib/tls", 0x7fff4722f250) = -1 ENOENT (No such file or directory)
open("/home/andrew/local/qt/lib/x86_64/libqcadecmaapi.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/andrew/local/qt/lib/x86_64", 0x7fff4722f250) = -1 ENOENT (No such file or directory)
open("/home/andrew/local/qt/lib/libqcadecmaapi.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/andrew/local/qt/lib", 0x7fff4722f250) = -1 ENOENT (No such file or directory)

Since there is no “andrew” user here, I have to wait for automount to timeout which takes about 2m and is rather annoying.

 1799 QCAD/CAMBug ReportVery Low Postprocessor: sign not forced for negative values roun ...Closed
100%
Task Description

formatValue returns “0” instead of “+0” for negative values that round up to 0 with the configured decimals.

 958 QCAD/CAMBug ReportLow CAM Export: points not exported Closed
100%
Task Description

Points are not being exported.

 961 QCAD/CAMBug ReportLow transactionlistener.so plugin gets installed to the wro ...Closed
100%
Task Description

When compiling QCAD 3.4.2.0 on Linux, the transactionlistener plugin gets installed to the wrong folder. The attached patch provides the correct directory path that trasactionlistener.so file gets installed too.

 1003 QCAD/CAMFeature RequestLow QCAD Community Edition: add unicode support for layer n ...Closed
100%
Task Description

Community version (still on FBSD only), so dxflib. I suspect the culprit is dxflib.

I have created layers and blocks and whatnot with (hungarian) accented characters in their names.
Apparently (according to the Internet, as evidenced probably most glaringly by usa.autodesk.com /adsk/servlet/ps/dl/item?siteID=123112&id=7586582&linkID=9240617) the R15 DXF version assumes single-byte character sets being used. Quick grepping the DXF2000 mentions “String (255-character maximum; less for Unicode strings)” (Group Code Value types), so it may be a false track...

Anyway, the DXF file written does have strings converted to single-byte encoding, but it seems it’s always ANSI-1252. When the output encoder encounters a character that is not representable in this one, it will use a literal question mark.

Actual case, I have a block with the name

106 egypólusú váltókapcsoló jelzőfénnyel

Of this, “ő” (U+0151) is not representable in ANSI-1252, so what gets written to the dxf is (non-ASCII shown in hex)

106 egyp<f3>lus<fa> v<e1>lt<f3>kapcsol<f3> jelz?f<e9>nnyel

Note the literal question mark.

Now the problem is this is an irreversible operation but the result is perfectly valid ANSI-1252, so upon opening the file again, I will get a block named

106 egypólusú váltókapcsoló jelz?fénnyel

IMHO the ideal resolution is to

  1. Have a preference for the export code page (and use it, too, circumstances permitting)
  2. Iff this is not set (or set to a default “Use system locale to determine” or something), use a look-up table to take a good guess (like old QCAD2 qcadlib/src/engine/rs_system.cpp:QCString RS_System::localeToISO())
  3. If the output encoder encounters a character that is not representable in the target code page, throw an error with an option to ignore the error (and keep using question marks, but then this must have been acknowledged by the user so not silent problem anymore), pick a new output code page, whatever else

This all assuming the R15 doesn’t actually depends hardly on ANSI-1252 and ANSI-1252 only. In that case, option #3 would still be nice.

Most Western European languages (and English) are not affected by this as ANSI-1252 has most of them covered, but a little to the east, a little to the south, a little to the north, and it does make a bit of a difference :)

 1013 QCAD/CAMBug ReportLow Option icon goes huge Closed
100%
Task Description

I moved all my tools bars to the side of the screen (vertical). only options was at the top. next restart it went HUGE.
it would only revert after putting another toolbar back (horizontal) and restarting qcad.

 1037 QCAD/CAMBug ReportLow great number of text editing operation leads to QCAD cr ...Closed
100%
Task Description

Hello!

When I’m trying to make a great number of text editing operation the QCAD 3.4.6 application crashes with following errors:

[email protected]:~/opt/qcad-3.4.6-linux-x86_32$ ./qcad
Debug: RCamScriptsPlugin: init
Debug: RDwgPlugin::init: trial
Debug: RDxfPlugin::init
Debug: RHelpPlugin::init
Debug: RProScriptsPlugin::init
Debug: TIMER: 56 ms - “loading add-ons”
Debug: TIMER: 672 ms - “initializing add-ons”
Debug: checking for updates...
Warning: QSslSocket: cannot resolve SSLv2_client_method
Warning: QSslSocket: cannot resolve SSLv2_server_method
Debug: no updates available
Debug: checking for updates...
Debug: no updates available
Warning: RHatchData::getPainterPaths: cannot load hatch pattern: “”
Warning: RHatchData::getPainterPaths: cannot load hatch pattern: “”
Debug: “RDwgServices::printErrorStackTrace: Handle already exists”
Warning: RDwgExporter::exportEntity: Exception occurred. Entity NOT saved:
RTextEntity(RTextBasedEntity(REntity(RObject(id: 3012, handle: “0xf33”, document: “0xa20e830”, address: “0xa9e1010”, undone: 0), type: 14, layerId: 21, blockId: 22, parentId: -1, childIds: QSet() , lineweight: -1 , linetypeId: 0 , color: RColor(ByLayer) , drawOrder: 2907 , selectionStatus: false , boundingBoxes: (RBox(RVector(1048.41, 175.238, 0) - RVector(1063.59, 177.762, 0)) ) ) , alignmentPoint: RVector(1056, 176.5, 0), position: RVector(0, 0, 0), text: “\fCalibri|b0|i1|;150”, textHeight: 1.85207, textWidth: 7, drawingDirection: 1))
Debug: “RDwgServices::printErrorStackTrace: Handle already exists”
Warning: RDwgExporter::exportEntity: Exception occurred. Entity NOT saved:
RTextEntity(RTextBasedEntity(REntity(RObject(id: 3012, handle: “0xf33”, document: “0xa20e830”, address: “0xa9e1010”, undone: 0), type: 14, layerId: 21, blockId: 22, parentId: -1, childIds: QSet() , lineweight: -1 , linetypeId: 0 , color: RColor(ByLayer) , drawOrder: 2907 , selectionStatus: false , boundingBoxes: (RBox(RVector(1048.41, 175.238, 0) - RVector(1063.59, 177.762, 0)) ) ) , alignmentPoint: RVector(1056, 176.5, 0), position: RVector(0, 0, 0), text: “\fCalibri|b0|i1|;150”, textHeight: 1.85207, textWidth: 7, drawingDirection: 1))
Debug: “RDwgServices::printErrorStackTrace: Handle already exists”
Warning: RDwgExporter::exportEntity: Exception occurred. Entity NOT saved:
RTextEntity(RTextBasedEntity(REntity(RObject(id: 3012, handle: “0xf33”, document: “0xa20e830”, address: “0xa9e1010”, undone: 0), type: 14, layerId: 21, blockId: 22, parentId: -1, childIds: QSet() , lineweight: -1 , linetypeId: 0 , color: RColor(ByLayer) , drawOrder: 2907 , selectionStatus: false , boundingBoxes: (RBox(RVector(1048.41, 175.238, 0) - RVector(1063.59, 177.762, 0)) ) ) , alignmentPoint: RVector(1056, 176.5, 0), position: RVector(0, 0, 0), text: “\fCalibri|b0|i1|;150”, textHeight: 1.85207, textWidth: 7, drawingDirection: 1))
Debug: “RDwgServices::printErrorStackTrace: Handle already exists”
Warning: RDwgExporter::exportEntity: Exception occurred. Entity NOT saved:
RTextEntity(RTextBasedEntity(REntity(RObject(id: 3012, handle: “0xf33”, document: “0xa20e830”, address: “0xa9e1010”, undone: 0), type: 14, layerId: 21, blockId: 22, parentId: -1, childIds: QSet() , lineweight: -1 , linetypeId: 0 , color: RColor(ByLayer) , drawOrder: 2907 , selectionStatus: false , boundingBoxes: (RBox(RVector(1048.41, 175.238, 0) - RVector(1063.59, 177.762, 0)) ) ) , alignmentPoint: RVector(1056, 176.5, 0), position: RVector(0, 0, 0), text: “\fCalibri|b0|i1|;150”, textHeight: 1.85207, textWidth: 7, drawingDirection: 1))
Debug: “RDwgServices::printErrorStackTrace: Handle already exists”
Warning: RDwgExporter::exportEntity: Exception occurred. Entity NOT saved:
RTextEntity(RTextBasedEntity(REntity(RObject(id: 3012, handle: “0xf33”, document: “0xa20e830”, address: “0xa9e1010”, undone: 0), type: 14, layerId: 21, blockId: 22, parentId: -1, childIds: QSet() , lineweight: -1 , linetypeId: 0 , color: RColor(ByLayer) , drawOrder: 2907 , selectionStatus: false , boundingBoxes: (RBox(RVector(1048.41, 175.238, 0) - RVector(1063.59, 177.762, 0)) ) ) , alignmentPoint: RVector(1056, 176.5, 0), position: RVector(0, 0, 0), text: “\fCalibri|b0|i1|;150”, textHeight: 1.85207, textWidth: 7, drawingDirection: 1))
Debug: “RDwgServices::printErrorStackTrace: Handle already exists”
Warning: RDwgExporter::exportEntity: Exception occurred. Entity NOT saved:
RTextEntity(RTextBasedEntity(REntity(RObject(id: 3012, handle: “0xf33”, document: “0xa20e830”, address: “0xa9e1010”, undone: 0), type: 14, layerId: 21, blockId: 22, parentId: -1, childIds: QSet() , lineweight: -1 , linetypeId: 0 , color: RColor(ByLayer) , drawOrder: 2907 , selectionStatus: false , boundingBoxes: (RBox(RVector(1048.41, 175.238, 0) - RVector(1063.59, 177.762, 0)) ) ) , alignmentPoint: RVector(1056, 176.5, 0), position: RVector(0, 0, 0), text: “\fCalibri|b0|i1|;150”, textHeight: 1.85207, textWidth: 7, drawingDirection: 1))
Could not allocate register file: 12
./qcad: line 18: 7332 Segmentation fault LD_LIBRARY_PATH=”$DIR” “$binary” -style plastique “[email protected]

OS: Linux Debian 7.0.1 (”uname -a” return: SMP Debian 3.13.7-1 (2014-03-25) i686 GNU/Linux)
Thanks.

 1055 QCAD/CAMBug ReportLow code page problem Closed
100%
Task Description

After creating the labels in drawing in Russian (Cyrillic), after saving and reopening the drawing file - changing the text encoding (??????????). Need to re-type the text ... How to fix this error?

 1089 QCAD/CAMBug ReportLow Convert polyline from segments on locked layers deletes ...Closed
100%
1 Task Description

If you select (line) segments in a visible yet locked layer and choose “convert segments to polyline” (OG), the segments are deleted, but inserting the polyline fails.
So you can easily destroy locked layers by mistake which contradicts the idea of locking layers.

 1097 QCAD/CAMBug ReportLow uncaught exception: /LibraryBrowser.js:362 Closed
100%
Task Description

$ git status
On branch master
Your branch is up-to-date with ‘origin/master’.

$ qcad
Debug: RDxfPlugin::init
Debug: RExamplePlugin::init
Debug: TransactionListenerPlugin::init
Debug: TIMER: 59 ms - “loading add-ons”
Warning: “QFormBuilder was unable to create a custom widget of the class ‘QWebView’; defaulting to base class ‘QWidget’.”
Debug: TIMER: 602 ms - “initializing add-ons”
Warning: Script Exception:
“TypeError: Result of expression ‘tagsBrowser.page’ [undefined] is not a function.”
Warning: “<anonymous>()@/home/mo/opt/qcad/scripts/Widgets/LibraryBrowser/LibraryBrowser.js:362”
Warning: RScriptHandlerEcma::eval: script engine exception: “TypeError: Result of expression ‘tagsBrowser.page’ [undefined] is not a function.”
Warning: “<anonymous>()@/home/mo/opt/qcad/scripts/Widgets/LibraryBrowser/LibraryBrowser.js:362”
Warning: At least one uncaught exception:
Warning: “<anonymous>()@/home/mo/opt/qcad/scripts/Widgets/LibraryBrowser/LibraryBrowser.js:362”

I have some large library, but the library browser is always crashing since long time and several versions, also tagged versions. I need to disable it by removing LibraryBrowser.js completely or deleting my configuration in order to get QCad starting again.
This is the master head from git, on [email protected]

 1122 QCAD/CAMBug ReportLow Objects move inappropriately when confirming alignment  ...Closed
100%
Task Description

I am trying to use the align tool (M, A) to align two text objects vertically. I am able to get them aligned how I want them, but when I confirm (click the green check box in the upper right-hand corner) they mysteriously jump up a large grid square or so. I am then able to get them back into the alignment by the “undo” command. In case that didn’t make sense I’ll try this one more time:

{Result} (User Action)

{text boxes out of alignment}(Align tool “M,A”){text boxes aligned}(click green checkmark){text boxes move randomly}(undo “ctrl-z”){text boxes aligned}

I’m thinking this is either operator error or a bug. It is consistent though.

 1134 QCAD/CAMBug ReportLow CAM Export: cut inner paths before outer paths broken Closed
100%
Task Description

This option seems to only work with the script debugger enabled.
See:
http://www.qcad.org/rsforum/viewtopic.php?f=33&t=3091

 1142 QCAD/CAMFeature RequestLow Distance Entry in "Feet and Inches" Closed
100%
1 Task Description

I use architectural units everyday in QCAD and would appreciate being able to enter feet and inches from the “command line” for convenience and accuracy.

I have been entering “calculations” to arrive at the distance values (i.e. 10*12+6.125 = 10’-6 1/8”), but this method is time consuming and prone to input error.

I would like to see Acad’s architectural distance method implemented in QCAD. This entry method would replace the “calculated” entry with (as an example): 10’6-1/8.

Command Line: Next point: 10’6-1/8
The <’> mark triggers a 12 times multiplier for the proceeding number,
the next number is the whole inches and
the ↔ is a separator that adds the fraction to the whole inches before it.

Thanks for considering this feature request. I’m certain that many QCAD users in the Architectural, Mechanical, Electrical and Construction professions wold appreciate this convenience (especially those moving past Acad).

 1183 QCAD/CAMBug ReportLow Info arc area specified on drawing is not the same as s ...Closed
100%
Task Description

Info arc area specified on drawing is no where near the same as shown in properties editor.

 1194 QCAD/CAMBug ReportLow Rounding fourth corner of rectangle causes rectangle to ...Closed
100%
Task Description

When rounding the fourth corner of a rectangle, with trim checked or unchecked, instead of the corner being trimmed to a radius, the rectangle itself disappears leaving only the corner with the rounded off portion intact.

 1197 QCAD/CAMBug ReportLow Small Polyline offset with 'round join' makes line segm ...Closed
100%
Task Description

When making an offset of a polyline with ‘round join’ enabled, and making a small offset of 0.0015 inches, no arcs are made, only coarsely interpolated line segments.
Further tests show that this is true until the offset is increased 0.040 inches; then the offset begins to create arcs.

The creation of arcs in a polyline offset with such small distances did work in QCAD 2.x.

 1240 QCAD/CAMBug ReportLow USB Flas Drive save makes the drive Read Only Closed
100%
Task Description

This problem is USB Flash drive related.

First of all, QCAD does not show the flash drive a drive where data can be stored, but it does when one wants to open a file.

If one then did open a file from the flash drive, saving it back tot he flash drive change the permission of the entire drive to read only and I could not manage to change that other than formatting the drive.

 1398 QCAD/CAMBug ReportLow Duplicate zoom buttons in toolbar and menu Closed
100%
Task Description

I am seeing duplicate zoom buttons in the View toolbar, and also under the View menu. Under Application Preferences→General→Tool Settings there are also multiple entries for these, with Shortcuts and Commands highlighted in red (means there are conflicts?). This is the QCAD/CAM version on Linux 32-bit Debian “testing” release. I also tried the same version on Windows 7 64-bit and am not seeing this issue. Screen shots attached.

 1418 QCAD/CAMFeature RequestLow Layerlist and hidden sublayer Closed
100%
Task Description

The layerlist shows at any operation all sublayer, even if they were previously hidden!

 1467 QCAD/CAMBug ReportLow Short leader will not render the arrow Closed
100%
Task Description

Hi,

I tried to add a leader and for some reason the arrow does not appear. I found out that this occurs when the line is short. To me, line is sufficiently long enough but somehow QCAD thinks it is too short.

Screenshot shows added leader.

Also when I try to change arrow: no to “yes”, while the dropdown shows yes, I am not able to select it. It just defaults to no.

Workaround:
Draw longer line.

 1483 QCAD/CAMBug ReportLow Draw -> Polyline -> Create from Segments deletes a segm ...Closed
100%
1 Task Description

With the attached DXF file, select Draw → Polyline → Create from Segments
(O, G) and click on the complex polyline inside the circle (eg on
the top left arc). Apolyline is created with a few segments,
and one or more segments are deleted!

Different segments are deleted depending on which segment is clicked.

 1512 QCAD/CAMBug ReportLow CTR command is not working Closed
100%
Task Description

1) Tool Circle WC
2) CTR circletangent2radius

This doesn’t work between two circles !
I can make a circle that touches a line and a circle.
But I can NOT make a third circle with a given radius that touches two other circles.

All the other commands in this menu are working properly, can someone help me out ?

 1538 QCAD/CAMBug ReportLow CAM not use the shortest way Closed
100%
Task Description

ich habe ein Linien Gitter in QCAD erstellt und dann mit CAM Export eine NC Datei erstellt.
Im CAM Simulator sieht man dass der GCODE Postprozessor nicht den kürzesten Weg verwendet.
Anbei folgende Dateien :
CAM_TEST_LINIEN.dxf, CAM_TEST_LINIEN.nc, CAM_TEST_LINIEN.log und eine Bilddatei CAM_TEST_LINIEN.png hier kann man sehen wie die Eistellungen für die GCODE Erstellung sind.

 1585 QCAD/CAMBug ReportLow hide/show layer delay Closed
100%
Task Description

Hi !
i’m trying the new qcad/cam 3.17.1 and i have a delay when i hide and show a layer..
(linux MINT 17.2 x64)

The function is working, but the layer will hide (and show) with a delay from click on the apposite button.

The qcad 3.16.7 DON’T have this problem.. when you click on button immediately the layer disappear/show..

 1593 QCAD/CAMBug ReportLow CAM > CAM Export: ZH in header always yields default va ...Closed
100%
Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=74&t=4914

 1610 QCAD/CAMPerformance IssueLow Switching from one drawing to another slow Closed
100%
Task Description

When switching from one drawing to another, the 3D view is updated which can be slow, especially for drawings with many text entities.

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=89&t=4945

 1685 QCAD/CAMBug ReportLow LinuxCNC no longer works under CAM Legacy Export  Closed
100%
Task Description

On any version newer than 3.18.0 the LinuxCNC options under “Configuration” drop-down no longer work under CAM→CAM Legacy Export. As you can see in the attached screen shot, the menu line which would normally contain LinuxCNC is blank. Also, when LinuxCNC (Inch) and LinuxCNC (Millimeter) are selected, none of the Global or per-Layer options are available, it just says “No Global Options” and “No Layer Options” as you can also see in the screen shot. I think this is because both of these are derivatives of the main LinuxCNC configuration which is not working.

I have confirmed this problem with fresh installs (using the installer) on both Windows 10 and Debian testing

 1803 QCAD/CAMBug ReportLow CAM configuration output unit fixed in inch instead of  ...Closed
100%
1 Task Description

Ij window CAM Configuration output unit appears as inch instead of mm. All parameters are in option
when create a nc file,units are in inches not in mm. unsuable and not possible to change

 1812 QCAD/CAMBug ReportLow Coordinate display: coordinates not updated while mouse ...Closed
100%
Task Description

The coordiantes (in the lower left corner) freeze while mouse is moving. Updates as soon as the mouse is stopped.

This slows me down considerably. I have to stop, wait (too see the coordinates), move, stop, wait, move back, stop, wait, move, stop wait... This gotta be a bug?

MacOS 10.12.6

 1813 QCAD/CAMBug ReportLow CAM Export: missing G01 Closed
100%
Task Description

Trying the EleksMaker EL01 Laser router I noticed some bugs in creating pathways, rapids, tolerance and homing.

See the attached pdf

 1814 QCAD/CAMBug ReportLow FS#1813 Revisited Closed
100%
Task Description

 FS#1813  Revisited. (Several bugs in QCAD/CAM 3.21.3. when generating G-code in “G-code Laser (offset).)

Hi Andrew,

After closing the bug notification I realised I didn’t add the DXF. My apologies for not attaching the DXF-file at hand.

Fortunately I am not the only one;

You can fix the missing G01 by replacing your file postprocessors/GCodeLaserOffsetMM.js with the attached updated file.

Since it was not attached, that makes two of us.

Anyway I have attached the DXF-file to be tested.

1815QCAD/CAMFeature RequestLowAdd Laser tool optionAssigned
0%
Task Description

Hi Andrew,

Creating G-code for cnc-laser, the laser-tool can not be correctly set at all.

Attached a laser tool proposal

 1816 QCAD/CAMBug ReportLow TAB function in CAM module fails  Closed
100%
Task Description

When using (adding a TAB on a radius fails).

Example:

When length of the TAB is set to 1 mm.

After export to *.nc code the code is not ok.

And then check this is NC viewer or gcode sender the length is not set to 1 mm but is smaller.

On a line this function (TAB) is correct working.

 1817 QCAD/CAMBug ReportLow CAM Export: offset fails for contours with arcs (tolera ...Closed
100%
Task Description

After regenerate selected toolpath OR regenerate all toolpath.

The result of the output is every time different.

When pushed for example 2 or 3 times this button.

See pictures

 1830 QCAD/CAMSuggestionLow HP7580 Penplotter Closed
100%
Task Description

Hi Andrew,

I was fiddeling around with a copy of the hpgl postprocessor, and has it adapted, up and running for a HP7580 penplotter. You may add this to QCAD if you like.

Poking and peeking in the other postprocessor files, I found enough information to generate a very acceptable hpgl.plt file now, including the required pen changes.

The purpose of a ‘bracket-field’ (as [S] ) is clear to me. Where are [S#] and [S!] used for?

1841QCAD/CAMFeature RequestLowQCAD/CAM Postprocessor "Hpgl": Add pen colors to HP/GL ...Assigned
0%
Task Description

Add SPx; with x being pen number from 1-8.

TODO:
- Which color corresponds to which pen number?
- What if there are more than 8 colors in a DXF files?

1843QCAD/CAMBug ReportLowCreating ToolPath StallsAssigned
0%
Task Description

Hi Andrew,

Still working with and on CAM HPGL for the HP7580 pen plotter.

I have added a penplotter test drawing, that might be used for testing en callibrating plotter and pens. You may add it to the Examples-directory.

QCAD has a lot of trouble creating toolpaths and exports. Much too often it shuts itself down, or gets stalled. Why? I am not sure.

1844QCAD/CAMFeature RequestLowHP/GL (PLT) importAssigned
0%
Task Description

Hi Andrew

QCAD/CAM misses a hpgl.plt import. If gerber and G-code can, so should plt.

1846QCAD/CAMFeature RequestLowToolpath preset offsetsAssigned
0%
Task Description

Hi Andrew

A request for adding some fields to the toolpath

1847QCAD/CAMBug ReportLowBUG MEMORYAssigned
0%
Task Description

Hi Andrew,

Still working on creating HPGL.PLT toolpaths for the HP7580 pen plotter. QCAD has some trouble creating toolpaths. Too often it shuts itself down, or the PC gets stalled.

Recreating the same error however is possible

 1850 QCAD/CAMBug ReportLow Toolpath error Closed
100%
Task Description

Hi Andrew,

While generating a toolpath I stumbled upon an odd error.

1877QCAD/CAMFeature RequestLowPost Processor TutorialAssigned
0%
Task Description

Hallo Andrew,

I am still busy on the never ending G-code story. Doing so I wrote a small Post Processor Tutorial for all those nerds who wants to write their own. If you like it you might add it to QCAD. However, since English is not my native tongue I suggest checking it would be wise.

Meanwhile I have downloaded the source code, and could not find the CAM’s Drill-path-script. I am now using a negative Drill Cut Depth to set a Laser Dwell time, were as a field “Dwell Time (in seconds)” in the Drill-path would be more appropiate. Is this script open source available or is it part of ‘closed part’ of QCAD?

1901QCAD/CAMFeature RequestLowCAM Traverse ToolpathAssigned
0%
Task Description

Hallo Andrew,

Still busy on the never ending G-code story. Urgently needed the very common Traverse Toolpath.

Example added as pdf.

Greetings

1902QCAD/CAMFeature RequestLowCAM G-Block ToolpathAssigned
0%
Task Description

Hallo Andrew,

Still busy on the never ending G-code story. Urgently needed the very handy G-code Block Toolpath. This ‘toolpath’ also solves a lot of “editing requests”.

 1907 QCAD/CAMBug ReportLow having issues importing and opening dxf files  Closed
100%
Task Description

can not import dxf files

1911QCAD/CAMFeature RequestLowDrill ToolpathAssigned
0%
Task Description

Hallo Andrew

It would be more than conveniant, defining the drilling locations of the drill toolpath, by selecting a circle’s center point.

Showing tasks 1901 - 1950 of 2010 Page 39 of 41<<First - 37 - 38 - 39 - 40 - 41 -

Available keyboard shortcuts

Tasklist

Task Details

Task Editing