QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategory  ascTask TypeSeveritySummaryStatusProgress
 1460 QCAD (main)Bug ReportVery Low Two Display Environment --> Problems with Toolboxes and ...Closed
100%
1 Task Description

Hello,

I’m unsing a two display environment and got all Tools and Widgets placed on the second display.
See qcad1.png

There are two problems:

1.) When I open another application on second display, three toolboxes stay on top, the others are behind new application.
See qcad2.png

2.) When I minimize Qcad only the mainwindow will be minimuzed, all the toolboxes and widgets stay on second display also with problem 1.
See qcad3.png

Whould be great, when this issues will be fixed :-)

Thank you very much
Andreas

P.S.: Hope described well, if not, please drop me a reply...

 1498 QCAD (main)Bug ReportVery Low Grid mask lines when zoom Closed
100%
Task Description

All lines are masked when I zoom. Not easy to work!

 1500 QCAD (main)Bug ReportVery Low Some plugins not built right in debug mode Closed
100%
Task Description

Building current HEAD (5468b69) with:

/usr/local/lib/qt5/bin/qmake \
        QMAKE_CXXFLAGS="-g -ggdb3 -I/usr/local/include" \
        QMAKE_LIBS="-lcxxrt -L/usr/local/lib" \
        -r
make debug
tinky:~/w/qcad/qcad$ ../qcad.sh
Launching QCAD debug
QCAD version  3.15.5.7
RPluginLoader.cpp:67, static QStringList RPluginLoader::getPluginFiles():
11:25:06: Debug:    Ignoring release plugin built in debug mode:  "libqcadexample.so"
RPluginLoader.cpp:67, static QStringList RPluginLoader::getPluginFiles():
11:25:06: Debug:    Ignoring release plugin built in debug mode:  "libtransactionlistener.so"
RDxfPlugin.cpp:9, virtual bool RDxfPlugin::init():
11:25:06: Debug:    RDxfPlugin::init
RDebug.cpp:81, static int RDebug::stopTimer(int, const QString &, int):
11:25:15: Debug:    TIMER:  1038000000 ns ( 1038 ms )  -  "loading add-ons"
RDebug.cpp:81, static int RDebug::stopTimer(int, const QString &, int):
11:25:19: Debug:    TIMER:  18446744073365584320 ns ( 18446744073365 ms )  -  "initializing add-ons"
RScriptHandlerEcma.cpp:1468, static QScriptValue RScriptHandlerEcma::ecmaMessageHandler(QScriptContext *, QScriptEngine *, RS::MessageType):

For whatever reason, libqcadexample.so and libtransactionlistener.so don’t get named _debug.so (which seems to be the cause for the message), while libqcaddxf_debug.so seems to be OK.

The following diff sorts this out, with no apparent ill effect:

diff --git a/support/examples/exampleplugin/exampleplugin.pro b/support/examples/exampleplugin/exampleplugin.pro
index 0c58c56..d72a866 100644
--- a/support/examples/exampleplugin/exampleplugin.pro
+++ b/support/examples/exampleplugin/exampleplugin.pro
@@ -1,7 +1,8 @@
-include(../../../shared.pri)
 CONFIG      += plugin
 TARGET      = $${RLIBNAME}example
 
+include(../../../shared.pri)
+
 TEMPLATE    = lib
 HEADERS     = RExamplePlugin.h
 SOURCES     = RExamplePlugin.cpp
diff --git a/support/examples/transactionlistener/transactionlistener.pro b/support/examples/transactionlistener/transactionlistener.pro
index ed6c84d..7ee9bef 100644
--- a/support/examples/transactionlistener/transactionlistener.pro
+++ b/support/examples/transactionlistener/transactionlistener.pro
@@ -1,7 +1,8 @@
-include(../../../shared.pri)
 CONFIG      += plugin
 TARGET      = transactionlistener
 
+include(../../../shared.pri)
+
 TEMPLATE    = lib
 HEADERS     = TransactionListenerPlugin.h
 SOURCES     = TransactionListenerPlugin.cpp
 1518 QCAD (main)Bug ReportVery Low Landscape/Portrait gets confused for custom page size Closed
100%
Task Description

Hello

In the Print Preview or Drawing Preferences / Page Settings if I select a Custom size, then landscape/portrait does not really make sense.

For instance, at work we have a laser cutter which uses a printer driver. The bed of the laser is 600 wide by 300 high. When I wanted to cut
something, I created a custom page size of 600×300 and selected Landscape (because it is wider than high)

Strangely, back in the Print Preview, the page is now sized opposite with regards to Portrait / Landscape mode, which was confusing somewhat.

(see pictures attached)

I think that for ‘Custom’ page size in Drawing Preferences, the option of Portrait or Landscape should probably be ghosted

Then, I think that for Portrait / Landscape mode in the Print Preview, it should display the shape most appropriate, rather than just assuming that the document fits the norm:

  1. Taller than Wide for Portrait mode
  2. Wider than Tall for Landscape mode
 1574 QCAD (main)Bug ReportVery Low Layer > Remove: deleting sublayer switches to layer 0 Closed
100%
Task Description

I have set the delete layer preference to make the next layer in the list the current. This will not work for sublayers. After deleting a sublayer the 0 layer will become current.

 1581 QCAD (main)Bug ReportVery Low View > Selection Filter: no inputs for property Linetyp ...Closed
100%
Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=32&t=4876

 1583 QCAD (main)Bug ReportVery Low Option / Rotation missing defaults for 15 and 345 degre ...Closed
100%
Task Description

... just cosmetic!

The Option drop down list for rotations (e.g. Paste etc) shows all steps incremental for every 15 degree - but 15 and 345 degree are missing.

I’m happy that we don’t have bigger problems!!! :-)

 1587 QCAD (main)Bug ReportVery Low PDF export created with wrong date time Closed
100%
Task Description

Hi guys,

when I export my dxf drawing to pdf, the pdf properties shows wrong “created date”. I am in UTC+2, the date shows 2 hours less.
I exported the pdf at 12:24, the attached ps shows 10:24.

BR,
Soma

 1607 QCAD (main)SuggestionVery Low Indent 'Spline Segments:' in explode preferences Closed
100%
1 Task Description

 FS#1604  was issued because of non-intuitive hierarchy of the preferences for the Explode function.
The task comment recieved explains the funcionallity in details not found elsewhere.

Indentation of the phrase ‘Spline Segments:’ suggest hierarchy.
Graying out the drop down box for the number of spline segments establish hierarchy.

1626QCAD (main)Feature RequestVery Low'Clip to Circle' toolAssigned
0%
1 Task Description

Hi Andrew,

Would it be possible to have a clip to circle tool also please?

Regards

Clive

1649QCAD (main)Feature RequestVery LowAdd configuarable format options for saving blocks to l...Assigned
0%
Task Description

Add configuarable format options in application preferences for saving blocks to library to either dxf or dwg.

 1659 QCAD (main)Bug ReportVery Low File > Print Preview: does not always open / close prop ...Closed
100%
Task Description

Case:
Drawing with Viewport,
in Model Space - launch Print Preview - Paper size and display ok,
change directly to Paper_Space - Paper size and display ok,
switch back to Model Space - Paper size ok but the Paper display looks infinitive big ...

Print Preview off/on or launching/canceling Drawing Preferences will solve the display issue.

 1660 QCAD (main)Bug ReportVery Low Draw > Viewport > Add Viewport: viewport in model space Closed
100%
Task Description

... I have the feeling that wasn’t the idea. I’m correct?

Case:
in Model Space, launch Add Viewport, determine the Viewport rectangle - when done QCAD will switch to a Layout Block.
Now in Layout Block, don’t(!) place the Viewport, switch back to Model Space and the Viewport is still attached to the Mouse pointer and you can place it in your Model Space. The source of the Viewport will then disappear.

 1668 QCAD (main)Bug ReportVery Low Text color of command line unreadable with KDE's Breeze ...Closed
100%
Task Description

I prefer the Breeze Dark color scheme as it find it less stressful on my eyes, however it’s unusable with QCAD where the Command Line prompts and responses are rendered as a very light grey on a white background. I believe the proper fix would be one (or both) of:

  • Make the Command Line area background follow the desktop scheme. (It appears that the text already does so, hence the light text, but since the background doesn’t it becomes unusable.)
  • Provide a configuration option for the text and/or background color used in the Command Line area.

Screen shots are attached showing both Breeze and Breeze Dark schemes.

1691QCAD (main)Bug ReportVery LowIssue with Layouts after "File-Revert"Assigned
0%
Task Description

QCad 3.19.2 Professional, 64bit, Liux Mint

Case:
1. Open some saved drawing with viewport entities on layout block (paper space). Print Preview mode is “On” automatically.
2. After “File-Revert” drawing is reopened on layout block (paper space), but now Print Previw mode is “Off” .

For example can try on “flange.dxf”

 1692 QCAD (main)Bug ReportVery Low Issue with Layouts. "Viewport" enteties are not highlig ...Closed
100%
Task Description

QCad 3.19.2 Professional, 64bit, Linux Mint

Case:
1. Open some drawing with viewport entities on layout block (paper scace). Print Preview mode is “On” automatically.
2. Switch to “Black/White Mode” from toolbar and move cursor on “Viewport” enteties. This entitie is not highlighted. With other enteties all works as expected.
In “Full Color Mode” and “Grayscale Mode” no problems.

For example can try on “flange.dxf”

 1709 QCAD (main)Feature RequestVery Low Feature request: Add extra padding to textbox. Closed
100%
Task Description

When placing text on a drawing you are offered with the choice of where you want the origin of the textbox to be. That’s very nice. Image 1 shows an example of text with top left origin. It seems there is already some top padding above the text.

Unfortunately there is no option to add extra padding to the other sides so the text is right to the left border of the textbox. To correct this you have to add some parallel construction lines and move the text a bit to the right. Now the text has nice padding. See image 2.

It would be nice to have some padding options when adding/editing text, like in web-design: https://www.w3schools.com/css/css_padding.asp

 1718 QCAD (main)Bug ReportVery Low File > SVG Export: selected entities exported in select ...Closed
100%
Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=31&t=5429

1719QCAD (main)Bug ReportVery LowUndo on converted drawing leads to wrong label position...Assigned
0%
Task Description

Drawing converted from inch to mm - undo leads to wrong dim label position. I can fix that with “Reset Label position” but it would be nice if QCAD could to that in first place.

 1743 QCAD (main)Bug ReportVery Low Draw > Text: Wrong bounding box for text with empty sup ...Closed
100%
1 Task Description

Hi,

I have a drawing where I use text with superscript. In this case when I use autozoom, it does not work as I expect. It includes the 0,0 coordinates too. The problem also occures when I export the drawing into svg.

I attached an example, just use the autozoom.

Thanks,
Soma


 1751 QCAD (main)Bug ReportVery Low Can't open files from terminal Closed
100%
Task Description

I have file /home/test/test.dxf . When i try open file from terminal (qcad test.dxf), i have warning “File not found”. When i write full path (qcad /home/test/test.dxf), the file opens.

 1759 QCAD (main)SuggestionVery Low Modify // .... selection of entities on locked layer al ...Closed
100%
Task Description

Without any selection.
Entities on a locked layer can be selected after choosing:

Asumed wrong
- Modify DI
- Modify
B2
- Modify D3
- Modify
MT

Questionable
- Modify RM
- Modify
CH
- Modify RN Less severe
- Modify
OF
- Modify OH
- Modify
SS

Regards

1760QCAD (main)Bug ReportVery LowSelf-crossing polylines can't be cut twice at segment c...Assigned
0%
Task Description

Re-entering dividing problem from  FS#1757 

Divide the poly selecting near segment 1 at the segment crossing.
> A new node is inserted on the crossing and made start and end node.
Divide the poly again selecting near segment 2 at the segment crossing.
> no division appears to be done.

One can’t divide the second segment at the crossing

Presumed intended behaviour like  FS#1750 

Regards

 1762 QCAD (main)Bug ReportVery Low Modify // .... selection of entities on locked layer al ...Closed
100%
Task Description

Not served with the degration to ‘Suggestion’  FS#1759 .
Demanded closing  FS#1759  & re-entered

Locking entities (by layer) to avoid selection,eg. nearby,very close by or on the same spot, does not have the intended influence.

Asumed wrong:
- Modify DI
- Modify B2
- Modify D3
- Modify MT
These 4 need a single entity to be selected and selection of a locked entity is allowed.(=questionable)
The action will allways leed to ‘not allowed’.(=correct)

Questionable:
- Modify RM
- Modify CH
- Modify RN
These 3 need a pair of entities.
RM: Selection of a locked limiting entity is allowed (=questionable), enity to trim not.(=correct)
The action will trim unlocked entities to the locked limiter.(=questionable)
CH & RN: Selection of a pair of entities is allowed.(=questionable)
Trimming if ‘trim’ is on will not occur because locked and leeds to ‘not allowed’.(=correct)
The creation of the bevel or rounding on an active locked layer will not occur because locked and leeds to ‘not allowed’.(=correct)
The creation, except for polyline segments (because locked themself), on an active unlocked layer will be done.(=correct)

Less severe but still questionable: (because these don’t necerally act on the locked entities themselves)
- Modify OF
- Modify OH
- Modify SS
OF: Selection of a locked base entity is allowed.(=questionable)
The preview is casted only if the active layer is unlocked.(=correct)
The creation is only done on an active unlocked layer.(=correct)
OH: Selection of a locked base entity is allowed.(=questionable)
Selection of point references from entities on locked layers is allowed.(=questionable)
The preview is casted only if the active layer is unlocked.(=correct)
The creation is only done on an active unlocked layer.(=correct)
SS: Selection of point references from entities on locked layers is allowed.(=questionable)
Strechting is only done for unlocked entities. (=correct)

1765QCAD (main)Bug ReportVery LowErrors with polyline offsetAssigned
0%
1 Task Description

Win 7 32 bit QCAD 3.20.1

Ofsset of a base-line with arcs results in massive ammount of errors.
Most of them occur as a cluster of very tiny segments and are part of the offset. (zoom far in at the red circles)
Mostly they occur where the offsetted arcs should merely be trimmend pairwise.
Some occur as detached entities or as detached strings of entities very near the offset (strings not documented).
Spooks occur at opposite site when base-line is not closed.
360° curls can occur with R = Offset.
Null-entities may occur (not documented, hard to find and not able to copy).

The base-line is checked and sound and has mixed tangentially or not tangentially connected arcs.
Offsetting the mother base-line of the base in the file has similar effect but not all and/or different ones.
Also encountered with offseting polys from fonts.
Used to define pocket paths for CNC.
Detected because the CNC driver will not accept Self-crossers, Null-entities or open ends depending on the settings.

Work arround is to explode and select small entities but this does not solves the issues.
1) Choosing the tolerance large enough will detect small segments that should stay.
2) Recombining will generate new ones at the place where the main segments remain crossed.
Cleaning up the paths is a daunting process with some thousand segments for several offsets.

I assume this has an infuence on the CAM part of QCAD too unless the offset method is different.

 1767 QCAD (main)Bug ReportVery Low Dimension Leader Closed
100%
Task Description

On print mode, the arrow not appear in the dimension

1788QCAD (main)Feature RequestVery LowNew snap: reference points of a block referencesAssigned
0%
Task Description

I know this was reported and fixed before ...

https://www.qcad.org/bugtracker/index.php?do=details&task_id=843

... but it looks like we have the issue now back with some kind of variation.

If I use the test drawing which I posted in 2013 ( FS#843 ) it works still as expected after it was fixed.

If I create a new block it won’t work in a new drawing nor in the old test drawing - no chance to snap to the Block Reference.

Edit: New Test drawing:

 1795 QCAD (main)Bug ReportVery Low Quit Menu Item disabled after opening preferences Closed
100%
Task Description

Quit Menu Item disabled after opening preferences.

System: OSX 10.13.6
Qcad version: 3.21.2.0

How to repeat:

  1. Open QCad
  2. Open preferences dialogue “QCad Pro → Preferences”
  3. Close dialogue
  4. The menu item “Quit QCad Pro” is now disabled. See attached screenshot

Repeatability: 100%

 1798 QCAD (main)Bug ReportVery Low Drawing Pref > Linetype > Scale of linetypes matches th ...Closed
100%
Task Description

“Drawing Preferences / General / Linetype / Scale of linetypes matches the scale of each viewport” is checked by default for new drawings, however the option is not applied until you open the “Drawing Preferences / General / Linetype” screen and click OK – no need to change anything, just opening the screen and clicking OK is sufficient.

 1804 QCAD (main)Bug ReportVery Low Application Preferences > Tool Settings: Filter for "Vi ...Closed
100%
Task Description

1. Search the Tool Settings for “View” and you will only find “Overlays” without the submenu information.
2. Check View manually without a search will provide the submenu information.

 1806 QCAD (main)Bug ReportVery Low Overlay Toolbar visibility in GUI not saved Closed
100%
Task Description

Switch “Overlay” Toolbar to visible below:
View/Toolbars and Widgets/Toolbars/View/Overlays, place the Toolbar in GUI, restart QCAD and the Toolbar is back to invisible.

 1899 QCAD (main)Bug ReportVery Low View > Auto zoom: zoom to invisible entities in blocks Closed
100%
Task Description

Create and insert a block with entities on layer “0” and layer “1”.

Switch off layer “1”.

Auto zoom zooms to block boundary of all entities, including those on layer “1”.

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=33&t=6336

1900QCAD (main)Bug ReportVery LowRemote shares initially not accessible.Assigned
0%
Task Description

My data files are stored on network shares (synology) with a GB link. QCAD Pro is run in Admin mode.

While in my Windows browser all remote shares are accessible (Green), in the QCAD file open menu they are initially shown as not accessible (Red). By accessing a specific drawing file in a remote share, the share will open and turn green.

Same behavior using ‘Open recent’. Always the message is given that the requested file does not exist, and the file is wiped from the ‘Recent Open’ list. Only if the share is first accessed through ‘Open’ with a random file, it will turn and a ‘recent open’ file for that share will open.

Drag and Drop from a remote share will never work.

 1904 QCAD (main)Bug ReportVery Low File > Bitmap Export: Non-plottable layers not exported Closed
100%
Task Description

File > Bitmap Export does not export non-plottable layers.

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=31&t=6364

1905QCAD (main)Bug ReportVery LowView > Property Editor: Changing attribute of block cha...Assigned
0%
Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=33&t=6367#p23947

1919QCAD (main)Bug ReportVery LowWrong order XY(Z) for Ordinate Dimension in property ed...Assigned
0%
Task Description

Win7pro Qcad Pro 3.22.1.2

In property editor
properties of an Ordinate Dimension

Without Show Z
DefPoint is displayed in order YX?

With Show Z
Origin is displayed in order XZY?
DefPoint is displayed in order YZX?
LeaderEndPoint is displayed in order ZXY?

Regards

1920QCAD (main)Feature RequestVery LowEdit > Application Preferences: Add preference to disab...Assigned
0%
Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=89&t=6447

 1921 QCAD (main)Feature RequestVery Low Add error message when requesting raster for a non-exis ...Closed
100%
Task Description

(sorry for duplicate task, cannot remove it now)

It would be nice if QCAD spit some kind of warning message when trying to render a layer with a name that doesn’t exist (and perhaps render nothing), rather than silently rendering an empty image. :D

See https://qcad.org/rsforum/viewtopic.php?f=33&t=6453

1923QCAD (main)Bug ReportVery LowFaulty rendering Polylines with Global/Local Widths and...Assigned
0%
Task Description

Win7pro 32bit Qcad 3.23.0

Andrew,
The Arc segments of Polylines with Global or any Local Width render faulty where Global Z or any of the arc’s local Z is not zero.

In the attached drawing setting the Global Z of the inner poly to 5,10,...

The setting of Z to not zero affects the radius of the projected arc and not the bulging of the poly.
It also affects the projected widths of the line inversely, but not by changing the widths properties.

Pritty rare combination! True.
Qcad is 2D native! True.

Flatten will resolve this.

It is not a purely visual rendering fault, the poly will explode as such.

Maybe similar flaw as with uneven scaling blocks with arcs.
https://qcad.org/rsforum/viewtopic.php?f=8&t=5566#p20703

Regards

 1932 QCAD (main)Bug ReportVery Low Check for update fails to discover new version Closed
100%
Task Description

“Help→Check for QCAD Pro Updates” fails to discover new version. Tested on OSX and Linux versions.

 1572 QCAD Community EditionBug ReportLow Dimension font not set to "Standard" when importing thr ...Closed
100%
Task Description

Since updating to QCAD 3.16 on MacOS, my dimension font face suddenly changed to something very unattractive and I can’t figure out how to reset it. I tried deleting QCAD and all references to it in ~/Library and then reinstalling, but no luck. Something weird has gone wrong with QCAD’s fonts.

The font change has made it impossible to open and redraw many DXF files because the new font face is larger and wider spaced and it ruins the layout of many documents.

Attached is an example of what the same DXF file looked like in the prior QCAD version, and the new version. No change to the DXF file.

Dan.

 1639 QCAD Community EditionBug ReportLow Layer > Hide all Layers: cannot turn individual layer b ...Closed
100%
Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=76&t=5092

 1724 QCAD Community EditionSuggestionLow "OVERKILL" command Closed
100%
Task Description

Is it possible to create “OVERKILL” command like in AUTOCAD

 1872 QCAD Community EditionSuggestionLow inconsistent color of the active layer icon for dark th ...Closed
100%
Task Description

Hello

So, I think .. that when the dark scheme has been chosen
the eye color for the active layers should be white
(similar to the list of blocks).

Best regards
Jacek

 1465 QCAD/CAMBug ReportCritical Circle is drawn as polygon Closed
100%
Task Description

Hi,

I have a circle and circle is not round.
Unit of drawing is in metres and radius is set to 2.38.
The circle displays as a polygon instead.

 1076 QCAD/CAMBug ReportHigh Crash on Mac OS X when using internal Trackpad Closed
100%
1 Task Description

Hi,

I have just updated my Mac OS from 10.9.2 to 10.9.4. QCAD 3.6.2 seems to be working normally under the newest version of Mac OS, but has developed a very specific bug which leads to reproducible crashes when a text object is edited.

Steps to minimally reproduce:
1. Open QCAD
2. Create a text object
3. Place the text object on the canvas
4. double-click the text object and edit its contents
5. click OK to accept changes
6. repeat from step 4 three or four times.

After several attempts to edit a text object, QCAD will crash with EXC_BAD_ACCESS (SIGBUS) in thread 0 (QCoreApplication).
The crash can also be triggered by moving the text object around on the canvas (instead of editing its contents).
The bug does not require anything else (no other objects on the canvas, no particular font, occurs in both new and previously saved documents).

Apart from this bug, QCAD seems to work fine on OS X 10.9. The text editing crash did not occur before the latest OS update. No other applications on my system seem to be having any problems. If this problem can be fixed, I think QCAD will be quite usable on 10.9.

See also related bugs in:
 FS#1091 

 1137 QCAD/CAMBug ReportHigh segfault creating dashed spline (without addons) Closed
100%
Task Description

Hello,

This is my first real bug report so please advise how i could provide more useful information.

I am not certain if the severity is correct.

The bug: segfault when creating a spline with a dashed linetype or opening a file containing one.

The bug isn’t present with the dwg extension installed

Steps to reproduce:
1. create drawing
2. create spline
3. set linetype to dashed
4. crash

 1322 QCAD/CAMBug ReportHigh Fonts mixed up witch code tables Closed
100%
Task Description

Hi,

In ‘Application preferences, Draw, Text’ fonts can be selected.

There is a mixing up between fonts (the appearance of characters on screen) and code tables (what digital code is used for each character).

‘ISO8859-11’ is the 8 bit Thai (!) code table and not a font
‘Unicode’ is the 16 bit code table and not a font.

For downward comptability QCAD should use default font Standard (ISO3098) with code table ISO8859-1 (US-ASCII Latin-1).

 1237 QCAD/CAMBug ReportMedium Blocks should be layer agnostic Closed
100%
Task Description

I have created a block from a selection. I have then later created more items on my CAD page using that block, then later yet, moved the objects to a new layer. I noticed that while the object has accepted being on the new layer, the color hasn’t changed to the new layer’s color. I can only get the line color to change if I go into the block itself and move the individual segments of the block to that new layer, then save the new block (which, by the way, I can’t save over the existing block?!?!)

In the sample file attached, you will see that the block item in the 3 o’clock position is in layer 0, while the rest are in “Vent Holes” layer. If you make layer 0 hidden, the one block is hidden (like it should), but the block item refuses to take on the layer’s color even though the block’s color is “By Layer”

 1293 QCAD/CAMBug ReportMedium Crash when snapping to intersection points between 3d l ...Closed
100%
Task Description

I have a file that makes QCAD crash. I’ve been editing this design across different versions of QCAD over time and this is the first time I have a problem with it.

Steps to reproduce:
Open the attached file and try to add some entities or dimensions to it (you may need to create large ones since it seems to depend on the zoom factor; for example a very large ellipse). After a freeze of a few seconds QCAD will quit.

The attached file is a simplified version from which I deleted a number of entities; on the original I can’t do anything – QCAD crashes as soon as I try to create any object.

Cause: 3D lines with x1==x2, y1==y2 but z1!=z2

Showing tasks 1801 - 1850 of 1935 Page 37 of 39<<First - 35 - 36 - 37 - 38 - 39 -

Available keyboard shortcuts

Tasklist

Task Details

Task Editing