QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategory  ascTask TypeSeveritySummaryStatusProgress
 1076 QCAD/CAMBug ReportHigh Crash on Mac OS X when using internal Trackpad Closed
100%
1 Task Description

Hi,

I have just updated my Mac OS from 10.9.2 to 10.9.4. QCAD 3.6.2 seems to be working normally under the newest version of Mac OS, but has developed a very specific bug which leads to reproducible crashes when a text object is edited.

Steps to minimally reproduce:
1. Open QCAD
2. Create a text object
3. Place the text object on the canvas
4. double-click the text object and edit its contents
5. click OK to accept changes
6. repeat from step 4 three or four times.

After several attempts to edit a text object, QCAD will crash with EXC_BAD_ACCESS (SIGBUS) in thread 0 (QCoreApplication).
The crash can also be triggered by moving the text object around on the canvas (instead of editing its contents).
The bug does not require anything else (no other objects on the canvas, no particular font, occurs in both new and previously saved documents).

Apart from this bug, QCAD seems to work fine on OS X 10.9. The text editing crash did not occur before the latest OS update. No other applications on my system seem to be having any problems. If this problem can be fixed, I think QCAD will be quite usable on 10.9.

See also related bugs in:
 FS#1091 

 1089 QCAD/CAMBug ReportLow Convert polyline from segments on locked layers deletes ...Closed
100%
1 Task Description

If you select (line) segments in a visible yet locked layer and choose “convert segments to polyline” (OG), the segments are deleted, but inserting the polyline fails.
So you can easily destroy locked layers by mistake which contradicts the idea of locking layers.

 1097 QCAD/CAMBug ReportLow uncaught exception: /LibraryBrowser.js:362 Closed
100%
Task Description

$ git status
On branch master
Your branch is up-to-date with ‘origin/master’.

$ qcad
Debug: RDxfPlugin::init
Debug: RExamplePlugin::init
Debug: TransactionListenerPlugin::init
Debug: TIMER: 59 ms - “loading add-ons”
Warning: “QFormBuilder was unable to create a custom widget of the class ‘QWebView’; defaulting to base class ‘QWidget’.”
Debug: TIMER: 602 ms - “initializing add-ons”
Warning: Script Exception:
“TypeError: Result of expression ‘tagsBrowser.page’ [undefined] is not a function.”
Warning: “<anonymous>()@/home/mo/opt/qcad/scripts/Widgets/LibraryBrowser/LibraryBrowser.js:362”
Warning: RScriptHandlerEcma::eval: script engine exception: “TypeError: Result of expression ‘tagsBrowser.page’ [undefined] is not a function.”
Warning: “<anonymous>()@/home/mo/opt/qcad/scripts/Widgets/LibraryBrowser/LibraryBrowser.js:362”
Warning: At least one uncaught exception:
Warning: “<anonymous>()@/home/mo/opt/qcad/scripts/Widgets/LibraryBrowser/LibraryBrowser.js:362”

I have some large library, but the library browser is always crashing since long time and several versions, also tagged versions. I need to disable it by removing LibraryBrowser.js completely or deleting my configuration in order to get QCad starting again.
This is the master head from git, on [email protected]

 1122 QCAD/CAMBug ReportLow Objects move inappropriately when confirming alignment  ...Closed
100%
Task Description

I am trying to use the align tool (M, A) to align two text objects vertically. I am able to get them aligned how I want them, but when I confirm (click the green check box in the upper right-hand corner) they mysteriously jump up a large grid square or so. I am then able to get them back into the alignment by the “undo” command. In case that didn’t make sense I’ll try this one more time:

{Result} (User Action)

{text boxes out of alignment}(Align tool “M,A”){text boxes aligned}(click green checkmark){text boxes move randomly}(undo “ctrl-z”){text boxes aligned}

I’m thinking this is either operator error or a bug. It is consistent though.

 1134 QCAD/CAMBug ReportLow CAM Export: cut inner paths before outer paths broken Closed
100%
Task Description

This option seems to only work with the script debugger enabled.
See:
http://www.qcad.org/rsforum/viewtopic.php?f=33&t=3091

 1137 QCAD/CAMBug ReportHigh segfault creating dashed spline (without addons) Closed
100%
Task Description

Hello,

This is my first real bug report so please advise how i could provide more useful information.

I am not certain if the severity is correct.

The bug: segfault when creating a spline with a dashed linetype or opening a file containing one.

The bug isn’t present with the dwg extension installed

Steps to reproduce:
1. create drawing
2. create spline
3. set linetype to dashed
4. crash

 1183 QCAD/CAMBug ReportLow Info arc area specified on drawing is not the same as s ...Closed
100%
Task Description

Info arc area specified on drawing is no where near the same as shown in properties editor.

 1194 QCAD/CAMBug ReportLow Rounding fourth corner of rectangle causes rectangle to ...Closed
100%
Task Description

When rounding the fourth corner of a rectangle, with trim checked or unchecked, instead of the corner being trimmed to a radius, the rectangle itself disappears leaving only the corner with the rounded off portion intact.

 1197 QCAD/CAMBug ReportLow Small Polyline offset with 'round join' makes line segm ...Closed
100%
Task Description

When making an offset of a polyline with ‘round join’ enabled, and making a small offset of 0.0015 inches, no arcs are made, only coarsely interpolated line segments.
Further tests show that this is true until the offset is increased 0.040 inches; then the offset begins to create arcs.

The creation of arcs in a polyline offset with such small distances did work in QCAD 2.x.

 1237 QCAD/CAMBug ReportMedium Blocks should be layer agnostic Closed
100%
Task Description

I have created a block from a selection. I have then later created more items on my CAD page using that block, then later yet, moved the objects to a new layer. I noticed that while the object has accepted being on the new layer, the color hasn’t changed to the new layer’s color. I can only get the line color to change if I go into the block itself and move the individual segments of the block to that new layer, then save the new block (which, by the way, I can’t save over the existing block?!?!)

In the sample file attached, you will see that the block item in the 3 o’clock position is in layer 0, while the rest are in “Vent Holes” layer. If you make layer 0 hidden, the one block is hidden (like it should), but the block item refuses to take on the layer’s color even though the block’s color is “By Layer”

 1240 QCAD/CAMBug ReportLow USB Flas Drive save makes the drive Read Only Closed
100%
Task Description

This problem is USB Flash drive related.

First of all, QCAD does not show the flash drive a drive where data can be stored, but it does when one wants to open a file.

If one then did open a file from the flash drive, saving it back tot he flash drive change the permission of the entire drive to read only and I could not manage to change that other than formatting the drive.

 1293 QCAD/CAMBug ReportMedium Crash when snapping to intersection points between 3d l ...Closed
100%
Task Description

I have a file that makes QCAD crash. I’ve been editing this design across different versions of QCAD over time and this is the first time I have a problem with it.

Steps to reproduce:
Open the attached file and try to add some entities or dimensions to it (you may need to create large ones since it seems to depend on the zoom factor; for example a very large ellipse). After a freeze of a few seconds QCAD will quit.

The attached file is a simplified version from which I deleted a number of entities; on the original I can’t do anything – QCAD crashes as soon as I try to create any object.

Cause: 3D lines with x1==x2, y1==y2 but z1!=z2

 1322 QCAD/CAMBug ReportHigh Fonts mixed up witch code tables Closed
100%
Task Description

Hi,

In ‘Application preferences, Draw, Text’ fonts can be selected.

There is a mixing up between fonts (the appearance of characters on screen) and code tables (what digital code is used for each character).

‘ISO8859-11’ is the 8 bit Thai (!) code table and not a font
‘Unicode’ is the 16 bit code table and not a font.

For downward comptability QCAD should use default font Standard (ISO3098) with code table ISO8859-1 (US-ASCII Latin-1).

 1369 QCAD/CAMBug ReportVery Low qcad-bin is trying to access non-existent /home/andrew Closed
100%
Task Description

I experience long start delays. I’ve trace the problem to the fact that I have autofs automounting my home directories. However, an strace of qcad-bin shows the following:

execve("/opt/ribbonsoft/qcad/qcad-3.12.6/qcad-bin", ["/opt/ribbonsoft/qcad/qcad-3.12.6"...], [/* 87 vars */]) = 0
brk(NULL)                               = 0x1eca000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fd6194ad000
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
open("/home/andrew/local/qt/lib/tls/x86_64/libqcadecmaapi.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/andrew/local/qt/lib/tls/x86_64", 0x7fff4722f250) = -1 ENOENT (No such file or directory)
open("/home/andrew/local/qt/lib/tls/libqcadecmaapi.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/andrew/local/qt/lib/tls", 0x7fff4722f250) = -1 ENOENT (No such file or directory)
open("/home/andrew/local/qt/lib/x86_64/libqcadecmaapi.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/andrew/local/qt/lib/x86_64", 0x7fff4722f250) = -1 ENOENT (No such file or directory)
open("/home/andrew/local/qt/lib/libqcadecmaapi.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/home/andrew/local/qt/lib", 0x7fff4722f250) = -1 ENOENT (No such file or directory)

Since there is no “andrew” user here, I have to wait for automount to timeout which takes about 2m and is rather annoying.

 1398 QCAD/CAMBug ReportLow Duplicate zoom buttons in toolbar and menu Closed
100%
Task Description

I am seeing duplicate zoom buttons in the View toolbar, and also under the View menu. Under Application Preferences→General→Tool Settings there are also multiple entries for these, with Shortcuts and Commands highlighted in red (means there are conflicts?). This is the QCAD/CAM version on Linux 32-bit Debian “testing” release. I also tried the same version on Windows 7 64-bit and am not seeing this issue. Screen shots attached.

 1465 QCAD/CAMBug ReportCritical Circle is drawn as polygon Closed
100%
Task Description

Hi,

I have a circle and circle is not round.
Unit of drawing is in metres and radius is set to 2.38.
The circle displays as a polygon instead.

 1467 QCAD/CAMBug ReportLow Short leader will not render the arrow Closed
100%
Task Description

Hi,

I tried to add a leader and for some reason the arrow does not appear. I found out that this occurs when the line is short. To me, line is sufficiently long enough but somehow QCAD thinks it is too short.

Screenshot shows added leader.

Also when I try to change arrow: no to “yes”, while the dropdown shows yes, I am not able to select it. It just defaults to no.

Workaround:
Draw longer line.

 1483 QCAD/CAMBug ReportLow Draw -> Polyline -> Create from Segments deletes a segm ...Closed
100%
1 Task Description

With the attached DXF file, select Draw → Polyline → Create from Segments
(O, G) and click on the complex polyline inside the circle (eg on
the top left arc). Apolyline is created with a few segments,
and one or more segments are deleted!

Different segments are deleted depending on which segment is clicked.

 1512 QCAD/CAMBug ReportLow CTR command is not working Closed
100%
Task Description

1) Tool Circle WC
2) CTR circletangent2radius

This doesn’t work between two circles !
I can make a circle that touches a line and a circle.
But I can NOT make a third circle with a given radius that touches two other circles.

All the other commands in this menu are working properly, can someone help me out ?

 1538 QCAD/CAMBug ReportLow CAM not use the shortest way Closed
100%
Task Description

ich habe ein Linien Gitter in QCAD erstellt und dann mit CAM Export eine NC Datei erstellt.
Im CAM Simulator sieht man dass der GCODE Postprozessor nicht den kürzesten Weg verwendet.
Anbei folgende Dateien :
CAM_TEST_LINIEN.dxf, CAM_TEST_LINIEN.nc, CAM_TEST_LINIEN.log und eine Bilddatei CAM_TEST_LINIEN.png hier kann man sehen wie die Eistellungen für die GCODE Erstellung sind.

 1564 QCAD/CAMBug ReportMedium QCAD/CAM: black main window or main window not painted  ...Closed
100%
Task Description

QCAD/CAM version 3.16.7.1 (snapshot release)

QCAD/CAM version 3.16.7.1 for Ubuntu Linux starts up with a totally black screen with only the title bar showing. By clicking around at the top of the screen I can get the menus to drop down and appear over the blank black screen. That is how I captured all the version information below. QCAD/CAM version: 3.15.5.0 for Ubuntu Linux starts with all the normal screen graphics appearing normally. I labeled this bug report as critical because QCAD/CAM is unusable on Ubuntu Linux, but for me it is not so critical since I can use the Windows version.

Versions
QCAD version: 3.16.7.1
Date: Mar 22 2017
Qt version: 5.8.0
Compiler version: gcc 4.8.1
Build Date: Mar 22 2017
Revision: 17a80fac27c3ae6aa68cd4ee15ffa4f3e2ab0a9a

Architecture: x86_64
OS: Linux
OS version: Unknown

Locale
QCAD locale: en
Name: en_US
Country: 225
Country name: United States
Language: 31
Language name: American English
Script: 7
Script name: Latin
Decimal point: 46
Negative sign: 45
Positive sign: 43
Text direction: 0
System codec: UTF-8

Arguments: /home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64/qcad-bin

Plugins
Description=CAM tools.
FileName=/home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64/plugins/libqcadcamscripts.so
ID=CAM
License=Proprietary
Name=CAM
NamePostfix=/CAM
PurchaseURL=http://ribbonsoft.com/add-ons/qcadcam-purchase QtVersion=5.8.0
SplashOverride=:/scripts/Cam/splashscreen.png
[email protected]=:/scripts/Cam/[email protected]
URL=http://ribbonsoft.com/add-ons/qcadcam Version=3.16.7.1

FileName=/home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64/plugins/libqcaddwg.so
ID=DWG
License=Proprietary
Name=QCAD Pro
PurchaseURL=http://ribbonsoft.com/add-ons/qcadpro-purchase QtVersion=5.8.0
SystemCodePage=0
URL=http://ribbonsoft.com/add-ons/qcadpro Version=3.16.7.1 (Teigha® 4.02.2.0)

Description=Import/export support for the DXF format. Based on dxflib.
FileName=/home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64/plugins/libqcaddxf.so
ID=DXF
License=GPLv2+
Name=DXF
QtVersion=5.8.0
URL=http://www.qcad.org Version=3.16.7.1 (dxflib 3.12.2.0)

Description=OpenGL ES 3D display.
FileName=/home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64/plugins/libqcadgles3d.so
ID=GLES
License=Proprietary
Name=QCAD Pro
PurchaseURL=http://ribbonsoft.com/add-ons/qcadpro-purchase QtVersion=5.8.0
URL=http://ribbonsoft.com/add-ons/qcadpro Version=3.16.7.1

Description=Integrated help browser.
FileName=/home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64/plugins/libqcadhelp.so
ID=HELP
License=Proprietary
Name=QCAD Pro
QtVersion=5.8.0
URL=http://www.ribbonsoft.com Version=3.16.7.1

Description=Polygon clipping, boolean polygon operations, path offset.
FileName=/home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64/plugins/libqcadpolygon.so
ID=POLYGON
License=Proprietary
Name=QCAD Pro
PurchaseURL=http://ribbonsoft.com/add-ons/qcadpro-purchase QtVersion=5.8.0
URL=http://ribbonsoft.com/add-ons/qcadpro Version=3.16.7.1

Description=QCAD Professional tools.
FileName=/home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64/plugins/libqcadproscripts.so
ID=PROTOOLS
License=Proprietary
Name=QCAD Pro
NamePostfix= Professional
PurchaseURL=http://ribbonsoft.com/add-ons/qcadpro-purchase QtVersion=5.8.0
URL=http://ribbonsoft.com/add-ons/qcadpro Version=3.16.7.1

Description=Polygon triangulation.
FileName=/home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64/plugins/libqcadtriangulation.so
ID=TRIANGULATION
License=Proprietary
Name=QCAD Pro
PurchaseURL=http://ribbonsoft.com/add-ons/qcadpro-purchase QtVersion=5.8.0
URL=http://ribbonsoft.com/add-ons/qcadpro Version=3.16.7.1

Environment
LC_TIME=en_US.UTF-8
DESKTOP_SESSION=default
SSH_AGENT_PID=1743
[email protected]=ibus
LOGNAME=dave
QT_ACCESSIBILITY=1
PAPERSIZE=letter
HOME=/home/dave
LC_NUMERIC=en_US.UTF-8
XDG_DATA_DIRS=/usr/share/default:/usr/share/gnome:/usr/local/share/:/usr/share/:/var/lib/snapd/desktop
XDG_VTNR=2
SHELL=/bin/bash
XDG_SEAT=seat0
GIO_LAUNCHED_DESKTOP_FILE=/home/dave/Desktop/Ribbonsoft-qcad.desktop
WINDOWPATH=2
QT_IM_MODULE=ibus
XDG_SESSION_TYPE=x11
XDG_RUNTIME_DIR=/run/user/1000
LC_MEASUREMENT=en_US.UTF-8
LC_TELEPHONE=en_US.UTF-8
XDG_CURRENT_DESKTOP=GNOME
UNICODEMAP_JP=cp932
DEFAULTS_PATH=/usr/share/gconf/default.default.path
LC_PAPER=en_US.UTF-8
XAUTHORITY=/run/user/1000/gdm/Xauthority
LC_ADDRESS=en_US.UTF-8
LC_IDENTIFICATION=en_US.UTF-8
QT_STYLE_OVERRIDE=gtk
LC_NAME=en_US.UTF-8
GIO_LAUNCHED_DESKTOP_FILE_PID=13310
LC_MONETARY=en_US.UTF-8
XDG_SESSION_DESKTOP=default
GTK_MODULES=gail:atk-bridge
XDG_MENU_PREFIX=gnome-
XDG_SESSION_ID=1
QT_LINUX_ACCESSIBILITY_ALWAYS_ON=1
XDG_CONFIG_DIRS=/etc/xdg/xdg-default:/etc/xdg
DISPLAY=:1
LD_LIBRARY_PATH=/home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64
PWD=/home/dave
USER=dave
SHLVL=1
_=/home/dave/opt/qcadcam-3.16.7.1-pro-linux-x86_64/qcad-bin
MANDATORY_PATH=/usr/share/gconf/default.mandatory.path
LANG=en_US.UTF-8
SSH_AUTH_SOCK=/run/user/1000/keyring/ssh
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-S2ePMZG3dG,guid=e590a63ac7ca3b971f776cae58d663c0
GDMSESSION=default
GNOME_DESKTOP_SESSION_ID=this-is-deprecated
SESSION_MANAGER=local/OPA:@/tmp/.ICE-unix/1681,unix/OPA:/tmp/.ICE-unix/1681
USERNAME=dave
PATH=/home/dave/bin:/home/dave/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin

 1585 QCAD/CAMBug ReportLow hide/show layer delay Closed
100%
Task Description

Hi !
i’m trying the new qcad/cam 3.17.1 and i have a delay when i hide and show a layer..
(linux MINT 17.2 x64)

The function is working, but the layer will hide (and show) with a delay from click on the apposite button.

The qcad 3.16.7 DON’T have this problem.. when you click on button immediately the layer disappear/show..

 1593 QCAD/CAMBug ReportLow CAM > CAM Export: ZH in header always yields default va ...Closed
100%
Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=74&t=4914

 1646 QCAD/CAMBug ReportMedium 3.18 has a HATCH issue Closed
100%
Task Description

If you pres the “hatch icon” then the word “hatch” appears in the command window, but. . . nothing happens.

But if you type “hatch” followed by “enter” then finally the Hatch Window pops up.

 1685 QCAD/CAMBug ReportLow LinuxCNC no longer works under CAM Legacy Export  Closed
100%
Task Description

On any version newer than 3.18.0 the LinuxCNC options under “Configuration” drop-down no longer work under CAM→CAM Legacy Export. As you can see in the attached screen shot, the menu line which would normally contain LinuxCNC is blank. Also, when LinuxCNC (Inch) and LinuxCNC (Millimeter) are selected, none of the Global or per-Layer options are available, it just says “No Global Options” and “No Layer Options” as you can also see in the screen shot. I think this is because both of these are derivatives of the main LinuxCNC configuration which is not working.

I have confirmed this problem with fresh installs (using the installer) on both Windows 10 and Debian testing

 1799 QCAD/CAMBug ReportVery Low Postprocessor: sign not forced for negative values roun ...Closed
100%
Task Description

formatValue returns “0” instead of “+0” for negative values that round up to 0 with the configured decimals.

 1803 QCAD/CAMBug ReportLow CAM configuration output unit fixed in inch instead of  ...Closed
100%
1 Task Description

Ij window CAM Configuration output unit appears as inch instead of mm. All parameters are in option
when create a nc file,units are in inches not in mm. unsuable and not possible to change

 1812 QCAD/CAMBug ReportLow Coordinate display: coordinates not updated while mouse ...Closed
100%
Task Description

The coordiantes (in the lower left corner) freeze while mouse is moving. Updates as soon as the mouse is stopped.

This slows me down considerably. I have to stop, wait (too see the coordinates), move, stop, wait, move back, stop, wait, move, stop wait... This gotta be a bug?

MacOS 10.12.6

 1813 QCAD/CAMBug ReportLow CAM Export: missing G01 Closed
100%
Task Description

Trying the EleksMaker EL01 Laser router I noticed some bugs in creating pathways, rapids, tolerance and homing.

See the attached pdf

 1814 QCAD/CAMBug ReportLow FS#1813 Revisited Closed
100%
Task Description

 FS#1813  Revisited. (Several bugs in QCAD/CAM 3.21.3. when generating G-code in “G-code Laser (offset).)

Hi Andrew,

After closing the bug notification I realised I didn’t add the DXF. My apologies for not attaching the DXF-file at hand.

Fortunately I am not the only one;

You can fix the missing G01 by replacing your file postprocessors/GCodeLaserOffsetMM.js with the attached updated file.

Since it was not attached, that makes two of us.

Anyway I have attached the DXF-file to be tested.

 1816 QCAD/CAMBug ReportLow TAB function in CAM module fails  Closed
100%
Task Description

When using (adding a TAB on a radius fails).

Example:

When length of the TAB is set to 1 mm.

After export to *.nc code the code is not ok.

And then check this is NC viewer or gcode sender the length is not set to 1 mm but is smaller.

On a line this function (TAB) is correct working.

 1817 QCAD/CAMBug ReportLow CAM Export: offset fails for contours with arcs (tolera ...Closed
100%
Task Description

After regenerate selected toolpath OR regenerate all toolpath.

The result of the output is every time different.

When pushed for example 2 or 3 times this button.

See pictures

 1820 QCAD/CAMBug ReportMedium CAM Export: exporting text entities broken Closed
100%
Task Description

Hi Andrew,

Kubuntu, QCAD/CAM 3.21.3

Font Standard. Selected as ‘single line’ font for engraving with mill or laser.

While CAM Exporting as G-code Laser (Offset) MM, or as Linux CNC, Exporting gets trapped in a loop.

In Font Standard the glyph’s ? & $ @ s S Q and 2 contains unwanted Z-movements. It seems these glyphs entities are not alligned properly; endpoint last line does not meet startpoint next line; why else the Z-movements?

Could this misallignment also traps Exporting?

1843QCAD/CAMBug ReportLowCreating ToolPath StallsAssigned
0%
Task Description

Hi Andrew,

Still working with and on CAM HPGL for the HP7580 pen plotter.

I have added a penplotter test drawing, that might be used for testing en callibrating plotter and pens. You may add it to the Examples-directory.

QCAD has a lot of trouble creating toolpaths and exports. Much too often it shuts itself down, or gets stalled. Why? I am not sure.

1847QCAD/CAMBug ReportLowBUG MEMORYAssigned
0%
Task Description

Hi Andrew,

Still working on creating HPGL.PLT toolpaths for the HP7580 pen plotter. QCAD has some trouble creating toolpaths. Too often it shuts itself down, or the PC gets stalled.

Recreating the same error however is possible

 1850 QCAD/CAMBug ReportLow Toolpath error Closed
100%
Task Description

Hi Andrew,

While generating a toolpath I stumbled upon an odd error.

 1907 QCAD/CAMBug ReportLow having issues importing and opening dxf files  Closed
100%
Task Description

can not import dxf files

1912QCAD/CAMBug ReportLowTool Description ErrorAssigned
0%
Task Description

Hallo Andrew,

Testing the drill toolpath I find it hard to select the correct tool by a small bug

1913QCAD/CAMBug ReportLow3D Simulation Behaves oddAssigned
0%
Task Description

Hallo Andrew,

testing the drill toolpath I used single point markers.

In 3D simulation the tool drills the toolpath AND uses the drill as a mill.

Cam Export and generated G-code is not effected.

 1946 QCAD/CAMBug ReportLow CAM > Cam Legacy Export: Cut inner paths before outer p ...Closed
100%
Task Description

The option “Cut inner paths before outer paths” is ignored, causing trouble when outer paths are cut first.

Attached is a link to the script files and gcode examples.

 1962 QCAD/CAMBug ReportLow CAM > Drill Toolpaths: Cannot be edited / updated from  ...Closed
100%
Task Description

Hallo Andrew,

Found a bug in the drill toolpath generator.

 1963 QCAD/CAMBug ReportLow Bug Font Standard OR Cam Config Closed
100%
Task Description

Hallo Andrew

Confronted with a bug in font Standard glyph ”s” (small S),
and a solution.

 1967 QCAD/CAMBug ReportLow Development snapshot: Toolpath generator problem Closed
100%
Task Description

Hallo Andrew,

I had updated QCAD/CAM to 3.23.0.2 and I am confronted with a major bug in the toolpath generator.

1971QCAD/CAMBug ReportLowCAD/CAM 3D SimulatorAssigned
0%
Task Description

Hallo Andrew,

Found a bug in the 3D Simulator execution

 1992 QCAD/CAMBug ReportLow Regenerate All Error Closed
100%
Task Description

Hallo Andrew,

I experienced some odd behaviour when using a final Regenerate All before an Export.

1997QCAD/CAMBug ReportLowCan't export gcode, intermittentlyAssigned
0%
Task Description

When I create a simple drawing, I cannot export the gcode until I restart qcad.

general steps to reproduce the issue:
1. open a new drawing
2. Add a letter “D” near the origin in Arial font, about 7mm tall.
3. explode it
4. save the drawing
5. Fill in in the “cam configuration” 6. Select the drawing and generate the tool paths.
7. Hit the “export button” or the menu item.
8. Observe that you see the “camexport” command appears in the command section, but there is no file generated for the gcode.

If you restart qcad, then the gcode will export as expected. Also, it appears to work for more complicated drawings. I had the same issue, when I tried to generate the same thing, but using the string “November 2019” at 5mm height. I am using up to date MX Linux with kernel version 4.19.0. I also observed this behavior under Windows 10 professional.

 2000 QCAD/CAMBug ReportLow CAM > Nesting: misleading "Sheet added" confirmation Closed
100%
Task Description

Within the nesting preparation:
A left mouse click to add a sheet will always be confirmed with “Sheet added”, regardless of a proper selection or where the left click is done in Model_Space.

 2001 QCAD/CAMBug ReportLow CAM > Nesting: Alignment fails Closed
100%
Task Description

Description for the CAM Nesting alignment:

Quote:
Alignment: Parts are arranged with the chosen alignment in mind. An alignment of “Left - Bottom” means that parts are shuffled to the left (primary alignment) and towards the bottom (secondary alignment).
Quote end

I tested a few scenarios. e.g
a Top Left, Align → leads to a top right alignment,
a Top left, Hull → leads to a Bottom Left alignment,
etc.

 1003 QCAD/CAMFeature RequestLow QCAD Community Edition: add unicode support for layer n ...Closed
100%
Task Description

Community version (still on FBSD only), so dxflib. I suspect the culprit is dxflib.

I have created layers and blocks and whatnot with (hungarian) accented characters in their names.
Apparently (according to the Internet, as evidenced probably most glaringly by usa.autodesk.com /adsk/servlet/ps/dl/item?siteID=123112&id=7586582&linkID=9240617) the R15 DXF version assumes single-byte character sets being used. Quick grepping the DXF2000 mentions “String (255-character maximum; less for Unicode strings)” (Group Code Value types), so it may be a false track...

Anyway, the DXF file written does have strings converted to single-byte encoding, but it seems it’s always ANSI-1252. When the output encoder encounters a character that is not representable in this one, it will use a literal question mark.

Actual case, I have a block with the name

106 egypólusú váltókapcsoló jelzőfénnyel

Of this, “ő” (U+0151) is not representable in ANSI-1252, so what gets written to the dxf is (non-ASCII shown in hex)

106 egyp<f3>lus<fa> v<e1>lt<f3>kapcsol<f3> jelz?f<e9>nnyel

Note the literal question mark.

Now the problem is this is an irreversible operation but the result is perfectly valid ANSI-1252, so upon opening the file again, I will get a block named

106 egypólusú váltókapcsoló jelz?fénnyel

IMHO the ideal resolution is to

  1. Have a preference for the export code page (and use it, too, circumstances permitting)
  2. Iff this is not set (or set to a default “Use system locale to determine” or something), use a look-up table to take a good guess (like old QCAD2 qcadlib/src/engine/rs_system.cpp:QCString RS_System::localeToISO())
  3. If the output encoder encounters a character that is not representable in the target code page, throw an error with an option to ignore the error (and keep using question marks, but then this must have been acknowledged by the user so not silent problem anymore), pick a new output code page, whatever else

This all assuming the R15 doesn’t actually depends hardly on ANSI-1252 and ANSI-1252 only. In that case, option #3 would still be nice.

Most Western European languages (and English) are not affected by this as ANSI-1252 has most of them covered, but a little to the east, a little to the south, a little to the north, and it does make a bit of a difference :)

 1142 QCAD/CAMFeature RequestLow Distance Entry in "Feet and Inches" Closed
100%
1 Task Description

I use architectural units everyday in QCAD and would appreciate being able to enter feet and inches from the “command line” for convenience and accuracy.

I have been entering “calculations” to arrive at the distance values (i.e. 10*12+6.125 = 10’-6 1/8”), but this method is time consuming and prone to input error.

I would like to see Acad’s architectural distance method implemented in QCAD. This entry method would replace the “calculated” entry with (as an example): 10’6-1/8.

Command Line: Next point: 10’6-1/8
The <’> mark triggers a 12 times multiplier for the proceeding number,
the next number is the whole inches and
the ↔ is a separator that adds the fraction to the whole inches before it.

Thanks for considering this feature request. I’m certain that many QCAD users in the Architectural, Mechanical, Electrical and Construction professions wold appreciate this convenience (especially those moving past Acad).

Showing tasks 1901 - 1950 of 2001 Page 39 of 41<<First - 37 - 38 - 39 - 40 - 41 -

Available keyboard shortcuts

Tasklist

Task Details

Task Editing