QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

ID  descCategoryTask TypeSeveritySummaryStatusProgress
2048QCAD (main)Bug ReportVery LowMove / Copy to current layer fails when reference point...Assigned
Task Description

QCAD 3.24.2 / macOS x86_64 10.14.6

Starting with empty doc:
1. Draw any object (e.g. a rectangle) on layer 0.
2. Create new layer (”1”) with color, say yellow.
3. Select new layer
4. Select new object
5. Modify → Move / Copy
6. Click reference point
7. Click target point same as reference point
8. In “Move / Copy Options” dialog, select “Delete Original” and check “Use current layer and attributes.” Click OK.

The moved object stays on the layer it was previously on. Using “Move / Copy” as a quick way to move a selection between layers is not useful even though it appears to be the recommended way in a Google search.

Note: if “Keep Original” is selected instead, the copied object is placed on the current layer and the original object remains on its layer, as expected.

Note: if the target point is different from the reference point, the moved object is placed on the current layer as expected.

There are other workarounds too, cut / paste with “To current layer” checked seems to work, as does chaging the layer in the Properties Editor.

 2047 QCAD (main)Bug ReportLow QCAD quits when inserting a library item, Ubuntu 19.10  ...Closed
Task Description

QCAD quits when trying to insert a library item (PC_1kW.dxf) from the library browser. Both by dragging it or clicking on insert.
Joined a copy of the terminal and dmesg (Linux) and what I found on the windows logs.

- Tested with other libraries elements of the same origin with the same result.
- The file opens normally in QCAD. When you create a block from it, you can re-insert it and it works as expected, try with PC_1kWblock.dxf...
- If you re-create a library item from the file with another name it fails also to insert.
- Tested with a new empty file or with a file containing same blocks...

Now the strange part:

-On a brand new HP Zbook 14u G6 it works flawlessly on Windows but fails on Linux... That was the first computer I tried (with Windows) when I decided that it will replace Draftsight... I was lucky...
-On a 4 years old Lenovo Yoga 14 it fails both on Linux & Windows... This computer has only 8Gb of RAM, but dedicated graphics...
-On a customer’s HP Pavillon 17’’ it fails... He bought a licence & Book of QCAD because of me...
-On my Dell 7720 it fails both on Windows and Linux. This workstation has everything to run any CAD software (64Gb RAM, Xeon 1535M v6, Quadro P5000)
-Reinstallation of the software doesn’t solve the problem. 2 independent sources tested (my download and my customer’s download)

These blocks have a lot of attributes on different layers, needed for the intended usage. I’m developping a script to extract them to a CSV file based on a template file... As on Draftsight.

Looks a lot like  FS#1938 ... But now you have files to test...

I made further testings and this bug is definitely related to the fact that the attributes definitions are on different layers...

If the layer definition exists before the library items is inserted, it works as expected.

If one layer existing in the item definition is missing from the layer list before the item is inserted it fails.

If you create a block from an instance of the library item, and create a new library item with the block, then it can be inserted without problems and the layers are created... But you must explode it first to access the attributes which is not the idea behind the block attributes that should be editable when a block with attributes is inserted.

So at the moment the only way to work is to start with a template document with all the possible layers on which attributes definitions are defined...

Can’t go further in debugging as block attributes are one of the feature of the ‘professional’ version I paid for and are not open source...

Ready and willing to sign a NDA to get access to the sources and make this work if nobody else takes care of this.

 2046 QCAD (main)Bug ReportLow Crash when scaling, rotating and mirroring Closed
1 Task Description

Hallo Andrew

Beim Skalieren(SZ), Rotieren(RO), Spiegeln(MI) beendet sich QCAD, wenn gespeichert wird. Änderungen werden nicht gepeichert.

When scaling (SZ), rotating (RO), mirroring (MI), QCAD ends when it is saved. Changes are not saved.

 2045 QCAD (main)Bug ReportLow The whole block disappear when one of its layer is hidd ...Closed
Task Description

If a block is created with entities from different layers and then one of these layers is hidden, the block disappears. I would expect that only that specific entity disappears.

 2044 QCAD (main)Feature RequestLow Filter selection entities according to more than one cr ...Closed
Task Description

At the moment there is no way to select all entities that match more than one criterion (i.e. layers, colours, object types, ..).

 2043 QCAD Community EditionBug ReportLow library browser's menu not consistent with empty namesp ...Closed
Task Description

The library browser’s accordion menu is not consistent when browsing back and forth through empty namespaces (directory).

In the image attached (top to bottom, left to right), I’m trying to open the empty namespace “Hydraulics”. If I close & open the “default” namespace, the empty namespace’s open arrow disappears.

 2042 QCAD (main)Bug ReportLow linetangent can't draw a tangent to arc through a point ...Closed
Task Description

Very often I need to draw a tangent line through a point on the arc or circle. Currently I solve this by drawing the perpendicular in that point and then the perpendicular to that perpendicular. As this problem is solvable I set the severity to “Low”.

But I think linetangent should be able to draw such tangents. And I think this tool should firstly ask for arc or circle and only then for a point. Currently linetangent firstly asks for a point.

2041QCAD (main)Bug ReportLowcircletangent2 doesn't solve correctly if the defining ...Assigned
Task Description

In my example I can’t draw a circle with circletangent2 if the defining point is on one of the defining tangents. The tangency is lost when I try to do this.

I attached 4 screenshots: TheExample.png, TryingPoint1.png, TryingPoint2.png and The_Point_Isn’t_On_The_Tangents.png.

 2040 QCAD (main)Feature RequestLow Parallel and Offset tool - digit limit for Number to s ...Closed
Task Description

LP - Number limit:
2 digits (max. 99)

LG - Number limit:
2 digits (max. 99)

OF - Number limit:
3 digits (max. 999)

OH - Number limit:
2 digits (max. 99)

Yes I know - it’s also a performance question but compared to ...

... Copy/Move (MV)
next to infinite digits (max. ???)

... Paste Along Entity (PE)
next to infinite digits (max. ???)

 2039 QCAD (main)Bug ReportLow splines are not showing when drawn by QCAD Simple API n ...Closed
1 Task Description

Hi guys,

I’m trying to create an spline to a complex library component, but it seems splines are not working properly. I would appreciate some help. These are minimum scripts to demonstrate the problem:

Example 1:


function TesteSpline() {

TesteSpline.init = function(formWidget) {
    if (!isNull(formWidget)) {
        TesteSpline.widgets = getWidgets(formWidget);

TesteSpline.generate = function(documentInterface, file) {
    return TesteSpline.criarCorpo(documentInterface);

TesteSpline.generatePreview = function(documentInterface, iconSize) {

TesteSpline.criarCorpo = function(documentInterface) {

    addSpline([[0,0],[20,30],[100,100],[110,120]], false); // it doesn't work :-(
    addLine(0,0, 100,100);  // it works!!!


Example 2:


function TesteSpline() {

TesteSpline.init = function(formWidget) {
    if (!isNull(formWidget)) {
        TesteSpline.widgets = getWidgets(formWidget);

TesteSpline.generate = function(documentInterface, file) {
    return TesteSpline.criarCorpo(documentInterface);

TesteSpline.generatePreview = function(documentInterface, iconSize) {

TesteSpline.criarCorpo = function(documentInterface) {
    var addOperation = new RAddObjectsOperation(false);
    var doc = documentInterface.getDocument()
    // Spline
    var cavaData = new RSplineData();
    cavaData.appendFitPoint(new RVector(0,0));
    cavaData.appendFitPoint(new RVector(10,10));
    cavaData.appendFitPoint(new RVector(30,30));
    cavaData.isClosed = false;
    // It doesn't work
    var cava = new RSplineEntity(doc,cavaData);

    // it works
    var textData = new RTextData(new RVector(2,10),new RVector(2,10),0.4,0.4,0,0,0,0,1,"Hello","Arial",false,false,0,false);
    addOperation.addObject(new RTextEntity(doc,textData));

    return addOperation;

 2038 QCAD (main)Bug ReportLow Cannot snap arc / circle reference points inside blocks Closed
Task Description

- Create block with arc or circle
- Auto snap / reference snap does not snap to reference points at circle / arc max / min coordinates

2037QCAD (main)Feature RequestLowSupport alternative angle referenceAssigned
Task Description

E.g. 0 degrees at the top, clock-wise for positive direction, alternative angle units.

 2036 QCAD (main)Bug ReportLow Arc rendering in block context Closed
Task Description

Arcs in nested scaled and rotated blocks are not always rendered properly (too rough, too fine).

 2035 QCAD (main)Bug ReportLow Linetype scale in viewports Closed
Task Description

The preference

Edit > Drawing Preferences > General > Linetype > Scale of linetypes matches the scale of each viewport

should take the individual line type scale of entities into account.

2034QCAD (main)Feature RequestLowPaint Properties to include modifying linetype scales w...Assigned
Task Description

Previous Feature Request #1285, dated 2015, incorporated in QCADPro 3.24. I regularly adjust linetype scales on hidden, centreline and phantom lines to achieve the best appearance on the drawing when printed. I note the Paint Properties feature copies all the attributes of the chosen line but does not copy the scale. I have to change the scale of each line, even after ‘painting’. This copying all Properties is something AutoCAD does. I know I could change the line to Hidden2 etc. and tick the ‘scale lines’ box in Drawing Properties but that is not always successful- copying properties is a quick and useful way of achieving the required result.
QCAD Pro 3.24 Windows10.

2033QCAD/CAMBug ReportLowRepeated warning message while updating toolpathAssigned
Task Description

While updating or regenerating toolpath on the attached dxf file I repeatedly get the warning message in the attached jpg file. If I keep clicking OK then the toolpath is successfully generated. This did not happen in version 3.23.0 with the same file.

 2032 QCAD (main)Bug ReportLow Draw > Circle > Three Tangents: Cannot select third tan ...Closed
Task Description

See also:

 2031 QCAD (main)Bug ReportLow Ordinate Dimensions don't act as expected Closed
Task Description

Hi Andrew

I wasn’t sure if this was a bug or feature request, when I’m drawing part sets that only change in lengths I dimension them
to save time then I stretch and save as whatever filename... I was surprised when Qcad reacted the way it did when stretching ordinate
dimensions on a part, the 1st thing I did was window select over the dimensions which didn’t work ( this is the typical way for
stretching ordinate dimensions in AutoCAD,IntelliCad,Draftsight etc )... anyway Husky and I had a fairly long debate and he told me
I had to select the object and only parts of the ordinate dimensions which when stretched leaves a bit of tidying up to do..
Please let me know if I’m going about this the wrong way.. do i really have to do multiple stretches and move all the jogged dimensions?

See Topic https://www.qcad.org/rsforum/viewtopic.php?f=32&t=6901&start=15 It started off with negative values for ordinate dimensions then turned into problems stretching ordinate dimensions..
I also posted dropbox links to quite a few videos..

Attached is a zip file containing some screenshots plus the original dxf file..

Best Regards
John Hyslop

 2030 QCAD (main)Bug ReportLow Cannot snap to points of mirrored blocks Closed
1 Task Description

Wenn ich selbst erstellte Blocks Spiegle, funtionieren gewisse Fangpunkte nicht mehr.

In der angehängten Datei, ist der gespiegelte Block und deren inaktive Fangpunkte mit Roten Kreisen markiert.

Ich arbeite mit macOS Catalina 10.15.2

Vielen Dank für das Beheben dieses Bugs, der mich gerade sehr viel Zeit kostet ;-(

 2029 QCAD (main)Bug ReportVery Low Block order issue within drawing exchange between CE an ...Closed
Task Description

If I create a dxf in Pro and open it in CE (or vice versa) the block order can change strange and a new Layout Block is occasionally added. Looks like dxf version (R15 etc.) doesn’t matters.


 2028 QCAD/CAMBug ReportLow CAM > CAM Export: Fails for new document created Closed
Task Description

1. Load drawing
2. Create new drawing
3. Add toolpath / tool
4. CAM > CAM Export

Fails to identify current config (post processor).

 2027 QCAD (main)Bug ReportLow File > Print: Minimum line weight for printing is 0.01  ...Closed
Task Description

Create drawing in Meters.
Create line with line weight 0.25mm.
Line prints as 1cm wide as minimum line weight is forced as 0.01 drawing units (i.e. 0.01m) for printing.

 2026 QCAD (main)Bug ReportLow Modify > Clip to Rectangle: fails on blocks Closed
Task Description

Clip to Area = deletes whole blocks
Clear Area = deletes whole blocks
Cut at Area Boundary = deletes whole blocks

It was working before e.g. in QCAD Version 3.18.0 ;-)

 2025 QCAD/CAMBug ReportLow Set Nesting Quantity shows wrong quantity Closed
Task Description

If I set “Set Nesting Quantity” to e.g. 5 it will remember this number within the session.
If I need to check which number I’ve used last time there is no way to find the actual used value - it will show me always 1.
If I restart QCAD/CAM the value is completely lost and the nesting tool tries to fit in as much as possible into the sheet - regardless that the quantity number still shows one.

It would be nice to have a remember function even after restarting QCAD/CAM and have some kind of possibility to see the last used value.

 2024 QCAD/CAMBug ReportLow CAM > Nesting: Nesting blocks with multiple parts fails Closed
Task Description

Nesting quantity all test: 3

Nesting block2 = works
Nesting block1 = fails (placed outside sheet),
Nesting both blocks = fails (placed partly outside sheet),

 2023 QCAD (main)Bug ReportLow Polyline with segment widths: error with clockwise arcs ...Closed
Task Description

- Create clockwise arc
- Convert to polyline
- Assign segment end width > 0

See also:

 2022 QCAD (main)Bug ReportLow File > SVG Export: polyline arc segments and hatches in ...Closed
Task Description

Block scales are not applied to the radius of arc segments of polylines and arc boundary segments of hatches.

See also:

2021QCAD (main)Performance IssueVery LowCannot work with big dwg filesAssigned
Task Description

Openning a big file or doing any action in it, takes minutes to load.
Even dragging the scrollbar slightly left or right, takes mintues to redraw the canvas again, which makes QCAD un-usable for professional use.
Is there a way to make QCAD usable, after loading completed:
- Like suppressing edit until user says so,
- or taking snapshots of rendered canvases to another file and use it, as windows uses thumb.db ( for negative latency :P )

PS: I wish I could help a bit, but my hand are tied. I am just a java freak, I am opt to any idea of porting it to java, if she is still alive.

Tuğalsan Karabacak
EEE, MSc Mobile Comp & App, IWE

 2020 QCAD (main)Bug ReportLow Edit > Paste: Wrong position for block references with  ...Closed
Task Description

Open the example drawing,
selected all,
copy to clipboard,
open new drawing,
paste clipboard content with a scale of 1:1, check preview = everything ok,
change scale to 1/10 etc., check preview = block references way of.

QCAD Pro Version

 2019 QCAD (main)Bug ReportLow Polyline with segment widths: uneven arc segments Closed
Task Description

Example shows the effect on a ring (Menu → Draw → Ring)

2018QCAD (main)Feature RequestLowLayer visibility setting per view/view-portAssigned
2 Task Description

In a medium complex drawing it’s often too much details to have all layers in a drawing visible at once. Also, it is of great importance to be able to have a single model to avoid duplication of work and risk inconsistency.

So i would like to create a number of views where each view has selected layers visible (that makes sense for the purpose of the view) and then assign the views to different layout blocks (using view-ports) in paper-space to be able to setup printing of several views on the same page/PDF

This also means that view-ports would have to be aware of what view they are displaying (if any besides the standard-view).
This will then make it possible for printouts of different views with selected layers visible (different for each view and view-port) and still have only one model. Today this is not possible.

As it is today the only limited workaround is to set the layers you want to display, print/PDF of that viewport on separate page, and then change it for the next page, and so on. The big drawback is that you cannot have two different views/view-ports on the same page with different layers visible. Also, for large drawing it is painful to have to do a lot of manual setup for each rendering of the complete drawing.

 2017 QCAD (main)Bug ReportLow Rendering of arcs in blocks with scale factor > 1 Closed
Task Description

Arcs in blocks are not rendered smoothly if the block is inserted with a scale factor > 1.

2016QCAD (main)Bug ReportLowOffsetting multi selection of polylines halts prematureAssigned
Task Description


Offsetting 32 polys from ellipses fails.
Offsetting 16 polys can be completed with 2 selections for outer and 2 for inner.

For some reason the offset function halts premature.


 2015 QCAD (main)Bug ReportLow Hatch from segments cannot be saved to DXF/DWG using Op ...Closed
Task Description

I have an example of a figure that I can solid-fill, but if I save and exit, and reload, it disappears.

2014QCAD (main)Bug ReportLowFocus on Options Toolbar failsAssigned
Task Description

Scenario: e.g. Tools Move/Copy and Rotate switched to “use without dialog.

Launch within a drawing Move/Copy, use the Keyboard keys CTRL + Space to focus on the Option Bar - the field for Numbers is Highlighted and I can change it. Further navigation with keys on the keyboard depends on remembered option (copy yes/no etc what make a navigation possible or not. It looks like the navigation with the Arrow keys is focused on the canvas and sooner or later the courser will jump to the Command Line or Property editor. Same behavior with the Rotation tool.

See also:

 2013 QCAD (main)Bug ReportLow Draw, Shape, Star - more options Closed
Task Description

I like the new shape tool “Star”. Comes at the right time ;-)

Would be nice if we could get the same options like all other shape tools: “Create Polyline” and “Fill”.

 2012 QCAD (main)Bug ReportLow Draw > Hatch > Hatch from Selection: block transforms n ...Closed
Task Description

Hello. I refer to https://www.qcad.org/rsforum/viewtopic.php?p=25905#p25905 where when a block is hatched that hatch reference point is located at absolute 0,0 )where the block reference point is mapped as the reference point of the hatch and that reference point is absolute 0,0).
Best regards

Using QCAD
Win 10

2011QCAD Community EditionSuggestionVery LowUpdate QCAD CE SpatialIndex module to latest versionAssigned
Task Description

Building with the bundled version, 1.8.5, works fine.

When I try to build using the system version, which for Mageia Cauldron is 1.9.3, the build fails.


Here is the current spec file for version

It looks like qcad is incompatible with versions above 1.8.5.

Are there plans to port to the new version?

Thanks in advance.

 2010 QCAD (main)Bug ReportLow hatches of type "gravel" doesn't appear inside an ellip ...Closed
Task Description

Draw an ellipse, select it, draw an hatch of type gravel: it doesn’t appear at all.

Only for gravel.

 2009 QCAD (main)Bug ReportLow dwginfo - no output Closed
Task Description

Tested on Windows and Linux with several DWG files.


[.] C:\opt\QCAD>dwginfo.bat D:\tmp\dwgtester\08.01.01.dwg
12:57:27: Debug:

You are using a trial version of QCAD Professional.

12:57:27: Debug:    If you would like to use this software productively,
12:57:27: Debug:    please purchase the full version for a small license fee from our
12:57:27: Debug:    Online Shop at:
12:57:27: Debug:    http://www.ribbonsoft.com/shop

12:57:27: Debug:    Thank you for trying this add-on!

12:57:27: Debug:    Your script will start in 15 seconds...
12:57:42: Debug:    Input file:  D:\tmp\dwgtester\08.01.01.dwg
12:57:42: Debug:    calling odInitialize


[email protected]:/qcad# ./dwginfo -platform offscreen /data/08.01.01.dwg
QCAD version  3.23.0
11:56:24: Debug:

You are using a trial version of QCAD Professional.

11:56:24: Debug:    If you would like to use this software productively,
11:56:24: Debug:    please purchase the full version for a small license fee from our
11:56:24: Debug:    Online Shop at:
11:56:24: Debug:    http://www.ribbonsoft.com/shop

11:56:24: Debug:    Thank you for trying this add-on!

11:56:24: Debug:    Your script will start in 15 seconds...
11:56:39: Debug:    Input file:  /data/08.01.01.dwg
11:56:39: Debug:    calling odInitialize
 2008 QCAD (main)Bug ReportLow windows: cannot call scripts\Pro\Tools\BoundingBox\Boun ...Closed
1 Task Description

Calling bbox tool via batch file works:

C:\Program Files\QCAD>bbox.bat D:\tmp\dwgtester\10.09.03.dwg


09:42:15: Debug:

You are using a trial version of QCAD Professional.

09:42:15: Debug:    If you would like to use this software productively,
09:42:15: Debug:    please purchase the full version for a small license fee from our
09:42:15: Debug:    Online Shop at:
09:42:15: Debug:    http://www.ribbonsoft.com/shop

09:42:15: Debug:    Thank you for trying this add-on!

09:42:15: Debug:    Your script will start in 15 seconds...
09:42:30: Debug:    calling odInitialize
Min: 2419.9969114297623/-125.36162367587679
Max: 2689.9969114297623/64.63837647546899
Size: 270/190.00000015134577

Calling bbox tool directly doesn’t work:

C:\Program Files\QCAD>qcad.exe -no-gui -allow-multiple-instances -autostart scripts\Pro\Tools\BoundingBox\BoundingBox.js D:\tmp\dwgtester\10.09.03.dwg

Output (empty line):

 2007 QCAD (main)Bug ReportLow bbox.bat cannot write log file Closed
Task Description

The out redirection file is not located in temp dir but in the batch files location. Due to missing file permissions in “C:\Programs\...” the file cannot be created.

This is a fixed an therefore working version of bbox.bat:

@echo off
qcad.exe -no-gui -allow-multiple-instances -autostart scripts\Pro\Tools\BoundingBox\BoundingBox.js %0 %* 1>%temp%\bbox.log 2>&1

type %temp%\bbox.log
del %temp%\bbox.log
 2006 dwg2pdfFeature RequestLow dwg2pdf: Auto detect page orientation Closed
1 Task Description

Auto detect page orientation based on width / height of document.

See also:

 2005 QCAD (main)Bug ReportLow Missing dialog in Command Line for "Create Block from s ...Closed
Task Description

Bugreport filled on behalf of John Hyslop / QCAD forum member.

If launching the Menu / Block / “Create Block from selection” tool the usually used Command Line dialog to prompt to the next required action is missing.
The Status bar is properly calling for “Reference Point” etc.


 2004 QCAD (main)Feature RequestLow Library Browser: configurable icon background color Closed
Task Description

Add preference for library browser icon background color.

 2003 QCAD/CAMBug ReportLow QCADCAM Crashes when starting up Closed
Task Description

I am trying to run the QCADCAM v3.23.0 64 bit version under Windows 10 x64. When I start the program, I get the splash screen showing it loading all of the plugins. When it gets to around 67% (Gerber stuff), the program crashes. I get the following exception:

Unhandled exception at 0x00007FFC5F51C706 (MxMGLV64.dll) in qcad.exe: 0xC0000005: Access violation reading location 0×0000000003304318. occurred

I also loaded the 64 bit version of just plain QCAD and it works with no problems.
I also tried loading the 32 bit version of QCADCAM and while it does not crash, it does not display any of the menus, toolbars, or toolboxes. it displays only a black screen with the title bar.

 2002 QCAD (main)Bug ReportLow Draw > Viewport > Add Viewport: Hatch is offset incorre ...Closed
Task Description

When a hatch have been offset in the Model then it appears incorrectly when rendered in a Viewport. It seems that in Viewports the hatch Origin value is not taken into consideration. This means that when adjusting a hatch in the Model to look correct (align along a line for example). This alignment is off in the Viewport.

See screenshots and attached test dxf file in this thread on the forum: https://qcad.org/rsforum/viewtopic.php?f=33&t=6742

Edit: After looking more into this issue is seems it is the Viewport’s position that is ignored when transforming the pattern into Viewport space. See the following gif:


Above it can be seen that that pattern is always rendered in ‘worldspace’ since the pattern is static (the pattern is not moved when the viewport is moved around)

 2001 QCAD/CAMBug ReportLow CAM > Nesting: Alignment fails Closed
Task Description

Description for the CAM Nesting alignment:

Alignment: Parts are arranged with the chosen alignment in mind. An alignment of “Left - Bottom” means that parts are shuffled to the left (primary alignment) and towards the bottom (secondary alignment).
Quote end

I tested a few scenarios. e.g
a Top Left, Align → leads to a top right alignment,
a Top left, Hull → leads to a Bottom Left alignment,

 2000 QCAD/CAMBug ReportLow CAM > Nesting: misleading "Sheet added" confirmation Closed
Task Description

Within the nesting preparation:
A left mouse click to add a sheet will always be confirmed with “Sheet added”, regardless of a proper selection or where the left click is done in Model_Space.

1999QCAD (main)Feature RequestLowViewport: Add additional properties for controlling dim...Assigned
1 Task Description

When working with multiple Viewports with different scale it could be very useful to have extra properties controlling how dimensions are rendered in the viewport:

E.g an extra “Dimension Scale” under “Scale” in the Viewport selection’s ‘Specific Properties’ section, could allow having the same size when printed.
This Dimension Scale would be multiplied on top of the Scale value, but only for Dimensions rendering.

Toggle button for hiding any dimensions in the Viewport. Maybe this should be controlled by being able to specify a Layer that should be hidden in this Viewport only, then I could select my Dimensions layer here.

The Viewport properties:

Showing tasks 51 - 100 of 2098 Page 2 of 42 - 1 - 2 - 3 - 4 - 5 - Last >>

Available keyboard shortcuts


Task Details

Task Editing