QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategoryTask TypeSeveritySummaryStatusProgress  desc
 300 QCAD (main)Bug ReportLow Dashed lines in SVG PG export Closed
100%
Task Description

Chat from  FS#194  singled out, so that can be closed.

Dash patterns in BETA2 are very much out of proportion. BETA2 always PG exports 1:1 and only scales strokes so that in the final rendering they match what a technical drawing would show. As dash patterns depend on stroke, both current stroke and final scale have to be brought in accord.

The patch below also restores the alignment of dashes, so that dashed lines do not end in a gap, at least in most occasions.

--- SvgExporterPG-orig.js	2011-09-15 23:11:40.000000000 +0200
+++ SvgExporterPG.js	2011-10-07 13:28:04.085376719 +0200
@@ -384,32 +384,29 @@
         continuous = true;
     }
     if (!continuous) {
-        //p.scale(this.getPatternFactor());
-        p.scale(1/this.scale);
+        // dash and gap lengths are to be proportional to line weight
+        // beware: line weight unit is 100 times millimeters, convert to current unit
+        // beware: the viewer scales lengths differently from weight
+        p.scale(RUnit.convert(this.weight / 100.0, RS.Millimeter, this.svgUnit) / this.scale);
         var num = p.getNumDashes();
-        var str = "";
+        var str = [];
         for ( var i = 0; i < num; ++i) {
             var len = Math.abs(p.getDashLengthAt(i));
-            // see FS#192:
-            //len = this.convert(len);
-            str += "" + len;
-            if (i < num - 1) {
-                str += ",";
-            }
-        }
-        additionalStyles += "stroke-dasharray:" + str;
-        
-        // does more harm than good
-//        if (isShape(this.shape)) {
-//            var length = this.shape.getLength();
-//            if (isNaN(this.offset)) {
-//                this.offset = this.getPatternOffset(length, p);
-//            } else {
-//                var num = Math.ceil(this.offset / p.getPatternLength());
-        //                this.offset -= num * p.getPatternLength();
-        //            }
-        //            additionalStyles += ";stroke-dashoffset:" + this.offset;
-        //        }
+            str.push(len);
+        }
+        additionalStyles += "stroke-dasharray:" + str.join(",");
+
+        // center dash-array
+        if (isShape(this.shape) && isFinite(this.shape.getLength())) {
+            var length = this.shape.getLength();
+            if (isNaN(this.offset)) {
+                this.offset = -this.getPatternOffset(length, p);
+            } else {
+                var num = Math.ceil(this.offset / p.getPatternLength());
+                this.offset -= num * p.getPatternLength();
+            }
+            additionalStyles += ";stroke-dashoffset:" + this.offset;
+        }
     }
 301 QCAD (main)Bug ReportMedium Open an existing DXF file Closed
100%
Task Description

When I open a dfx file I have made from AutoCad, QC will open the file fine but then when I try to save it I get a dialog box stating that the drawing was not saved and asks if I have permission or is the disk full. Yes, I have permission and no the disk is not full.
Then when I close the dfx file and try to reopen it the second time, QC will not open the file and a dialog box reads “Cannot open file, please check your access rights, the file format and the file extension”

 303 QCAD (main)Bug ReportLow Hatch with spline boundary Closed
100%
Task Description

If spline boundary has fit points, hatch is loaded with visible inaccuracy.

 306 QCAD (main)Bug ReportMedium Grid can`t be turned off Closed
100%
Task Description

Not possible to turn off grid (in application preferencies). In settings looks that accepted (checkbox is unchecked) but in program window is still visible.

 307 QCAD (main)Bug ReportLow Library Browser DB File Locked Closed
100%
Task Description

Handle situation in which DB file is locked (from previous crash, ...).

Currently, the debugger is shown repeatedly.

 308 QCAD (main)Bug ReportHigh Cant start V3 beta 2 on debian linux 64bit Closed
100%
Task Description

Tried the Beta on Debian 64 bit with the tarball, .. I didn’t want to use installer as I have a working qcad-2.2.2.0-1-prof.linux.x86

steve@dolphin:~/Downloads/qcad-3.0.0-beta2-trial-linux$ uname -a
Linux dolphin 2.6.39-2-amd64 #1 SMP Tue Jul 5 02:51:22 UTC 2011 x86_64 GNU/Linux

qcad-2.2.2.0-1-prof.linux.x86

steve@dolphin:~/Downloads/qcad-3.0.0-beta2-trial-linux$ ./qcad-trial
#1 SMP Tue Jul 5 02:51:22 UTC 2011
x86_64
./qcad-trial-bin: error while loading shared libraries: libgthread-2.0.so.0: wrong ELF class: ELFCLASS64
steve@dolphin:~/Downloads/qcad-3.0.0-beta2-trial-linux$

 309 QCAD (main)Bug ReportVery Low Templates Closed
100%
Task Description

Edit–>Application Preferences–>Load/Save–>Templates

click Add, then Cancel ⇒ enabled Down button ⇒ click Down ⇒

Uncaught exception at C:/Program Files/QCAD Professional\scripts/Widgets/DirectoryList/DirectoryList.js:72: Error: QListWidget::insertItem(): could not find a function match; candidates are: insertItem(int row, QListWidgetItem item) insertItem(int row, String label)

 311 QCAD (main)Bug ReportMedium Layer locking Closed
100%
Task Description

Pendant la réalisation d’un plan le calque 0 s’est verrouillé, impossible de le modifier. En l’enregistrant sous un autre nom le calque 0 est toujours verrouillé.

During the implementation of a plan the layer 0 was locked, impossible to change it. By saving it under another name Layer 0 is always locked.

 312 QCAD (main)Bug ReportMedium Crash Closed
100%
Task Description

Pendant la création d’un plan le logiciel se bloque, puis une boite de dialogue Windows apparait : “QCAD a cessé de fonctionner”.
Après validation de la fenêtre le logiciel se ferme et toutes les modifications non enregistrées sont perdues.

When creating a plan software hang, then a dialog window appears: “QCad has stopped working”.
After validation of the software window is closed and all unsaved changes are lost.

 314 QCAD (main)Bug ReportLow Polyline from segments puts result in layer 0 Closed
100%
Task Description

A polyline or polygon created from segments always ends up in layer 0, shouldn’t it stay in the same layer as the segments have been?

 317 QCAD (main)Bug ReportLow Debugger with -always-load-scripts Closed
100%
Task Description

Starting qcad Beta 3 with command line argument -always-load-scripts will bring up debugger:

Uncaught exception at /opt/qcad-3.0.0-beta3-prof-linux/scripts/library.js:2: RangeError: Maximum call stack size exceeded.
2 include(”sprintf.js”);

 318 QCAD (main)Bug ReportLow Text of dimensions label in SVG PG export  Closed
100%
Task Description

The labels of dimensions in PG exporter are moved half text-height. Thats a bit much, and actually, no such movement looks more true to the display of same in QCAD itself.

--- SvgExporterPG.js.orig	2011-10-15 18:57:29.994666881 +0200
+++ SvgExporterPG.js	2011-10-15 18:57:39.284666834 +0200
@@ -434,7 +434,7 @@
         //debugger;
         var angle = this.text.getAngle();
         //this.text.setAngle(entity.getAngle());
-        var offset = RVector.createPolar(this.text.getHeight()/2, angle + Math.PI/2);
+        var offset = RVector.createPolar(0, angle + Math.PI/2);
         this.text.move(offset);
         this.textColor = entity.getColor();
         this.exportText();
 319 QCAD (main)Bug ReportMedium Prints as though A4 even though I change paper size in  ...Closed
100%
Task Description

This continues a problem that occurred in Qcad 2.2/OpenSuse 11.1:

1. The default paper size is always A4. (minor, but annoying)

2. Here is the serious problem: When I change the paper size to, for example tabloid, in File/Drawing Preferences/Page and in Print/Properties, the print job prints as though it were A4. This occurs unless I first go to Yast or Control Center and (as superuser) change the default page size. Other programs (such as Open Office) don’t require this.

The printer is an HP deskjet 9800, and the problem occurs with either CUPS or hplip printing.

I am using Opensuse 11.3 (I haven’t been able to install successfully opensuse 11.4 on my computer), Qcad
Version:
3.0 Beta 2
Date:
Sep 17 2011
Qt Version:
4.7.3
Edition:
Full Version

 322 QCAD (main)Bug ReportLow Line type scaling with print scale factor Closed
100%
Task Description

In QCAD 2, line type patterns are scaled according to the print preview drawing scale, also in model space.
This is not the case in QCAD 3 and possibly needs a different solution.

Possible solutions:

  • two different LTSCALEs for model space and print preview
  • same behavior as QCAD 2
 325 QCAD (main)Bug ReportLow Layer renaming: changing name from lower case to upper  ...Closed
100%
Task Description

Layer renaming: changing name from lower case to upper case

 328 QCAD (main)Bug ReportLow Persistent selections Closed
100%
Task Description

Preference for persistent selections

 330 QCAD (main)Bug ReportLow Text Edit command replaces \U+00B0 with %%[dD] Closed
100%
Task Description

when editing text which contains the degree symbol the proper escape sequence is \U+00B0
Qcad 3Beta3 replaces \U+00B0 with %%[dD]

 331 QCAD (main)Bug ReportLow Snap buttons doubled Closed
100%
Task Description

1. For some reason on the Window machine, the snap toolbar buttons are doubled for all functions. I therefore have two buttons for each type of snap and cannot access the bottom snaps unless I undoc the toolbar.

For some reason, this is still fine in the Linux Beta 3. Single buttons like always.

Reported by: koosjr

 333 QCAD (main)Bug ReportLow Add layer: new layer should be active one Closed
100%
Task Description

Add layer: new layer should be active one

 334 QCAD (main)Bug ReportMedium SVG Export Polygons, arcs converted to straight lines. Closed
100%
Task Description

When exporting a drawing to SVG, polygons containing arcs (trimmed circles in this case) are converted to straight lines. If the polygon is exploded first, then it exports correctly. Of course, this isn’t useful if closed polygons are required for the program using the SVG file. Solid hatch fills export correctly. See attached DXF and corresponding SVG export.

 336 QCAD (main)Bug ReportLow Tool bars with tools without icon Closed
100%
Task Description

Some tool bars (e.g. ‘Block’ tool bar) contain tools without an icon (empty button).
Not all tools are available in tool bars.

 337 QCAD (main)Bug ReportMedium Polylines with arcs export to SVG as lines Closed
100%
Task Description

If I create a closed polygon that include arcs or parts of circles, they export to SVG as straight lines.

If I explode the polyline, they export fine.

If I create a solid fill, those arcs export fine.

See attached DXF and SVG output.

This may be a duplicate bug, but my previous bug report vanished.

 338 QCAD (main)Bug ReportMedium PDF export generates an empty document Closed
100%
Task Description
  • simple drawing: 1 rectangle, 1 circle
  • File → Export PDF

→ generates an empty document (or maybe both the lines and the background is white)

Note: After the export ones stays in print preview mode, which is a bit confusing if the command was invoked from the “normal” drawing mode.

 339 QCAD (main)Bug ReportMedium PrintPreview: multi page widget doesn't work anymore Closed
100%
Task Description
  • the cells are not shown anymore
 340 QCAD (main)Bug ReportMedium Bitmap export shows selected entities Closed
100%
Task Description
  • Selected entities are exported in the way as they are shown on screen.
  • Same applies for highlighted entities.
  • See attachment.
 341 QCAD (main)Bug ReportMedium PrintPreview: Auto Fit Pages doesn't work as excepted Closed
100%
Task Description
  1. load attached drawing
  2. print preview
  3. auto fit pages
  4. shows 2 columns (wrong) and 13 rows (correct), see attachment
 342 QCAD (main)Bug ReportMedium SIGPIPE QPrinter::init() Closed
100%
Task Description
  • tried different options in print preview (auto scale, auto fit etc.)
Thread [1] 18993 (Suspended : Signal : SIGPIPE:Broken pipe)	
	__kernel_vsyscall() at 0xffffe424	
	send() at 0xb517d5b8	
	0xacd3d8b2	
	httpFlushWrite() at 0xacd3dc21	
	0xacd3fcb8	
	cupsSendRequest() at 0xacd56470	
	cupsDoIORequest() at 0xacd56bc7	
	cupsDoRequest() at 0xacd56f0b	
	0xacd35d7f	
	cupsGetDests2() at 0xacd375d5	
	cupsGetDests() at 0xacd379a3	
	0xb5ad5153	
	0xb5a12133	
	0xb5a28344	
	0xb5a2b78c	
	QPrinter::init() at 0xb5a2d4ee	
	QPrinter::QPrinter() at 0xb5a2f01f	
	QtScriptShell_QPrinter::QtScriptShell_QPrinter() at 0xb02c9e29	
	qtscript_QPrinter_static_call() at 0xafe863ba	
	0xb6bd7f88	
	0xb6ac7c97	
	0xb6a91114	
	0xa95f7580	
	0xb6a44262	
	0xb6a445f7	
	0xb6bb0f92	
	QScriptEngine::evaluate() at 0xb6bba46f	
	RScriptHandlerEcma::ecmaInclude() at RScriptHandlerEcma.cpp:1,051 0x87d5f9d	
	0xb6bd813c	
	0xb6ac1f68	
	0xb6a9164c	
	0xa970b87d	
	0xb6a44262	
	0xb6a445f7	
	0xb6bb0f92	
	QScriptEngine::evaluate() at 0xb6bba46f	
	RScriptHandlerEcma::ecmaInclude() at RScriptHandlerEcma.cpp:1,051 0x87d5f9d	
	0xb6bd813c	
	0xb6ac1f68	
	0xb6a9164c	
	0xa9717387	
	0xb6a44262	
	0xb6a445f7	
	0xb6bb0f92	
	QScriptEngine::evaluate() at 0xb6bba46f	
	RScriptHandlerEcma::eval() at RScriptHandlerEcma.cpp:786 0x87d4014	
	RScriptHandlerEcma::doScript() at RScriptHandlerEcma.cpp:782 0x87d3ef8	
	RScriptHandlerEcma::createActionDocumentLevel() at RScriptHandlerEcma.cpp:873 0x87d4677	
	RGuiAction::slotTrigger() at RGuiAction.cpp:628 0x8f7a23c	
	RGuiAction::qt_metacall() at moc_RGuiAction.cpp:86 0x8fc60a9	
	QMetaObject::metacall() at 0xb5478c83	
	QMetaObject::activate() at 0xb5489134	
	QAction::triggered() at 0xb5869d99	
	QAction::activate() at 0xb586b48f	
	QToolButton::nextCheckState() at 0xb5da52b2	
	0xb5cbb61f	
	QAbstractButton::mouseReleaseEvent() at 0xb5cbb8dc	
	QToolButton::mouseReleaseEvent() at 0xb5da53ac	
	QWidget::event() at 0xb58da629	
	QAbstractButton::event() at 0xb5cba7bf	
	QToolButton::event() at 0xb5da82ae	
	QApplicationPrivate::notify_helper() at 0xb5871d7c	
	QApplication::notify() at 0xb58772c4	
	QCoreApplication::notifyInternal() at 0xb547215b	
	QApplicationPrivate::sendMouseEvent() at 0xb5875152	
	0xb59066b5	
	QApplication::x11ProcessEvent() at 0xb5905d26	
	0xb5932f04	
	g_main_context_dispatch() at 0xb4aee509	
	0xb4aeed10	
	g_main_context_iteration() at 0xb4aeefce	
	QEventDispatcherGlib::processEvents() at 0xb54a2741	
	0xb5932a55	
	QEventLoop::processEvents() at 0xb547131d	
	QEventLoop::exec() at 0xb54715aa	
	QCoreApplication::exec() at 0xb5473701	
	qtscript_QCoreApplication_static_call() at 0xb08dc4b7	
	0xb6bd813c	
	0xb6ac1f68	
	0xb6a9164c	
	0xb100cf6b	
	0xb6a44262	
	0xb6a445f7	
	0xb6bb0f92	
	QScriptEngine::evaluate() at 0xb6bba46f	
	RScriptHandlerEcma::eval() at RScriptHandlerEcma.cpp:786 0x87d4014	
	RScriptHandlerEcma::doScript() at RScriptHandlerEcma.cpp:782 0x87d3ef8	
	RScriptHandler::init() at RScriptHandler.cpp:31 0x8fa7476	
	main() at main.cpp:228 0x87cd9c9	
 343 QCAD (main)Bug ReportMedium 2 drawings in print preview: inconsistencies Closed
100%
Task Description
  1. load 2 drawings
  2. switch both into print preview
  3. see attachment
  4. scale combo box shows only “1:1”
  5. switching drawings does not update options tool bar from drawing but drawing from options tool bar
 345 QCAD (main)Bug ReportLow unit foot: no dotted line Closed
100%
Task Description

can’t make a dotted line on a drawing with unit foot.

  • drawing unit: foot (length taken from a actual architecture plan)
  • layer settings: as shown in the screen shot
  • selected line is on layer “dotted”
  • line types is shown as continues for almost everything
 349 QCAD (main)Bug ReportMedium Cannot open saved files Closed
100%
Task Description

Hi Andrew

Using Beta 3 v3 saving files to DXf 2010, DWG 2010, or even 2007 only saves succesfully some times. Most of the time I get a warning dialog stating that “Cannot open file” - no suitable importer found?

Please help

Clive

 350 QCAD (main)Bug ReportLow Strech function of version 3.0.0 Beta does not work (ha ...Closed
100%
Task Description

The stretch function does not work at all. I tried it in the old version 2.2.2 where it worked.

 351 QCAD (main)Bug ReportLow Simple text: position, simple text flag Closed
100%
Task Description

Simple text tool does not create simple text but mtext.
When changed to simple in property editor, position does not work

 352 QCAD (main)Bug ReportLow Info Tool, Polygonal Area shows decimal units instead o ...Closed
100%
Task Description

Drawing preferences / dimension = Fraction

Info Tool, Polygonal Area shows decimal units instead of fractions.

 353 QCAD (main)Bug ReportLow Relative Angle / Line Orthogonal caused malfunction in  ...Closed
100%
Task Description

After using Line “Relative Angle” or “Line Orthogonal” the Toolbar is in a loop without showing all the Cad tools such as “Modify” “Hatch” etc..
Escape switch only between the “Lines Menu” and the “Select Menu”. To get all Cad Tools back you have to restart QCad.

 354 QCAD (main)Bug ReportLow Property Editor / Select Layer Malfunction Closed
100%
Task Description

RC1b
To change the postfix for dimension.
Situation: New drawing, Dimension in Drawing, Dimension on one Layer. Menu > Select > Select Layer and click on a dimension. Went to Property Editor > Geometry > Label and change the Label in <>”. Nothing happens.

The same procedure with a other kind of selection works and it works also in the 2.2.2.0

 356 QCAD (main)Bug ReportHigh Javascript exception: any time user double clicks on te ...Closed
100%
Task Description

Javascript exception

Any time user double clicks on text, an exception is raised in the following script:

/qcad-3.0.0-rc1-prof-linux/scripts/Draw/Text/TextDialog/TextDialog.js

Fix is to comment out the line

      //bug.... simpleText.checked = textDataIn.isSimple();
 357 ECMAScriptBug ReportLow include should raise exception if file not found Closed
100%
Task Description

include() should raise exception if file not found.

This is actually the case but does not seem to work properly.

 361 QCAD (main)Bug ReportLow New from template: save saves template Closed
100%
Task Description

- New from template
- Choose template
- File - Save

→ Template is overwritten instead of the “Save As” dialog being shown.

 362 QCAD (main)Bug ReportLow Regression in SvgExporterPG.prototype.exportEntity Closed
100%
Task Description

In RC1 text in PG SVG will be in the wrong location. The position passed from native code to the SvgExporterPG.prototype.exportEntity is wrong:

Instead of the actual place of the text it gets the position of the surrounding block entity, or, for text that is not in a block, “0,0,0”.

Dimension labels are not affected by this. Also HAlign and VAlign are not passed correctly for text in the model-view block.

 363 QCAD (main)Bug ReportLow Modify tool "Stretch" only one time ... Closed
100%
Task Description

3.0 RC1

The Stretch Tool works only for one task and than you have to reselect it again for the next task.
Who really works with the stretch tool has to use it (often) a couple times consecutively to get the job done.

It was nice working in 2.2.2.0

 364 QCAD (main)Bug ReportLow Default paper with default unit inch Closed
100%
Task Description

Default paper might be configured as 210×297 inches if inch is chosen as default unit.

 365 QCAD (main)Bug ReportLow Auto fit to paper fails with some drawings in inches Closed
100%
Task Description

Auto fit to paper fails with some drawings in inches

e.g. Bathroom mod 2.dxf

 368 QCAD (main)Bug ReportLow Appearance preference Closed
100%
Task Description

RC1 is lazy in saving appearance to config. I noticed, because it always started with default window size. Maximizing was not carried over, also the panels were consistently reset.

Only when eg. dragging the handle to change cad-toolbar width not from preferences it would write an “appearance” section to the config file.

The appearance section should be written rather sooner than later.

 369 QCAD (main)Bug ReportMedium "Edit Text" Function fails ... Closed
100%
Task Description

3 RC1b

Trying to edit a Text calls the Qt Script Debugger with following Message:

Uncaught exception at C:/Programme/QCAD 3rc1b/scripts/Draw/Text\TextDialog/TextDialog.js:170: ReferenceError: Can’t find variable: simpleText
170 simpleText.checked = textDataIn.isSimple();

I’m able to close the Script Debugger but I can’t edit the Text ....

 370 QCAD (main)Bug ReportLow Canceling quit leaves windows in half-closed state Closed
100%
Task Description
  1. File - New
  2. File - New
  3. Draw line
  4. Quit
  5. Cancel
  6. Switch to first tab
 371 QCAD (main)Bug ReportLow Ctrl-P not working in print preview Closed
100%
Task Description

Ctrl-P not working in print preview

Linux only.

 372 QCAD (main)Bug ReportLow Loading QCAD 3 layer names with international character ...Closed
100%
Task Description

Loading QCAD 3 layer names with international characters fails in QCAD 2.

e.g. æøå

 373 QCAD (main)Bug ReportMedium QCAD3 does not open dxf-files containing ellipses Closed
100%
Task Description

QCAD3 does not open dxf-files containing ellipses!
Error Message: Can’t open file, check fileformat, fileextension, accesrights

 374 QCAD (main)Bug ReportLow Text: spaces at beginning of line does not indent Closed
100%
Task Description

Text: non-breaking spaces (\~) at beginning of line does not indent.

See aeg_koe_1_H0_A.dxf

 375 QCAD (main)Bug ReportLow Text: white text shown as white on white in text dialog Closed
100%
Task Description

Text: white text shown as white on white in text dialog

See: aeg_koe_1_H0_A.dxf

Showing tasks 201 - 250 of 1971 Page 5 of 40<<First - 3 - 4 - 5 - 6 - 7 - Last >>

Available keyboard shortcuts

Tasklist

Task Details

Task Editing