QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategoryTask TypeSeverity  ascSummaryStatusProgress
2174QCAD (main)Bug ReportLow[SOLVED] Numerous shortcomings when exploding Polylines...Assigned
0%
1 Task Description

QCAD Professional
Windows 7, Win installer 32bit
Version: 3.25.2.7 (3.25.2.7)
Internet: QCAD.org
Build Date: Dec 16 2020
Revision: e06f230
Qt Version: 5.13.2
Architecture: i386
Compiler: Unknown

Issues most likely unrelated to OS and installations before 3.25.
Related post:
https://qcad.org/rsforum/viewtopic.php?&t=7982

Flaws documented in full in attached dxf.
The dxf has meaningful Layer States.

4 Columns:
- Prior Art
- The test cases
- Actual results
- Results with proposed fix

Tried as many things as I can come up with.
Orange: Flaws
Red: Errors
Green: Good results (or as good as I can get them)

Solution(s) given in attached script explode.js
(I am just a simple guy and wouldn’t know how to file a pull request on GitHub ......)

In section: “explode polyline into line and arc segments”
group: “if (RPolyline.hasProxy() && polyline.hasWidths()) {....}”
All additions, updates & typos are marked with “CVH”, one can textual search for it.
Over-documented for sure.
Any Eaction is to debug in Windows and is obsolete.

Included PreferencesPage.ui is updated for the all Splines from Text fix
Still in consideration: Forcing cubic splines from text to degree 2 ...
... I am rather convinced ...

CVH

 1108 QCAD (main)Bug ReportLow [patch] fix linking and fix compiling with glibc 2.20 Closed
100%
Task Description

There are patches in attachment.

 1052 QCAD (main)Performance IssueLow (Isometric) projection: poor preview performance Closed
100%
Task Description

Preview performance can be improved by projecting only once and then moving / pasting the projection.

 1862 ECMAScriptBug ReportLow (Groups of) Radio Button does not remember its state. Closed
100%
Task Description

Also, the way the state of radioButtons is saved on Qcad3.conf is rather confusing.

Exemple :
Two radioButtons _cr_i and _cr_x are in the same QWidget.
- check _cr_i
- validate the form with OK
- reopen the form, check _cr_x
- validate the form with OK

the config file reads

[_myPlenum2]
VisibleInMenu=true
...
_cr_i=_cr_i
_cr_x=_cr_x
...

On next form run, even if I select _cr_i, the radiobutton QWidget always takes the value of _cr_x.

 899 QCAD (main)Bug ReportLow (De-)Select Polygon - No Mode buttons/Icons showing Closed
100%
Task Description

Linux Mint -64

(De-)Select Polygon - No Mode buttons/Icons showing

 663 QCAD (main)Feature RequestLow (de-)select by property Closed
100%
Task Description

It would be nice if one could
- select
- deselect from the current selection
all entities with a specific property, for example:
- all entities which are texts
- all entities with angle === 180
- all entities with color !== red
The current property editor has the perfect gui for it. On a similar gui one could change a value there which changes the selection instead of the properties of the selected entities.

I think there would be no need for “and” or “or”, if the current selection can be reduced or extended.

 2220 QCAD (main)Bug ReportLow (CU) Convert Drawing Unit (inch, mm etc) to None fails Closed
100%
Task Description

(CU) Convert Drawing Unit (inch, mm etc) to none fails with the message “Warning, Unit “None” selected. Nothing to be done”.
In the same drawing I can change the Drawing Unit below “Drawing preferences/ Drawing Unit” to None without any problems.

 1527 QCAD (main)SuggestionLow "Zeichnungseinheit konvertieren" translation missing .. ...Closed
100%
Task Description

... for the Option bar.

 672 QCAD (main)Bug ReportLow "Snap to intersection" followed by "Dimension" does not ...Closed
100%
Task Description

Version 2.1:

Managed to use “Snap to grid” as the item was precisely 100mm or 120mm, but had it not been a precise multiple of 10mm there would have been a problem.

Thanks.

 1274 QCAD (main)Bug ReportLow "Select Contour" selects every connected object Closed
100%
Task Description

Right now the “Select Contour” feature behaves like a “Select each and every connected line”.
I think that was not the intended purpose, so I report this as a bug.

I tested it on a honeycomb structure and instead of selecting just the outer contour it selected also every line inside the structure, which were connected to the contour.

1473QCAD (main)Feature RequestLow"Partial" circular/radial dimensionsAssigned
0%
Task Description

This is kind of related to FS#952, or rather a superset of it.

Consider the situation in the attached image. There is a perfectly good, albeit really shallow arc, making the radius somewhere in the vicinity of 600 millimeters, and the radial dimension being drawn accordingly.

Considering the other dimensions of the part, this is completely unusable, even to work with, really, but definitely so when it needs to be put on paper.

It would be nice to have some sort of “partial” (for my lack of a better word) radial/diametric dimensions where the dimension length can be adjusted.

Considering that this can be done with Leader, maybe a better (more generic) solution would be for Leader type dimensions to have options so they could automatically generate labels for various dimensions of a selected entity – sort of like having the Prefix/Tolerance/Scale options the other dimensions have, and have some additional fields there for selected entity and maybe dimension type (for example, radial or diametric for an arc-type entity).

 1724 QCAD Community EditionSuggestionLow "OVERKILL" command Closed
100%
Task Description

Is it possible to create “OVERKILL” command like in AUTOCAD

 1588 QCAD (main)Feature RequestLow "hole" realisation Closed
100%
Task Description

Trying to design PCB with QCad (as hobby ;) I found an inconvenience with routing tracks through holes: I need end one line, snapped to the one edge of contact pad and start new line from other side of the pad, otherwise if line goes through the hole and covers it, hole disappears or becomes damaged; or I need to clean each hole of track parts before printing.

so, subject is: to define a certain area of white or background colour, so if any object (line or other shape) intersects it, it will be just invisible inside this area. they may still be visible, say, in draft mode.

I’ve been thinkig about simpliest way to make it, but not sure. Maybe it can be an additional property of the hatch, or it can be specific “background” solid colour, which can be applied to the hatch (apply this colour to other kind of object is not a good idea).

Then contact pad can be defined as shape with smaller round hatch inside to designate hole, so we can route lines, snapping them to the hole centers, not caring about clearing these holes later of little pieces of tracks.

Maybe it can be usefull :) Thanks for your great work!

 1522 QCAD (main)Bug ReportLow "Hatch from Segments" problem with polylines ... Closed
100%
Task Description

I tried to hatch an area and the Reference Manual said all entities can be used but it doesn’t works at my example. Did I missed something?

The test drawing shows at the top the goal with exploded polylines. At the bottom I have rectangles (Polylines, drawn with the Rectangle tool) what is unfortunately not working.

 978 QCAD (main)Feature RequestLow "Frequently used" items for text Closed
100%
Task Description

Just floating an idea, recently I’ve had to use the diameter symbol many times in texts. At this moment it’s a chore, as that usually means browser, look for a page with symbol in it, copy, paste.

I wonder if the text entry could have some sort of a box for “frequently used” characters (or even phrases, or whatnot, but I presume a handful special characters that everyone can tailor to their needs would already be a huge plus)? Like, a 3×3 to 5×5 matrix below the Alignment panel or something along these lines.

2128QCAD (main)Feature RequestLow"Create Library Item" "Save As" dialogue doesn't rememb...Assigned
0%
2 Task Description

This is either a bug or a feature request, depending on perspective; my apologies if I’ve picked the wrong one. Additional discussion can be found here.

Steps to reproduce:
1. Create an entity
2. Run “Create Library Item” [BT]
3. Select Reference Point

Expected outcome:
“Save As” dialogue opens in the directory that the previous library item was saved in

Actual outcome:
“Save As” dialogue opens in ( RSettings.getLaunchPath() + “/libraries” )

Additional Context:
The reason I’ve categorized this as a bug is because, relative to the behaviour of the main “Save As” dialogue (which does remember the last directory used) the behaviour of the “Create Library Item” “Save As” dialogue is unexpected.

Software versions:
QCAD 3.25.2 Pro
Windows 10 Pro

860QCAD (main)Feature RequestLow"Create Library item from selection" default Path ...Assigned
0%
1 Task Description

Default Path for “Create Library item from selection” / “Save us” is C:\Programme\QCAD pro 3.1.6 ...
... regardless of the settings in the “Application Preferences / Library Browser / for Library Sources.
And QCAD doesn’t remember the last path choice ....

If I have to save 50 Library Items I have to navigate 50 times thru my system to find - the same place.

It would be nice if QCAD would point in first place to the Library Source or, at least, remember the last used path ... ;-)

 804 QCAD (main)Bug ReportLow "Color by Layer" uses wrong Layer for Blocks Closed
100%
Task Description

Not sure whether this is intentional, but IMHO it is not logical and wrong:

When loading a block that has a drawing set to “color by layer” into any layer but “0”, it will still always show the color of the “0” layer.

However, it should show the color of the layer that this Block is in (this is likely true for all the other attributes).

 1260 QCAD (main)Bug ReportLow "Break out segment" again arc is not a sharp cut to the ...Closed
100%
Task Description

Break out segment / Auto trim again arc is not a sharp cut to the arc (to long or to short),
Break out manual can’t snap to a line/arc intersection,

 863 QCAD (main)Bug ReportLow "Auto Zoom" is aligned also on invisible blocks ... Closed
100%
Task Description

If I switch a Block to invisible and use then the “Auto Zoom” in my drawing - the zoom cutout will appear like the block would still be visible :-(

Attachment:
1. “Auto Zoom” (Z, A) / Visible Block
2. “Auto Zoom” (Z, A) / Invisible Block

681QCAD (main)Feature RequestLow'Plug-in' for Gear generatorAssigned
0%
1 Task Description

Feature request for a ‘plug-in’ for generating different types of gears, like - Ring, Spur, Sprocket, Rack, etc... etc...
To produce 2D templates for all sorts of projects.

 1546 QCAD (main)Bug ReportLow 'Open file' dialog shows no files - although the direct ...Closed
100%
Task Description

I have many .dxf files created in QCad-2.2.2.0 (which I still use) all of which open in LibreCad without issues.

If I try to open a file in the version below (or an earlier fairly recent version) the file chooser dialog is empty.

Version: 3.16.5.0 (3.16.5)
Build Date: Feb 20 2017
Qt Version: 5.6.2
Architecture: x86_64
Compiler: gcc 5.4.0
OS: Mageia 6 x86_64 with plasma5 D.E

However if I copy a file name from the same directory using Dolphin file manager and paste it into the filename field in the chooser (which is showing no files) the file opens up correctly.

I reported this in Mageia bugzilla here against an earlier version but there was no response as I think the maintainer is MIA. https://bugs.mageia.org/show_bug.cgi?id=18816

Today I decided to try the latest version in the hope that this issue would be fixed (I am also a packager with Mageia) but it is still the same.

I will add the build log as an attachment in case you see something that may be specific to our configuration.

It would be good if we could resolve this before the imminent release of Mageia 6 ;)

Running from CLI I see these around the time I open the file chooser dialog:
——–snip——— 22:05:02: Debug: TransactionListenerPlugin::postInit
22:05:02: Debug: got transaction
22:05:16: Debug: Refilling KProtocolInfoFactory cache in the hope to find “file” 22:05:16: Debug: Refilling KProtocolInfoFactory cache in the hope to find “file” 22:05:16: Debug: Refilling KProtocolInfoFactory cache in the hope to find “file” 22:05:16: Debug: Refilling KProtocolInfoFactory cache in the hope to find “file” 22:05:16: Debug: Refilling KProtocolInfoFactory cache in the hope to find “file” 22:05:16: Debug: Refilling KProtocolInfoFactory cache in the hope to find “file” 22:05:16: Debug: Refilling KProtocolInfoFactory cache in the hope to find “file” 22:05:16: Debug: Refilling KProtocolInfoFactory cache in the hope to find “file” 22:05:19: Debug: got transaction
22:05:47: Debug: got transaction
22:06:08: Debug: Refilling KProtocolInfoFactory cache in the hope to find “file” 22:06:09: Debug: got transaction
———-snip——–

 745 QCAD (main)Bug ReportLow -always-load-scripts not working Closed
100%
Task Description

Command line switch -always-load-scripts has no effect.

 1378 QCAD (main)Bug ReportLow  Wrong value separator accepted and accomplished Closed
100%
Task Description

My settings for Coordinate Format: Decimal Point = Dot

Accidentally using a comma instead of a dot in a value field leads to a wrong result without any warning.

Test:

Using the “Rectangle with Size” tool accidentally with a comma will not trigger a warning (red text) and it will draw a wrong sized rectangle.
It seems to me that QCAD is using the after comma value to draw this rectangle.
Given value 30,5 by 50,7 leads to a rectangle 5 by 7
Crazy values like 1.,.35 by 71.,.75 are also accepted and leads to a rectangle size of 35 by 75 without any warning.
A crazy value like 71.,..75 will finally trigger a red text warning!

Counter test horiz. Line: Value 100,25 leads to a line with 25 in length.
Value 100.25 leads to a line with 100.25 in length.

Using the same tools with the correct separator will work as expected!

Same game with most of all other tools which are asking for a given value. No warning at all - just wrongly accomplished.

 522 QCAD (main)Bug ReportLow  View > toolbars is only accessible by right clicking. Closed
100%
Task Description

Andrew

In Windows 7-64, the view > toolbar options are only available by ‘right clicking’ in the main menu somewhere. They are not included in the view ‘drop down’ menu!

 869 QCAD (main)Feature RequestLow  Support for block attributes Closed
100%
Task Description

I would like to use QCAD at work.
Since the drawing using block attributes (ATTRIB) is not displayed correctly, I am troubled.
Please give me correspondence by all means.

1870QCAD (main)Feature RequestLow Stretch tool / option to turn selection restriction on...Assigned
0%
Task Description

Hi,

since 3.19.2 the Stretch tool looks for any selection and follows the specification “Only stretch selected entities if there is a selection”.

That is a nice feature but it leads many times to confusing because I have to deselect a selection just because I need to use the stretch tool on something else on the fly. The same if I “forgot” a selection outside of my zoom which is still important for me. The stretch tool just won’t work without any message why not. My routine now is that I terminate every selection just before I use the stretch tool just not to be surprised by “why isn’t it working”?

It would be nice to have in the Stretch option bar a checkbox to turn the “only selection feature” on or off. QCAD should remember that setting.

 1604 QCAD (main)Bug ReportLow  Exploding splines has equal results disregarding the s ...Closed
100%
Task Description

The explode function preference ‘Spline Segments’ has no influence on the created number of polyline segments any more.

Attached is a file with an example.
The same spline exploded with setting 2-4-8 & 128 segments.
Result for the indicated spline is 59 and constant.

 655 QCAD (main)Bug ReportLow  Changing Minimal grid spacing option (px) - proves no ...Closed
100%
Task Description

Changing the Minimal grid spacing (px) proves non effective, in that - it does not reduce the number of steps to to reach target view!

Tested and agreed on Win 7 -64

See Topics:

http://www.ribbonsoft.com/rsforum/viewtopic.php?f=31&p=6691#p6691

and related - http://www.ribbonsoft.com/rsforum/viewtopic.php?f=32&p=6694#p6694

 1819 QCAD (main)Feature RequestLow  Additional Options for "Paste along Entity" Closed
100%
Task Description

Please see:

http://www.qcad.org/rsforum/viewtopic.php?f=31&t=5929&p=22098#p22098

 395 QCAD (main)Bug ReportMedium wrong text origin when pasting scaled text and graphics Closed
100%
Task Description

Text origins are not properly scaled when pasting text and graphics at a scale other than 1:1

 251 QCAD (main)Bug ReportMedium wrong tab names Closed
100%
Task Description

After I open the second file, the tab name of the first file is changed to the name of second file. After that I see two tabs with the same names but with two different files.

 170 QCAD (main)Bug ReportMedium wrong scaling for ellipses / ellipse arcs Closed
100%
Task Description
  • see attachment
  • factor x/y: 0.5
  • green: original entities
  • red: properly scaled entities
 2113 QCAD (main)Bug ReportMedium wrong objects are selected while selecting region with  ...Closed
100%
1 Task Description

wrong objects are selected while selecting region with mouse.
Actions:Trying to select small rectangle area using mouse while holding left mouse button. (ScreenShot_1.png)
Expected result: only objects inside selection rectangle (text, lines, rectangles) are selected.
Factual result: objects inside selection rectangle are selected as well as other objects which are farther away (marked with purple arrows in ScreenShot_2.png)

 1608 QCAD (main)Bug ReportMedium Unsupported XData type NOT imported Closed
100%
Task Description

Unsupported XData type NOT imported errors on loading DWG files.
Resulting lines in image are not drawn correctly.
See details and sample file in forum post: https://www.qcad.org/rsforum/viewtopic.php?f=33&p=18223#p18223

 73 QCAD (main)Bug ReportMedium Uncaught exception: "cannot access member of deleted QO ...Closed
100%
Task Description

occurs sporadically, often when the application or a MDI child is closed, usually not reproducible.

  • 2011-05-11 15.19:32 unsaved drawing, after choosing “no” at the confirmation dialog
Uncaught exception at /home/martin/workspace/rsframework/scripts/Tools/PainterPathViewer/../../library.js:50:
Error: cannot access member `isNull' of deleted QObject
50	            (typeof(obj.isNull)=="function" && obj.isNull()===true));
 518 QCAD (main)Bug ReportMedium Unable to use Library browser properly in RC4 Closed
100%
Task Description

Hi Andrew

In Ubuntu 11.10 and Windows 7 everything so far is working ok in QCAD apart from the Library browser!

1.In Win 7-64 I can run the browser and make a new folder, but when I try to set the permissions/open the folder - browser crashes.

2.In ubuntu 11.10 I first uninstalled RC2 then installed RC4. QCAD program runs ok but this time when I try to open up the browser (not a new folder)I get an error message stating that I do not have permissions to open the first file (vehicle -I think!)in RC2? If I select OK in the warning window the warning just keeps on repeating the same message for the next and subsequent files until I quit it.

 970 QCAD (main)Bug ReportMedium Unable to save file with leading / trailing spaces in l ...Closed
100%
Task Description

Layer and block names with leading / trailing spaces lead to exception when saving file through Teigha.

 1750 QCAD (main)Bug ReportMedium trimming polylines Closed
100%
Task Description

Trimming polylines especialy those with a string of small segments should be done at the intersection of those polylines.
Now trimming is done with the seggments that where the nearest when selecting the two polylines.

 175 QCAD (main)Bug ReportMedium Trim.js: uncaught exception for ellipse / ellipse arcs Closed
100%
Task Description
  1. draw line as limiting entity
  2. draw ellipse and ellipse arc, both intersecting
  3. modify → trim
  4. select the diagonal line as limiting entity
  5. move around with the mouse over ellipse or ellipse arc → crash
Uncaught exception at scripts/Modify/Trim/Trim.js:267: TypeError: Result of expression
'trimmed1.trimStartPoint' [undefined] is not a function.
267	        trimmed1.trimStartPoint(is);
qsdb> .backtrace
#0  <anonymous>(op = RMixedOperation(0xc37b998), limitingEntity = RLineEntityPointer(0xc20c098),
limitingShape = RLine(RShape(address: "0xc217bd8"), startPoint: RVector(40, 36, 0) ,
endPoint:  RVector(-3, -3, 0) ) , limitingPos = RVector(2.81463, 1.47073, 0) ,
trimEntity = REllipseEntityPointer(0xc3775f8), trimPos = RVector(12.4488, 5.03537, 0) ,
trimBoth = false, preview = true) at scripts/Modify/Trim/Trim.js:267
#1  <anonymous>(preview = true) at scripts/Modify/Trim/Trim.js:167
#2  <anonymous>() at /home/martin/workspace/rsframework/scripts/Modify/../EAction.js:1150
#3  <anonymous>(event = REntityPickEvent(0xbfffd3c8), preview = true) at scripts/Modify/Trim/Trim.js:147
#4  <anonymous>(event = REntityPickEvent(0xbfffd3c8)) at /home/martin/workspace/rsframework/scripts/Modify/../EAction.js:1225
#5  <global>() at -1
 497 QCAD (main)Bug ReportMedium Trim: Tangent on circle: debugger appears Closed
100%
Task Description

having a line tangent on a circle, the Qt Debugger appears when:
- select trim tool
- select line
- mouse over circle

The debugger stops in line 326 of scripts/Modify/Trim/Trim.js (trimmed1.trimStartPoint(is2);) with the following message:
Uncaught exception at scripts/Modify/Trim/Trim.js:326: Error: :-1:-1: Wrong number/types of arguments for RArcEntity.trimStartPoint().
<native>(undefined) at -1
<anonymous>(op = RMixedOperation(0xe50a9a0), limitingEntity = RLineEntityPointer(0xff9b740), limitingShape = RLine(RShape(address: “0xe2a1608”), startPoint: RVector(36379.7, 46367.3, 0) , endPoint: RVector(40858.6, 44174.7, 0) ) , limitingPos = RVector(37446.8, 45886.1, 0) , trimEntity = RCircleEntityPointer(0xefa0170), trimPos = RVector(37054.5, 45938.9, 0) , trimBoth = false, preview = true) at scripts/Modify/Trim/Trim.js:326
<anonymous>(preview = true) at scripts/Modify/Trim/Trim.js:186
<anonymous>() at /opt/qcad-3.0.0-rc2-prof-linux/scripts/Modify/../EAction.js:1162
<anonymous>(event = REntityPickEvent(0xbfdc3614), preview = true) at scripts/Modify/Trim/Trim.js:166
<anonymous>(event = REntityPickEvent(0xbfdc3614)) at /opt/qcad-3.0.0-rc2-prof-linux/scripts/Modify/../EAction.js:1237
<global>() at -1
326 trimmed1.trimStartPoint(is2);
Uncaught exception at scripts/Modify/Trim/Trim.js:326: Error: :-1:-1: Wrong number/types of arguments for RArcEntity.trimStartPoint().
<native>(undefined) at -1
<anonymous>(op = RMixedOperation(0xec6fea8), limitingEntity = RLineEntityPointer(0×11830730), limitingShape = RLine(RShape(address: “0x10c1c988”), startPoint: RVector(36379.7, 46367.3, 0) , endPoint: RVector(40858.6, 44174.7, 0) ) , limitingPos = RVector(38065.4, 45591.8, 0) , trimEntity = RCircleEntityPointer(0xeee04a0), trimPos = RVector(37145, 45818.2, 0) , trimBoth = false, preview = true) at scripts/Modify/Trim/Trim.js:326
<anonymous>(preview = true) at scripts/Modify/Trim/Trim.js:186
<anonymous>() at /opt/qcad-3.0.0-rc2-prof-linux/scripts/Modify/../EAction.js:1162
<anonymous>(event = REntityPickEvent(0xbfdc3614), preview = true) at scripts/Modify/Trim/Trim.js:166
<anonymous>(event = REntityPickEvent(0xbfdc3614)) at /opt/qcad-3.0.0-rc2-prof-linux/scripts/Modify/../EAction.js:1237
<global>() at -1

 236 QCAD (main)Feature RequestMedium trial version: teaser dock showing a small web page Closed
100%
Task Description
  • small dock widget showing a web page (for teaser, special sales etc.)
 905 QCAD (main)Bug ReportMedium Text tool regression Closed
100%
Task Description

Happened somewhere between ab3e02 (works) and 67516a (doesn’t work).

In 67516a (current HEAD), when I attempt to launch the Text tool, the following is printed on stderr:

Warning:  Script Exception:
 "ReferenceError: Can't find variable: RTextBasedData" 
Warning:  "<anonymous>()@/tmp/qcad/scripts/Draw/Text/TextDialog/TextDialog.js:838"          

The Tool options toolbar does appear and it can be interacted with. The Text tool does not appear at all (and text input in the Toolbar can not be placed either).

In ab3e02, the Text tool works as usual.

Hope I got it right this time – several clean builds have been made to double-check results.

 1353 QCAD (main)Bug ReportMedium Text rendering: subscripts and superscripts display Closed
100%
Task Description

Text with subscripts (e.g. “S\S^3;”) is display incorrectly with the latest version on both Mac OS X and windows 64-bit.

The subscript (”3”) is displayed before the normal text (”S”).

I have been using subscripts to indicate electrical switch types on my blue prints.

It appears that superscripts are also being displayed incorrectly.

 385 QCAD (main)Bug ReportMedium Text position of texts in blocks Closed
100%
Task Description

Text position of texts in blocks wrong.

 1118 QCAD (main)Bug ReportMedium Text not saved Closed
100%
1 Task Description

Hello,

I am stage manager and I have been using QCAD PRO nearly every day for 2 years now.
But since yesterday it seems that text is not saved within the file : when I reopen a saved file, text doesn’t show up. Do I miss a setting ?
I currently run Mac OS X Mavericks but there haven’t been any issues with this OS for months.

I deleted the app and prefs and tried out with 3.6.0 (which I don’t use because it often quits brutally), and also the free version of 3.6.4
But the issue still the same.

As I use this app for my work, it is very annoying not to be able to use text !
Thanks for your help

 8 QCAD (main)Bug ReportMedium Text Dialog: custom text height broken Closed
100%
Task Description

Custom text height cannot be set (enter closes the dialog, tab does not activate the entered text height)

 2166 QCAD (main)SuggestionMedium Text box creates wrong line break - Textbox erzeugt fal ...Closed
100%
Task Description

Englisch:
A text that ends with a line break is displayed incorrectly.

I think the \P should be passed to the program to create the line break. Unfortunately it is taken over directly into the text.

See attachment


Deutsch:
Textbox erzeugt falschen Umbruch

Ein Text der mit einen Zeilenumbruch endet, wird falsch dargestellt.

Ich denke mal das \P sollte an das Programm weitergegeben werden um den Zeilenumbruch zu erzeugen. Leider wird es direkt in den Text mit ├╝bernommen.

Siehe Anhang

 334 QCAD (main)Bug ReportMedium SVG Export Polygons, arcs converted to straight lines. Closed
100%
Task Description

When exporting a drawing to SVG, polygons containing arcs (trimmed circles in this case) are converted to straight lines. If the polygon is exploded first, then it exports correctly. Of course, this isn’t useful if closed polygons are required for the program using the SVG file. Solid hatch fills export correctly. See attached DXF and corresponding SVG export.

693QCAD (main)Feature RequestMediumSupport for external references (XREF)Likely to be implemented
0%
26 Task Description

Support for external references (XREF)

Showing tasks 2001 - 2050 of 2283 Page 41 of 46<<First - 39 - 40 - 41 - 42 - 43 - Last >>

Available keyboard shortcuts

Tasklist

Task Details

Task Editing