QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategoryTask TypeSeverity  descSummaryStatusProgress
 1348 QCAD (main)Bug ReportMedium Points move during print/PDF-export Closed
Task Description

Points move by a constant offset relative to the rest of the drawing when printing or exporting to PDF.

This is the exact same bug as  FS#1243 , which was reportedly fixed in version 3.9.7 with commit https://github.com/qcad/qcad/commit/9c9d7bbc3fd845b8475ff12a919ad8e86bbaeb1f, but has resurfaced in version 3.12.4 (and possibly earlier versions that I have not tested).

To replicate the bug, create a simple drawing with points and lines then print or export to PDF, and notice that the points have moved relative to the lines or have disappeared off of the page entirely.

Tested with Arch Linux, 64 bit; QCAD version 3.12.4 using the prebuilt binaries supplied from the qcad.org download site.

 1347 QCAD (main)Bug ReportMedium Point style bug. Closed
Task Description

Hi !
i have find another strangeware about points.. if you set a different point style in program options, on the display the style is correct, but when you try to print or export the drawing, the points are printed as default “point” (little black circle).

 1294 dxflibBug ReportMedium Hatches scale differently now from earlier releases Closed
Task Description

Something with hatching changed between 3.10 and 3.12; Changelog for 3.11.2 states: “Add support for hatch patterns defined per entity”. That may be?

Attached drawing from an older version; open in current and see a black box where there should be earth. Change scaling of hatch from 10 to 254 and it will be exactly the same it was when saving the file.

Curiously, that is like swapping inches and mm? Looking into prefs, there is a new drop down: “Messsytem für Linien und Schraffuren” and it read “imperial”; making it metric and bingo, my drawing looks as intended!

This is bad, because each drawing has to be changed! I changed the application default drawing setting to metric and the existing drawing still had imperial set…

Probably a heuristic was on order? If the drawing does not specify the new setting, and the drawing units is metric, use metric?

 1293 QCAD/CAMBug ReportMedium Crash when snapping to intersection points between 3d l ...Closed
Task Description

I have a file that makes QCAD crash. I’ve been editing this design across different versions of QCAD over time and this is the first time I have a problem with it.

Steps to reproduce:
Open the attached file and try to add some entities or dimensions to it (you may need to create large ones since it seems to depend on the zoom factor; for example a very large ellipse). After a freeze of a few seconds QCAD will quit.

The attached file is a simplified version from which I deleted a number of entities; on the original I can’t do anything – QCAD crashes as soon as I try to create any object.

Cause: 3D lines with x1==x2, y1==y2 but z1!=z2

 1268 QCAD (main)Bug ReportMedium DXF/DWG import: cannot open file with custom linetypes Closed
Task Description

If custom complex linetypes embedded in a file refer to a font that is not available for linetype shapes, the file cannot be opened.

Can not open file Please check your access rights, file format and file extensions


 1243 QCAD (main)Bug ReportMedium Printing / PDF Export: points offset Closed
Task Description

Hi !
im’ trying the 3.9.6 base version, and i have found a problem in printing/exporting..

To replicate the bug:
Try to draw a simple form, for ex a circle, and draw a center of this circle using POINT function.

Now if you make a print preview, then CENTER the circle in the page and try to export to pdf or print, the circle and the POINT (center) are ofsetted !!

i have try to make the same operation with 3.9.5 and i have no problem !!!

 1241 QCAD (main)Bug ReportMedium Options tool bar fields not editable, no interaction wi ...Closed
Task Description

Likely affects Windows Vista, 7, 8.

http://www.qcad.org/rsforum/viewtopic.php?f=33&t=3588 http://www.qcad.org/rsforum/viewtopic.php?f=33&t=3587

Caused by update from Qt 4.7.4 to Qt 4.8.7

 1237 QCAD/CAMBug ReportMedium Blocks should be layer agnostic Closed
Task Description

I have created a block from a selection. I have then later created more items on my CAD page using that block, then later yet, moved the objects to a new layer. I noticed that while the object has accepted being on the new layer, the color hasn’t changed to the new layer’s color. I can only get the line color to change if I go into the block itself and move the individual segments of the block to that new layer, then save the new block (which, by the way, I can’t save over the existing block?!?!)

In the sample file attached, you will see that the block item in the 3 o’clock position is in layer 0, while the rest are in “Vent Holes” layer. If you make layer 0 hidden, the one block is hidden (like it should), but the block item refuses to take on the layer’s color even though the block’s color is “By Layer”

 1216 QCAD (main)Bug ReportMedium DXF/DWG writing: block name mixup with anonymous blocks Closed
Task Description

Anonymous blocks (with names starting with *, imported from other software) can be mixed up on writing.

 1181 QCAD (main)Bug ReportMedium Paper borders displayed wrong on paper unit being chang ...Closed
Task Description

When paper unit being change to other values (other than default “Milimeter” or “None”), the paper borders are wrongly displayed in print preview.
The attachment screenshot images is for example.
1, Edit →Drawing Preferences →Drawing Unit →Pager Unit, choose the value “Centimeter”.
2, Edit →Drawing Preferences →Page →Pager →Paper size, choose the value “ISO A4”.
3, File →Print Preview, the displayed print borders are wrongly displayed as a very narrow rectangle, which is obviously wrong.
Thanks for any help.

 1167 QCAD (main)Bug ReportMedium Aligned dimensions not displayed Closed
Task Description

Aligned dimensions are not displayed correctly after loading. Definition point and text position are set to NaN.

 1164 QCAD (main)Feature RequestMedium make selected layer default parent for new layer Closed
1 Task Description


I would like to suggest a small, but yet important improvement to usabilty.

When adding a new layer the currently selected layer should be default for parent layer.

Currently a new layer is by default a top level layer, and so the user has to select the parent layer for each sub-layer, again and again.


 1163 ECMAScriptBug ReportMedium DoveTail-script crashes QCAD Closed
Task Description


I just installed QCAD v3.7.5 and it works like a charm.

Then I installed the DoveTail-script (http://www.qcad.org/rsforum/download/file.php?id=623) and after that QCAD won’t start anymore.

This is the output on the command line in Linux:

Debug: RDwgPlugin::init
Debug: RDxfPlugin::init
Debug: RHelpPlugin::init
Debug: RProScriptsPlugin::init
Debug: loading patterns from file: “/opt/qcad-3.7.5-pro-linux-x86_64/linetypes/metric/qcadiso.lin”
Debug: shape found: “ZIG”
Debug: shape found: “BAT”
Debug: shape found: “TRACK1”
Debug: shape found: “BOX”
Debug: shape found: “CIRC1”
Debug: shape found: “RIGHT_ARROW”
Debug: loading patterns from file: “/opt/qcad-3.7.5-pro-linux-x86_64/linetypes/imperial/qcad.lin”
Debug: TIMER: 67 ms - “loading add-ons”
Warning: RScriptHandlerEcma::eval: script engine exception: “TypeError: Result of expression ‘action.addToWidget’ [undefined] is not a function.”
Warning: “<anonymous>()@/opt/qcad-3.7.5-pro-linux-x86_64/scripts/File/../EAction.js:1180”
Warning: At least one uncaught exception:
Warning: “<anonymous>()@/opt/qcad-3.7.5-pro-linux-x86_64/scripts/File/../EAction.js:1180”
Debug: “<global>() at -1”

Don’t know whether that is a bug in the script or in QCAD, so I am reporting it here.


 1123 QCAD (main)Performance IssueMedium Hatch in block causes performance problem Closed
Task Description

Hatches in blocks cause poor performance while (auto-)snapping.
The lines that make up those hatches are included in the search for intersection points which is not desirable.

 1121 QCAD (main)Bug ReportMedium Draw > Polyline > Append Node(s) broken Closed
Task Description

Selecting the polyline is not possible.
Possibly related to update of DrawPolyline tool.

 1118 QCAD (main)Bug ReportMedium Text not saved Closed
1 Task Description


I am stage manager and I have been using QCAD PRO nearly every day for 2 years now.
But since yesterday it seems that text is not saved within the file : when I reopen a saved file, text doesn’t show up. Do I miss a setting ?
I currently run Mac OS X Mavericks but there haven’t been any issues with this OS for months.

I deleted the app and prefs and tried out with 3.6.0 (which I don’t use because it often quits brutally), and also the free version of 3.6.4
But the issue still the same.

As I use this app for my work, it is very annoying not to be able to use text !
Thanks for your help

 1047 QCAD (main)Bug ReportMedium Preview does not use drawing settings Closed
Task Description

See forum thread:

 1032 QCAD (main)Bug ReportMedium Copy / paste: pasting copied block references results i ...Closed
1 Task Description

- Copy two block references of block “circle” which contains one circle
- Paste into new, empty drawing
- Pasted block “circle” contains two circles

 1018 QCAD (main)Bug ReportMedium Crash when using Draw > Polyline > Trim Segments Closed
Task Description

Draw > Polyline > Trim Segments crashes if QCAD is compiled using gcc 4.2.1 which is the case for the Mac OS X package.

 1017 QCAD (main)Bug ReportMedium crash when saving file with block attributes Closed
Task Description


QCAD crashes when saving a drawing that has a block attribute added.
This happens both with a block and the exploded version of the block.

Please find attached the system info, as well as an example drawing.
In this drawing, there are three boxes. The lower 2 boxes are intended to contain text attributes.

Output from the command line:
metastable@metastable:~/opt/qcad-3.4.5-pro-linux-x86_32$ ./qcad
Debug: RDxfPlugin::init
Debug: RHelpPlugin::init
Debug: RProScriptsPlugin::init
Debug: TIMER: 90 ms - “loading add-ons”
Debug: TIMER: 781 ms - “initializing add-ons”
Debug: checking for updates...
Warning: QSslSocket: cannot resolve SSLv2_client_method
Warning: QSslSocket: cannot resolve SSLv2_server_method
Debug: no updates available
Debug: checking for updates...
Debug: no updates available
Debug: RPluginBase: postInit: “DWG”
Debug: RPluginBase: postInit: “Pro Tools”
Debug: code page: 30
Debug: autosave skipped [08:54:14]: no modifications
./qcad: line 18: 3850 Segmentation fault (core dumped) LD_LIBRARY_PATH=”$DIR” “$binary” -style plastique “$@”

Kind regards,


 993 QCAD (main)Bug ReportMedium QCAD fails to load drawing with message: maximum recurs ...Closed
Task Description

Since today, QCAD fails to load my drawings, with the following error message in the console:

Warning: RBlockReferenceData::getBoundingBox: maximum recursion depth reached: block: “Drukknop”

The block in question is the AREI (Belgian standard for symbols in electrical installations) symbol for a “button” light switch.
It’s a small and simple drawing (see attachment).

I’ve added a lot of these buttons in the drawing since the previous version, but there were some already present, and this never caused problems.

QCAD version: QCAD 3.4.4 Pro for Ubuntu Linux 32bit
System output: see attached file

 973 QCAD (main)Bug ReportMedium Drawing outside zoom limit Closed
Task Description

When a drawing is placed in X,Y coordinates QCAD is unable to zoom to the drawing.

We use X,Y coordinates like X=182,635,000 mm Y=579,005,000 mm for the location of the constructions.

If you use Auto Zoom you get to see a small dot on the screen but as soon as you try to zoom to the drawing QCAD jumps within a certain limit and you can’t get to the drawing.

 970 QCAD (main)Bug ReportMedium Unable to save file with leading / trailing spaces in l ...Closed
Task Description

Layer and block names with leading / trailing spaces lead to exception when saving file through Teigha.

 966 QCAD (main)Bug ReportMedium Print Dialog Print>Properties>Advanced is blank Closed
Task Description

Just started using v.3.4.2 under Linux Mint 14. To begin with I could not print my drawing in color. Worked out that this was due to the default printer setting (driver hpcups 3.12.6) which was Draft Grayscale. My drawing printed in color fine when I changed this. I believe that it ought to be possible to set this from within QCAD, but the dialog “Print>[printer]Properties>Advanced” is blank. Has it been disconnected somehow?

 954 QCAD (main)Bug ReportMedium Coordinates entered are interpreted as direct distance  ...Closed
Task Description

Entering a coordinate (e.g. 20,20) results in direct distance entry instead (angle from relative zero to mouse pointer, length 20).

 953 QCAD (main)Bug ReportMedium Crash while rendering dashed lines with zero length Closed
Task Description

Line pattern factor for zero weight lines defaults to 0 which can lead to division by zero.

 943 QCAD (main)Bug ReportMedium Dashed lines with line weight 0 are displayed as contin ...Closed
Task Description

When we create a draft in version 2.2.2 we put dashed lines and the length is 0. We see a dash lines. (see attach file).

When we open the same draft in the version 3.3.2 we don’t see the dashed lines we see a continous lines.

If I changed in the dxf this lines DASHED 370 0 per DASHED 370 5 and changes the preference of the drawing it’s work.

But we don’t want to open all of 180000 drawings to change the length of the dashed lines from 0 to 5. We want that the version 3 print the dashed lines as the version 2.



 917 QCAD (main)Bug ReportMedium Integrated help not working Closed
Task Description

Help - Reference Manual does not have any effect on Windows.

 905 QCAD (main)Bug ReportMedium Text tool regression Closed
Task Description

Happened somewhere between ab3e02 (works) and 67516a (doesn’t work).

In 67516a (current HEAD), when I attempt to launch the Text tool, the following is printed on stderr:

Warning:  Script Exception:
 "ReferenceError: Can't find variable: RTextBasedData" 
Warning:  "<anonymous>()@/tmp/qcad/scripts/Draw/Text/TextDialog/TextDialog.js:838"          

The Tool options toolbar does appear and it can be interacted with. The Text tool does not appear at all (and text input in the Toolbar can not be placed either).

In ab3e02, the Text tool works as usual.

Hope I got it right this time – several clean builds have been made to double-check results.

 875 QCAD (main)Bug ReportMedium malloc.h is deprecated Closed
Task Description

This concerns the third-party openNURBS project and should probably be reported there, but I failed to find a bug tracker or anything of the sort, so here it goes.

malloc.h is deprecated (it has not been required since at least SUSv2, ratified in 1997). Apparently FreeBSD takes a more explicit stance against the use of it than other systems. The attached patch does away with it in openNURBS (conservatively leaving it in on Linux, but that should not really be neccessary either).

This makes the openNURBS component buildable on FreeBSD (9).

 872 QCAD (main)Bug ReportMedium Crash in dwg2svg Closed
Task Description

Conversion of certain files leads to crashes (segmentation fault).


 847 QCAD (main)Bug ReportMedium Info - Distance PP, EP: ruler ticks too dense Closed
Task Description

Info tools show too many ticks which leads to slow down / crash.

 831 QCAD (main)Bug ReportMedium Multiple words of non-english language in Richtext are  ...Closed
1 Task Description

Version - 3.1, binary.

If I “Draw text” with text “aaaa bbbb” - it displays correctly, but when I enter “аааа бббб” (with russian keyboard) - I see that “аааа” and “бббб” are displayed one above other - see screenshot.

The same problem is for imported .dxf file with russian texts in it. Problem makes the solution as a whole actually inusable for (at least, some of) russian users.

 739 QCAD (main)Bug ReportMedium QCAD fails to open a DXF file generated by itself Closed
Task Description

QCAD does not manage to load an DXF file created by itself (presumably, I don’t remember excactly, could be the last 2.x version). When selecting File ⇒ Open on the file in attachment, QCAD shows a pop-up reporting the following error :

Cannot open file
»‘/home/gillonr/Documents/Projects/Familly/Br.../Chambre Parents/Plans/Plan-PaterNoster.dxf’.
» Please check your access rights, the file format and file extension.

The file permissions are OK, there is no issue of disk space on the volume where the file reside or where the QCAD distribution is installed or at any other critical location. The problem does not happen on other files created with QCAD, so it appears to be data dependent.

The file causing trouble in QCAD can be imported in LibreOffice 3.4.2 w/o reporting errors (but that application does not provide the suitable methods / tools to edit this format...).

(1) Is there a way to activate debugging when reading in data from a DXF ?
(2) Is there some tool (ev. 3rd party) allowing to check that the data is clean ?
(3) Can someone identify the cause of the problem (presumably some data construct or maybe corruption) ?
(4) In case it would turn out that the problem is a QCAD bug, is there a work-around (I need these drawings...).

 727 QCAD (main)Bug ReportMedium 100% CPU Usage with 3.0 Final Version. Closed
Task Description

I am continuing my testing on version 3.0 Final.

I noticed that, with 3.0 Final open, the service “syslogd” (on OSX Leopard PPC) does get CPU consumption up to 100%, making the machine unusable.

This has never happened with the RC2 version.

It’s possible to have a copy of RC2 while they investigated the problem? Unfortunately I have not kept a copy.

 725 QCAD (main)Bug ReportMedium Inserting items from part library may create invalid bl ...Closed
Task Description

To reproduce:
- Create a part library item with file name “Test1 .dxf” (note the space at the end of the base name)
- Insert this part library item into a blank drawing
- Try to save the drawing
- Error “Invalid Symbol Table Name” occurs

 707 QCAD (main)Bug ReportMedium segmentation fault on every start - after crash Closed
Task Description

I was drawing on a drawing done in qcad2 - and now working on it in qcad3 - where I had saved it in the new dxf 2010 format (if this has any relevance) and then the computer ran out of power (old battery - I missed that I hadn’t turned on external power) - and shut down hard.

When I rebooted and tried to start qcad - it crashed on startup - giving only this output:
Debug: TIMER: 42 ms - “loading plugins”
Debug: TIMER: 459 ms - “initializing plugins”
./qcad/qcad: line 38: 2955 Segmentation fault (core dumped) LD_LIBRARY_PATH=”$DIR” “$binary” $OPT1 $OPT2 “$@”

I then tried removing the entire qcad-3.0.0-prof-linux-alt-x86 folder - and unpackaging the install tar.gz again.

It then started up and came to initializing plugins - 79% - and just hung - I’ve attached screenshot.

After I ctrl+c’ed it - it segfaulted and now it won’t even show the startup splash again.

I’m guessing qcad has saved some state somewhere.. but qcad hasn’t made a ~klavs/.qcad - so I don’t know where it is.

I would very much like to be able to use qcad again :(

 706 QCAD (main)Bug ReportMedium Part Library not displaying parts Closed
Task Description

When I open the part library, it displays a dialog saying “Updating Index”, after it finishes, none are displayed, and the filesystem bar at the top is empty, clicking on it does nothing.

693QCAD (main)Feature RequestMediumSupport for external references (XREF)Likely to be implemented
14 Task Description

Support for external references (XREF)

 688 QCAD (main)Bug ReportMedium QCAD3: Deadlock happens during text operation when one  ...Closed
Task Description

I just use QCAD3 for the first time. I work with OpenSuse 12.2.
After having unpacked the downloaded package, I am able to start QCAD3 with the QCAD command icon.
Check shows that i used the most actual version.
Obviously no further installation steps are necessary.
I am able to draw some lines, etc.
However, when trying to select a font, I recognized that the computer hangs at least for 5 minutes.
The CPU load is about 50%, and i am not able to move the mouse and to do anything else.
During this time, sometimes there is access to disk, sometimes not.
So, in order lo cancel the hanging, i must make a hard system reboot.
Before i have entered the font selection, i have tried to look into the help options.
However, It was not possible to get the FAQs and the QCAD forum, so i am not aware about similar documented problems.
I have looked after similar bugs, using the words ‘text, font’. No similar bugs found.

 653 QCAD (main)Bug ReportMedium crash on some file operations may be Qt related Closed
Task Description

On file open selection from main menu or on output to PDF Qcad crashes


I/O error : No such file or directory
/usr/share/mime/inode/directory.xml:1: parser error : Extra content at the end of the document

 635 QCAD (main)Bug ReportMedium hatch fills wrong area, saving results in "Exception oc ...Closed
Task Description

Attached you’ll find a floor plan.

Trying to fill the walls (layer “KG_Wand”), the hatch does not fill them but the space inside the rooms.
Saving the file (with the wrong hatch) leads to

Exception occurred. Entity NOT saved: 148

in the Command Window, after re-opening the file the hatch is (as expected) not existing anymore.

 608 QCAD (main)Bug ReportMedium Page orientation can not be changed while page preview  ...Closed
Task Description

When in print-preview mode, the page orientation (portrate or landscape) can be changed using its document-preference dialog box, but it does not take effect.

 580 QCAD (main)Bug ReportMedium Black color reverted to white color on each close Closed
Task Description


When I started Q3, I selected a White background in the initial dialog window. I opened a copy of a good Q2 file and saw that ALL entities with Q2 Black/White color where forced to be White. Andrew explains this as a mean to avoid unreadable items against the background colors. Remember I selected White as background ? I guess Black/White entities could be better kept as Black ?

Following Andrew’s advice, in Application Preferences =⇒ Graphics View, I unchecked the Auto correct black and white colors check box. The background settings is white. OK.

I went through a process of changing the White color for several layers to Black. I also had to change the color codes for the hatch areas. For instance, the hatch area layer “055_F_Murs” has “14-76-255 / 255-197-179” values in Q2. Why these values are auto corrected to “30-128-255 / 255-191-127” ?

After these changes, I saved the file, closed Q3 and opened the file again.

Catastrophique ! All “Black/White” layers were back to Black and the hatch colors were back to the “auto corrected” values.

Changing the background color to black then white seemed to solve the problem : the layers kept the Black color. Actually it was just an illusion.

Yesterday too much confident, I spent the whole day, modifying layers to Black, adding new layers also Black or custom color, checking the line weight (replacing the “default” (?) value of 0.25 mm with my preferred default value of 0,00 mm, I’ve posted on the forum about this) and so on. I saved the file, closed it.
To-day, nearly all layers have lost their colors :
- Black ones are again White,
- custom color are “auto corrected” as above for “055_F_Murs”,
- only the standard non Black/White colors are preserved, like Blue, Magenta etc.

At this point, I can’t continue using QCAD 3 with enough reliability as my color settings are always lost. This is why I qualify this bug as CRITICAL.
I don’t want to use a Black background or a Light Blue one. Why do you think all old “green on black VDU” were replaced with “black/color on white” displays, to begin by Apple ?

NB I already reported this but can’t find it in the list (maybe because I forgot to enter a summary ? No warning, happily I had a copy with Notepad), sorry for the duplicate.

 563 QCAD (main)Bug ReportMedium Hatches and colors transformed in Q3 Closed
Task Description

To check compatibility for the same .dxf drawing prepared with Q2, I prepared 2 copies, one with a “_Q2” suffix and the other with “_Q3”. I managed to keep an operational Q2 system on the same Win7-HomeEditionPremium-64bits PC. As you can guess, I opened each copy with the relevant QCAD version.

In each version, I selected the same hatch layer and list here their properties along with a hardcopy of a display of a similar part of the hatched area, with blue lines showing the differences in hatching, apparently the density.
Q2 : Solid:False, Scale:3.00, Angle:0, Name:ar-brelm ; the color is described in its panel as 20,255,255 and 255,85,0 (left colum first from top to bottom).
Q3 : all identical values but Scale:0.78189.

Another comparison with a global view of the same drawing. Just notice how the hatching in the areas at the bottom are different (red lines). Also, I noticed that increasing the zoom let the hatching appear in the Q3 version instaed of the grey homogenous color, but the hatching in Q3 remains more dense than in the Q2 version.
Q2 : Solid:False, Scale:1.00, Angle:0, Name:ar-conc : color is a standard grey (0,0,128 & 128,128,128)
Q3 : Solid:False, Scale:0.246063, Angle:0, Name:AR-CONC : color is qualified as “custom” even with the same values.
Both have “centimeter” as drawing units.

Then I opened another Q2 drawing with Q3. I elected to hide all layers then to show all of them. And the color hatching of some aras were then modified. See 3rd picture with all black areas. (Just changing the layers shown or hidden was enough to not allow to close the drawing without a save...).

Than you for your attention or letting me know which setting can correct the differences.

 552 QCAD (main)Feature RequestMedium autosave removing last auto saved file Closed
Task Description

I would like to see an autosave-option which allows to autosave, but which keeps only the latest autosave file (instead of all). So there would be autosave (if something crashes) but the hard disk is not filled up too fast.

 531 QCAD (main)Bug ReportMedium Qcad stops working after selecting and moving an entity ...Closed
Task Description

I am a new user and bought qcad this afternoon.
Sometimes qcad stops working after selecting and moving an entity. it happens almost every one to two hours. twice until now.
I tried version that didn’t have this problem.

 530 QCAD (main)Bug ReportMedium sporadic unwanted close of QCad Closed
Task Description

Using the move and scale tools, QCad sometimes (reason unknown so far) crashes in RC4 (never seen that in RC2).

 520 QCAD (main)Bug ReportMedium move entity from command line is broken on ubuntu 64 bi ...Closed
Task Description

when I try to move an entity via the command line using the mv command the entity does not move to the specified position. it works if i use the mouse. this was fine in rc2 and rc3 ubuntu 64 bit and windows 64 bit machines.

 518 QCAD (main)Bug ReportMedium Unable to use Library browser properly in RC4 Closed
Task Description

Hi Andrew

In Ubuntu 11.10 and Windows 7 everything so far is working ok in QCAD apart from the Library browser!

1.In Win 7-64 I can run the browser and make a new folder, but when I try to set the permissions/open the folder - browser crashes.

2.In ubuntu 11.10 I first uninstalled RC2 then installed RC4. QCAD program runs ok but this time when I try to open up the browser (not a new folder)I get an error message stating that I do not have permissions to open the first file (vehicle -I think!)in RC2? If I select OK in the warning window the warning just keeps on repeating the same message for the next and subsequent files until I quit it.

Showing tasks 101 - 150 of 1863 Page 3 of 38 - 1 - 2 - 3 - 4 - 5 - Last >>

Available keyboard shortcuts


Task Details

Task Editing