QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategoryTask TypeSeverity  descSummaryStatusProgress
 360 QCAD (main)Performance IssueLow Application Preferences - Shortcuts (slow) Closed
100%
Task Description

In the “Application Preferences”-menu a click on submenu “Shortcuts and Commands” freeze the application for a view minutes.

 359 QCAD (main)Feature RequestLow Bigger lineweights Closed
100%
Task Description

Currently lineweights seem to be available up to 2.11mm,how about extending the range for some bigger lineweights!

Regards

Clive

 358 ECMAScriptFeature RequestLow lfVVCSSMBo Closed
100%
Task Description

Good point. I hadn’t thgouht about it quite that way. :)

 357 ECMAScriptBug ReportLow include should raise exception if file not found Closed
100%
Task Description

include() should raise exception if file not found.

This is actually the case but does not seem to work properly.

355QCAD (main)Feature RequestLowRemember function for dimension OptionAssigned
0%
Task Description

I think it would be nice to have more flexibility for Prefix etc. option (not only the drop down with a given choice) and a remember function for all those fields like postfix and tolerance.

Why Remember Function:
If I use a postfix like <>” in the postfix field I’m only able to use it for this particular dimension type at this time. If I change the type (from Horizontal to vertical or what ever) I have always to repeat my postfix. The same with tolerances.

 354 QCAD (main)Bug ReportLow Property Editor / Select Layer Malfunction Closed
100%
Task Description

RC1b
To change the postfix for dimension.
Situation: New drawing, Dimension in Drawing, Dimension on one Layer. Menu > Select > Select Layer and click on a dimension. Went to Property Editor > Geometry > Label and change the Label in <>”. Nothing happens.

The same procedure with a other kind of selection works and it works also in the 2.2.2.0

 353 QCAD (main)Bug ReportLow Relative Angle / Line Orthogonal caused malfunction in  ...Closed
100%
Task Description

After using Line “Relative Angle” or “Line Orthogonal” the Toolbar is in a loop without showing all the Cad tools such as “Modify” “Hatch” etc..
Escape switch only between the “Lines Menu” and the “Select Menu”. To get all Cad Tools back you have to restart QCad.

 352 QCAD (main)Bug ReportLow Info Tool, Polygonal Area shows decimal units instead o ...Closed
100%
Task Description

Drawing preferences / dimension = Fraction

Info Tool, Polygonal Area shows decimal units instead of fractions.

 351 QCAD (main)Bug ReportLow Simple text: position, simple text flag Closed
100%
Task Description

Simple text tool does not create simple text but mtext.
When changed to simple in property editor, position does not work

 350 QCAD (main)Bug ReportLow Strech function of version 3.0.0 Beta does not work (ha ...Closed
100%
Task Description

The stretch function does not work at all. I tried it in the old version 2.2.2 where it worked.

 348 QCAD (main)Feature RequestLow Dimensions: Inch / Architectural: supporess 0 feet Closed
100%
Task Description

Dimensions: Inch / Architectural: supporess 0 feet

 347 QCAD (main)TaskLow Investigate QPainter warnings when running QCAD in -no- ...Closed
100%
Task Description

Invastiagte QPainter warnings when running QCAD in -no-gui mode

See forum:
http://www.ribbonsoft.com/rsforum/viewtopic.php?t=1653&start=45

 346 QCAD (main)Feature RequestLow Set up fixed grid Closed
100%
Task Description

Set up fixed grid without any auto scaling or adjusting or meta grid at all.

 345 QCAD (main)Bug ReportLow unit foot: no dotted line Closed
100%
Task Description

can’t make a dotted line on a drawing with unit foot.

  • drawing unit: foot (length taken from a actual architecture plan)
  • layer settings: as shown in the screen shot
  • selected line is on layer “dotted”
  • line types is shown as continues for almost everything
 336 QCAD (main)Bug ReportLow Tool bars with tools without icon Closed
100%
Task Description

Some tool bars (e.g. ‘Block’ tool bar) contain tools without an icon (empty button).
Not all tools are available in tool bars.

 335 QCAD (main)Feature RequestLow Drawing preferences: Change font of dimensions Closed
100%
7 Task Description

Configure font used for dimensions.

 333 QCAD (main)Bug ReportLow Add layer: new layer should be active one Closed
100%
Task Description

Add layer: new layer should be active one

 332 QCAD (main)Feature RequestLow Modify - divide should remain active after one use Closed
100%
Task Description

1. When selecting the Scissors function, it deactivates after the cut is done. One can therefore not continuously select lines and cut it at the selected point. Each time the function has to be activated from the start.

 331 QCAD (main)Bug ReportLow Snap buttons doubled Closed
100%
Task Description

1. For some reason on the Window machine, the snap toolbar buttons are doubled for all functions. I therefore have two buttons for each type of snap and cannot access the bottom snaps unless I undoc the toolbar.

For some reason, this is still fine in the Linux Beta 3. Single buttons like always.

Reported by: koosjr

 330 QCAD (main)Bug ReportLow Text Edit command replaces \U+00B0 with %%[dD] Closed
100%
Task Description

when editing text which contains the degree symbol the proper escape sequence is \U+00B0
Qcad 3Beta3 replaces \U+00B0 with %%[dD]

 329 QCAD (main)Feature RequestLow PDF Export: from file menu Closed
100%
Task Description

PDF Export: from file menu

 328 QCAD (main)Bug ReportLow Persistent selections Closed
100%
Task Description

Preference for persistent selections

 327 QCAD (main)Feature RequestLow Text tool: options tool bar Closed
100%
Task Description

Text tool: options tool bar with text, angle, text height.

 326 QCAD (main)Feature RequestLow Print preview: auto center / scale Closed
100%
Task Description

Print preview: auto center / scale

 325 QCAD (main)Bug ReportLow Layer renaming: changing name from lower case to upper  ...Closed
100%
Task Description

Layer renaming: changing name from lower case to upper case

 324 ECMAScriptFeature RequestLow SVG export depends on GUI Closed
100%
Task Description

SvgExporter.js uses PrintPreview to parse the scale string, and therefore depends on the qt GUI part. That should not make maintenance harder to call RMath directly there? Results seem to match from a first look.

--- SvgExporter.js~	2011-10-20 14:11:45.527589416 +0200
+++ SvgExporter.js	2011-10-20 14:12:46.277502814 +0200
@@ -1,6 +1,5 @@
 include("scripts/library.js");
 include("scripts/date.js");
-include("scripts/File/PrintPreview/Print.js");
 
 /**
  * File exporter implementation for the SVG format.
@@ -116,7 +115,7 @@
     this.svgUnitAbbr = ret[1];
 
     // scale
-    this.scale = Print.parseScale(this.scaleStr);
+    this.scale = RMath.parseScale(this.scaleStr);
 
     var bb = this.doc.getBoundingBox();
     var size = bb.getSize();
 323 ECMAScriptFeature RequestLow Exceptions in headless scripts Closed
100%
Task Description

The capability of running headless, ie. without GUI, is a very welcome addition to QCAD. I suggest one more improvement:

When an exception occurs in a script (running from autostart) and no-gui was opted for on the command line, QCAD should not try to bring up the debugger ever (regardless of any preferences), but print the message of the exception and possibly a backtrace instead.

Otherwise all errors will produce the same messageā€¦

 322 QCAD (main)Bug ReportLow Line type scaling with print scale factor Closed
100%
Task Description

In QCAD 2, line type patterns are scaled according to the print preview drawing scale, also in model space.
This is not the case in QCAD 3 and possibly needs a different solution.

Possible solutions:

  • two different LTSCALEs for model space and print preview
  • same behavior as QCAD 2
 321 QCAD (main)TaskLow Add license to ECMAScript files Closed
100%
Task Description

Add license header for all ECMAScript files.

 320 QCAD (main)Feature RequestLow CAD Tool Bar: Back button should go back one menu Closed
100%
Task Description

CAD Tool Bar: Back button should go back one menu. Possibly use two buttons, one to go back to the previous tool bar, one to go back to the main tool bar.

 318 QCAD (main)Bug ReportLow Text of dimensions label in SVG PG export  Closed
100%
Task Description

The labels of dimensions in PG exporter are moved half text-height. Thats a bit much, and actually, no such movement looks more true to the display of same in QCAD itself.

--- SvgExporterPG.js.orig	2011-10-15 18:57:29.994666881 +0200
+++ SvgExporterPG.js	2011-10-15 18:57:39.284666834 +0200
@@ -434,7 +434,7 @@
         //debugger;
         var angle = this.text.getAngle();
         //this.text.setAngle(entity.getAngle());
-        var offset = RVector.createPolar(this.text.getHeight()/2, angle + Math.PI/2);
+        var offset = RVector.createPolar(0, angle + Math.PI/2);
         this.text.move(offset);
         this.textColor = entity.getColor();
         this.exportText();
 317 QCAD (main)Bug ReportLow Debugger with -always-load-scripts Closed
100%
Task Description

Starting qcad Beta 3 with command line argument -always-load-scripts will bring up debugger:

Uncaught exception at /opt/qcad-3.0.0-beta3-prof-linux/scripts/library.js:2: RangeError: Maximum call stack size exceeded.
2 include(”sprintf.js”);

316QCAD (main)Feature RequestLowBlocks list and selected blockAssigned
0%
1 Task Description

Wouldn’t it be nice, if selecting a block in model view would somehow highlight (just like clicking a block in the list does) the selected block in the “Block List” window?

(Feature request sounds a little harsh, enhancement proposal would seem more apt.)

 315 QCAD (main)Feature RequestLow SVG PG export polylines Closed
100%
Task Description

Polylines may consist of lines and arcs. The SVG PG exporter writes them as all straight lines. A better mapping than polyline then was path, as is done with arcs now.

 314 QCAD (main)Bug ReportLow Polyline from segments puts result in layer 0 Closed
100%
Task Description

A polyline or polygon created from segments always ends up in layer 0, shouldn’t it stay in the same layer as the segments have been?

 313 QCAD (main)Feature RequestLow Isometric grid Closed
100%
Task Description

Switch grid from orthogonal to isometric.

 310 QCAD (main)Feature RequestLow show/hide grid Closed
100%
Task Description

You removed the button to show and hide grid

I cannot find it and when I turn the grid off and on

 307 QCAD (main)Bug ReportLow Library Browser DB File Locked Closed
100%
Task Description

Handle situation in which DB file is locked (from previous crash, ...).

Currently, the debugger is shown repeatedly.

 305 ECMAScriptFeature RequestLow executing script at terminal command prompt Closed
100%
Task Description

Hello. My question is: can I run my script under Linux QCAD using Linux command prompt.
Something like this. Print in terminal: “./qcad myscript.qs” And can the script executing without QCAD GUI? I need to make my drawing by printing specific command in linux command prompt without using GUI. So after script end his work I want to have my drawing at destination directory.

Thank you.

 303 QCAD (main)Bug ReportLow Hatch with spline boundary Closed
100%
Task Description

If spline boundary has fit points, hatch is loaded with visible inaccuracy.

 302 QCAD (main)Feature RequestLow Printer calibration Closed
100%
Task Description

Calibrate printer X/Y ratio and possibly scale to allow accurate printing even on inaccurate printers.

 300 QCAD (main)Bug ReportLow Dashed lines in SVG PG export Closed
100%
Task Description

Chat from  FS#194  singled out, so that can be closed.

Dash patterns in BETA2 are very much out of proportion. BETA2 always PG exports 1:1 and only scales strokes so that in the final rendering they match what a technical drawing would show. As dash patterns depend on stroke, both current stroke and final scale have to be brought in accord.

The patch below also restores the alignment of dashes, so that dashed lines do not end in a gap, at least in most occasions.

--- SvgExporterPG-orig.js	2011-09-15 23:11:40.000000000 +0200
+++ SvgExporterPG.js	2011-10-07 13:28:04.085376719 +0200
@@ -384,32 +384,29 @@
         continuous = true;
     }
     if (!continuous) {
-        //p.scale(this.getPatternFactor());
-        p.scale(1/this.scale);
+        // dash and gap lengths are to be proportional to line weight
+        // beware: line weight unit is 100 times millimeters, convert to current unit
+        // beware: the viewer scales lengths differently from weight
+        p.scale(RUnit.convert(this.weight / 100.0, RS.Millimeter, this.svgUnit) / this.scale);
         var num = p.getNumDashes();
-        var str = "";
+        var str = [];
         for ( var i = 0; i < num; ++i) {
             var len = Math.abs(p.getDashLengthAt(i));
-            // see FS#192:
-            //len = this.convert(len);
-            str += "" + len;
-            if (i < num - 1) {
-                str += ",";
-            }
-        }
-        additionalStyles += "stroke-dasharray:" + str;
-        
-        // does more harm than good
-//        if (isShape(this.shape)) {
-//            var length = this.shape.getLength();
-//            if (isNaN(this.offset)) {
-//                this.offset = this.getPatternOffset(length, p);
-//            } else {
-//                var num = Math.ceil(this.offset / p.getPatternLength());
-        //                this.offset -= num * p.getPatternLength();
-        //            }
-        //            additionalStyles += ";stroke-dashoffset:" + this.offset;
-        //        }
+            str.push(len);
+        }
+        additionalStyles += "stroke-dasharray:" + str.join(",");
+
+        // center dash-array
+        if (isShape(this.shape) && isFinite(this.shape.getLength())) {
+            var length = this.shape.getLength();
+            if (isNaN(this.offset)) {
+                this.offset = -this.getPatternOffset(length, p);
+            } else {
+                var num = Math.ceil(this.offset / p.getPatternLength());
+                this.offset -= num * p.getPatternLength();
+            }
+            additionalStyles += ";stroke-dashoffset:" + this.offset;
+        }
     }
 299 QCAD (main)Bug ReportLow Text of rotated dimensions in SVG PG export Closed
100%
Task Description

Sometimes the text of a dimension (that is in a block - just a suspicion of mine) will not get rotated. I do not know why this.text.getAngle() sometimes returns a wrong value, but there is a simple workaround: always rotate the text with the dimension:

--- SvgExporterPG-orig.js	2011-09-15 23:11:40.000000000 +0200
+++ SvgExporterPG.js	2011-10-07 13:07:03.715374911 +0200

@@ -428,9 +427,7 @@
         // dimension entity: export text:
         this.writeEntityComment(entity);
         this.text = entity.getTextData();
-//        var angle = this.text.getAngle();
-//        var offset = RVector.createPolar(this.text.getHeight()/2, angle + Math.PI/2);
-//        this.text.move(offset);
+        this.text.setAngle(entity.getAngle());
         this.textColor = entity.getColor();
         this.exportText();
         this.text = undefined;
 297 QCAD (main)Feature RequestLow Support drawing linetype scale factor (LTSCALE) Closed
100%
Task Description

Support drawing linetype scale factor (LTSCALE)

 296 QCAD (main)Bug ReportLow Segmentation Fault: Mac OS X: Print Preview Closed
100%
Task Description

Thread 0 Crashed: Dispatch queue: com.apple.main-thread
0 libobjc.A.dylib 0x9392df87 objc_msgSend + 23
1 QtGui 0x05006ceb -[QCocoaWindow sendEvent:] + 267
2 com.apple.AppKit 0x902b760b -[NSApplication sendEvent:] + 6431
3 QtGui 0x0500a3ed -[QNSApplication sendEvent:] + 93
4 com.apple.AppKit 0x9024b253 -[NSApplication run] + 917
5 QtGui 0×05014481 QEventDispatcherMac::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) + 1505
6 QtCore 0x04d60941 QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) + 65
7 QtCore 0x04d60c8a QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) + 170
8 QtCore 0x04d620e6 QCoreApplication::exec() + 182
9 ...ript_core_debug.1.0.0.dylib 0x1dec391e qtscript_QCoreApplication_static_call(QScriptContext*, QScriptEngine*) + 1316 (qtscript_QCoreApplication.cpp:314)
10 QtScript 0x04af8318 QScript::FunctionWrapper::proxyCall(QTJSC::ExecState*, QTJSC::JSObject*, QTJSC::JSValue, QTJSC::ArgList const&) + 136
11 QtScript 0x04a10871 QTJSC::NativeFuncWrapper::operator()(QTJSC::ExecState*, QTJSC::JSObject*, QTJSC::JSValue, QTJSC::ArgList const&) const + 113
12 QtScript 0x049e5ac9 cti_op_call_NotJSFunction + 489
13 ??? 0x202e626f 0 + 539910767
14 QtScript 0x0499d057 QTJSC::Interpreter::execute(QTJSC::EvalExecutable*, QTJSC::ExecState*, QTJSC::JSObject*, int, QTJSC::ScopeChainNode*, QTJSC::JSValue*) + 1031
15 QtScript 0x0499d351 QTJSC::Interpreter::execute(QTJSC::EvalExecutable*, QTJSC::ExecState*, QTJSC::JSObject*, QTJSC::ScopeChainNode*, QTJSC::JSValue*) + 97
16 QtScript 0x04aca7b6 QScriptEnginePrivate::evaluateHelper(QTJSC::ExecState*, long, QTJSC::EvalExecutable*, bool&) + 582
17 QtScript 0x04acb011 QScriptEngine::evaluate(QString const&, QString const&, int) + 801
18 com.ribbonsoft.qcad 0x0003868b RScriptHandlerEcma::eval(QString const&, QString const&) + 57
19 com.ribbonsoft.qcad 0x00037c6f RScriptHandlerEcma::doScript(QString const&, QStringList const&) + 805
20 com.ribbonsoft.qcad 0x009c3b8d RScriptHandler::init(QString const&, QStringList const&) + 641
21 com.ribbonsoft.qcad 0x0002f4b8 main + 3878 (main.cpp:218)
22 com.ribbonsoft.qcad 0x0002e289 _start + 208
23 com.ribbonsoft.qcad 0x0002e1b8 start + 40

 295 QCAD (main)Bug ReportLow SEGFAULT in Plugin.prototype.initDoc() Closed
100%
Task Description

Plugin.js:

/**
 * \internal Called once on startup.
 */// TODO crashes under OpenSUSE 11.4
 

Backtrace:

Thread [1] 31002 (Suspended : Signal : SIGSEGV:Segmentation fault)	
	strncmp() at 0xb505089a	
	__xmlParserInputBufferCreateFilename() at xmlIO.c:2,525 0x92c27b9	
	xmlParserInputBufferCreateFilename() at xmlIO.c:2,559 0x92c284a	
	xmlNewInputFromFile() at parserInternals.c:1,549 0x9285697	
	xmlDefaultExternalEntityLoader() at xmlIO.c:3,881 0x92c45fd	
	xmlLoadExternalEntity() at xmlIO.c:3,941 0x92c46f6	
	xsltDocDefaultLoaderFunc() at documents.c:85 0x922b0d9	
	xsltParseStylesheetFile() at xslt.c:6,726 0x9224da3	
	RXslt::parseStylesheet() at RXslt.cpp:14 0x9212ce7	
	REcmaXslt::parseStylesheet() at REcmaXslt.cpp:196 0x8dff0e4	
	0xb6bd813c	
	0xb6ac1f68	
	0xb6a9164c	
	0xac23d732	
	0xb6a44262	
	0xb6a445f7	
	0xb6bb0f92	
	QScriptEngine::evaluate() at 0xb6bba46f	
	RScriptHandlerEcma::eval() at RScriptHandlerEcma.cpp:775 0x87d1bf4	
	RScriptHandlerEcma::doScript() at RScriptHandlerEcma.cpp:771 0x87d1ad8	
	RScriptHandler::init() at RScriptHandler.cpp:31 0x8f9bf9e	
	main() at main.cpp:218 0x87cb5bf	

/rsframework/src/xml/xml/libxml2/xmlIO.c:

#ifdef HAVE_ZLIB_H
	if ((xmlInputCallbackTable[i].opencallback == xmlGzfileOpen) &&
		(strcmp(URI, "-") != 0)) {
	    if (((z_stream *)context)->avail_in > 4) {
	        char *cptr, buff4[4];
		cptr = (char *) ((z_stream *)context)->next_in;
		if (gzread(context, buff4, 4) == 4) {
		    if (strncmp(buff4, cptr, 4) == 0)
===>		        ret->compressed = 0;
		    else
		        ret->compressed = 1;
		    gzrewind(context);
		}
	    }
	}
#endif

 294 QCAD (main)Bug ReportLow Printing: Exception: page tags Closed
100%
Task Description

Uncaught exception at C:/DISEGNO/QCAD Professional/scripts/File/PrintPreview\Print.js:345: Error: QFont::QFont(): could not find a function match; candidates are: QFont() QFont(QFont arg1) QFont(QFont arg1, QPaintDevice pd) QFont(String family, int pointSize, int weight, bool italic)

293QCAD (main)Feature RequestLowmulti-select for blocksAssigned
0%
Task Description

It would be nice if one could select multiple blocks in the block list at once (holding ctrl or ctrl+shift). Main purpose would be to delete them if they are not needed anymore. If possible, the same applies to layers.

 291 QCAD (main)Bug ReportLow Tangent Point - Circle Closed
100%
Task Description

See:
http://www.ribbonsoft.com/rsforum/viewtopic.php?t=1642

 290 QCAD (main)Bug ReportLow Arrow on Leaders do not scale  Closed
100%
Task Description

I consider this a bug or at least poor software design.

When I edit the drawing preferences and change the arrow size (under the Dimensions tab), the arrows of my dimensions change as expected, but those of the leaders to not change.

No drawing preference exists to adjust the leaders separately, and scaling a leader does not scale its arrow. I currently must delete my leaders and redraw them completely to change the arrow size. Very inconvenient.

P.S. I’m using QCad 2.0.5.0-Free-1 (Community Edition) and didn’t see that version in your list. Does it have another name?

Showing tasks 1851 - 1900 of 2237 Page 38 of 45<<First - 36 - 37 - 38 - 39 - 40 - Last >>

Available keyboard shortcuts

Tasklist

Task Details

Task Editing