QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategoryTask TypeSeverity  descSummaryStatusProgress
 447 QCAD (main)Bug ReportHigh Issue opening/saving files Closed
Task Description

I’m not able to open or save a file using the open/save file dialog.
When I change the Look in: directory nothing happens.
Even when I click on My Computer or Chris.

The same applies to saving files.



 475 QCAD (main)Bug ReportHigh Mac OSX 10.6.8 frequent crashes Closed
Task Description

I’m getting frequent crashes for no apparent reason, in a variety of commands. Sorry, Qcad 3 is unusable for me at the moment.

 478 QCAD (main)Bug ReportHigh crash on "Draw" - "Insert Bitmap" Closed
Task Description

Selecting “Draw” and “Insert Bitmap” from the menu shows file dialog “Import Bitmap” for a split second and then crashes completely with segmentation fault.

Running Ubuntu Linux 10.04 LTS with QCad3 rc2.

Console output:
Debug: updateScenes...
Debug: updateGuiActions...
Debug: notifyListenersSlot...
Warning: RScriptHandlerEcma::createActionDocumentLevel(): “scripts/Snap/RestrictOff/RestrictOff.js” : Engine is busy. Aborting...
Warning: RScriptHandlerEcma::createActionDocumentLevel(): “scripts/Snap/SnapAuto/SnapAuto.js” : Engine is busy. Aborting...
/opt/qcad-3.0.0-rc2-prof-linux/qcad: line 35: 5905 Segmentation fault LD_LIBRARY_PATH=”$DIR” “$binary” $OPT1 $OPT2 “[email protected]

 524 QCAD (main)Bug ReportHigh Debugger appears when using lengthen tool Closed
Task Description

When attempting to use the Lengthen tool, the Qt Script Debugger was activated. The following exception was noted:

Welcome to the Qt Script debugger.
Debugger commands start with a . (period).
Any other input will be evaluated by the script interpreter.
Type “.help” for help.

Uncaught exception at scripts/Modify/Lengthen/Lengthen.js:137: TypeError: Result of expression ‘this.entity.trimStartPoint’ [undefined] is not a function.
137 this.entity.trimStartPoint(is);

The application then crashed and report was sent to Apple.

 536 QCAD (main)Bug ReportHigh Update RC5 NO icons Closed
1 Task Description

After Update to RC5 there are NO icons displayed

 797 QCAD (main)Bug ReportHigh QCAD hanging after loading working file Closed
Task Description

I have the german Version of QCAD 3.0.0.
After starting QCAD I load my current work file (an architecture one).
After loading I get two working Areas in QCAD and after a while the complete Software QCAD (only QCAD) is hanging. It is not possible to close the QCAD SW with the task Manager of Windows 7. Only to log out helps to Close or remove the running SW. The attachment Shows a Screen copy. The view is when you see through milky glasses to QCAD.

I bought this SW a few days ago and then this happened. I have spend a lot of time to generate my Project and now this.

Is there any one who knows what the Problem is?
Is that a Problem of thw QCAD SW or can be the problem my current work file (generated with QCAD on my Notebook). Note, Problem happens on my work Station. I have started to work on my Notebook, but i found out that the Screen is to small to work with QCAD. So i moved the SW to my work Station. (Both working with Windows 7) This to get more Details abou the handling and whathappens before.

Would be great to get a quick Response or better a working solution for my Problem. When you need more details please let me know.

[Edited by Admin for profanity]

 799 QCAD (main)Bug ReportHigh Detect duplicates not working properly Closed
Task Description

Windows 7-64
Detect duplicates tool not working properly.
Selecting this tool causes program to lag endlessly and malfunctions.
To reproduce bug:
1. Select all entities.
2. Select duplicates tool.
3. Nothing happens.
4. Select duplicate tool again and...bug!

 900 QCAD (main)Bug ReportHigh Using text in 3.1.2 freezes QCAD Closed
Task Description

Placing text in a drawing using 3.2.1 causes the application to freeze.
Please see topic:

 904 QCAD (main)Bug ReportHigh Crash when inserting some blocks from part library Closed
Task Description

Tested on Linux Mint-64
Inserting some exsisting blocks or newly user created blocks makes QCAD quit!
Permissions were checked and also tested by submitting new blocks to new folder...but problem remains.
See related topic:

 1043 QCAD (main)Bug ReportHigh QCAD 3.4.7 pro crash Closed
Task Description


intensive work in QCAD 3.4.7 pro leads to crash it after 30-40 minutes.

Console output (OS Debian jessie):

Could not allocate register file: 12
./qcad: line 18: 6266 Segmentation fault LD_LIBRARY_PATH=”$DIR” “$binary” -style plastique “[email protected]

 1076 QCAD/CAMBug ReportHigh Crash on Mac OS X when using internal Trackpad Closed
1 Task Description


I have just updated my Mac OS from 10.9.2 to 10.9.4. QCAD 3.6.2 seems to be working normally under the newest version of Mac OS, but has developed a very specific bug which leads to reproducible crashes when a text object is edited.

Steps to minimally reproduce:
1. Open QCAD
2. Create a text object
3. Place the text object on the canvas
4. double-click the text object and edit its contents
5. click OK to accept changes
6. repeat from step 4 three or four times.

After several attempts to edit a text object, QCAD will crash with EXC_BAD_ACCESS (SIGBUS) in thread 0 (QCoreApplication).
The crash can also be triggered by moving the text object around on the canvas (instead of editing its contents).
The bug does not require anything else (no other objects on the canvas, no particular font, occurs in both new and previously saved documents).

Apart from this bug, QCAD seems to work fine on OS X 10.9. The text editing crash did not occur before the latest OS update. No other applications on my system seem to be having any problems. If this problem can be fixed, I think QCAD will be quite usable on 10.9.

See also related bugs in:

 1091 QCAD (main)Bug ReportHigh Qcad-Pro 3.6.3 Repeatable crash when using mirror tool  ...Closed
Task Description

Under OS X 10.9.4 I often experiencing a crash with QCad-Pro 3.6.3 when using the mirror tool. It’s repeatable to roughly 90% , just do it a few times and it will crash.

In this report I have included the crash trace from OS X as well as a simple example DXF file (a house gate) which can be used to repeat the crash. Just do a vertical mirroring a few times and the crash will happen.

It usually happens more if you choose “Keep original”

While not quite a showstopper I would consider this something that really needs fixing ASAP as it could mean data loss (which happened to me).

 1135 QCAD (main)Bug ReportHigh Minimally reproducible segfault when moving a leader in ...Closed
Task Description


I have a nice minimally reproducible bug on QCAD v3.7.4 on Mac OS X 10.9.5 (Mavericks).
QCAD will segfault whenever I take the following steps:

1. Open a new document
2. Create a leader object (D,E) in the default ‘0’ layer. Leave its style and color defined by the layer, as per default.
3. Create a new layer, with a non-default line style or color. The line weight & layer name do not matter.
4. Select the leader object previously create
5. Open the property editor and assign the object to the new layer just created.
Every time, this will cause QCAD to segfault on my machine. The crash report is attached.

Another minimally reproducible path to the same error is to do the following:
1. Open a new document
2. Create a leader object (D,E) in the default ‘0’ layer. Give it a custom color and line style that over-ride the layer defaults.
3. Create a new layer, with a non-default line style or color. The line weight & layer name do not matter.
4. Select the leader object previously created.
5. Open the property editor and assign the object to the new layer just created.
6. Still in the property editor, switch the leader object’s color back to ‘By Layer’.
The same segfault will occur.

It seems that the crash is triggered by the action of changing a leader object’s color (and/or line style) in a manner that requires the object to check the containing layer’s default color and style. You can achieve this by either changing the object’s layer, or switching the color and style from being custom defined to ‘by layer’, as long as the selection requires the line’s appearance to change.

Any thoughts? My machine’s crash report is attached.


 1137 QCAD/CAMBug ReportHigh segfault creating dashed spline (without addons) Closed
Task Description


This is my first real bug report so please advise how i could provide more useful information.

I am not certain if the severity is correct.

The bug: segfault when creating a spline with a dashed linetype or opening a file containing one.

The bug isn’t present with the dwg extension installed

Steps to reproduce:
1. create drawing
2. create spline
3. set linetype to dashed
4. crash

 1145 QCAD (main)Bug ReportHigh Closing inactive tab of a modified drawing: drawing fil ...Closed
Task Description

Steps to reproduce:

1. Create new drawing and fill it with some contents that’s easy to distinguish, for example text “DRAWING 1”.
2. Save it as dr1.dxf
3. Close it
4. Open dr1.dxf
5. Edit it, for example change text from “DRAWING 1” to “DRAWING 2” 6. Save changed file as dr2.dxf
7. Close it
8. Open dr1.dxf (it should have content “DRAWING 1”)
9. Open dr2.dxf (it should have content “DRAWING 2”)
10. Close tab dr1.dxf
10.1 Qcad will ask you to save changes.
10.2 Press “Yes” –> nothing happens, dialog doesn’t disappear.
10.3 Press “Discard” –> dialog disappears, tab gets closed
10.4 Tab that has content of file dr2.dxf (”DRAWING 2”) remains open but gets title “dr1.dxf” (!)
11. Close tab
12. Press “Yes” in dialog that asks to save changes

1. Open dr1.dxf
2. Open dr2.dxf
As you can see, both files have equal contents (”DRAWING 2”)

Expected results:

1. Files have their own contents.
2. Dialogs asking to save files disappear when checking “Yes”, “Cancel” or “Discard” 3. Tabs don’t change titles and associated file names when other tabs are closed.

 1177 QCAD (main)Bug ReportHigh Bugs on Win 7- 64bit Closed
Task Description

Just installed (31 jan 2015) on Win 7 64 bit. Two bugs are immediately apparent...

 bug 1 : Network drives are not listed in the file open or import dialogs - no way to access files stored on networked drives. (This is not a windows configuration error- all my other apps work perfevtly ok.)

 bug 2 : After about 5 minutes of initial exploration immediately after installation a window pops up... Trial Expired: The trial add-on CAM is no longer active (restart required).

Note: I do have neither of these problems on Windows XP (32 bit) which I installed yesterday

 1217 QCAD (main)Bug ReportHigh Modify > Explode: crash for non-explodable entities Closed
Task Description

- Select line
- Modify > Explode

 1249 QCAD (main)Bug ReportHigh QCAD makes USB stick read only Closed
Task Description

After the first time I have saved a file from QCAD to the USB stick, the USB stick becomes read only.

Highly inconvenient as one then needs to copy over the data and format it again.

 1280 QCAD (main)Bug ReportHigh Dimension > Leader: crash when attempting to draw leade ...Closed
Task Description

- Create new empty drawing
- Make layer 0 invisible or lock it
- Dimension > Leader
- Set start point

 1283 QCAD (main)Bug ReportHigh Crash when snapping to intersection points between zero ...Closed
1 Task Description

Create spline through point P.
Create zero length line at P.
Snap to P → crash.

 1322 QCAD/CAMBug ReportHigh Fonts mixed up witch code tables Closed
Task Description


In ‘Application preferences, Draw, Text’ fonts can be selected.

There is a mixing up between fonts (the appearance of characters on screen) and code tables (what digital code is used for each character).

‘ISO8859-11’ is the 8 bit Thai (!) code table and not a font
‘Unicode’ is the 16 bit code table and not a font.

For downward comptability QCAD should use default font Standard (ISO3098) with code table ISO8859-1 (US-ASCII Latin-1).

 1331 QCAD (main)Bug ReportHigh QCAD cannot be launched, application preferences incomp ...Closed
Task Description

Missing file Qt5XmlPatterns.dll in Windows 64bit release.

 1354 QCAD (main)Bug ReportHigh 64 bit version crashes on Save or Save As command Closed
Task Description

I just installed (3.12.5) on a Dell Latitude E7250 (8GB RAM, i7-56000 CPU, 2.6GHz, Win 7 Pro 64 bit OS).

Started working my way through the user manual, tried to save a new file as ‘example’ and QCAD (64 bit Pro) crashed. Tried a few times with Save and Save As, empty files and a simple rectangle and it crashed every time.

Removed and re-installed the 64 bit version - same problem

Downloaded, installed 32 bit version as work around - works fine

 1450 QCAD (main)Bug ReportHigh File > Save: Invalid Symbol Table Name Closed
Task Description

Opens an Autocad .dwg file happily (Pro version x64). Allows you to make changes, when you go to save (or save as), you get the “Invalid symbol table name”.

It should figure this out when file is opened and squawk immediately.

Would be extremely useful to get some additional error details that might allow one to diagnose and fix the problem. i.e. “Invalid symbol table name: _” with the name of the offender.

I tried removing unused blocks, no joy.

 1536 QCAD (main)Bug ReportHigh Draw > Polyline > Delete Node(s): crash when deleting 2 ...Closed
Task Description

QCAD crashes when you perform the following operations:

1. Create Polyline with just one segment.  
2. Delete the node with DELETE NODE(S) command.  
3. Press ESC several times.
(-> QCAD crashes..)
 1602 QCAD (main)Bug ReportHigh QCAD crashes whenever I use the Help/Check for QCAD Pro ...Closed
Task Description

2016 I Mac running Mac OS X Sierra Ver 10.12.5
Program crashes when I use the “Check for QCad Pro updates” in the “Help” menu
Therefor I cannot update to latest version

Version: (3.16.5)
Build Date:
Feb 6 2017
Qt Version:
Clang 8.0.0

 1658 QCAD (main)Bug ReportHigh Crash when switching to layout block (32bit Linux, Qt4) Closed
Task Description

Affects 32bit Linux when compiled against Qt4 (legacy platform release).

 1758 QCAD (main)Bug ReportHigh Draw > Polyline > Create from Selected Entities: crash  ...Closed
Task Description

(Re-)combining polys touching at node with ‘create from selected’ leads to application crash.

QCAD 3.20.1 Win7 32bit

In the file example 2.

 1774 QCAD (main)Bug ReportHigh Draw > Polyline > Morph: crash under macOS Closed
Task Description

Depolyment issue with qcaddwg plugin.

 1777 QCAD (main)Bug ReportHigh Crash when pasting / importing drawing with missing ima ...Closed
Task Description

Importing or pasting a drawing which references a non-existing image crashes.

RGraphicsSceneDrawable or type image references deleted, temporary preview document through RImageData which leads to crash when trying to load the image.

 1778 QCAD (main)Bug ReportHigh Draw > Point > Single Point: Exception Closed
Task Description

Exception due to invalid include path.

 1781 QCAD (main)Bug ReportHigh QCAD 3.21.2 crashes when selecting an entity in attache ...Closed
Task Description

QCAD 3.21.2 x86_64 Linux crashes if I try to select any entity of the attached file. The qt4 legacy version is working fine.

 1839 QCAD (main)Bug ReportHigh Lost in migration Closed
Task Description

Hi Andrew,

I am trying to ‘HP pen plotter’ a test file, created by AutoCAD 10.

Saving the in QCAD loaded file goes fine. However, the tool table is empty now.

Trying to make a new tool 1 Errors it exists already but does not show up in the tool table.

What do I miss?

 1897 QCAD (main)Bug ReportHigh File - Import broken in 3.22.1 Closed
Task Description

Import of a block from a file from file - import or its related icon does not place anything on the drawing or add it to the block list.
When you open the command, the import drawing dialog appears as well as the options tool bar. Whether save as block is checked or not, nothing happens and the options tool bar closes when a file name has been selected and open is clicked on the import drawing dialog.

Dragging and dropping a file on the main screen still works

 1953 dwg2pdfBug ReportHigh Too small to see any drawings in pdf which converted by ...Closed
Task Description

Hello, I found a bug.

See the problem2.png.

Original file: 004.dwg.
After converting pdf by dwg2pdf. The file is 004.pdf. I can’t find any drawings. I scale the pdf reader to 6400%.
But the drawings are still too small.

This is my using command: .\dwg2pdf.bat -f -a -recompute-dim -ltscale=1 path

 1966 dwg2pdfFeature RequestHigh Add a new option to convert all blocks to pdfs Closed
Task Description

Relative to https://www.ribbonsoft.com/bugtracker/index.php?do=details&task_id=1965

I suggest that if dwg2pdf have an new options that can convert all the blocks to pdf.
Now, I need to know all the block names before converting.

But if I put qcad on server, the computer won’t know how many blocks in the dwg and their names.

For examples:

There are 4 blocks in dwg.block1, block2, block3, block4

Command line: ./dwg2pdf -block-all path

Result: block1.pdf block2.pdf block3.pdf block4.pdf

 1968 dwg2pdfFeature RequestHigh Add a -max-lineweight option Closed
Task Description

Good afternoon! I have a suggestion.

Relative to https://www.ribbonsoft.com/bugtracker/index.php?do=details&task_id=1964

I did not find option -max-lineweight.
Please see the attachment.

693QCAD (main)Feature RequestMediumSupport for external references (XREF)Likely to be implemented
18 Task Description

Support for external references (XREF)

 259 QCAD (main)Feature RequestMedium Chain dimensions Closed
11 Task Description

Chain dimensions

 260 QCAD (main)Feature RequestMedium Reference dimensioning Closed
9 Task Description

Reference dimensioning (baseline dimensioning)

Create multiple dimensions using the same base line.

 264 QCAD (main)Feature RequestMedium Support for "Layouts" (paper space, viewport) Closed
25 Task Description

There is one important ACAD feature that I would really like to see supported in QCAD3 and that is “Layouts”

Looking at the block lists, it seems to me that it can’t be too much extra work to support it, since the model space and different paper spaces are already shown there - and one can edit it.

QCAD draws infinitely easier than ACAD and drawing layouts is a primary feature of ACAD. With this in QCAD I can hardly see why anyone that does 2D work would need ACAD at all.

 73 QCAD (main)Bug ReportMedium Uncaught exception: "cannot access member of deleted QO ...Closed
Task Description

occurs sporadically, often when the application or a MDI child is closed, usually not reproducible.

  • 2011-05-11 15.19:32 unsaved drawing, after choosing “no” at the confirmation dialog
Uncaught exception at /home/martin/workspace/rsframework/scripts/Tools/PainterPathViewer/../../library.js:50:
Error: cannot access member `isNull' of deleted QObject
50	            (typeof(obj.isNull)=="function" && obj.isNull()===true));
 349 QCAD (main)Bug ReportMedium Cannot open saved files Closed
Task Description

Hi Andrew

Using Beta 3 v3 saving files to DXf 2010, DWG 2010, or even 2007 only saves succesfully some times. Most of the time I get a warning dialog stating that “Cannot open file” - no suitable importer found?

Please help


 312 QCAD (main)Bug ReportMedium Crash Closed
Task Description

Pendant la création d’un plan le logiciel se bloque, puis une boite de dialogue Windows apparait : “QCAD a cessé de fonctionner”.
Après validation de la fenêtre le logiciel se ferme et toutes les modifications non enregistrées sont perdues.

When creating a plan software hang, then a dialog window appears: “QCad has stopped working”.
After validation of the software window is closed and all unsaved changes are lost.

 688 QCAD (main)Bug ReportMedium QCAD3: Deadlock happens during text operation when one  ...Closed
Task Description

I just use QCAD3 for the first time. I work with OpenSuse 12.2.
After having unpacked the downloaded package, I am able to start QCAD3 with the QCAD command icon.
Check shows that i used the most actual version.
Obviously no further installation steps are necessary.
I am able to draw some lines, etc.
However, when trying to select a font, I recognized that the computer hangs at least for 5 minutes.
The CPU load is about 50%, and i am not able to move the mouse and to do anything else.
During this time, sometimes there is access to disk, sometimes not.
So, in order lo cancel the hanging, i must make a hard system reboot.
Before i have entered the font selection, i have tried to look into the help options.
However, It was not possible to get the FAQs and the QCAD forum, so i am not aware about similar documented problems.
I have looked after similar bugs, using the words ‘text, font’. No similar bugs found.

 707 QCAD (main)Bug ReportMedium segmentation fault on every start - after crash Closed
Task Description

I was drawing on a drawing done in qcad2 - and now working on it in qcad3 - where I had saved it in the new dxf 2010 format (if this has any relevance) and then the computer ran out of power (old battery - I missed that I hadn’t turned on external power) - and shut down hard.

When I rebooted and tried to start qcad - it crashed on startup - giving only this output:
Debug: TIMER: 42 ms - “loading plugins”
Debug: TIMER: 459 ms - “initializing plugins”
./qcad/qcad: line 38: 2955 Segmentation fault (core dumped) LD_LIBRARY_PATH=”$DIR” “$binary” $OPT1 $OPT2 “[email protected]

I then tried removing the entire qcad-3.0.0-prof-linux-alt-x86 folder - and unpackaging the install tar.gz again.

It then started up and came to initializing plugins - 79% - and just hung - I’ve attached screenshot.

After I ctrl+c’ed it - it segfaulted and now it won’t even show the startup splash again.

I’m guessing qcad has saved some state somewhere.. but qcad hasn’t made a ~klavs/.qcad - so I don’t know where it is.

I would very much like to be able to use qcad again :(

 993 QCAD (main)Bug ReportMedium QCAD fails to load drawing with message: maximum recurs ...Closed
Task Description

Since today, QCAD fails to load my drawings, with the following error message in the console:

Warning: RBlockReferenceData::getBoundingBox: maximum recursion depth reached: block: “Drukknop”

The block in question is the AREI (Belgian standard for symbols in electrical installations) symbol for a “button” light switch.
It’s a small and simple drawing (see attachment).

I’ve added a lot of these buttons in the drawing since the previous version, but there were some already present, and this never caused problems.

QCAD version: QCAD 3.4.4 Pro for Ubuntu Linux 32bit
System output: see attached file

 1017 QCAD (main)Bug ReportMedium crash when saving file with block attributes Closed
Task Description


QCAD crashes when saving a drawing that has a block attribute added.
This happens both with a block and the exploded version of the block.

Please find attached the system info, as well as an example drawing.
In this drawing, there are three boxes. The lower 2 boxes are intended to contain text attributes.

Output from the command line:
[email protected]:~/opt/qcad-3.4.5-pro-linux-x86_32$ ./qcad
Debug: RDxfPlugin::init
Debug: RHelpPlugin::init
Debug: RProScriptsPlugin::init
Debug: TIMER: 90 ms - “loading add-ons”
Debug: TIMER: 781 ms - “initializing add-ons”
Debug: checking for updates...
Warning: QSslSocket: cannot resolve SSLv2_client_method
Warning: QSslSocket: cannot resolve SSLv2_server_method
Debug: no updates available
Debug: checking for updates...
Debug: no updates available
Debug: RPluginBase: postInit: “DWG”
Debug: RPluginBase: postInit: “Pro Tools”
Debug: code page: 30
Debug: autosave skipped [08:54:14]: no modifications
./qcad: line 18: 3850 Segmentation fault (core dumped) LD_LIBRARY_PATH=”$DIR” “$binary” -style plastique “[email protected]

Kind regards,


 1293 QCAD/CAMBug ReportMedium Crash when snapping to intersection points between 3d l ...Closed
Task Description

I have a file that makes QCAD crash. I’ve been editing this design across different versions of QCAD over time and this is the first time I have a problem with it.

Steps to reproduce:
Open the attached file and try to add some entities or dimensions to it (you may need to create large ones since it seems to depend on the zoom factor; for example a very large ellipse). After a freeze of a few seconds QCAD will quit.

The attached file is a simplified version from which I deleted a number of entities; on the original I can’t do anything – QCAD crashes as soon as I try to create any object.

Cause: 3D lines with x1==x2, y1==y2 but z1!=z2

 1938 QCAD (main)Bug ReportMedium Segfault when trying to insert block from library (Fedo ...Closed
Task Description

(base) [[email protected] qcad-3.23.0-pro-linux-x86_64]$ ./qcad
QCAD version 3.23.0
10:21:34: Debug: calling odInitialize
10:21:34: Debug: dropped global XDATA (no res buf): “ViewportCenter” 10:21:52: Debug: importing file: /home/kforrester/Resilio Sync/Technical/Process Engineering/equipment_tag_and_name.dxf
./qcad: line 9: 3844 Segmentation fault (core dumped) LD_LIBRARY_PATH=”$DIR” “$binary” “[email protected]

QCAD has unexpectedly quit.

Please use the offscreen platform plugin for headless systems
(without a running X11 server):
./qcad -platform offscreen

In addition, you might have to override the default Qt style
to prevent the loading of a native desktop style (such as GTK):
./qcad -style plastique

I have tested this in version 3.22.1 too and get the same result. Reverting all the way back to 3.13.1 results in an operable version of qcad when working on the same file and library blocks.

Showing tasks 51 - 100 of 2095 Page 2 of 42 - 1 - 2 - 3 - 4 - 5 - Last >>

Available keyboard shortcuts


Task Details

Task Editing