QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategoryTask TypeSeverity  descSummaryStatusProgress
 1981 QCAD/CAMFeature RequestLow I would like an external post processor Closed
100%
Task Description

I use gcode ripper for some of my jobs. (see here: https://www.scorchworks.com/Gcoderipper/gcoderipper.html) This is a large python script that I use to wrap flat code around a cylinder for engraving. What I would like to see is a way to run it from my own custom post processor that I wrote for my machine. Maybe some kind of keyword that allows me to specify an arbitrary external command with some parameters. It would be very helpful to me. I create a lot of ad-hock jobs to run.

Thanks,
Chuck Tilbury

 1984 QCAD (main)Performance IssueLow Block > Create Block from Selection: Slow for large num ...Closed
100%
Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=33&t=6672

 1985 QCAD (main)Bug ReportLow Hatch dots are rendered as lines with fixed lenght of 0 ...Closed
100%
Task Description

With some unit and scale combinations dots rather look like dashes.
https://qcad.org/rsforum/viewtopic.php?t=6685#p25325

 1986 QCAD (main)Bug ReportLow Page Tags set as default not displayed Closed
100%
Task Description

Cases:

1. QCAD default start drawing:
Application Preferences, Page Tags enabled,
Load new drawing (Menu/File/New),
Launch Print Preview, Page Tags not displayed on print preview page,
Check Drawing Preferences shows that Page Tags are still enabled, turn it off, turn it on, confirm with OK makes the Page Tags visible on the Print Page.

2. Customized start template drawing - saved as template with enabled Page Tags - same behavior.

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=33&t=6673

 1987 QCAD (main)Bug ReportLow File > SVG Export: full circle hatch Closed
100%
Task Description

Hatch of full circle (loaded from DXF) does not export to SVG.

 1988 TranslationBug ReportLow Translation: "Automatisches Speichern" wird mit "Autosa ...Closed
100%
Task Description

QCAD Pro, Deutsche Benutzeroberfläche:

Kommando Zeilen Mitteilung:
[13:35:12] Automatisches Speichern in: C:\Users\......xxx.dxf...
[13:35:12] Autosave abgeschlossen.

Englische und Deutsche Benutzeroberfläche:
Die angezeigten 3 Punkte nach dem xxx.dxf sind überflüssig da die Zeile nach dem dxf definitive endet.

 1989 QCAD (main)Bug ReportLow Qcad does not show DWF-files Closed
100%
Task Description

Hello
Qcad does not show! DWF-files. it seems, that the File is opened, but thre is nothing displayed on the screen. onl the Rastes is showed, but not the DWf-drawing.

 1990 QCAD (main)Bug ReportLow Layer > Duplicate Layer: fails for layer "0" Closed
100%
Task Description

Duplicating layer “0” results in duplicate entities on same layer instead of new layer.

 1991 QCAD (main)Bug ReportLow Modify > Divide: Preview indicator fails on infinitive  ...Closed
100%
Task Description

Case:
Infinitive line,
launch Divide (DI),
click infinitive line

An orthogonal preview line should now indicates where the cut will happen when the next point is chosen.
QCAD version 3.23.0.5 displays that indicator below a variable angle to the infinitive line. Regardless what it shows - the cut will happen orthogonal. ;-)

 1992 QCAD/CAMBug ReportLow Regenerate All Error Closed
100%
Task Description

Hallo Andrew,

I experienced some odd behaviour when using a final Regenerate All before an Export.

 1993 QCAD (main)Bug ReportLow Draw > Insert Bitmap: relative zero point not set Closed
100%
Task Description

If I insert a bitmap the relative zero point (RZ) isn’t set at all. It will be set at the mouse position in the moment when I terminate the tool.

This leads among other things that I can’t use the Alt key for ortho mode or other tools for restrictions.

 1994 QCAD (main)Bug ReportLow Explode used on Ray or Infinitive lines deletes the lin ...Closed
100%
Task Description

If I use accidentally explode on a ray or infinitive line the line will be deleted without a warning.

QCAD 3.23.0.5

 1995 QCAD (main)Bug ReportLow Explode used on a bitmap will delete the bitmap Closed
100%
Task Description

1. If I use accidentally explode on a bitmap it will be deleted without a warning.

2. If I select an area with a selection rectangle as preparation for the “Clip to rectangle” tool all bitmaps within the selection are deleted - without a warning.

QCAD 3.23.0.5

 1996 QCAD (main)Bug ReportLow File > Save: DXF header variable CECOLOR changed Closed
100%
Task Description

- Open a DXF file with CECOLOR (current drawing color) set to 256 (ByLayer).
- Save DXF
- CECOLOR has changed

 1997 QCAD/CAMBug ReportLow CAM > CAM Export: Fails for new document created Closed
100%
1 Task Description

When I create a simple drawing, I cannot export the gcode until I restart qcad.

general steps to reproduce the issue:
1. open a new drawing
2. Add a letter “D” near the origin in Arial font, about 7mm tall.
3. explode it
4. save the drawing
5. Fill in in the “cam configuration” 6. Select the drawing and generate the tool paths.
7. Hit the “export button” or the menu item.
8. Observe that you see the “camexport” command appears in the command section, but there is no file generated for the gcode.

If you restart qcad, then the gcode will export as expected. Also, it appears to work for more complicated drawings. I had the same issue, when I tried to generate the same thing, but using the string “November 2019” at 5mm height. I am using up to date MX Linux with kernel version 4.19.0. I also observed this behavior under Windows 10 professional.

 1998 Snapshot ReleaseBug ReportLow Viewport: Dimension text not scaled correctly in scaled ...Closed
100%
Task Description

Hi,

Dimensions texts are not showing in layouts when using a Viewport scale of 1/100.
This issue is present in 3.23.0.6 but not in 3.23.0.

See this thread on the forum for more info and repro file:
https://qcad.org/rsforum/viewtopic.php?f=33&t=6725

 2000 QCAD/CAMBug ReportLow CAM > Nesting: misleading "Sheet added" confirmation Closed
100%
Task Description

Within the nesting preparation:
A left mouse click to add a sheet will always be confirmed with “Sheet added”, regardless of a proper selection or where the left click is done in Model_Space.

 2001 QCAD/CAMBug ReportLow CAM > Nesting: Alignment fails Closed
100%
Task Description

Description for the CAM Nesting alignment:

Quote:
Alignment: Parts are arranged with the chosen alignment in mind. An alignment of “Left - Bottom” means that parts are shuffled to the left (primary alignment) and towards the bottom (secondary alignment).
Quote end

I tested a few scenarios. e.g
a Top Left, Align → leads to a top right alignment,
a Top left, Hull → leads to a Bottom Left alignment,
etc.

 2002 QCAD (main)Bug ReportLow Draw > Viewport > Add Viewport: Hatch is offset incorre ...Closed
100%
Task Description

Hi,
When a hatch have been offset in the Model then it appears incorrectly when rendered in a Viewport. It seems that in Viewports the hatch Origin value is not taken into consideration. This means that when adjusting a hatch in the Model to look correct (align along a line for example). This alignment is off in the Viewport.

See screenshots and attached test dxf file in this thread on the forum: https://qcad.org/rsforum/viewtopic.php?f=33&t=6742

Edit: After looking more into this issue is seems it is the Viewport’s position that is ignored when transforming the pattern into Viewport space. See the following gif:

https://i.imgur.com/vD8cOuC.gif

Above it can be seen that that pattern is always rendered in ‘worldspace’ since the pattern is static (the pattern is not moved when the viewport is moved around)

 2003 QCAD/CAMBug ReportLow QCADCAM Crashes when starting up Closed
100%
Task Description

I am trying to run the QCADCAM v3.23.0 64 bit version under Windows 10 x64. When I start the program, I get the splash screen showing it loading all of the plugins. When it gets to around 67% (Gerber stuff), the program crashes. I get the following exception:

Unhandled exception at 0x00007FFC5F51C706 (MxMGLV64.dll) in qcad.exe: 0xC0000005: Access violation reading location 0×0000000003304318. occurred

I also loaded the 64 bit version of just plain QCAD and it works with no problems.
I also tried loading the 32 bit version of QCADCAM and while it does not crash, it does not display any of the menus, toolbars, or toolboxes. it displays only a black screen with the title bar.

 2004 QCAD (main)Feature RequestLow Library Browser: configurable icon background color Closed
100%
Task Description

Add preference for library browser icon background color.

 2005 QCAD (main)Bug ReportLow Missing dialog in Command Line for "Create Block from s ...Closed
100%
Task Description

Bugreport filled on behalf of John Hyslop / QCAD forum member.

If launching the Menu / Block / “Create Block from selection” tool the usually used Command Line dialog to prompt to the next required action is missing.
The Status bar is properly calling for “Reference Point” etc.

https://www.qcad.org/rsforum/viewtopic.php?f=8&t=6762

 2006 dwg2pdfFeature RequestLow dwg2pdf: Auto detect page orientation Closed
100%
1 Task Description

Auto detect page orientation based on width / height of document.

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=32&t=6774

 2007 QCAD (main)Bug ReportLow bbox.bat cannot write log file Closed
100%
Task Description

The out redirection file is not located in temp dir but in the batch files location. Due to missing file permissions in “C:\Programs\...” the file cannot be created.

This is a fixed an therefore working version of bbox.bat:

@echo off
qcad.exe -no-gui -allow-multiple-instances -autostart scripts\Pro\Tools\BoundingBox\BoundingBox.js %0 %* 1>%temp%\bbox.log 2>&1

type %temp%\bbox.log
del %temp%\bbox.log
 2008 QCAD (main)Bug ReportLow windows: cannot call scripts\Pro\Tools\BoundingBox\Boun ...Closed
100%
1 Task Description

Calling bbox tool via batch file works:

C:\Program Files\QCAD>bbox.bat D:\tmp\dwgtester\10.09.03.dwg

Output:

09:42:15: Debug:

You are using a trial version of QCAD Professional.

09:42:15: Debug:    If you would like to use this software productively,
09:42:15: Debug:    please purchase the full version for a small license fee from our
09:42:15: Debug:    Online Shop at:
09:42:15: Debug:    http://www.ribbonsoft.com/shop

09:42:15: Debug:    Thank you for trying this add-on!


09:42:15: Debug:    Your script will start in 15 seconds...
09:42:30: Debug:    calling odInitialize
Min: 2419.9969114297623/-125.36162367587679
Max: 2689.9969114297623/64.63837647546899
Size: 270/190.00000015134577

Calling bbox tool directly doesn’t work:

C:\Program Files\QCAD>qcad.exe -no-gui -allow-multiple-instances -autostart scripts\Pro\Tools\BoundingBox\BoundingBox.js D:\tmp\dwgtester\10.09.03.dwg

Output (empty line):


	
 2009 QCAD (main)Bug ReportLow dwginfo - no output Closed
100%
Task Description

Tested on Windows and Linux with several DWG files.

Windows:

[.] C:\opt\QCAD>dwginfo.bat D:\tmp\dwgtester\08.01.01.dwg
12:57:27: Debug:

You are using a trial version of QCAD Professional.

12:57:27: Debug:    If you would like to use this software productively,
12:57:27: Debug:    please purchase the full version for a small license fee from our
12:57:27: Debug:    Online Shop at:
12:57:27: Debug:    http://www.ribbonsoft.com/shop

12:57:27: Debug:    Thank you for trying this add-on!


12:57:27: Debug:    Your script will start in 15 seconds...
12:57:42: Debug:    Input file:  D:\tmp\dwgtester\08.01.01.dwg
12:57:42: Debug:    calling odInitialize

Linux:

[email protected]9459a5:/qcad# ./dwginfo -platform offscreen /data/08.01.01.dwg
QCAD version  3.23.0
11:56:24: Debug:

You are using a trial version of QCAD Professional.

11:56:24: Debug:    If you would like to use this software productively,
11:56:24: Debug:    please purchase the full version for a small license fee from our
11:56:24: Debug:    Online Shop at:
11:56:24: Debug:    http://www.ribbonsoft.com/shop

11:56:24: Debug:    Thank you for trying this add-on!


11:56:24: Debug:    Your script will start in 15 seconds...
11:56:39: Debug:    Input file:  /data/08.01.01.dwg
11:56:39: Debug:    calling odInitialize
 2010 QCAD (main)Bug ReportLow hatches of type "gravel" doesn't appear inside an ellip ...Closed
100%
Task Description

Draw an ellipse, select it, draw an hatch of type gravel: it doesn’t appear at all.

Only for gravel.

 2012 QCAD (main)Bug ReportLow Draw > Hatch > Hatch from Selection: block transforms n ...Closed
100%
Task Description

Hello. I refer to https://www.qcad.org/rsforum/viewtopic.php?p=25905#p25905 where when a block is hatched that hatch reference point is located at absolute 0,0 )where the block reference point is mapped as the reference point of the hatch and that reference point is absolute 0,0).
Best regards

Using QCAD 3.23.0.10
Win 10

 2013 QCAD (main)Bug ReportLow Draw, Shape, Star - more options Closed
100%
Task Description

I like the new shape tool “Star”. Comes at the right time ;-)

Would be nice if we could get the same options like all other shape tools: “Create Polyline” and “Fill”.

 2015 QCAD (main)Bug ReportLow Hatch from segments cannot be saved to DXF/DWG using Op ...Closed
100%
Task Description

I have an example of a figure that I can solid-fill, but if I save and exit, and reload, it disappears.

 2017 QCAD (main)Bug ReportLow Rendering of arcs in blocks with scale factor > 1 Closed
100%
Task Description

Arcs in blocks are not rendered smoothly if the block is inserted with a scale factor > 1.

 2019 QCAD (main)Bug ReportLow Polyline with segment widths: uneven arc segments Closed
100%
Task Description

Example shows the effect on a ring (Menu → Draw → Ring)

 2020 QCAD (main)Bug ReportLow Edit > Paste: Wrong position for block references with  ...Closed
100%
Task Description

Open the example drawing,
selected all,
copy to clipboard,
open new drawing,
paste clipboard content with a scale of 1:1, check preview = everything ok,
change scale to 1/10 etc., check preview = block references way of.

QCAD Pro Version 3.24.0.1

 2022 QCAD (main)Bug ReportLow File > SVG Export: polyline arc segments and hatches in ...Closed
100%
Task Description

Block scales are not applied to the radius of arc segments of polylines and arc boundary segments of hatches.

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=32&t=6854

 2023 QCAD (main)Bug ReportLow Polyline with segment widths: error with clockwise arcs ...Closed
100%
Task Description

- Create clockwise arc
- Convert to polyline
- Assign segment end width > 0

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=33&t=6853

 2024 QCAD/CAMBug ReportLow CAM > Nesting: Nesting blocks with multiple parts fails Closed
100%
Task Description

Case:
Nesting quantity all test: 3

Nesting block2 = works
Nesting block1 = fails (placed outside sheet),
Nesting both blocks = fails (placed partly outside sheet),

 2025 QCAD/CAMBug ReportLow Set Nesting Quantity shows wrong quantity Closed
100%
Task Description

If I set “Set Nesting Quantity” to e.g. 5 it will remember this number within the session.
If I need to check which number I’ve used last time there is no way to find the actual used value - it will show me always 1.
If I restart QCAD/CAM the value is completely lost and the nesting tool tries to fit in as much as possible into the sheet - regardless that the quantity number still shows one.

It would be nice to have a remember function even after restarting QCAD/CAM and have some kind of possibility to see the last used value.

 2026 QCAD (main)Bug ReportLow Modify > Clip to Rectangle: fails on blocks Closed
100%
Task Description

Clip to Area = deletes whole blocks
Clear Area = deletes whole blocks
Cut at Area Boundary = deletes whole blocks

It was working before e.g. in QCAD Version 3.18.0 ;-)

 2027 QCAD (main)Bug ReportLow File > Print: Minimum line weight for printing is 0.01  ...Closed
100%
Task Description

Create drawing in Meters.
Create line with line weight 0.25mm.
Line prints as 1cm wide as minimum line weight is forced as 0.01 drawing units (i.e. 0.01m) for printing.

 2028 QCAD/CAMBug ReportLow CAM > CAM Export: Fails for new document created Closed
100%
Task Description

1. Load drawing
2. Create new drawing
3. Add toolpath / tool
4. CAM > CAM Export

Fails to identify current config (post processor).

 2030 QCAD (main)Bug ReportLow Cannot snap to points of mirrored blocks Closed
100%
1 Task Description

Wenn ich selbst erstellte Blocks Spiegle, funtionieren gewisse Fangpunkte nicht mehr.

In der angehängten Datei, ist der gespiegelte Block und deren inaktive Fangpunkte mit Roten Kreisen markiert.

Ich arbeite mit macOS Catalina 10.15.2

Vielen Dank für das Beheben dieses Bugs, der mich gerade sehr viel Zeit kostet ;-(

 2031 QCAD (main)Bug ReportLow Ordinate Dimensions don't act as expected Closed
100%
Task Description

Hi Andrew

I wasn’t sure if this was a bug or feature request, when I’m drawing part sets that only change in lengths I dimension them
to save time then I stretch and save as whatever filename... I was surprised when Qcad reacted the way it did when stretching ordinate
dimensions on a part, the 1st thing I did was window select over the dimensions which didn’t work ( this is the typical way for
stretching ordinate dimensions in AutoCAD,IntelliCad,Draftsight etc )... anyway Husky and I had a fairly long debate and he told me
I had to select the object and only parts of the ordinate dimensions which when stretched leaves a bit of tidying up to do..
Please let me know if I’m going about this the wrong way.. do i really have to do multiple stretches and move all the jogged dimensions?

See Topic https://www.qcad.org/rsforum/viewtopic.php?f=32&t=6901&start=15 It started off with negative values for ordinate dimensions then turned into problems stretching ordinate dimensions..
I also posted dropbox links to quite a few videos..

Attached is a zip file containing some screenshots plus the original dxf file..

Best Regards
John Hyslop

 2032 QCAD (main)Bug ReportLow Draw > Circle > Three Tangents: Cannot select third tan ...Closed
100%
Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=33&t=6915

 2035 QCAD (main)Bug ReportLow Linetype scale in viewports Closed
100%
Task Description

The preference

Edit > Drawing Preferences > General > Linetype > Scale of linetypes matches the scale of each viewport

should take the individual line type scale of entities into account.

 2036 QCAD (main)Bug ReportLow Arc rendering in block context Closed
100%
Task Description

Arcs in nested scaled and rotated blocks are not always rendered properly (too rough, too fine).

 2038 QCAD (main)Bug ReportLow Cannot snap arc / circle reference points inside blocks Closed
100%
Task Description

- Create block with arc or circle
- Auto snap / reference snap does not snap to reference points at circle / arc max / min coordinates

 2039 QCAD (main)Bug ReportLow splines are not showing when drawn by QCAD Simple API n ...Closed
100%
1 Task Description

Hi guys,

I’m trying to create an spline to a complex library component, but it seems splines are not working properly. I would appreciate some help. These are minimum scripts to demonstrate the problem:

Example 1:

include("scripts/simple.js");

function TesteSpline() {
}

TesteSpline.init = function(formWidget) {
    if (!isNull(formWidget)) {
        TesteSpline.widgets = getWidgets(formWidget);
    }
};

TesteSpline.generate = function(documentInterface, file) {
    return TesteSpline.criarCorpo(documentInterface);
};

TesteSpline.generatePreview = function(documentInterface, iconSize) {
};

TesteSpline.criarCorpo = function(documentInterface) {

    addSpline([[0,0],[20,30],[100,100],[110,120]], false); // it doesn't work :-(
    addLine(0,0, 100,100);  // it works!!!

};

Example 2:

include("scripts/library.js");

function TesteSpline() {
}

TesteSpline.init = function(formWidget) {
    if (!isNull(formWidget)) {
        TesteSpline.widgets = getWidgets(formWidget);
    }
};

TesteSpline.generate = function(documentInterface, file) {
    return TesteSpline.criarCorpo(documentInterface);
};

TesteSpline.generatePreview = function(documentInterface, iconSize) {
};

TesteSpline.criarCorpo = function(documentInterface) {
    var addOperation = new RAddObjectsOperation(false);
    var doc = documentInterface.getDocument()
    // Spline
    var cavaData = new RSplineData();
    cavaData.appendFitPoint(new RVector(0,0));
    cavaData.appendFitPoint(new RVector(10,10));
    cavaData.appendFitPoint(new RVector(30,30));
    cavaData.isClosed = false;
  
    // It doesn't work
    var cava = new RSplineEntity(doc,cavaData);
    addOperation.addObject(cava);

    // it works
    var textData = new RTextData(new RVector(2,10),new RVector(2,10),0.4,0.4,0,0,0,0,1,"Hello","Arial",false,false,0,false);
    addOperation.addObject(new RTextEntity(doc,textData));

    return addOperation;
};



 2040 QCAD (main)Feature RequestLow Parallel and Offset tool - digit limit for Number to s ...Closed
100%
Task Description

LP - Number limit:
2 digits (max. 99)

LG - Number limit:
2 digits (max. 99)

OF - Number limit:
3 digits (max. 999)

OH - Number limit:
2 digits (max. 99)

Yes I know - it’s also a performance question but compared to ...

... Copy/Move (MV)
next to infinite digits (max. ???)

... Paste Along Entity (PE)
next to infinite digits (max. ???)

 2042 QCAD (main)Bug ReportLow linetangent can't draw a tangent to arc through a point ...Closed
100%
Task Description

Very often I need to draw a tangent line through a point on the arc or circle. Currently I solve this by drawing the perpendicular in that point and then the perpendicular to that perpendicular. As this problem is solvable I set the severity to “Low”.

But I think linetangent should be able to draw such tangents. And I think this tool should firstly ask for arc or circle and only then for a point. Currently linetangent firstly asks for a point.

 2043 QCAD Community EditionBug ReportLow library browser's menu not consistent with empty namesp ...Closed
100%
Task Description

The library browser’s accordion menu is not consistent when browsing back and forth through empty namespaces (directory).

In the image attached (top to bottom, left to right), I’m trying to open the empty namespace “Hydraulics”. If I close & open the “default” namespace, the empty namespace’s open arrow disappears.

Showing tasks 1901 - 1950 of 2100 Page 39 of 42<<First - 37 - 38 - 39 - 40 - 41 - Last >>

Available keyboard shortcuts

Tasklist

Task Details

Task Editing