QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategoryTask TypeSeverity  descSummaryStatusProgress
 381 QCAD (main)Bug ReportMedium Multiple chice Closed
Task Description

Multiple choice of enteties with “CTRL”+mouseclick is not possible

 385 QCAD (main)Bug ReportMedium Text position of texts in blocks Closed
Task Description

Text position of texts in blocks wrong.

 387 QCAD (main)Bug ReportMedium Export to pdf fails if same file name used as one previ ...Closed
Task Description

In File>PDF Export save a file with the same name in the same place as a previously saved pdf file.

Issue 1
Note that there is no alert to indicate that an attempt to overwrite is being made.

Then use the close preview button and navigate to the top panel file menu.

Issue 2
The usual drop down menu does not work. All other drop down menus do work.

 389 QCAD (main)Bug ReportMedium Changes in "Shortcuts and Commands" are not storable... Closed
Task Description

You can’t save changes in “Application Preferences > Shortcuts and Commands”!
It works only for the current session - after a restart the settings are back on default

 394 QCAD (main)Bug ReportMedium Scaling a drawing Closed
Task Description

By scaling a drawing (base drawing) the text is OK in height but not in position

 395 QCAD (main)Bug ReportMedium wrong text origin when pasting scaled text and graphics Closed
Task Description

Text origins are not properly scaled when pasting text and graphics at a scale other than 1:1

 409 QCAD (main)Bug ReportMedium cross-hatching is not possible in v2 drawings with v3 Closed
Task Description

If you had created a drawing in v2, it is NOT possible do make cross-hatch in v3.

(the hatch will be made but it is not visible) → drawing example

 410 QCAD (main)Bug ReportMedium Grid preferred before enteties Closed
Task Description

When I want to select in example a intersection or a endpoint, QCAD v3RC2 preferred to choose the grid not the intersection or the endpoint of enteties.

 414 QCAD (main)Bug ReportMedium SEGFAULT on exit: RDocumentInterface::repaintViews() Closed
Task Description
  • exited QCAD, 2 drawings opened


Thread [1] 5272 (Suspended : Signal : SIGSEGV:Segmentation fault)	
	memcpy() at 0xb5050d16	
	QList<RGraphicsScene*>::detach_helper() at qlist.h:696 0x8ccb0b6	
	QList<RGraphicsScene*>::detach_helper() at qlist.h:710 0x8ccaef3	
	QList<RGraphicsScene*>::detach() at qlist.h:126 0x8f76f58	
	QList<RGraphicsScene*>::begin() at qlist.h:254 0x8f75f3c	
	RDocumentInterface::repaintViews() at RDocumentInterface.cpp:577 0x8f70e98	
	RDocumentInterface::mouseMoveEvent() at RDocumentInterface.cpp:634 0x8f7111e	
	RGraphicsScene::handleMouseMoveEvent() at RGraphicsScene.cpp:160 0x8f88ae7	
	RGraphicsView::handleMouseMoveEvent() at RGraphicsView.cpp:444 0x8f8b54a	
	RGraphicsViewQt::mouseMoveEvent() at RGraphicsViewQt.cpp:195 0x8e80bef	
	QWidget::event() at 0xb58da661	
	RGraphicsViewQt::event() at RGraphicsViewQt.cpp:104 0x8e80a6c	
	QApplicationPrivate::notify_helper() at 0xb5871d7c	
	QApplication::notify() at 0xb58772c4	
	QCoreApplication::notifyInternal() at 0xb547215b	
	QApplicationPrivate::sendMouseEvent() at 0xb5875152	
	QApplication::x11ProcessEvent() at 0xb5905d26	
	g_main_context_dispatch() at 0xb4aee509	
	g_main_context_iteration() at 0xb4aeefce	
	QEventDispatcherGlib::processEvents() at 0xb54a2741	
	QEventLoop::processEvents() at 0xb547131d	
	QEventLoop::exec() at 0xb54715aa	
	QCoreApplication::exec() at 0xb5473701	
	qtscript_QCoreApplication_static_call() at 0xb08dc4b7	
	QScriptEngine::evaluate() at 0xb6bba46f	
	RScriptHandlerEcma::eval() at RScriptHandlerEcma.cpp:790 0x87d5a26	
	RScriptHandlerEcma::doScript() at RScriptHandlerEcma.cpp:786 0x87d591f	
	RScriptHandler::init() at RScriptHandler.cpp:31 0x8fbbbc2	
	main() at main.cpp:256 0x87cf40a	

 434 QCAD (main)Bug ReportMedium filling wrong areas Closed
Task Description


qcad3 shows wrong filling of areas, see attached example in qcad3rc2 (wrong) vs. qcad2 (ok).

Regards - Stefan

 435 QCAD (main)Bug ReportMedium QCAD3 RC3 Windows XP - Stretch command does not appear  ...Closed
Task Description

The modify tools → stretch command does not appear to function.

The two attachments contain the source drawing (blackburne_engine_breather_0210A.dxf) and five screen shots (qcad3_rc3_stretch.odt) showing the steps taken to replicate the problem.

I have also performed a similar exercise with a Linux trial version 3.0 RC2 (OpenSuse 11.4) with the same result.


 442 QCAD (main)Bug ReportMedium Library incompatible licence Closed
Task Description

Reading  FS#441  I fired up the Library Browser, which works fine here, RC2 from tgz on Ubuntu 10.04, BTW.

The freedxf.com drawings “horseman” and two “women” claim to be “Creative Commons Attribution-NonCommercial-ShareAlike 3.0”. In my opinion, the “NonCommercial” clause does prohibit distribution in QCAD3, which is a commercial package. For a discussion see http://wiki.creativecommons.org/Defining_Noncommercial

 452 QCAD (main)Bug ReportMedium Printing issues OSX Lion Closed
Task Description

When printing a drawing to A3 format on a Canon iX4000 in Qcad 3 RC2 the image is cropped when as if i am trying to print to a A4 page. Setting are correct, however.
(I see a release candidate 3, but where can i download it? Checking versions confirm that i am up-to-date)

 461 QCAD (main)Bug ReportMedium QCAD3 rc2 Opening DXF Created by 2.2.2 Block Position I ...Closed
Task Description

When opening a DXF created by 2.2.2 the block entities are sometimes not being drawn in correct position and orientation.

The following is seen on the console (Which I think is related)

Debug: importing entities in block ' “Sw1pwo” '
Warning: RDwgBlockReferenceImporter::import: block reference references invalid block: “*X15”

and also (which is probably not related)
Debug: importing entities in block ' “A$C6329746C” '
Warning: RSpline::updateFromControlPoints: not enough control points: 0
Warning: RSpline::getExploded: invalid spline
Debug: RSpline: knotVector ignored
Debug: RSpline: knots: 11
Debug: RSpline: order: 4
Debug: RSpline: controlPoints: 7
Warning: RSpline::updateFromControlPoints: not enough control points: 0
Warning: RSpline::getExploded: invalid spline
Debug: RSpline: knotVector ignored
Debug: RSpline: knots: 11
Debug: RSpline: order: 4
Debug: RSpline: controlPoints: 7

Drawing file shown.

This could be a bug in 2.2.2, but it would be nice to ensure 3 can pull in old drawings without us having to rework them all.

Any questions james at enrogen dot com.


 497 QCAD (main)Bug ReportMedium Trim: Tangent on circle: debugger appears Closed
Task Description

having a line tangent on a circle, the Qt Debugger appears when:
- select trim tool
- select line
- mouse over circle

The debugger stops in line 326 of scripts/Modify/Trim/Trim.js (trimmed1.trimStartPoint(is2);) with the following message:
Uncaught exception at scripts/Modify/Trim/Trim.js:326: Error: :-1:-1: Wrong number/types of arguments for RArcEntity.trimStartPoint().
<native>(undefined) at -1
<anonymous>(op = RMixedOperation(0xe50a9a0), limitingEntity = RLineEntityPointer(0xff9b740), limitingShape = RLine(RShape(address: “0xe2a1608”), startPoint: RVector(36379.7, 46367.3, 0) , endPoint: RVector(40858.6, 44174.7, 0) ) , limitingPos = RVector(37446.8, 45886.1, 0) , trimEntity = RCircleEntityPointer(0xefa0170), trimPos = RVector(37054.5, 45938.9, 0) , trimBoth = false, preview = true) at scripts/Modify/Trim/Trim.js:326
<anonymous>(preview = true) at scripts/Modify/Trim/Trim.js:186
<anonymous>() at /opt/qcad-3.0.0-rc2-prof-linux/scripts/Modify/../EAction.js:1162
<anonymous>(event = REntityPickEvent(0xbfdc3614), preview = true) at scripts/Modify/Trim/Trim.js:166
<anonymous>(event = REntityPickEvent(0xbfdc3614)) at /opt/qcad-3.0.0-rc2-prof-linux/scripts/Modify/../EAction.js:1237
<global>() at -1
326 trimmed1.trimStartPoint(is2);
Uncaught exception at scripts/Modify/Trim/Trim.js:326: Error: :-1:-1: Wrong number/types of arguments for RArcEntity.trimStartPoint().
<native>(undefined) at -1
<anonymous>(op = RMixedOperation(0xec6fea8), limitingEntity = RLineEntityPointer(0×11830730), limitingShape = RLine(RShape(address: “0x10c1c988”), startPoint: RVector(36379.7, 46367.3, 0) , endPoint: RVector(40858.6, 44174.7, 0) ) , limitingPos = RVector(38065.4, 45591.8, 0) , trimEntity = RCircleEntityPointer(0xeee04a0), trimPos = RVector(37145, 45818.2, 0) , trimBoth = false, preview = true) at scripts/Modify/Trim/Trim.js:326
<anonymous>(preview = true) at scripts/Modify/Trim/Trim.js:186
<anonymous>() at /opt/qcad-3.0.0-rc2-prof-linux/scripts/Modify/../EAction.js:1162
<anonymous>(event = REntityPickEvent(0xbfdc3614), preview = true) at scripts/Modify/Trim/Trim.js:166
<anonymous>(event = REntityPickEvent(0xbfdc3614)) at /opt/qcad-3.0.0-rc2-prof-linux/scripts/Modify/../EAction.js:1237
<global>() at -1

 499 QCAD (main)Bug ReportMedium hatch does not save Closed
Task Description

When adding a hatch in a drawing, the hatch is vissible and printable but after saving and closing some of the hatches have dissapeared when reopening the drawing.

After several attempts the same hatches in the same objects always dissapear or are not saved.

When needed i can send the drawing, please let me now!

 510 QCAD (main)Bug ReportMedium paste between layers always indicates "locked Layer" Closed
Task Description

1. copy an item from one layer
2. add new layer
3. attempt to paste into new layer

Error message:
“Trying to draw on or modify entities on a locked layer”

The layer is not locked as I can draw into it...
Also tried turning lock “on” and then “off” again; still same message.

 515 QCAD (main)Bug ReportMedium File - Save / Save as: Null Object ID Closed
Task Description

“Null Object ID” exception when saving a previously loaded file.

File: “fs515.dwg”

 518 QCAD (main)Bug ReportMedium Unable to use Library browser properly in RC4 Closed
Task Description

Hi Andrew

In Ubuntu 11.10 and Windows 7 everything so far is working ok in QCAD apart from the Library browser!

1.In Win 7-64 I can run the browser and make a new folder, but when I try to set the permissions/open the folder - browser crashes.

2.In ubuntu 11.10 I first uninstalled RC2 then installed RC4. QCAD program runs ok but this time when I try to open up the browser (not a new folder)I get an error message stating that I do not have permissions to open the first file (vehicle -I think!)in RC2? If I select OK in the warning window the warning just keeps on repeating the same message for the next and subsequent files until I quit it.

 520 QCAD (main)Bug ReportMedium move entity from command line is broken on ubuntu 64 bi ...Closed
Task Description

when I try to move an entity via the command line using the mv command the entity does not move to the specified position. it works if i use the mouse. this was fine in rc2 and rc3 ubuntu 64 bit and windows 64 bit machines.

 530 QCAD (main)Bug ReportMedium sporadic unwanted close of QCad Closed
Task Description

Using the move and scale tools, QCad sometimes (reason unknown so far) crashes in RC4 (never seen that in RC2).

 531 QCAD (main)Bug ReportMedium Qcad stops working after selecting and moving an entity ...Closed
Task Description

I am a new user and bought qcad this afternoon.
Sometimes qcad stops working after selecting and moving an entity. it happens almost every one to two hours. twice until now.
I tried version that didn’t have this problem.

 552 QCAD (main)Feature RequestMedium autosave removing last auto saved file Closed
Task Description

I would like to see an autosave-option which allows to autosave, but which keeps only the latest autosave file (instead of all). So there would be autosave (if something crashes) but the hard disk is not filled up too fast.

 563 QCAD (main)Bug ReportMedium Hatches and colors transformed in Q3 Closed
Task Description

To check compatibility for the same .dxf drawing prepared with Q2, I prepared 2 copies, one with a “_Q2” suffix and the other with “_Q3”. I managed to keep an operational Q2 system on the same Win7-HomeEditionPremium-64bits PC. As you can guess, I opened each copy with the relevant QCAD version.

In each version, I selected the same hatch layer and list here their properties along with a hardcopy of a display of a similar part of the hatched area, with blue lines showing the differences in hatching, apparently the density.
Q2 : Solid:False, Scale:3.00, Angle:0, Name:ar-brelm ; the color is described in its panel as 20,255,255 and 255,85,0 (left colum first from top to bottom).
Q3 : all identical values but Scale:0.78189.

Another comparison with a global view of the same drawing. Just notice how the hatching in the areas at the bottom are different (red lines). Also, I noticed that increasing the zoom let the hatching appear in the Q3 version instaed of the grey homogenous color, but the hatching in Q3 remains more dense than in the Q2 version.
Q2 : Solid:False, Scale:1.00, Angle:0, Name:ar-conc : color is a standard grey (0,0,128 & 128,128,128)
Q3 : Solid:False, Scale:0.246063, Angle:0, Name:AR-CONC : color is qualified as “custom” even with the same values.
Both have “centimeter” as drawing units.

Then I opened another Q2 drawing with Q3. I elected to hide all layers then to show all of them. And the color hatching of some aras were then modified. See 3rd picture with all black areas. (Just changing the layers shown or hidden was enough to not allow to close the drawing without a save...).

Than you for your attention or letting me know which setting can correct the differences.

 580 QCAD (main)Bug ReportMedium Black color reverted to white color on each close Closed
Task Description


When I started Q3, I selected a White background in the initial dialog window. I opened a copy of a good Q2 file and saw that ALL entities with Q2 Black/White color where forced to be White. Andrew explains this as a mean to avoid unreadable items against the background colors. Remember I selected White as background ? I guess Black/White entities could be better kept as Black ?

Following Andrew’s advice, in Application Preferences =⇒ Graphics View, I unchecked the Auto correct black and white colors check box. The background settings is white. OK.

I went through a process of changing the White color for several layers to Black. I also had to change the color codes for the hatch areas. For instance, the hatch area layer “055_F_Murs” has “14-76-255 / 255-197-179” values in Q2. Why these values are auto corrected to “30-128-255 / 255-191-127” ?

After these changes, I saved the file, closed Q3 and opened the file again.

Catastrophique ! All “Black/White” layers were back to Black and the hatch colors were back to the “auto corrected” values.

Changing the background color to black then white seemed to solve the problem : the layers kept the Black color. Actually it was just an illusion.

Yesterday too much confident, I spent the whole day, modifying layers to Black, adding new layers also Black or custom color, checking the line weight (replacing the “default” (?) value of 0.25 mm with my preferred default value of 0,00 mm, I’ve posted on the forum about this) and so on. I saved the file, closed it.
To-day, nearly all layers have lost their colors :
- Black ones are again White,
- custom color are “auto corrected” as above for “055_F_Murs”,
- only the standard non Black/White colors are preserved, like Blue, Magenta etc.

At this point, I can’t continue using QCAD 3 with enough reliability as my color settings are always lost. This is why I qualify this bug as CRITICAL.
I don’t want to use a Black background or a Light Blue one. Why do you think all old “green on black VDU” were replaced with “black/color on white” displays, to begin by Apple ?

NB I already reported this but can’t find it in the list (maybe because I forgot to enter a summary ? No warning, happily I had a copy with Notepad), sorry for the duplicate.

 608 QCAD (main)Bug ReportMedium Page orientation can not be changed while page preview  ...Closed
Task Description

When in print-preview mode, the page orientation (portrate or landscape) can be changed using its document-preference dialog box, but it does not take effect.

 635 QCAD (main)Bug ReportMedium hatch fills wrong area, saving results in "Exception oc ...Closed
Task Description

Attached you’ll find a floor plan.

Trying to fill the walls (layer “KG_Wand”), the hatch does not fill them but the space inside the rooms.
Saving the file (with the wrong hatch) leads to

Exception occurred. Entity NOT saved: 148

in the Command Window, after re-opening the file the hatch is (as expected) not existing anymore.

 653 QCAD (main)Bug ReportMedium crash on some file operations may be Qt related Closed
Task Description

On file open selection from main menu or on output to PDF Qcad crashes


I/O error : No such file or directory
/usr/share/mime/inode/directory.xml:1: parser error : Extra content at the end of the document

 688 QCAD (main)Bug ReportMedium QCAD3: Deadlock happens during text operation when one  ...Closed
Task Description

I just use QCAD3 for the first time. I work with OpenSuse 12.2.
After having unpacked the downloaded package, I am able to start QCAD3 with the QCAD command icon.
Check shows that i used the most actual version.
Obviously no further installation steps are necessary.
I am able to draw some lines, etc.
However, when trying to select a font, I recognized that the computer hangs at least for 5 minutes.
The CPU load is about 50%, and i am not able to move the mouse and to do anything else.
During this time, sometimes there is access to disk, sometimes not.
So, in order lo cancel the hanging, i must make a hard system reboot.
Before i have entered the font selection, i have tried to look into the help options.
However, It was not possible to get the FAQs and the QCAD forum, so i am not aware about similar documented problems.
I have looked after similar bugs, using the words ‘text, font’. No similar bugs found.

 706 QCAD (main)Bug ReportMedium Part Library not displaying parts Closed
Task Description

When I open the part library, it displays a dialog saying “Updating Index”, after it finishes, none are displayed, and the filesystem bar at the top is empty, clicking on it does nothing.

 707 QCAD (main)Bug ReportMedium segmentation fault on every start - after crash Closed
Task Description

I was drawing on a drawing done in qcad2 - and now working on it in qcad3 - where I had saved it in the new dxf 2010 format (if this has any relevance) and then the computer ran out of power (old battery - I missed that I hadn’t turned on external power) - and shut down hard.

When I rebooted and tried to start qcad - it crashed on startup - giving only this output:
Debug: TIMER: 42 ms - “loading plugins”
Debug: TIMER: 459 ms - “initializing plugins”
./qcad/qcad: line 38: 2955 Segmentation fault (core dumped) LD_LIBRARY_PATH=”$DIR” “$binary” $OPT1 $OPT2 “[email protected]

I then tried removing the entire qcad-3.0.0-prof-linux-alt-x86 folder - and unpackaging the install tar.gz again.

It then started up and came to initializing plugins - 79% - and just hung - I’ve attached screenshot.

After I ctrl+c’ed it - it segfaulted and now it won’t even show the startup splash again.

I’m guessing qcad has saved some state somewhere.. but qcad hasn’t made a ~klavs/.qcad - so I don’t know where it is.

I would very much like to be able to use qcad again :(

 725 QCAD (main)Bug ReportMedium Inserting items from part library may create invalid bl ...Closed
Task Description

To reproduce:
- Create a part library item with file name “Test1 .dxf” (note the space at the end of the base name)
- Insert this part library item into a blank drawing
- Try to save the drawing
- Error “Invalid Symbol Table Name” occurs

 727 QCAD (main)Bug ReportMedium 100% CPU Usage with 3.0 Final Version. Closed
Task Description

I am continuing my testing on version 3.0 Final.

I noticed that, with 3.0 Final open, the service “syslogd” (on OSX Leopard PPC) does get CPU consumption up to 100%, making the machine unusable.

This has never happened with the RC2 version.

It’s possible to have a copy of RC2 while they investigated the problem? Unfortunately I have not kept a copy.

 739 QCAD (main)Bug ReportMedium QCAD fails to open a DXF file generated by itself Closed
Task Description

QCAD does not manage to load an DXF file created by itself (presumably, I don’t remember excactly, could be the last 2.x version). When selecting File ⇒ Open on the file in attachment, QCAD shows a pop-up reporting the following error :

Cannot open file
»‘/home/gillonr/Documents/Projects/Familly/Br.../Chambre Parents/Plans/Plan-PaterNoster.dxf’.
» Please check your access rights, the file format and file extension.

The file permissions are OK, there is no issue of disk space on the volume where the file reside or where the QCAD distribution is installed or at any other critical location. The problem does not happen on other files created with QCAD, so it appears to be data dependent.

The file causing trouble in QCAD can be imported in LibreOffice 3.4.2 w/o reporting errors (but that application does not provide the suitable methods / tools to edit this format...).

(1) Is there a way to activate debugging when reading in data from a DXF ?
(2) Is there some tool (ev. 3rd party) allowing to check that the data is clean ?
(3) Can someone identify the cause of the problem (presumably some data construct or maybe corruption) ?
(4) In case it would turn out that the problem is a QCAD bug, is there a work-around (I need these drawings...).

 847 QCAD (main)Bug ReportMedium Info - Distance PP, EP: ruler ticks too dense Closed
Task Description

Info tools show too many ticks which leads to slow down / crash.

 872 QCAD (main)Bug ReportMedium Crash in dwg2svg Closed
Task Description

Conversion of certain files leads to crashes (segmentation fault).


 875 QCAD (main)Bug ReportMedium malloc.h is deprecated Closed
Task Description

This concerns the third-party openNURBS project and should probably be reported there, but I failed to find a bug tracker or anything of the sort, so here it goes.

malloc.h is deprecated (it has not been required since at least SUSv2, ratified in 1997). Apparently FreeBSD takes a more explicit stance against the use of it than other systems. The attached patch does away with it in openNURBS (conservatively leaving it in on Linux, but that should not really be neccessary either).

This makes the openNURBS component buildable on FreeBSD (9).

 905 QCAD (main)Bug ReportMedium Text tool regression Closed
Task Description

Happened somewhere between ab3e02 (works) and 67516a (doesn’t work).

In 67516a (current HEAD), when I attempt to launch the Text tool, the following is printed on stderr:

Warning:  Script Exception:
 "ReferenceError: Can't find variable: RTextBasedData" 
Warning:  "<anonymous>()@/tmp/qcad/scripts/Draw/Text/TextDialog/TextDialog.js:838"          

The Tool options toolbar does appear and it can be interacted with. The Text tool does not appear at all (and text input in the Toolbar can not be placed either).

In ab3e02, the Text tool works as usual.

Hope I got it right this time – several clean builds have been made to double-check results.

 917 QCAD (main)Bug ReportMedium Integrated help not working Closed
Task Description

Help - Reference Manual does not have any effect on Windows.

 943 QCAD (main)Bug ReportMedium Dashed lines with line weight 0 are displayed as contin ...Closed
Task Description

When we create a draft in version 2.2.2 we put dashed lines and the length is 0. We see a dash lines. (see attach file).

When we open the same draft in the version 3.3.2 we don’t see the dashed lines we see a continous lines.

If I changed in the dxf this lines DASHED 370 0 per DASHED 370 5 and changes the preference of the drawing it’s work.

But we don’t want to open all of 180000 drawings to change the length of the dashed lines from 0 to 5. We want that the version 3 print the dashed lines as the version 2.



 953 QCAD (main)Bug ReportMedium Crash while rendering dashed lines with zero length Closed
Task Description

Line pattern factor for zero weight lines defaults to 0 which can lead to division by zero.

 954 QCAD (main)Bug ReportMedium Coordinates entered are interpreted as direct distance  ...Closed
Task Description

Entering a coordinate (e.g. 20,20) results in direct distance entry instead (angle from relative zero to mouse pointer, length 20).

 966 QCAD (main)Bug ReportMedium Print Dialog Print>Properties>Advanced is blank Closed
Task Description

Just started using v.3.4.2 under Linux Mint 14. To begin with I could not print my drawing in color. Worked out that this was due to the default printer setting (driver hpcups 3.12.6) which was Draft Grayscale. My drawing printed in color fine when I changed this. I believe that it ought to be possible to set this from within QCAD, but the dialog “Print>[printer]Properties>Advanced” is blank. Has it been disconnected somehow?

 970 QCAD (main)Bug ReportMedium Unable to save file with leading / trailing spaces in l ...Closed
Task Description

Layer and block names with leading / trailing spaces lead to exception when saving file through Teigha.

 973 QCAD (main)Bug ReportMedium Drawing outside zoom limit Closed
Task Description

When a drawing is placed in X,Y coordinates QCAD is unable to zoom to the drawing.

We use X,Y coordinates like X=182,635,000 mm Y=579,005,000 mm for the location of the constructions.

If you use Auto Zoom you get to see a small dot on the screen but as soon as you try to zoom to the drawing QCAD jumps within a certain limit and you can’t get to the drawing.

 993 QCAD (main)Bug ReportMedium QCAD fails to load drawing with message: maximum recurs ...Closed
Task Description

Since today, QCAD fails to load my drawings, with the following error message in the console:

Warning: RBlockReferenceData::getBoundingBox: maximum recursion depth reached: block: “Drukknop”

The block in question is the AREI (Belgian standard for symbols in electrical installations) symbol for a “button” light switch.
It’s a small and simple drawing (see attachment).

I’ve added a lot of these buttons in the drawing since the previous version, but there were some already present, and this never caused problems.

QCAD version: QCAD 3.4.4 Pro for Ubuntu Linux 32bit
System output: see attached file

 1017 QCAD (main)Bug ReportMedium crash when saving file with block attributes Closed
Task Description


QCAD crashes when saving a drawing that has a block attribute added.
This happens both with a block and the exploded version of the block.

Please find attached the system info, as well as an example drawing.
In this drawing, there are three boxes. The lower 2 boxes are intended to contain text attributes.

Output from the command line:
[email protected]:~/opt/qcad-3.4.5-pro-linux-x86_32$ ./qcad
Debug: RDxfPlugin::init
Debug: RHelpPlugin::init
Debug: RProScriptsPlugin::init
Debug: TIMER: 90 ms - “loading add-ons”
Debug: TIMER: 781 ms - “initializing add-ons”
Debug: checking for updates...
Warning: QSslSocket: cannot resolve SSLv2_client_method
Warning: QSslSocket: cannot resolve SSLv2_server_method
Debug: no updates available
Debug: checking for updates...
Debug: no updates available
Debug: RPluginBase: postInit: “DWG”
Debug: RPluginBase: postInit: “Pro Tools”
Debug: code page: 30
Debug: autosave skipped [08:54:14]: no modifications
./qcad: line 18: 3850 Segmentation fault (core dumped) LD_LIBRARY_PATH=”$DIR” “$binary” -style plastique “[email protected]

Kind regards,


 1018 QCAD (main)Bug ReportMedium Crash when using Draw > Polyline > Trim Segments Closed
Task Description

Draw > Polyline > Trim Segments crashes if QCAD is compiled using gcc 4.2.1 which is the case for the Mac OS X package.

 1047 QCAD (main)Bug ReportMedium Preview does not use drawing settings Closed
Task Description

See forum thread:

 1121 QCAD (main)Bug ReportMedium Draw > Polyline > Append Node(s) broken Closed
Task Description

Selecting the polyline is not possible.
Possibly related to update of DrawPolyline tool.

Showing tasks 151 - 200 of 2125 Page 4 of 43<<First - 2 - 3 - 4 - 5 - 6 - Last >>

Available keyboard shortcuts


Task Details

Task Editing