QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategoryTask TypeSeveritySummaryStatus  ascProgress
 12 QCAD (main)Feature RequestLow File Export Formats Closed
100%
Task Description

Open

Postponed

  • SQL
  • DGN
  • Google SketchUp
  • Canonical representation of DXF that would allow for meaningful diffs
  • XML representation of DXF

Not Planned

  • EMF/WMF (use SVG instead or use SVG to EMF converter)

Done

  • SVG
  • PDF
 11 QCAD (main)Feature RequestLow File: SVG Export Closed
100%
Task Description

Open

  • ExporterPG (preserve geometry)
    • Texts are exported as text tags, with ‘similar’ font
  • text
    • other formatting
      • exporter for presentation (based on paths): implemented
      • ExporterPG: TODO

Postponed

  • Global Preferences:
    • Number of generated segments for ellipses [postponed]
      • Problem: exported SVG files can be very large under certain circumstances
  • ExporterPG
    • Export layer information if possible / maybe group by layer [postponed]

Done

  • hatches
    • solid fill
    • pattern
  • text
    • line breaks
      • ExporterPG: Since line spacing is rendered differently in SVG, the used text space might be different, too.
    • position broken for some texts
 10 BookBug ReportLow Book numbering in PDF is incorrect Closed
100%
Task Description

The numbers in the book don’t match with the bookmarks numbers in the PDF as shown in Acrobat Reader.

 9 QCAD (main)Bug ReportLow RSettings.setValue() doesn't work for "GraphicsViewColo ...Closed
100%
Task Description

Context: Needed to set color settings for book images.

"GraphicsViewColors/BackgroundColor""GraphicsViewColors/MetaGridColor"

QCAD3.conf:

[email protected](\0\0\0\x7f\0\0\0\aRColor\0\x1\xff\xff\0\0\0\0\0\0\0\0\0\x2)
MetaGridColor  [email protected](\0\0\0\x7f\0\0\0\aRColor\0\x1\xff\xff\xff\xff\xfe\xfe\xfd\xfd\0\0\0\x2)

Setting the alpha channel value and the color mode for RColor doesn’t change anything.
Using view.setBackgroundColor() instead works for the background color, but not for other colors such as the meta grid color.

 8 QCAD (main)Bug ReportMedium Text Dialog: custom text height broken Closed
100%
Task Description

Custom text height cannot be set (enter closes the dialog, tab does not activate the entered text height)

 6 QCAD (main)Performance IssueMedium Auto snap near splines Closed
100%
Task Description

Move cursor near spline, e.g. when drawing line with auto snap active.

 5 QCAD (main)Bug ReportMedium print preview: paper disappears on focus out / in Closed
100%
Task Description

when changing the window focus, the paper in the print preview disappears and doesn’t come back anymore

 4 BookBug ReportMedium Book "CAD Instruction" layout issues Closed
100%
1 Task Description

Post all kind of layout issues for the book “CAD Instruction” here, e.g. overlapping text.

 3 BookFeature RequestLow Automatically generate images for "CAD Introduction" Closed
100%
Task Description

QCAD introduction Book

  • automatically generate screen shots of book in desired language
  • don’t use absolute paths in URLs
  • SVN:set up a new version for QCAD3
    1. start dialog → PNG
    2. set PNG resolution
    3. set PNG non-alpha-channel format
  • languages en/de/es/fr
  • script: $ generate_book_images.sh [en|de|es|fr]
  • Try to switch on / off antialiasing to render text / circles (whichever prints better):
 

User Reference Manual

done

  • paste/doc/description.html:
<p>
			The paste command inserts
			the entities previously copied to the
			clipboard. Paste is
...
  • ReferenceManual.js:
    • insert description HTML file under section “description”
    • save HTML files in right folder → paste/doc/Paste_de.xhtml
    • merge all HTML files to a reference manual
      • /home/martin/workspace/rsframework/support/doc/manual/qcad_user_manual.qhp
  • Iterate through all actions:
var actions = RGuiAction.getActions()
  • generate high-res PNG for every SVG tool icon:
BiLibrary.createAndSaveButton(iconSvgFile, pngFile);
  • generate some basic HTML for every tool:
<h2>[Title]</h2>
<b>Toolbar:</b>
[icon]
<b>Menu:</b> [Top menu] - [Menu entry]
<b>Hotkey:</b> [two letter code or hotkey]
 2 QCAD (main)Feature RequestLow PDF Export Closed
100%
Task Description

Add PDF export from print preview.

 350 QCAD (main)Bug ReportLow Strech function of version 3.0.0 Beta does not work (ha ...Closed
100%
Task Description

The stretch function does not work at all. I tried it in the old version 2.2.2 where it worked.

 301 QCAD (main)Bug ReportMedium Open an existing DXF file Closed
100%
Task Description

When I open a dfx file I have made from AutoCad, QC will open the file fine but then when I try to save it I get a dialog box stating that the drawing was not saved and asks if I have permission or is the disk full. Yes, I have permission and no the disk is not full.
Then when I close the dfx file and try to reopen it the second time, QC will not open the file and a dialog box reads “Cannot open file, please check your access rights, the file format and the file extension”

 1938 QCAD (main)Bug ReportMedium Segfault when trying to insert block from library (Fedo ...Closed
100%
Task Description

(base) [[email protected] qcad-3.23.0-pro-linux-x86_64]$ ./qcad
QCAD version 3.23.0
10:21:34: Debug: calling odInitialize
10:21:34: Debug: dropped global XDATA (no res buf): “ViewportCenter” 10:21:52: Debug: importing file: /home/kforrester/Resilio Sync/Technical/Process Engineering/equipment_tag_and_name.dxf
./qcad: line 9: 3844 Segmentation fault (core dumped) LD_LIBRARY_PATH=”$DIR” “$binary” “[email protected]

QCAD has unexpectedly quit.

Please use the offscreen platform plugin for headless systems
(without a running X11 server):
./qcad -platform offscreen

In addition, you might have to override the default Qt style
to prevent the loading of a native desktop style (such as GTK):
./qcad -style plastique

I have tested this in version 3.22.1 too and get the same result. Reverting all the way back to 3.13.1 results in an operable version of qcad when working on the same file and library blocks.

 1842 QCAD (main)Bug ReportLow svg export shows texts in different place Closed
100%
Task Description

Hi,

when I export a dxf draw to svg the text objects shows in a bit different place.

QCAD version is 3.21.3.14

 1835 QCAD (main)Bug ReportLow QCAD Professional crashing when trying to open .dwg fil ...Closed
100%
Task Description

Hi I am having an issue with the attached DWG file, when I try to open the file qcad opens then immediately crashes and I am unable to do anything.

Here is the event viewer log:

Faulting application name: qcad.exe, version: 3.21.3.0, time stamp: 0x5b9fbdd3
Faulting module name: MSVCR120.dll, version: 12.0.21005.1, time stamp: 0x524f83ff
Exception code: 0xc0000409
Fault offset: 0x0000000000074a30
Faulting process id: 0x1ad8
Faulting application start time: 0x01d48bbf05480557
Faulting application path: C:\Program Files\QCAD\qcad.exe
Faulting module path: C:\Program Files\QCAD\MSVCR120.dll
Report Id: fa661b18-d0df-41a8-88e9-37c2ea345bcb
Faulting package full name:
Faulting package-relative application ID:

 1816 QCAD/CAMBug ReportLow TAB function in CAM module fails  Closed
100%
Task Description

When using (adding a TAB on a radius fails).

Example:

When length of the TAB is set to 1 mm.

After export to *.nc code the code is not ok.

And then check this is NC viewer or gcode sender the length is not set to 1 mm but is smaller.

On a line this function (TAB) is correct working.

 1813 QCAD/CAMBug ReportLow CAM Export: missing G01 Closed
100%
Task Description

Trying the EleksMaker EL01 Laser router I noticed some bugs in creating pathways, rapids, tolerance and homing.

See the attached pdf

 1806 QCAD (main)Bug ReportVery Low Overlay Toolbar visibility in GUI not saved Closed
100%
Task Description

Switch “Overlay” Toolbar to visible below:
View/Toolbars and Widgets/Toolbars/View/Overlays, place the Toolbar in GUI, restart QCAD and the Toolbar is back to invisible.

 1803 QCAD/CAMBug ReportLow CAM configuration output unit fixed in inch instead of  ...Closed
100%
1 Task Description

Ij window CAM Configuration output unit appears as inch instead of mm. All parameters are in option
when create a nc file,units are in inches not in mm. unsuable and not possible to change

 1767 QCAD (main)Bug ReportVery Low Dimension Leader Closed
100%
Task Description

On print mode, the arrow not appear in the dimension

 1751 QCAD (main)Bug ReportVery Low Can't open files from terminal Closed
100%
Task Description

I have file /home/test/test.dxf . When i try open file from terminal (qcad test.dxf), i have warning “File not found”. When i write full path (qcad /home/test/test.dxf), the file opens.

 1689 QCAD (main)Bug ReportLow Issue with Block Attributes Closed
100%
Task Description

QCad 3.19.2 Professional, 64bit, Liux Mint

Case:
1. Create some block with attributes.
2. Insert this bock into “Model Space” or “Paper Space”.
3. Edit this block. Rename some Attribute names (tag, prompt).
4. And when in “Model Space” or “Paper Space” Synchronize Attributes, we have in properties old and new attributes.

 1687 QCAD (main)Bug ReportLow Invalid entry not caught in Scaling task Closed
100%
Task Description

QCAD hangs up in Scaling task when invalid value given: example .0.50
Inadvertently entering two decimal points hangs it up.

 1683 QCAD (main)Bug ReportLow Print Page Borders option does not switch to lay-out Closed
100%
Task Description

The Print Page Borders option does not switch to lay-out blocks

 1679 QCAD (main)Bug ReportLow Print Preview scale format metric/imperial selection bo ...Closed
100%
Task Description

Not sure: Bug or feature request. However - it’s right now confusing :-)

It would be nice if the scale format list would respond to the “Measurement System (for line types and hatch patterns)” setting.

If my setting is Metric:

1:1

1:2

1:5 etc etc

If my settings is imperial:

1”=1”

1”=2”

1”=4” etc etc

 1675 dwg2pdfBug ReportLow draw order incorrect using dwg2pdf to convert DXF to PD ...Closed
100%
Task Description

explicit drawing order of objects (such as sending hatch to back and bringing text to front) not respected when export to pdf used, the order of overlapping objects seems to use the order in which they were added to the drawing

this causes problems if we try to export a dxf to pdf and the hatching was drawn after some of the text

observed in Mac OSX El Capitan and Linux

 1667 QCAD (main)Bug ReportLow Problem with changing Paper Size in Drawing Preferences Closed
100%
Task Description

V3.19: In Drawing Preferences-Printing I cannot seem to get paper size change to remain. I change from A4 to A3, but this has no effect, seems stuck on A4.

I can change it in Application Preferences, but obviously this does not have an effect once I have started a new drawing.

 1633 ThemesBug ReportLow Scrollbar in dark theme Closed
100%
Task Description

The scrollbar in the dark theme remains visible when there are many levels. For example, it blocks some operations such as unlocking or blocking individual levels after you have blocked all levels.

 1615 QCAD (main)Bug ReportLow Decimal point of dimensions shown as '?', preferences p ...Closed
100%
Task Description

First. I am not able to find OS selection for macOS Sierra so I choose Mac OS X.
I noticed that when I opened my drawing, I saw dimensions on drawing showed ‘156?6’ instead of ‘156.6’ in prior version I had installed. Probably in 3.16.5

So I opened Dimension Settings page to review and found when opening Dimension Settings under Drawing Preferences,
Dimension Settings does not show. It remains blank.

Then I clicked on other settings menu item from left and clicked back on the Dimension Settings I was able to see the Dimension setting.
However; when I closed the dialog and try to open the Dimension Settings again, I am not able to see the settings page at all. Just blank. I can see other settings page fine.

One time when I was able to see the Dimension Setting, I noticed that the Separator symbol was blank. So I updated that to ‘.’ and hit OK.
The drawing still shows ‘156?6’ instead of expected ‘156.6’.

It seems the separator symbol is not being saved for some reason.

 1606 QCAD (main)Performance IssueLow Selecting 'Draw Order' halts system temporary Closed
100%
Task Description

Merely clicking on ‘Draw Order’, and usualy unintended, halts the system for several seconds up to several tens of seconds.

Intel(R) Core(TM) i7-2600K CPU @ 3.40Ghz
4,00 GB RAM installed 3,49 GB usable
32-bit Operating System
Windows 7 Professional SP1

 1585 QCAD/CAMBug ReportLow hide/show layer delay Closed
100%
Task Description

Hi !
i’m trying the new qcad/cam 3.17.1 and i have a delay when i hide and show a layer..
(linux MINT 17.2 x64)

The function is working, but the layer will hide (and show) with a delay from click on the apposite button.

The qcad 3.16.7 DON’T have this problem.. when you click on button immediately the layer disappear/show..

 1568 QCAD (main)Bug ReportLow Issues: Snaps, Trim, Green selection tool Closed
100%
Task Description

Hello,

There is some issues with the snap tool and the selection tool.The trim button only trims some lines but not all.

1. The snap tool does not let me snap to certain things when i select something. For example i will select a box and i will try to extend the corner to another entities corner but the snap is not there so its free and thus not accurate.

2. For some reason the selection tool does not allow me to select certain things. If i have two boxes overlapping and i use the selection tool (from right to left “green selection box”) it does not allow me to select what i want i have to actually click it. This is annoying when it comes to selecting specific things.

3. The trim tool does not work properly.If i want to trim the inside of a cross hair or such, it only allows me to trim the inside of one line and if i try to trim the other it deletes the complete line.

Please fix as soon as possible. Thanks

 1560 QCAD (main)Bug ReportHigh Main menu not selectable (Ubuntu 16.04, Unity) Closed
100%
Task Description

The main menu bar does not allow any selections, there is not even an underscored shortcut character shown.

 1547 QCAD (main)Bug ReportLow PDF won't print out properly Closed
100%
Task Description

Hi Andrew

I have attached a file which was drawn in QCAD, but for some reason when exported to PDF from QCAD it doesn’t print out properly,all I get is the dimensions only.

When printed direct from QCAD all is fine?

Regards

Clive

 1543 QCAD (main)Bug ReportLow Input with dead-keys broken (Linux) Closed
100%
1 Task Description

Latin characters do not work in version 3.16.5 on Linux, such as ã, õ, é, à, the curious thing is that “ç-” works. If on your machine the Latin characters that do not work are not appearing follow a bitmap for visualization.

 1535 QCAD (main)Bug ReportLow File > Save: image references of deleted images remain  ...Closed
100%
1 Task Description

by inserting and deleting many figures in the drawing the references to these figures are not excluded from the dxf / dwg file structure, if you exclude a figure and include it again, the reference is duplicated, etc .. this causes an increase of the size of the files dwg / dxf.

 1529 QCAD (main)Bug ReportLow File > Save: error if dimension text size is zero Closed
100%
Task Description

The error shown in the attached figure (print sreen) appears when you try to create a library item from the selection. Versions 3.15.5 and 3.16.4 on Windows 10 and Linux Mint; Sometimes terminates the QCad program.

 1528 QCAD (main)Bug ReportLow Block attributes: relationship with block reference los ...Closed
100%
Task Description

The blocks that are included in drawings by version 3.16.4 do not obey the rule “select attributes along with block references” while in version 3.15.5 in the same drawings and for the same blocks the rule is obeyed.
Note: Blocks already included in the previous version will enforce this rule in the new version.

 1525 QCAD (main)Bug ReportLow Block attributes: escaped unicode sequences in files no ...Closed
100%
1 Task Description

The characters in Portuguese such as “ç é â ... etc ...” are replaced by codes starting with version 3.16.x
Files created with versions of QCAD 3.15.x whose characters were correct in the Properties List when opened by QCAD 3.15.x appear in this strange way when opened in versions 3.16.x.
However, in the screen and in the extraction of the list of attributes the characters are correct.
Apparently the error only occurs in texts on the Block Properties List and Attributes.
However, you can use correctly the characters in a file created from version 3.16.x

Exemplo: “dormitory’ in portuguese is “dormitório” it’s appear like “DORMIT\U+00d3RIO” when file is opened on QCAD 3.16.x

 1515 QCAD (main)Bug ReportLow hatch fail Closed
100%
Task Description

The hatch window does not open in version 3.16.1

 1512 QCAD/CAMBug ReportLow CTR command is not working Closed
100%
Task Description

1) Tool Circle WC
2) CTR circletangent2radius

This doesn’t work between two circles !
I can make a circle that touches a line and a circle.
But I can NOT make a third circle with a given radius that touches two other circles.

All the other commands in this menu are working properly, can someone help me out ?

 1504 QCAD (main)Bug ReportLow Dimension - Aligned not working with context menu Closed
100%
Task Description

Dimension - Aligned, not working with context menu.

 1495 QCAD (main)Bug ReportLow wrong utf8 encoding|decoding Closed
100%
Task Description

QCAD Community Edition:

Hi!
I created a document at home with QCAD and added text in Russian language. The OS is OpenSuse 42.1. Now I need to edit the document at work on Windows 7 and I can’t open the document because an error appear!
I think this happend because Linux version of QCAD has put text to the document in UTF-8 in style of: 04_\U+00CD\U+00EE\U+00EC\U+00E5\U+00F0\U+00D3\U+00F7\U+00E0\U+00F1\U+00F2\U+00EA\U+00E0
but in Windows 7 codepage is Windows-1251. So I need to change QCAD to anothe software to exclude this issue because I can’t to work. QCAD error looks like: Can’t open the file.....import error!
I supposed that common software ensured me from different errors and troubles, but actually not!

Can you solve the problem?

 1494 QCAD (main)Bug ReportLow polyline offset fails ? Closed
100%
Task Description

Hi Andrew

Exploded a spline, then created a single polyline from the segments ... but I cannot offset it, to produce another one ?

Is this a bug ?

Regards

Clive

 1493 ECMAScriptBug ReportLow script processing failure using -exec Closed
100%
Task Description

I have just updated from 3.11.0 to 3.15.5. Often, I load a script with the command format ..../qcad -exec ..../dims.js Note that the script filename is dims.

* Everything is satisfactory with 3.11.0 and always has been.

* qcad-3.15.5 runs satisfactorily without an -exec switch

* qcad-3.15.5 -exec same-file-as-for-3.11.0 crashes per the attached screenshot. The screenshot has been generated by adding the -enable-script-debugger switch.

* It appears that the script dims.js runs completely, and the crash happens as the script handler terminates. The qcad window is complete with the contents defined in dims.js, also qcad is usable normally. This qcad disappears when the debugger is terminated.

* This problem is totally repeatable.

 1492 QCAD (main)Bug ReportHigh Crash when selecting polygon Closed
100%
Task Description

When trying to select the innermost square (created as a polygon) - Qcad immediately crashes.

Selection can be either a box select or by clicking on the polygon.

This happened with the latest (3v15.5.0) QCAD/CAM Pro on Linux
I have not attempted to verify problem on windows.

 1486 QCAD (main)Bug ReportLow objects layers confusion with windows clipboard copy/pa ...Closed
100%
Task Description

Hi, since the 3.9.1 (now 3.15.5) version I have this problem: when I copy / paste objects with the windows clipboard (ctr c / ctr v), some layers of pasted objects are lost.
The layers of the new objects are exchanged casually.
This is serious for a fee CAD design, i know others free with less hassle.
Thanks Pasquale

my OS version:
Windows 7 professional service pack 1 - 64-bit

my QCAD version:
Version:
3.15.5.0 (3.15.5)
Internet:
QCAD.org
Date build:
Aug 19, 2016
revision:
15ef1a1
Qt version:
5.5.1
Architecture:
x86_64
Compiler:
MSVC ++ 12.0 (2013)

 1468 QCAD (main)Bug ReportLow Custom patterns are not selectable from qcad Closed
100%
Task Description

Hi,

I added a new custom pattern into patterns/metric folder
However, even after restarting QCAD, new pattern is not showing in hatch dialog.

 1463 QCAD (main)Bug ReportLow Scaling also scales locked layers Closed
100%
Task Description

Hi,

Upon selecting and scaling multiple objects, locked layers are also scaled.

Expected:
Locked layers are unaffected by any modification commands

Workaround:
Manually unselect objects before scaling

 1385 QCAD (main)Bug ReportLow Default unit for new drawings reset to Inch on restart Closed
100%
Task Description

Application Preferences > Defaults for New Drawings > Drawing Units

Do not save new selected value, It keeps “Inch”.

Could be changed per file in Edit > Drawing Preferences. I normally use Millimeter. I have no tested in command line / automation mode.

Error tested in:
Mac OS X 10.11.2 El Capitan
Mac OX X 10.7.5 Server Lion
Windows 10 (also with QCad fresh install)

Showing tasks 1901 - 1950 of 1995 Page 39 of 40<<First - 36 - 37 - 38 - 39 - 40 -

Available keyboard shortcuts

Tasklist

Task Details

Task Editing