QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategoryTask TypeSeveritySummaryStatus  descProgress
 1856 QCAD (main)Feature RequestLow SVG import: add support for rotate transformations with ...Closed
Task Description

QCAD seems either to mishandle or ignore svg group transformations altogether.

Importing the attached file into QCAD renders the largest polygon (polygon18) to be rotated and misplaced. This is shown in actual.png. The expected result (original Inkscape renedering) is shown in expected.png.

Looking at the code of the original drawing it can be observed there is a transformation applied to the group which polygon18 is in:

   transform="rotate(-90,316.66796,298.95141)" >
      d="..." />

Removing the ‘transform’ attribute produces virtually identical (erroneous) rendering in Inkscape as well.

 1857 QCAD (main)Bug ReportLow Layer List: current layer not highlighted after collaps ...Closed
Task Description

Hi. This is a layers confusion..

I have layers:

v Layer 1
Layer 1a
v Layer 2
Layer 2a

I select (highlight) “Layer 1a” add an entity on “Layer 1a”
I select (highlight) “Layer 2a” add an entity on “Layer 2a”

I then collapse “Layer 2” and then collapse “Layer1” - in that order:

> Layer 1
> Layer 2

No layers shown highlighted.

I immediately add a 3rd entity.

I then open “Layer 2” and see that “Layer 2a” is still highlighted.

I then hide “Layer 1”

That third entity that I added is now hidden (as is the first entity that I added in “Layer 1a”) and properties show it is part of “Layer 1”, not “Layer 2a”. Seems like the third entity is added to the top layer that was last collapsed.

Even happens if I collapse “Layer 2” and then immediately expand it. Add an entity and that entity is placed in “Layer 2” even though “Layer 2a” is still highlighted.

I hope this makes sense. Not a huge issue, just a strange UI peculiarity.

Best regards
Hugh and 3.21.3 Windows 10 as updated as possible

 1858 QCAD (main)Feature RequestLow Enter measurements from drawing into line inputs Closed
Task Description

Add option to line input context menu to enter a distance from the drawing, measured from two points.
Perhaps existing measuring tools can be re-used to feedback values into line edits to avoid duplication.

See also:

 1859 QCAD (main)Bug ReportLow Modify > Stretch: dimension completely inside area not  ...Closed
Task Description

Dimension entities that lay completely within the stretch area are not moved.

See also:

 1860 QCAD (main)Bug ReportLow Rendering of nested blocks / use of negative scale fact ...Closed
Task Description

I received an ACAD file for a cinema we’re working on and the handicapped toilets were rotated 180-degrees referenced to everything (so the toilet appears to be in the hallway rather than the restroom. The handicapped toilet is part of a block with the handrails and those are in their proper place, just the toilet is rotated.

I have verified the problem on both MAC and PC versions.

The drawing appears correct in AutoCAD as well as TrueView and other programs that can read AutoCAD (that I’ve checked). This problem seems to be QCAD specific.

 1861 QCAD (main)Bug ReportLow Modify > Stretch: block references inside stretch box a ...Closed
Task Description

I know that I can’t stretch a block in Model space but a block completely inside a Blocks should move. It doesn’t works that way in

 1864 QCAD (main)Bug ReportLow File > Print Current View: multiple pages printed Closed
Task Description

Case: My last “Print preview” setting was “Multiple Pages” = 4
QCAD will remember this setting until I change it.

If I then - maybe days later - start a “Print current view” out of my drawing then QCAD will show me the current view on ONE page. Exactly what I expected. If I start the print QCAD will print on FOUR pages regarding to the last “Print preview” setting. Not what I was looking for .... :-(

Now knowing what will happen I launch “Print current view”, see my current view on ONE page, launch the “Drawing preferences”, see that FOUR is the number for pages, doesn’t change anything and cancel the dialog. NOW I can see that FOUR pages are used for the current view print.

That is confusing and it would be nice to have somehow more control over this behavior. ;-)

 1865 QCAD (main)Bug ReportLow Scaling polyline with width by negative factor removes  ...Closed
Task Description
  1. Create polyline with global width (e.g. 10)
  2. Scale polyline by factors X=-1, Y=1
  3. Polyline loses width
 1866 QCAD (main)Bug ReportLow DXF: EXTMIN/EXTMAX interchanged Closed
Task Description

In the attached drawing, the origin is at the lower left, but $EXTMAX 10 = 0, 20 = .66473 and $EXTMIN = 10 = 3.2, 20 = 0

The X value for $EXTMAX should be 3.2
The X value for #EXTMIN should be 0

the following is an excerpt from the file



 1867 QCAD (main)Bug ReportLow Can you provided a worked example for scripting (I can' ...Closed
Task Description

Please can you provided a worked example for scripting (I can’t find anything similar in the Help/Book)?

I have a 2D drawing that has a segmented circle that is divided into 12/16/20 segments etc.

I want to show this in a side 2D view e.g. there are 6/8/10 segments visible to fill in a rectangle.

I can manually calculate the distance to draw vertical “fill” lines by calculating the angle of the end of each segment. With the option to rotate the position of the lines by half/third of a segment.

A simple example with only 2 segments visible, it’s 0, 50% and 100%.
With 4 segments, it’s tan(22.5), tan(45), -tan(45) and 90 degrees that’s approximately 41%, 50%, 59% and 100%.

So the task, is to receive the coordinates of the area e.g. a rectangle, divide the rectangle into unequal smaller rectangles.

I imagine that a 3D program can do this, but I want to do something similar. Perhaps this is more easily applied - I’m new to CAD and QCAD.

 1868 QCAD (main)Bug ReportMedium Reading ellipse from DXF Closed
Task Description

Loading the appended dxf-file should show a circle and an ellipse.
The circle is ok.
The ellipse gets always an ellipse with center at (0|0),
main vertex at (1|0) and ratio of 1.

 1869 QCAD (main)Bug ReportLow QCAD Community startup failure on Linux/Qt 5.10.1 Closed
Task Description

QCAD Community, built from Git HEAD (bf30371), Linux (Ubuntu 18.04 x64), Qt 5.10.1, fresh build on a completely clean, new checkout.

Warning:  QApplication: invalid style override passed, ignoring it.
17:00:05: Debug:    RDxfPlugin::init
17:00:05: Debug:    RScriptsPlugin::init
Warning:  Cannot load translation: "qtbase_en"
Warning:  Cannot load translation: "qt_en"
Warning:  Cannot load translation: "assistant_en"
Warning:  Cannot load translation: "qt_help_en"
Warning:  Qt WebEngine seems to be initialized from a plugin. Please set Qt::AA_ShareOpenGLContexts using QCoreApplication::setAttribute before constructing QGuiApplication.
Warning:  action not found: "Scheme"
Warning:  RScriptHandlerEcma::eval: script engine exception:  "TypeError: Result of expression 'global[defaultActionClass].init' [undefined] is not a function."
Warning:  "<anonymous>() at /home/ice/w/qcad/qcad/scripts/File/OpenFile/../NewFile/NewFile.js:522\n<anonymous>(documentInterface = RDocumentInterface(0x55651e9299c0)) at /home/ice/w/qcad/qcad/scripts/File/OpenFile/../NewFile/NewFile.js:472\n<anonymous>() at /home/ice/w/qcad/qcad/scripts/File/OpenFile/../NewFile/NewFile.js:251\n<anonymous>() at /home/ice/w/qcad/qcad/scripts/File/OpenFile/../NewFile/NewFile.js:109\n<eval>() at 1\nslotTrigger() at -1\nopenFiles(args = , createNew = true) at scripts/autostart.js:209\nmain() at scripts/autostart.js:794\n<global>() at scripts/autostart.js:832"
Warning:  RScriptHandlerEcma::eval: script engine exception:  "TypeError: Result of expression 'global[defaultActionClass].init' [undefined] is not a function."
Warning:  "<anonymous>() at /home/ice/w/qcad/qcad/scripts/File/OpenFile/../NewFile/NewFile.js:522\n<anonymous>(documentInterface = RDocumentInterface(0x55651e9299c0)) at /home/ice/w/qcad/qcad/scripts/File/OpenFile/../NewFile/NewFile.js:472\n<anonymous>() at /home/ice/w/qcad/qcad/scripts/File/OpenFile/../NewFile/NewFile.js:251\n<anonymous>() at /home/ice/w/qcad/qcad/scripts/File/OpenFile/../NewFile/NewFile.js:109\n<eval>() at 1\nslotTrigger() at -1\nopenFiles(args = , createNew = true) at scripts/autostart.js:209\nmain() at scripts/autostart.js:794\n<global>() at scripts/autostart.js:832"
Warning:  At least one uncaught exception:
Warning:  "<anonymous>() at /home/ice/w/qcad/qcad/scripts/File/OpenFile/../NewFile/NewFile.js:522\n<anonymous>(documentInterface = RDocumentInterface(0x55651e9299c0)) at /home/ice/w/qcad/qcad/scripts/File/OpenFile/../NewFile/NewFile.js:472\n<anonymous>() at /home/ice/w/qcad/qcad/scripts/File/OpenFile/../NewFile/NewFile.js:251\n<anonymous>() at /home/ice/w/qcad/qcad/scripts/File/OpenFile/../NewFile/NewFile.js:109\n<eval>() at 1\nslotTrigger() at -1\nopenFiles(args = , createNew = true) at scripts/autostart.js:209\nmain() at scripts/autostart.js:794\n<global>() at scripts/autostart.js:832"
17:00:07: Debug:    "<global>() at 522"

My best guess is this was introduced sometime during last week or thereabouts (i.e. before that, Git HEAD used to work fine).

 1871 QCAD (main)Bug ReportLow View > Block List: Renaming current block does not upda ...Closed
Task Description


launch BE / Edit contents of selected block,
Pencil symbol shows that this block is now in edit mode,
launch Rename Block / rename it, confirm with ok, dialog closes,
renaming doesn’t works, pencil symbol is still on that block,
try to launch rename block again - doesn’t work anymore,
return to main drawing,
if I then select this block it will show the new name in the Property editor but not in the block list,
if I try to open this block within the block list again it doesn’t works,
if I open this block within a double-click in my drawing it will open but the pencil isn’t shown.

 1873 QCAD (main)Bug ReportLow dark theme / invisible shortcuts in tool tooltips Closed
Task Description


I noticed that
when the dark scheme has been chosen
the shortcut for any toolbar tool, shown inside tool tooltip
has color similar to the tooltip background
which makes it invisible.

QCAD version (3.22.0) revision 2ba5a26
Checked on Windos, Suse, Archlinux.

Best regards

 1874 QCAD (main)Bug ReportLow Crossing selection not working Closed
Task Description

When doing the selection shown in attached image, only horizontal line gets selected.

This only happen in some drawings. When starting a new drawing all selects as expected but when increasing complexity some lines can’t be selected using crossing selection.

If you copy/paste to new file it’s still not working, nor in other computer.

 1875 QCAD (main)Bug ReportLow Add new layer - minor issue Closed
Task Description

Create new drawing.
Add new layer (Layer 1)
Layer 0 still selected (highlighted) but new entities drawn on Layer 1

Very best

 1876 QCAD (main)Bug ReportLow Edit > Convert Drawing Unit: block array spacing Closed
Task Description

Block array column and row spacing not scaled in unit conversion.

 1879 QCAD (main)Bug ReportLow File > PDF Export: print preview unclosable Closed
Task Description

If the print preview is opened automatically using File > PDF Export, the print preview does not open correctly or is unclosable (script exception).

 1880 QCAD (main)Bug ReportLow Line only trims one end when trimmed to circle Closed
Task Description

using the trim (RM) command
the drawing has a circle with a line going through it. I want to trim the line ends to the circle with the remaining lines inside the circle.
select the circle as limiting entity.
command line says Choose entity to trim. click the line on the right side of center, the excess line on the right is properly trimmed.
command line says Choose entity to trim. Click the remaining line inside the circle on the left side of center. nothing happens.

if I exit the trim command and re-enter, now I can trim the left side of the line

 1881 QCAD (main)Bug ReportLow Layers issue resurfaces Closed
Task Description

Layers issue has returned. Add new layer and the new layer, even though active, is not highlighted although the pencil icon shows. And in some cases no layers are highlighted after the new layer is added or the wrong layer is highlighted after adding new layer. 3.22.09

 1882 QCAD (main)Bug ReportLow Found a two bugs in the formation of the text Closed
Task Description

\fGOST Common|b0|i1|c204|p34|;Text - not correctly recognized in Qcad, displays all content (with last “|”, so forms AutoCAD)
\fGOST Common|b0|i1|c204|p34;Text - normally recognized in Qcad

Line spacing (\pxsm1; \pxsm2; \pxsm3; etc.) is not recognized in Qcad:


output as:


 1883 QCAD (main)Bug ReportLow File > SVG Export: invalid SVG comments Closed
Task Description

SVG / XML output is invalid if text contains “–“.

See also:

 1884 QCAD (main)Bug ReportLow File > Bitmap Export: margins despite zero margin setti ...Closed
Task Description

A margin of 0px can still lead to a margin if width is much larger than height or vice versa.

See also:

 1885 QCAD (main)Bug ReportLow Modify > Edit Text: Text dialog messes up formatting of ...Closed
Task Description

See also:

Create text with formatting:


i.e. Capital, italic R with subscript 2 (not italic).

Edit text.

Formatting changed to (invalid):

 1891 QCAD (main)Bug ReportLow File > Import: import fails Closed
2 Task Description

I’m not able to import any dxf or dwg.

 1892 QCAD (main)Bug ReportLow weird/inconsistent text-alignment Closed
Task Description

I guess I’ve discovered a bug:

Text elements align the same no matter if “base” or “bottom” alignment is chosen. The text is “shifting” (in both cases) when the characteristic “contains glyphs that cross the base line” is changed. Same shifting also occurs with text aligned “top” with having no glyphs reaching the top-line.
I assume this isn’t the intended behaviour ...

For demonstration I attached a file where I’ve put lines (to align with) and three sample texts “as” (only “center”-glyphs), “aps” (glyph crossing base-line) and “this” (glyphs reaching top-line), each aligned with all vertical alignment-options (1-top, 2-midlle , 3-base , 4-bottom).

Hope fixing this dosen’t take too much effort.

 1893 QCAD (main)Bug ReportLow Translations not loaded during first start Closed
Task Description

See also:

 1894 QCAD (main)Bug ReportLow File > Bitmap Export: points rendered too big Closed
Task Description

See also:

The problem is related to PDSIZE being set to 0 which means “5% of drawing area height”.

 1896 QCAD (main)Bug ReportLow File > Open: Import fails for some files with layer sta ...Closed
Task Description

Layer states in DXF/DWG files may contain NULL layers (likely deleted layers). Import fails in these cases.

 1897 QCAD (main)Bug ReportHigh File - Import broken in 3.22.1 Closed
Task Description

Import of a block from a file from file - import or its related icon does not place anything on the drawing or add it to the block list.
When you open the command, the import drawing dialog appears as well as the options tool bar. Whether save as block is checked or not, nothing happens and the options tool bar closes when a file name has been selected and open is clicked on the import drawing dialog.

Dragging and dropping a file on the main screen still works

 1898 QCAD (main)Bug ReportLow Lines are broken when saved in layers. Closed
Task Description

QCAD community edition.

I use this program to generate CAM data. Whenever I save a the same text in different layers - one of the layers saved has broken lines. I have to spend hours extending and trimming each segment to reattach them.

Duplicate problem:

New file
Add some text
Explode into lines
Add layer
Add same text to same location on new layer
Explode into lines
Save file

 1899 QCAD (main)Bug ReportVery Low View > Auto zoom: zoom to invisible entities in blocks Closed
Task Description

Create and insert a block with entities on layer “0” and layer “1”.

Switch off layer “1”.

Auto zoom zooms to block boundary of all entities, including those on layer “1”.

See also:

 1904 QCAD (main)Bug ReportVery Low File > Bitmap Export: Non-plottable layers not exported Closed
Task Description

File > Bitmap Export does not export non-plottable layers.

See also:

 1906 QCAD (main)Bug ReportLow Draw > Polyline > Polyline from Segments: Converting fu ...Closed
Task Description


Full 360 degrees Arcs don’t convert correct to polylines with the methods OG and OC.
Both methods create a zero-length open type Polyline and remove the full Arc.
OG creates a Poly with 2 vertexes at the startpoint (= endpoint) and OC one with 0 (zero!) vertexes.
The firts one is selectable, the second one only with ‘Select All’//TA because there are no references.

The OL method with the same start and endpoint doens’t affect the full arc.
Neither a poly is created nor an error is generated that the method failed.

Typical the bulge of the OG method is (-)16331239353195370, the OC method has no references.
The math to calculate the bulge should result in a division by zero or an illegal function as tan(π/2).
Therefore a polyline can’t contain a 360 degrees arc by standard means.

From the OC method is known that it simplify coradial arc strings to a single arc.
This should not result in 360 degrees arcs what would result in zero-length segments.
(With CAM fuzzy things may happen at such positions)

Simplifying coradial arcs strings that would create a 360 degrees arc should result in no less then two coradial Arcs.
The OG method will then creates a open Poly with 3 vertexes, OC a closed one with 2 vertexes.

Found while fiddling around with editing CXF fonts.
CXF uses full Arcs, two half arcs and even polylines with coradial segments that forms circles are supported,
the OC closed polyline with 2 vertexes is recoded as two 180 degree Arcs (90-270&270-90).


 1909 QCAD (main)Bug ReportLow Blocks invisible when loading disappear when made visib ...Closed
Task Description

See also:

Regression caused by fix to  FS#1899 .

 1910 QCAD (main)SuggestionLow Please take a look at 1898 again Closed
Task Description

Please take a look at 1898 again. There is a problem.

 1918 QCAD (main)Bug ReportLow Splines whit control points of order 1 and 4 not select ...Closed
Task Description

Set up a spline with control points let’s say of the order 3.
Clone it 3 times with some offset in x&y.
Edit the degree property and set 1ste to 1, 2nd to 2, aso
Draw select partially from right to left.
Those of the order 1 and 4 aren’t selected.


 1919 QCAD (main)Bug ReportVery Low Wrong order XY(Z) for Ordinate Dimension in property ed ...Closed
Task Description

Win7pro Qcad Pro

In property editor
properties of an Ordinate Dimension

Without Show Z
DefPoint is displayed in order YX?

With Show Z
Origin is displayed in order XZY?
DefPoint is displayed in order YZX?
LeaderEndPoint is displayed in order ZXY?


 1921 QCAD (main)Feature RequestVery Low Add error message when requesting raster for a non-exis ...Closed
Task Description

(sorry for duplicate task, cannot remove it now)

It would be nice if QCAD spit some kind of warning message when trying to render a layer with a name that doesn’t exist (and perhaps render nothing), rather than silently rendering an empty image. :D

See https://qcad.org/rsforum/viewtopic.php?f=33&t=6453

 1924 QCAD (main)Bug ReportLow SweepAngle = 0 Closed
Task Description

Win7pro 32bit Wininstaller Qcadpro 3.23.0

Draw an arc.
Select the arc.
In Property Editor:
Set start angle to 135
Set end angle to 135

SweepAngle = */-360

edit the end angle and add “+360”, hit enter

SweepAngle = 0

An arc with zero sweep is a point.
A point is not an arc.
With the same start and end parameter an arc should have a sweep of +/-360.
As for entries by points or by angles.


 1925 QCAD (main)SuggestionLow Poly Ref Points manipulation that generates null-segmen ...Closed
Task Description

Win7pro 32bit Wininstaller Qcadpro 3.23.0

With a polyline.

Select the poly.
Pick any reference point of a vertex.
Place it on any of its neighboring vertex reference points.

A null-segment is created.
The placement can not be undone by re-picking the reference point.
Can be Undone/Redone.
The action can result from editing the vertex coordinates.
When exploding null-entities are created.

This action should delete:
- if the target is next: the picked vertex. (incl. start or end-1)
- if the target is prior: the targetted vertex. (incl. start or end-1)
- if the target is and next and prior: both the prior and the picked vertex.

As the user intentionally places any vertex reference points on:
- any excluding its neighbors:
→ the intented nature is ‘Self-Touching’, ‘Self-Crossing’ or ‘Trace-Back’.
- any of its neighbors:
→ the intention is to delete the segment(s).


 1927 QCAD (main)Bug ReportLow Drawing and printing inconsistent, with wrong/missing e ...Closed
1 Task Description

Drawing and PrintPreview are consistent, but printout differs : rectangle missing (bottom right), line missing (bottom green line) - see att. Error can be reproduced, after saves and restores.
A VERY elementary WYSIWIG-problem....

 1929 QCAD (main)Bug ReportMedium Printing Problem - Preview differs from Printout Closed
Task Description

... ? I reported this already some days ago, but the task doesn’t show up in the list? ...

Comparing ‘Drawing’ and ‘Preview’ - o.k.
Comparing ‘Preview’ and ‘Printout’ - NOT o.k. ! Elements are missing
(Rem: in the QCAD sketch itself, the missing elements are in a separate layer; however, anyway - preview should show the same image as the printout !?)


 1931 QCAD (main)Bug ReportLow File > SVG Export: hatch arc interpolation Closed
Task Description

Hatches with arc boundaries are exported as crude polygons.

See also:

 1932 QCAD (main)Bug ReportVery Low Check for update fails to discover new version Closed
Task Description

“Help→Check for QCAD Pro Updates” fails to discover new version. Tested on OSX and Linux versions.

 1933 QCAD (main)Bug ReportLow File > Advanced SVG export: file overwrite check doesn' ...Closed
Task Description

In the Advance SVG Export dialog, when I edit the filename to be different than the default file that already exists and then clear the checkbox for “Overwrite existing file without asking” just to make sure that I haven’t already created a file with the modified name as well, then I get a popup warning that the export would overwrite the default filename, not the name as edited. In other words, the overwrite check ignored the fact that I edited the filename.

Observed on MacOS Mojave (10.14), but probably applies to all.

 1935 QCAD (main)Bug ReportLow Startup preferences Closed
Task Description

Startup preferences

On Mac 10.14.6: QCAD Pro → Preferences... → Startup

Check or uncheck “Enable Splash Screen”

1. Restart of QCAD, the splash screen with Initialising add-ons xx% is identical

2. Apply, Cancel and OK buttons - why have both Apply and OK buttons?

 1936 QCAD (main)Bug ReportLow ver 3.23 not saving font information Closed
Task Description

The attached file is not saving font preference.
All fonts on the online layer are reported as the standard font. If I highlight one or all of the text entities and change the font to something like Yu gothic light, the property page reports yu gothic light and the screen reflects the changed font.
If I save, close and reload, the fonts for all text is again “standard”.

So then I try to enter new text via the “A” draw text command icon. I select “Broadway.ttf” as the main font in the text entry dialog.
One word “Broadway” is entered as the text. it appears on the upper left of the screen as expected and the font name is Broadway in the property editor. If I look at the dxf file source there is a whole bunch of text styles.
I save and close the file, and then open it again. Now the word Broadway has changed to font name “standard” in the property editor and is very definitely not the Broadway.ttf font.

I am not the originator of the file, I am just trying to change the font. If I start a new file and enter new text the font saves just fine, so I am thinking it is a setting somewhere, but I am unable to find it.

We (me and my customers) use these files for engraving so exact font is critical.

 1937 QCAD (main)Bug ReportLow Circle shown in QCAD but not in AutoCAD Closed
Task Description

The attached drawing shows two large concentric circles when viewed in QCAD but the inner circle is missing when viewed in other CAD programmes. This cost $50 in rework as my laser cutting was not cut correctly!

 1942 QCAD (main)Bug ReportLow Draw > Circle > Two tangents and point: fails for case  ...Closed
Task Description

The result of the tool CT2 depends on the position where the circle is constructed.

See also https://www.qcad.org/rsforum/viewtopic.php?f=32&t=6577&p=24772#p24772

Showing tasks 1901 - 1950 of 2192 Page 39 of 44<<First - 37 - 38 - 39 - 40 - 41 - Last >>

Available keyboard shortcuts


Task Details

Task Editing