QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategoryTask TypeSeveritySummary  descStatusProgress
 643 QCAD (main)Feature RequestLow Zooming mode of operation Closed
Task Description

I just realized, that Zoom-in and Zoom-out (with the mousewheel) works different from graphical editors I know (as soon as drawing is larger than full screen).

Graphical editor (PSP X2 (and other too I think)):
Will make the position of the cursor the center of the drawing area. Thus allowing very fast to reposition the viewable area without changing into a move mode (Hand icon) and without the rulers on the left or down of the drawing area. The reposition is very handsome!
But this solution is only half way practical: If you use the wheel twice to zoom twice in sequence without moving the cursor, it will reposition the image twice - this double reposition is not practical at all, as the second reposition is rather random!

Lets the center unchanged and just zooms-in or Zooms-out.

My proposal:
- Zoom-in or Zoom-out around the current position of the cursor
- move this current position to the center of the screen
- move the cursor itself to the center of the screen (thus avoiding to shift the image again with a subsequent zoom-operation

  1. if the user uses a second zoom-op the new center remains mostly fixed. This would allow best of both solutions:
  2. but the user is free to make an other area of the drawing the new center if he actively moves the cursor again.

I think this would be very simple, intuitive and efficient to handle, reducing the need to reposition the drawing manually a lot.

Actually I think earlier version of graphical editors I used worked with were implemented that way.

I’m not an extensive CAD user. Maybe there are special requests for this type of work that are in contradiction to my idea. Maybe it would be practical to activate this type of zooming when used along with <ALT>. Hmmm - no: Allow original QCAD-zooming with <ALT>!


By the way:
Mouse right-click seems never assigned in QCAD. In Windows a user usually expects ‘Properties’ to be activated with right-click. But I think with the clever way you implemented this, there is no real need to change this. As the standard is already broken: Why not assign permanently a ‘Move’ (Hand icon) to ‘right-click’...

2284QCAD (main)Bug ReportLowZooming in & out causes grid/snap scale value change in...Assigned
1 Task Description

I have set the grid/snap value to X=.0625 Y=.0625 on all 4 viewports.
When zooming in and out the grid/snap scale changes from .0625 to 3.90625. at this point the grid/snap points differ,
This causes a variation in the grid/snap reference points lending to drawing errors.

When I use the grid settings defaults .01, when zooming in and out, the grid/snap scaling doesn’t seem to have this issue.
Other values do, See below.

set value first zoom second zoom next zoom

	point		point		point ...	

0.01 0.1 1.0 10.0 ...
0.02 0.04 0.4 4.0 ...
0.04 0.16 1.6 16.0 ...
0.05 0.25 2.5 25.0 ...
0.0625 0.390625 3.90625 39.0625 ...
0.0254 0.64516 6.4516 64.516 ...

Why is there a squaring of the original set value? Which then becomes a new zoomed grid/snap value?

QCAD Professional
Version: (3.26.4)
Internet: QCAD.org
Build Date: Jun 3 2021
Revision: 0bb4334
Qt Version: 5.13.2
Architecture: i386
Compiler: Unknown

 1041 QCAD (main)Bug ReportLow Zoom to selection: invalid view if only one point is se ...Closed
Task Description

- Select one single point
- Zoom to selection

 1161 QCAD (main)Bug ReportLow Zoom to selection not working Closed
Task Description

Zoom to selection not working.

See attached screenshot and test file- selecting longer line fails for zoom to selection, but selecting smaller line works?

 508 QCAD (main)Feature RequestLow zoom speed option Closed
1 Task Description

Add a zoom speed option in preferences

 1764 QCAD (main)Feature RequestLow Zoom in with middle click Closed
1 Task Description

I would suggest adding a feature Inkscape has, which is that a single middle click zooms in. This is not at the detriment of panning, since the mouse/pen (I use a Wacom tablet) doesn’t move. Right now middle click doesn’t do anything so I don’t think it should be a problem.

Another awesome and related Inkscape zooming feature is that Shift+middle click shifts to window zooming. But with the added bonus that you don’t lose the tool you’re in. Try it out on Inkscape if I’m not clear!


 1245 QCAD (main)Bug ReportLow Zoom in / zoom out: drawing painted at inconsistent off ...Closed
Task Description

Zooming in or out repeatedly (keeping + or - key pressed or using mouse wheel) shows the drawing at incorrect offsets in between frames with the correct offset.

Original report:

Zoom in and out with the Mouse wheel is working but it is unfortunately jumping in a zickzack course.

 1461 QCAD (main)Bug ReportLow Zoom in / out: not centred under mouse cursor if Retina ...Closed
Task Description

see topic:

1811QCAD (main)Feature RequestLowZoom 1:1Assigned
1 Task Description

It would be nice to be able to adjust the zoom factor so that the scale on the screen matches a ruler which I lay on the screen.


 1022 QCAD (main)Bug ReportLow ZeroLengthDetection fails on arc Closed
Task Description


it seems zero length detection fails on finding very small arcs.
As in previous 3.0.0 release the script ZeroLengthDetection.js was given, I found that the related line is #65 :

      } else if (isArcEntity(entity)) {
          if (entity.getRadius() <= this.distanceTolerance

should be

      } else if (isArcEntity(entity)) {
          if (entity.getLength() <= this.distanceTolerance

because a big radius with a very small angle will yield a very small arc length ...

Since 3.0.0 or so, the ZeroLengthDetection.js script seems to have been binarized in plugins/libqcadproscripts.so, and is not easily correctible any more ...

 1557 QCAD (main)Bug ReportLow Zero length lines not shown Closed
Task Description

Zero length lines are not shown in QCAD. For best compatibility these should be shown as dots.

 1011 QCAD (main)Bug ReportLow Y,R Works only some of the time! Closed
Task Description

On a 2011 MacBook Air, the Y,R key combination for deleting layers barely works. It does in fact delete a layer occasionally, and oddly it appears to go in spurts. But it does not consistently work which significantly reduces its usefulness.

While on the matter, the reason to use YR is mostly because there is no bulk way to select a bunch of layers and delete them! This is a real pain if needing to separate layers apart (becomes some CAM programs will only accept one layer per file. We need a way to select a bunch of layers, and just delete the whole lot at one time.

 1062 QCAD (main)Bug ReportLow Xrefs are not displayed Closed
Task Description

I have a .dwg file, which has two images attached. When I open this file in qcad from the source folder with images xrefs are lost and qcad doesn’t even report about lost xrefs.

Is it possible in general to open .dwgs with xrefs in qcad?

How to fix it?

Thank you in advance!

 2064 QCAD (main)Bug ReportLow XLines in blocks appear shortened Closed
Task Description

Coming from https://www.qcad.org/rsforum/viewtopic.php?f=76&t=7148 ...

I create help lines of infinite length inside a block, layer is “helplines”, red, 0,25mm, DOT(2x). Inside the block I can see the lines at any zoom level. Leaving the block editor, the lines are getting shorter when zooming closer. Zooming far away the lines look like infinite length, zooming closer, the lines look like cut shorter, and zooming very close, the lines disappear completely.

As Husky confirmed:

Infinitive lines in blocks are displayed shortened in Model_Space. I would consider that a bug which pertains the QCAD Pro version too.
 1138 QCAD (main)Feature RequestLow Xlines (infinite lines) via 'Parallel Line' Closed
Task Description

Would it be possible to add Xline (infinite line) draw via ‘Parallel Line’ tool?

 885 QCAD (main)Bug ReportLow Xcode Clang wrongly reported as GCC Closed
Task Description

src/core/RSettings.cpp:RSettings::getCompilerVersion() doesn’t account for Clang, used in Xcode. Instead of reporting the appropriate Clang version number, it reports the GCC compatibility level. The following patch addresses the issue.

diff --git a/src/core/RSettings.cpp b/src/core/RSettings.cpp
index 46dc6df..d6fbe63 100644
--- a/src/core/RSettings.cpp
+++ b/src/core/RSettings.cpp
@@ -363,7 +363,9 @@ QString RSettings::getQtVersion() {
 QString RSettings::getCompilerVersion() {
-#if defined(Q_CC_GNU)
+#if defined(Q_CC_CLANG)
+    return QString("Clang %1.%2.%3").arg(__clang_major__).arg(__clang_minor__).arg(__clang_patchlevel__);
+#elif defined(Q_CC_GNU)
     return QString("gcc %1.%2.%3").arg(__GNUC__).arg(__GNUC_MINOR__).arg(__GNUC_PATCHLEVEL__);
 #elif defined(Q_CC_MSVC)
 #   if _MSC_VER==1310
 2187 QCAD Community EditionBug ReportLow X Scale text property is not saved Closed
Task Description

I added a link to a short video showing the issue.

In that case I set the `X Scale` property to `0.5`. When reopening the file after saving it, that property turned back to `1`. Other values (e.g. `2`) give the same result.

 1622 QCAD (main)Bug ReportLow X Scale Property lost for Simple Texts and Attributes Closed
Task Description

The X scale of block attributes, (and simple text) is not being saved with the drawing.
This problem was fixed for a while, but has re-appeared lately.

 462 QCAD (main)Bug ReportLow Wrong zoomlevel by open with double click Closed
Task Description

When i open a dxf with a double click in my windows-explorer the drawing views very very small.
(win7/64/ger, qcad3 RC3)

 1432 QCAD (main)Bug ReportLow Wrong x scale for imported texts Closed
Task Description

If text style has a text width (x scale) that is not 1, the property x scale from the text style is applied to all texts of that style.
See also:

 887 QCAD (main)Bug ReportLow Wrong warning window with area selection ... Closed
Task Description

Lower left to upper right selection which includes invisible blocks causes warning window if I try to use the clipboard “copy” or “cut” function:

“Trying to draw on or modify entities on a locked or invisible layer”

... but it works!

Upper right to lower left selection over all doesn’t calls the warning window!

 1495 QCAD (main)Bug ReportLow wrong utf8 encoding|decoding Closed
Task Description

QCAD Community Edition:

I created a document at home with QCAD and added text in Russian language. The OS is OpenSuse 42.1. Now I need to edit the document at work on Windows 7 and I can’t open the document because an error appear!
I think this happend because Linux version of QCAD has put text to the document in UTF-8 in style of: 04_\U+00CD\U+00EE\U+00EC\U+00E5\U+00F0\U+00D3\U+00F7\U+00E0\U+00F1\U+00F2\U+00EA\U+00E0
but in Windows 7 codepage is Windows-1251. So I need to change QCAD to anothe software to exclude this issue because I can’t to work. QCAD error looks like: Can’t open the file.....import error!
I supposed that common software ensured me from different errors and troubles, but actually not!

Can you solve the problem?

 395 QCAD (main)Bug ReportMedium wrong text origin when pasting scaled text and graphics Closed
Task Description

Text origins are not properly scaled when pasting text and graphics at a scale other than 1:1

 1335 QCAD (main)Bug ReportLow Wrong tangential snap point by moving an existing line  ...Closed
1 Task Description

When I try to make a tangential snap of an existing line to a circle by moving one line end to the circle, qcad snaps to a wrong snap point on the circle.

 251 QCAD (main)Bug ReportMedium wrong tab names Closed
Task Description

After I open the second file, the tab name of the first file is changed to the name of second file. After that I see two tabs with the same names but with two different files.

 1336 QCAD (main)Bug ReportLow Wrong snap points on circle Closed
Task Description

When you draw a line to a circle the offered snap points (orthogonal, tangential ...) are ok.
But if you change a line by moving an end- or startpoint qcad gives you snap points corresponding to the opposite endpoint of the line.

 1729 QCAD (main)Bug ReportLow Wrong sizes for dimensions in blocks viewed through vie ...Closed
Task Description

See also:

 170 QCAD (main)Bug ReportMedium wrong scaling for ellipses / ellipse arcs Closed
Task Description
  • see attachment
  • factor x/y: 0.5
  • green: original entities
  • red: properly scaled entities
 1716 TranslationBug ReportLow Wrong plural forms in translations Closed
1 Task Description

I found that words which has plural forms are translated in manner where only two forms are possible - like in English language. For example: “Object” and “Objects”. But other languages (for example Polish) very often have more than 2 plural forms.
There are also strings which use only one form (for example: “Reset label position of %1 dimension(s).”) but cardinal number placed in string point on more forms than one.
All these strings looks bad when translated and sometimes even in English. I mark most of them using comments:




I believe problem can be fixed using plural form strings: https://www.gnu.org/software/gettext/manual/html_node/Plural-forms.html

 888 BookBug ReportLow Wrong pictures in hands-on Closed
Task Description

In the “Drawing a Shape Using Absolute Polar Coordinates” hands-on, step 3, there are two toolbar pictures, each with a caption. The pictures don’t match the captions; ie. the pictures should be swapped.

 1919 QCAD (main)Bug ReportVery Low Wrong order XY(Z) for Ordinate Dimension in property ed ...Closed
Task Description

Win7pro Qcad Pro

In property editor
properties of an Ordinate Dimension

Without Show Z
DefPoint is displayed in order YX?

With Show Z
Origin is displayed in order XZY?
DefPoint is displayed in order YZX?
LeaderEndPoint is displayed in order ZXY?


 2113 QCAD (main)Bug ReportMedium wrong objects are selected while selecting region with  ...Closed
1 Task Description

wrong objects are selected while selecting region with mouse.
Actions:Trying to select small rectangle area using mouse while holding left mouse button. (ScreenShot_1.png)
Expected result: only objects inside selection rectangle (text, lines, rectangles) are selected.
Factual result: objects inside selection rectangle are selected as well as other objects which are farther away (marked with purple arrows in ScreenShot_2.png)

 2112 QCAD (main)Bug ReportLow wrong objects are selected while selecting region with  ...Closed
1 Task Description

wrong objects are selected while selecting region with mouse.
Actions:Trying to select small rectangle area using mouse while holding left mouse button. (ScreenShot_1.jpg)
Expected result: only objects inside selection rectangle (text, lines, rectangles) are selected.
Factual result: objects inside selection rectangle are selected as well as other objects which are farther away (marked with purple arrows in ScreenShot_2.jpg)

 1704 QCAD (main)Bug ReportLow Wrong labels for information area buttons Closed
Task Description

In Information → Arc/circle/ellipse area tool labels for Area of sector and Area of segment buttons are switched.

 851 QCAD (main)Bug ReportLow Wrong font name in DXF files created with dxflib 3.1 Closed
Task Description

dxflib 3.1 saves the text style name as style font in text styles.

 886 BookBug ReportLow Wrong coordinates in the Orthographic Projections hands ...Closed
Task Description

I have the book dating about a year back, with the following metadata (no other version information in there):

Producer:       FPDF 1.7
CreationDate:   Fri Aug 24 15:10:36 2012

I believe there is a slight error in the Orthographic Projections hands-on (it may not be there in current versions of the book, but since my download timeframe is long over, I can not check that – should that be the case, sorry for the noise).

On page 219, step 1 of the exercise (drawing the front view), it is said

Set the first corner of the rectangle at the origin of the drawing (1)
and the other corner at 30,20 (2).

On pages 225-226, steps 7 and 8, drawing a 45-degree auxiliary line for the right-side view, it is said

Set the position of the line at the origin of the drawing (coordinate 0/0).

0/0 is the “bottom left” corner of the top view. The correct coordinates for the auxiliary line’s position are 0/30, the “bottom left” corner of the front view.

(I had not realized the bug tracker had a Book category as well – hence this is a duplicate of an e-mail report I have sent to [email protected])

 812 QCAD (main)Bug ReportLow Wrong Alert messages ... Closed
Task Description

3.1 Beta / XP32

Two Points (C2),
Two Points and Angle (A2),
Two Points and Radius (CD),
ONE Mouse-click = Alert message: “The two points are identical”

Tangent two circles (LT2),
Click on first circle = Alert message: “No tangent possible”,
Click on second circle = Alert message: “No tangent possible”

1506dxflibFeature RequestLowwriteVPort parametersAssigned
Task Description

Add parameters to the function DL_Dxf::writeVPort.
This way users will be able to specify the desired viewport.

Is the github the official repository? Are pull requests sent there accepted?

 1115 QCAD (main)Performance IssueLow Windows: slow file dialogs Closed
Task Description

Windows 7 Professional 64bit SP1

File > Open shows empty dialog for 1 minute, then shows dialog contents.

 2008 QCAD (main)Bug ReportLow windows: cannot call scripts\Pro\Tools\BoundingBox\Boun ...Closed
1 Task Description

Calling bbox tool via batch file works:

C:\Program Files\QCAD>bbox.bat D:\tmp\dwgtester\10.09.03.dwg


09:42:15: Debug:

You are using a trial version of QCAD Professional.

09:42:15: Debug:    If you would like to use this software productively,
09:42:15: Debug:    please purchase the full version for a small license fee from our
09:42:15: Debug:    Online Shop at:
09:42:15: Debug:    http://www.ribbonsoft.com/shop

09:42:15: Debug:    Thank you for trying this add-on!

09:42:15: Debug:    Your script will start in 15 seconds...
09:42:30: Debug:    calling odInitialize
Min: 2419.9969114297623/-125.36162367587679
Max: 2689.9969114297623/64.63837647546899
Size: 270/190.00000015134577

Calling bbox tool directly doesn’t work:

C:\Program Files\QCAD>qcad.exe -no-gui -allow-multiple-instances -autostart scripts\Pro\Tools\BoundingBox\BoundingBox.js D:\tmp\dwgtester\10.09.03.dwg

Output (empty line):

 1328 QCAD (main)ReleaseLow Windows 64bit install dir Closed
Task Description

I only noticed today (perhaps they were available earlier?) that there are 64 bit binaries for windows; I suppose these are true 64 bit.

Yet, the installer prompts me to put them into “Programs (x86)”, where all the 32bit software lives, I guess - this seems to be a pure convention though, the application runs just fine.

Maybe the reason is, that the 32bit version was installed before; Maybe it should change? Maybe it should stay, so that there are not two?

 987 QCAD (main)Bug ReportLow Window size bigger than screen, unable to reduce it Closed
Task Description

Using the 32-bit linux .tar.gz package on Opensuse 12.3 - KDE4, it opens with a window size larger than the screen (you cannot reach the maximise, minimise icons with the mouse.
Having maximised it with the keyboard, using the mouse on the corners the window can only be stretched in the east-west dimension and remains at a fixed height. I have reverted to 3.4.2 which is fine.


 2051 QCAD (main)Bug ReportLow Window selection of rotated and aligned dimensions with ...Closed
Task Description

Please see item 1) in topic https://www.qcad.org/rsforum/viewtopic.php?f=33&t=7037 item 2) I can’t reproduce at present

Issue is about left→right selection of dimensions.

Thank you.

 861 QCAD (main)Bug ReportLow Widgets blends to early in ... Closed
Task Description

I don’t know: Bug or Feature request ....

Example: If I move the “Library Browser” with the mouse closer than ~63px to the top corner it will go to blend in.
Undo doesn’t works in this case - so I have to pull it out and re-size the widget.

Usually it should blend in if I’m over the bar or at least I have to be much closer to the corner - or not?

1863ECMAScriptFeature RequestLowWidgetFactory.saveState: save state of checkable QGroup...Assigned
Task Description

QGroupBox widgets with <property name=”checkable”> are not saved in Qcad3.conf

 124 QCAD (main)Feature RequestLow White lines in SVG Closed
Task Description

In DXF world, as far as I know, colour 7 - white - is magic, in that it shows white in model space on a black background, possibly also black on a light background, and commonly black in paper space irrespectively of background colour. In my opinion, SVG should be considered paper space.

I propose, that white entities get rendered black in SVG files exported from QCAD. What do you think?

1754QCAD (main)SuggestionLowWhen Selecting multiple blocks that contain the same at...Assigned
Task Description

When selecting multiple blocks that contain the same attribute names, attribute properties appear with the values of the last selected block instead of “various”. I do not know if this is a “bug” or developer option, but “various” would be better in my opinion.

 666 QCAD (main)Bug ReportLow When opening a qcad edited or created dwg in autocad, o ...Closed
Task Description

When opening a qcad edited or created dwg in autocad, only the first line of text is displayed for each Qcad edited or created text entry.
Qcad 3.0.0 Autocad Mac 2011
You can see that when opening the drawing in Autocad that only the First line of text is present.

 679 QCAD (main)Bug ReportLow When drawing, a "escape" does not always cancel the las ...Closed
Task Description

This problem experienced since the first beta in both Win and Linux versions.

When a function (like a line) was selected for use and one press ESC twive to get back tot he main menu, it sort of does not cancel that last function. If one wouls now press on another function (like edit or circle) QCAD goes back to the line function.

the only way to rectify this is to press Esc many times. Sometimes the process needs to be repeated more than once.

I could not yet devise a sure fire way of reproducing this, but it does seems to happen as soon as the drawing gets bigger. I could not make it work with a clean page.

Although not crippling, it does break the elegance of drawing seamlessly and is a bit frustrating..

That said, I find QCAD 3.0.0 now significanlty faster than the Betas when loading and zooming in and out.

 534 QCAD (main)Feature RequestLow Werkzeug Lengthen erweitern mit minus amount .... Closed
Task Description

Wäre schön wenn das Werkzeug “Lengthen” auch mit Minus Amounts funktionieren würde ....

Showing tasks 1 - 50 of 2290 Page 1 of 461 - 2 - 3 - 4 - 5 - Last >>

Available keyboard shortcuts


Task Details

Task Editing