QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategoryTask TypeSeveritySummary  descStatusProgress
 623 QCAD (main)Feature RequestLow C++ plugin interface Closed
Task Description

C++ plugin interface to add functionality from existing C / C++ libraries to QCAD.

 1637 QCAD (main)Bug ReportLow Buttons Layer List Widget acting on other open file  Closed
1 Task Description

With multiple files open 4 of the 5 buttons of the Layer List Widget are acting on an other file that is open instead of acting on the file in focus.
in this condition only Add Layer YA acts on the file in focus.

Not easy to reproduce.
Encountered it more frequent
after copy with ref and pasting.
with more then 2 files open.
with similar drawing file names.
Did reproduce after several hopping between files.
Usually acts on the first open file but this can be different as in the example.

workarround none; save all; close all; close Qcad; reopen and redo.

 759 QCAD (main)Bug ReportLow Button "Flip Block" doesn't remains Highlighted ... Closed
Task Description

Insert Block:

If I use the “Flip Block” option (Horizontal and/or Vertical) the Buttons doesn’t remains Highlighted. It should remain Highlighted ... ;-)

 944 QCAD (main)Bug ReportLow Build system: some dependencies are not rebuilt when ne ...Closed
Task Description

As came up towards the end of  FS#892 .

What happens is a change in src/3rdparty/dxflib/src/dl_dxf.cpp does trigger a rebuild of release/libdxflib.a, but this does not, in turn, trigger a re-link of plugins/libqcaddxf.so, a (the?) consumer of libdxflib.a.

This causes partial rebuilds to be broken (I think I got puzzled by this earlier too).

How to reproduce: on a fully built tree, `touch src/3rdparty/dxflib/src/dl_dxf.cpp’ then `make’. Nothing but libdxflib.a gets rebuilt.

 1854 QCAD (main)Bug ReportLow Build failure due to missing RZip.h Closed
Task Description

Linux, gcc:

make[4]: Entering directory '/home/ice/w/qcad/qcad/src/scripting/ecmaapi'
g++ -c -include release/qcadecmaapi -pipe -O2 -w -D_REENTRANT -fPIC -DQT_DISABLE_DEPRECATED_BEFORE=0x000000 -DQCAD_DLL -DQCADECMAAPI_LIBRARY -DQT_NO_DEBUG -DQT_PLUGIN -DQT_PRINTSUPPORT_LIB -DQT_SVG_LIB -DQT_OPENGL_LIB -DQT_HELP_LIB -DQT_UITOOLS_LIB -DQT_DESIGNER_LIB -DQT_UIPLUGIN_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_SCRIPT_LIB -DQT_SCRIPTTOOLS_LIB -DQT_SQL_LIB -DQT_XMLPATTERNS_LIB -DQT_NETWORK_LIB -DQT_XML_LIB -DQT_CORE_LIB -DQDESIGNER_EXPORT_WIDGETS -I. -I../../core -I../../core/math -I../../grid -I../../snap -I../../gui -I../../entity -I../../operations -I../../scripting -I../../stemmer -I. -Igenerated -Iadapters -I../../io/dxf -I../../spatialindex -I../../3rdparty -I/home/ice/w/qcad/qcad/src/zip -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtPrintSupport -isystem /usr/include/x86_64-linux-gnu/qt5/QtSvg -isystem /usr/include/x86_64-linux-gnu/qt5/QtOpenGL -isystem /usr/include/x86_64-linux-gnu/qt5/QtHelp -isystem /usr/include/x86_64-linux-gnu/qt5/QtUiTools -isystem /usr/include/x86_64-linux-gnu/qt5/QtDesigner -isystem /usr/include/x86_64-linux-gnu/qt5/QtUiPlugin -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtScript -isystem /usr/include/x86_64-linux-gnu/qt5/QtScriptTools -isystem /usr/include/x86_64-linux-gnu/qt5/QtSql -isystem /usr/include/x86_64-linux-gnu/qt5/QtXmlPatterns -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtXml -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -Irelease -isystem /usr/include/libdrm -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++ -o release/RScriptHandlerEcma.o RScriptHandlerEcma.cpp
In file included from RScriptHandlerEcma.cpp:372:0:
generated/REcmaZip.h:15:26: fatal error: RZip.h: No such file or directory
                 #include "RZip.h"
compilation terminated.
Makefile.Release:3622: recipe for target 'release/RScriptHandlerEcma.o' failed
make[4]: *** [release/RScriptHandlerEcma.o] Error 1

Seems to have been introduced in 854baacb, it seems.

 1177 QCAD (main)Bug ReportHigh Bugs on Win 7- 64bit Closed
Task Description

Just installed (31 jan 2015) on Win 7 64 bit. Two bugs are immediately apparent...

 bug 1 : Network drives are not listed in the file open or import dialogs - no way to access files stored on networked drives. (This is not a windows configuration error- all my other apps work perfevtly ok.)

 bug 2 : After about 5 minutes of initial exploration immediately after installation a window pops up... Trial Expired: The trial add-on CAM is no longer active (restart required).

Note: I do have neither of these problems on Windows XP (32 bit) which I installed yesterday

 1437 QCAD (main)Bug ReportLow Bug with Polyline > Offset Closed
Task Description

Spotted a bug with Polyline > Offset (OQ)

On the attached file (png image, link : http://nikel.ovh/~tukuyomi/oq_bug.png ), the white entity is a polyline (1 line, 1 arc, 1 line).
Using Polyline > Offset (OQ) with a big value (1100 in my case), I expect to get the green polyline.
What I have is the red one (also CPU is maxed for some seconds every time I move the mouse.)

1847QCAD/CAMBug ReportLowBUG MEMORYAssigned
Task Description

Hi Andrew,

Still working on creating HPGL.PLT toolpaths for the HP7580 pen plotter. QCAD has some trouble creating toolpaths. Too often it shuts itself down, or the PC gets stalled.

Recreating the same error however is possible

 1963 QCAD/CAMBug ReportLow Bug Font Standard OR Cam Config Closed
Task Description

Hallo Andrew

Confronted with a bug in font Standard glyph ”s” (small S),
and a solution.

 493 QCAD (main)Bug ReportVery Low Bug File's Name Closed
Task Description

If in the file’s name I’ve “/” (for ex. 2012/02/10) QCAD substite with “:” (2012:02:10). Regard the file’s name in the tab of QCAD.

 1105 QCAD (main)Bug ReportLow Bug - Layers lost when using Isometric Projection tool Closed
Task Description

Windows 8.1

Layers lost when using Isometric Projection tool

Test case

1.Set up layers.
2.Draw shape (I used a square).
3. Select shape and use Isometric tool (PJ).
5. Layers are lost as soon as reference point is selected.

please see screenshots:

 819 QCAD (main)Feature RequestLow Bring back option to make Hatch patterns in .dxf for QC ...Closed
Task Description

Please see topic:

 857 QCAD (main)Bug ReportLow Breakout / Autotrim not working Closed
Task Description

Windows 7-64

Please see attached a simple test to demonstrate the problem.

Breakout tool

1. When selecting the top half of the circle - the top half of the circle ‘breaks’ out as expected.
2. When selecting the bottom half of the circle - the whole circle disappears!

Autotrim tool

1. When selecting the top half of the circle - the trim seems to work.

2. When selecting the bottom half of the circle - no trim happens at all!

 256 QCAD (main)Feature RequestLow Break out segments of ellipses Closed
Task Description

Break out segments of ellipses

 731 QCAD (main)Bug ReportLow Break out segment: fails in some cases Closed
1 Task Description

See fs731.dxf

 1078 QCAD (main)Bug ReportLow Break out segment: break out last segment of ray / xlin ...Closed
Task Description


 1040 DocumentationBug ReportLow Break out Manual on Circle/Ellipse does not respect Rem ...Closed
Task Description

3.4.7 trial as well as community Git 9d3979

  • Draw a circle
  • B2
  • Make sure “Remove segment” is ticked
  • Select circle, then select two points to break out in between


  • Segment gets removed (not really, but read on)


  • Segment does not get removed, but circle is indeed broken into two arcs

Same for an ellipse.

I can see that by selecting two points on a closed circular shape it’s nigh impossible to tell which segment the user actually wants to remove :)

The documentation doesn’t mention this corner case. For clarity, a note detailing this effect a bit should be added to the docs.

On a slightly related note, I do not see why the feature couldn’t work on Polyline objects as well (with the same corner case restriction if it’s a closed polyline).

Very useful feature btw, thanks for it.

 166 QCAD (main)Bug ReportLow break out Closed
Task Description

break out for top segment of arc broken

 713 QCAD (main)Bug ReportLow Box select selects invisible blocks Closed
Task Description

Make sure that block references of hidden blocks cannot be selected.

 1305 dxflibPerformance IssueLow Bottleneck in DL_Dxf::toReal caused by std::locale Closed
Task Description

Loading any larger dxf file takes very long because of this line:

The call to std::locale is very slow. File-loading can be speed up by approximately factor 5 times on my system when replacing it. I just removed that line and instead added the following in DL_Dxf::in so it is changed only once per file:

std::locale oldLocale = std::locale::global(std::locale(”C”)); // use dot in numbers
while (readDxfGroups(fp, creationInterface)) {}

 10 BookBug ReportLow Book numbering in PDF is incorrect Closed
Task Description

The numbers in the book don’t match with the bookmarks numbers in the PDF as shown in Acrobat Reader.

 4 BookBug ReportMedium Book "CAD Instruction" layout issues Closed
1 Task Description

Post all kind of layout issues for the book “CAD Instruction” here, e.g. overlapping text.

 1592 QCAD (main)Bug ReportLow Bold in the text editor causes transaction fail. Closed
Task Description

Using the bold function (button) in the text editor causes transaction fail on new text entries. Emboldening selected text on existing text shows bold in the editor but this does not carry through to drawing or print preview views.

2245QCAD (main)Bug ReportLowBold fonted text appears regular sized - v 3.26.2Assigned
Task Description

Text that has been applied to a drawing with the ‘bold’ attribute sometimes appears as regular, un-bolded, text. When increasing the viewing magnification one will see the text adopt the bold attribute, but at smaller sizes the text appears without the bold. This can be confusing causing the draftsman to double-check whether the text had the bold attribute.

Current version: 3.26.2

Previous version: 3.22.1 (note: in this version, bolded text appeared bold at all viewing magnifications.)

396QCAD (main)Feature RequestLowBlocks: moving blocks: show bounding boxAssigned
Task Description

Blocks: moving complex blocks with drag and drop should show bounding box as preview

 1237 QCAD/CAMBug ReportMedium Blocks should be layer agnostic Closed
Task Description

I have created a block from a selection. I have then later created more items on my CAD page using that block, then later yet, moved the objects to a new layer. I noticed that while the object has accepted being on the new layer, the color hasn’t changed to the new layer’s color. I can only get the line color to change if I go into the block itself and move the individual segments of the block to that new layer, then save the new block (which, by the way, I can’t save over the existing block?!?!)

In the sample file attached, you will see that the block item in the 3 o’clock position is in layer 0, while the rest are in “Vent Holes” layer. If you make layer 0 hidden, the one block is hidden (like it should), but the block item refuses to take on the layer’s color even though the block’s color is “By Layer”

316QCAD (main)Feature RequestLowBlocks list and selected blockAssigned
1 Task Description

Wouldn’t it be nice, if selecting a block in model view would somehow highlight (just like clicking a block in the list does) the selected block in the “Block List” window?

(Feature request sounds a little harsh, enhancement proposal would seem more apt.)

 1909 QCAD (main)Bug ReportLow Blocks invisible when loading disappear when made visib ...Closed
Task Description

See also:

Regression caused by fix to  FS#1899 .

 748 QCAD (main)Feature RequestLow Blocks ... Closed
Task Description

It would be nice ...

- to be able to use " and / in Block names what is really helpful in the Inch and Fraction world ... ;-)

- the ability to overwrite an existing Block what is often much easier/faster than editing a Block ;-)

- After selecting a Block you get the info of the Block name in the Property Editor (Geometry / Referenced Block).
If I need to edit this Block I have to go to the Block List - have to search for this name because it is not marked .... and of course it is a long long list.
It would be nice to have a “Edit this Block” Button in the Property Editor / Geometry / Referenced Block dialog ... ;-)

614QCAD (main)Feature RequestLowBlocks - overwrite current layer yes/no ...Assigned
Task Description

I would appreciate an option for the library Browser that gives me the possibility to decide by my self to use the current (same name) layer in my drawing or overwrite it with the existing layers in the library item.

Imagine the possibility’s of this feature .... ;-)

 555 QCAD (main)Feature RequestLow Blöcke zählen .... Closed
Task Description

Eine Zählfunktion die erfasst wie oft ein Block in einer Zeichnung vorhanden ist.

Hintergrund ist das es damit eine Unterstützung gäbe die das erstellen von Stücklisten etc. erleichtert würde.

Die Anzahl der Blöcke könnte z.B in der Block List eingeblendet werden wie z.B.: “Schraube M6x40 (17x)” oder auch in einer extra Text Liste.
Zudem könnten so auch nicht (oder nicht mehr) benutze Blöcke ermittelt werden wie z.B. “Schraube M6x20 (0x)” welche dann aus der Zeichnung entfernt werden könnten.

Siehe auch:


 558 QCAD (main)Feature RequestLow Blöcke aus dem Editiermodus direkt in der Library speic ...Closed
Task Description

Blöcke aus dem Editiermodus direkt in der Library speichern zu können wäre eine erheblicher Arbeitsersparnis.

Wenn ich persönlich einen Block in einer Zeichnung erstelle überlege ich mir natürlich gleich ob ich diesen nicht auch in anderen Zeichnungen verwenden könnte. Somit erhalte ich leicht eine Umfangreiche Library die mein Leben leichter macht .... ;-)

 1030 QCAD (main)Bug ReportLow Block->Create Library Item Issue Closed
Task Description

I create a number of library items to create parts assemblies..

I will build a component in a drawing that has other components in its own layer then isolate the component and only select it. I then use Block→Create Library Item to create a component, set it origin and save the item.. When I open the item, there apears to be a set of duplicate lines generated. I have to select all the components and do a detect duplicates then delete them before doing anything else with the drawing.. I found this issue by trying to create a cutaway view then adding a crosshatch. The crosshatch tool does not like lines on top of lines..

2138QCAD (main)SuggestionVery LowBlock zoomstate supersedes Model_Space after Undo of BCAssigned
1 Task Description

Summary: Block zoomstate supersedes Model_Space after Undo of BC

QCAD Professional
Version: (
Internet: QCAD.org
Build Date: Oct 15 2020
Revision: 2895712
Qt Version: 5.13.2
Architecture: i386
Compiler: Unknown «< (Win installer 32 bit)

With the file provided:
ZW to see the top green ‘revision cloud’ up close
Box select around the cloud
»> 2 entities in selection
BC, select origin somewhere inside the selection, accept proposed naming
»> ‘Block 1’ is created from the selection
BD, select the newly created Block Reference
»> Auto zoom of ‘Block 1’ (Intended behavior)
»> Returns to Model_Space with the zoomstate of the removed Block
»> Halfway down the drawing
»> The former zoomstate of the Model_Space is lost

Intended behavior is that the zoomstate of Model_Space and Blocks don’t mix
See: https://www.qcad.org/rsforum/viewtopic.php?f=31&t=7797&p=30371#p30378

This proves they do, even if the block doesn’t exists anymore.


PS: 3th trial to enter a suggestion ...

 737 QCAD (main)Bug ReportLow Block with Circle - can't snap to ... Closed
Task Description

XP32 / QCAD 3.0.5

Block with Circles - can’t snap to “Reference”, Intersection.

 168 QCAD (main)Bug ReportLow block visibility Closed
Task Description

disable for now or implement

 1944 QCAD (main)Bug ReportLow Block toggle switch for visibility fails Closed
Task Description

3.23.02 Block toggle switch for visibility fails.
3.23.0 Block toggle switch for visibility works.

 1550 QCAD (main)Bug ReportLow Block references: mirrored block references in 3rd part ...Closed
Task Description

Files imported from other CAD applications might contain blocks that are mirrored if the block reference uses an inverted extrusion direction.

 1845 QCAD (main)Bug ReportLow Block reference points cannot be supressed in printer o ...Closed
Task Description

Drawing preferences have no effect on point type when printed or in print-preview for block reference points.
Notice in “print output”, the “Dot” (Block reference point) is displayed (drawing preferences are ignored).

See attached photos.

 1395 QCAD (main)Bug ReportLow Block reference not selectable Closed
Task Description

Block references to blocks with an origin other than 0,0 are not selectable.

See also:

 2262 QCAD (main)Bug ReportLow Block referece attributes are orpaned when using "edit  ...Closed
Task Description

This happens only when using “save and update” and then “close”. “save and close” works ok. See in video
Buttons for adding and removing from working set seams buggy for me when I played with them for a while (some block references completely disappear form drawing). But I am not able to describe this behavior.

 2029 QCAD (main)Bug ReportVery Low Block order issue within drawing exchange between CE an ...Closed
Task Description

If I create a dxf in Pro and open it in CE (or vice versa) the block order can change strange and a new Layout Block is occasionally added. Looks like dxf version (R15 etc.) doesn’t matters.


 1481 QCAD (main)Bug ReportLow Block List: update changes selected item Closed
Task Description

- Select a block in the block list.
- Toggle the visibility of another block or add a block, etc.
- Selected block changes

 110 QCAD (main)Bug ReportLow Block list: blocks disappear when showing hatch dialog Closed
Task Description

Block list: blocks disappear when showing hatch dialog

 939 QCAD (main)Bug ReportLow block hierarchy Closed
Task Description

The block hierarchy is lost after saving. Only one item appears in the block after reload, and it is doubled outside, too.

attached file:

Tried to put the four patches and the bar in a “Pzeile” block, this works, but after save and open, only the bar is in the block and is doubled to layer “0”.

The attached file is the destroyed version with removed doublette.

 1528 QCAD (main)Bug ReportLow Block attributes: relationship with block reference los ...Closed
Task Description

The blocks that are included in drawings by version 3.16.4 do not obey the rule “select attributes along with block references” while in version 3.15.5 in the same drawings and for the same blocks the rule is obeyed.
Note: Blocks already included in the previous version will enforce this rule in the new version.

 1525 QCAD (main)Bug ReportLow Block attributes: escaped unicode sequences in files no ...Closed
1 Task Description

The characters in Portuguese such as “ç é â ... etc ...” are replaced by codes starting with version 3.16.x
Files created with versions of QCAD 3.15.x whose characters were correct in the Properties List when opened by QCAD 3.15.x appear in this strange way when opened in versions 3.16.x.
However, in the screen and in the extraction of the list of attributes the characters are correct.
Apparently the error only occurs in texts on the Block Properties List and Attributes.
However, you can use correctly the characters in a file created from version 3.16.x

Exemplo: “dormitory’ in portuguese is “dormitório” it’s appear like “DORMIT\U+00d3RIO” when file is opened on QCAD 3.16.x

 1514 QCAD (main)Bug ReportLow Block attributes: association with block reference lost ...Closed
Task Description

Create block reference with attribute
Copy block reference and attribute

The copied attribute is now associated with the first block reference instead of the second.

 2240 QCAD (main)Bug ReportLow Block Attributes not showing on "Specific Properties" o ...Closed
1 Task Description

I just updated my QCAD to (3.26.2) version and lost the hability to edit block attributes of my sheet or in any other block.

I tried to save as the drawing and the problem persists.

When I open the block, the attribute is there and is all set in the Specific Properties, but when I exit to the Model Space to edit the Attribute text, the created attributes don’t appear on Specific Properties tab.

The use of block attributes in sheets, balloon or any block that contains text is very necessary.

 265 QCAD (main)Feature RequestLow Block Attributes Closed
1 Task Description


  • Ask user to enter block attribute values when inserting block
  • If attribute definition changes (tag changes), update attributes accordingly (note that other CAD systems don’t do this)
  • Support for multiline attributes
  • Control order of attributes (as shown to user in property editor, when inserting blocks)


  • Defining new block attribute definitions (constructing block attribute definition entities)
  • Editing block attribute definitions (property editor)
  • Synchronize attributes based on attribute definitions (position, angle, size, ...)
  • Loading block attribute definitions from DXF / DWG
  • Saving block attribute definitions to DXF / DWG
  • Loading block attributes from DXF / DWG
  • Saving block attributes to DXF / DWG

Related commands: DDATTE, ATTEDIT, ATTDEF

Showing tasks 2001 - 2050 of 2281 Page 41 of 46<<First - 39 - 40 - 41 - 42 - 43 - Last >>

Available keyboard shortcuts


Task Details

Task Editing