QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategoryTask TypeSeveritySummary  descStatusProgress
 1145 QCAD (main)Bug ReportHigh Closing inactive tab of a modified drawing: drawing fil ...Closed
Task Description

Steps to reproduce:

1. Create new drawing and fill it with some contents that’s easy to distinguish, for example text “DRAWING 1”.
2. Save it as dr1.dxf
3. Close it
4. Open dr1.dxf
5. Edit it, for example change text from “DRAWING 1” to “DRAWING 2” 6. Save changed file as dr2.dxf
7. Close it
8. Open dr1.dxf (it should have content “DRAWING 1”)
9. Open dr2.dxf (it should have content “DRAWING 2”)
10. Close tab dr1.dxf
10.1 Qcad will ask you to save changes.
10.2 Press “Yes” –> nothing happens, dialog doesn’t disappear.
10.3 Press “Discard” –> dialog disappears, tab gets closed
10.4 Tab that has content of file dr2.dxf (”DRAWING 2”) remains open but gets title “dr1.dxf” (!)
11. Close tab
12. Press “Yes” in dialog that asks to save changes

1. Open dr1.dxf
2. Open dr2.dxf
As you can see, both files have equal contents (”DRAWING 2”)

Expected results:

1. Files have their own contents.
2. Dialogs asking to save files disappear when checking “Yes”, “Cancel” or “Discard” 3. Tabs don’t change titles and associated file names when other tabs are closed.

 48 QCAD (main)Bug ReportLow Close drawing from print preview Closed
Task Description

Fails if drawing was modified and user wishes to save drawing.

 146 QCAD (main)RefactoringLow cloning entities: optional ID cloning Closed
Task Description

add parameter to REntity::clone to allow cloning without cloning object ID.

 963 QCAD (main)Bug ReportLow Clip to rectangle / clear area on block references Closed
Task Description

“Clip to rectangle / clear area” in combination with a Block will explode the Block and change all line attributes for the exploded ex-block.

Pics: Before / after using the tool.

609QCAD (main)Feature RequestLowClean up toolAssigned
1 Task Description

To have a ‘clean up ' tool to:

- eradicate duplicate lines
- eradicate stray points
- remove empty layers
- remove unused blocks

Perhaps with an initial dialog which allows the user to choose what they want to clean up.

2041QCAD (main)Bug ReportLowcircletangent2 doesn't solve correctly if the defining ...Assigned
Task Description

In my example I can’t draw a circle with circletangent2 if the defining point is on one of the defining tangents. The tangency is lost when I try to do this.

I attached 4 screenshots: TheExample.png, TryingPoint1.png, TryingPoint2.png and The_Point_Isn’t_On_The_Tangents.png.

 858 QCAD (main)Feature RequestLow Circle/Arc tangential on entities ... Closed
Task Description

I’m not sure but if this is a duplicate please delete!

Feature Request:
It would be nice to have a tool what will help to draw tangential circles and arcs between other entities.

I imagine this tools with a three entities (circles, lines) selection or two entities plus a radius.

 1800 QCAD (main)Bug ReportLow circle/arc intersection bug with line Closed
Task Description

There is a case that qcad do not detect intersection between a circle/arc and a line. Attached is an example.

 898 QCAD (main)Bug ReportLow Circle tool regression in git ec746571 Closed
Task Description

Git ec746571 introduced the following artifact:

  • Start circle tool, center and radius
  • Click on point to select radius
  • Circle appears, along with a line to the coordinate system origin; also circle is not closed at around where this ghost line hits the circle entity
  • Happens with any circle tool, in slightly different manners
  • Doesn’t happen with any other tool, as far as I can tell

100% reproducible, doesn’t happen on git 6171094d.

This ghost line is also added to existing circles; ie. opening a drawing that has circles, a ghost line is attached to each of them. Not always pointing to the origin, but seems kind of random (changes with zoom level etc.)

It doesn’t seem to be a part of the drawing as such, as in ZA will not zoom so that all these ghost lines are fully visible, but the visual artifact remains.

If relevant: Linux/amd64 (Ubuntu 12.04), Qt 4.8.1, GCC 4.6.3, and as said, QCAD git ec746571.

Lines on attached illustration were not actually drawn in any way, shape or form; also they behave as if a particular line and its corresponding circle were a block, except one end of the line is firmly attached to origin.

 1937 QCAD (main)Bug ReportLow Circle shown in QCAD but not in AutoCAD Closed
Task Description

The attached drawing shows two large concentric circles when viewed in QCAD but the inner circle is missing when viewed in other CAD programmes. This cost $50 in rework as my laser cutting was not cut correctly!

 1465 QCAD/CAMBug ReportCritical Circle is drawn as polygon Closed
Task Description


I have a circle and circle is not round.
Unit of drawing is in metres and radius is set to 2.38.
The circle displays as a polygon instead.

 852 QCAD (main)Bug ReportLow Circle hatch undo not correctly working .... Closed
Task Description

Task: Selected “all” (Circle + Hatch)
Move / Copy tool,
Reference, move/copy, place, KEEP ORIGINAL, OK,

Same scenario but DELETE ORIGINAL,
Doesn’t works correctly! :-(

 292 QCAD (main)Feature RequestVery Low Choose number of copies when using 'snap with distance  ...Closed
Task Description

Choose number of copies when using ‘snap with distance to end’.

This might make sense for certain tools only.

See also:

 1828 QCAD (main)Bug ReportLow Chinese language not loading correctly Closed
Task Description

Most of the Chinese items cannot be shown correctly. But when I check the qm files, the translation are there and the contents are correct.

I’m using the Pro version

 930 QCAD (main)Bug ReportLow Chinese font type saving problem Closed
Task Description

Dear Sir:
I am an user in Taiwan. I need to use Chinese. While editing, the font appearance can be display in view port, but after saving-closing-re-opening, the font type is missing. For example, while I type Chinese with font type “B” or “C” and save the file, the font all become font type “A” with reopening and the “Main Font” selector inside “Text” dialog window is blank. I need to re-open “Text” dialogue window and re-select font type, then click the working view port, the display of text changes. Its inconvient. In previous version it’s ok. I can’t remember the exact version of well-saving-Chinese-font function because my computer is not in my house. It might be version 3.1.x. I don’t think it’s a major problem, but could you please deal with this problem while having time.

 1932 QCAD (main)Bug ReportVery Low Check for update fails to discover new version Closed
Task Description

“Help→Check for QCAD Pro Updates” fails to discover new version. Tested on OSX and Linux versions.

 182 QCAD (main)Bug ReportLow check for new version Closed
Task Description

Check for new version of QCAD:

  • during start up
  • through menu ‘Help - Check for new version’


  • URL which contains current version number as plain text


  • request URL
  • compare versions
  • different version available:
    • minor update: you can download an update... (1st online page)
    • major update: you can purchase an update... (2nd online page)
 1571 QCAD (main)Bug ReportLow character map not showing special characters that have  ...Closed
Task Description

I use a font that changes the characters of latin and greek to technical symbols.
http://www.fontspace.com/micronus/y145m-2009 The font is installed and working okee.
But in the text tool → special characters button → others I expect to see this modified character map but instead I see the standard unicode characters.
When I use a gtk tool gucharmap I can see the character map as expected.
Now it is really combersome to enter the special characters.

2140QCAD (main)SuggestionLowChanging navigation mode for mouse wheel doesn't change...Assigned
1 Task Description

Looks like error, but may be that’s feature request.

CAD software uses typical navigation behavior as:
Wheel = Zoom; Ctrl+Wheel = Scroll up/down; Shift+Wheel = Scroll left/right.

Any other software like browsers, office software (openoffice writer, ms excel and so on), 2d paint software like GIMP (Photoshop and so on) uses other behavior:
Wheel = Scroll up/down; Ctrl+Wheel = Zoom; Shift+Wheel = Scroll left/right.

Users, that intensively use CAD and other software simultaneously prefer to make same behavior in their applications switching CAD scroll to plain mouse wheel.

QCAD’s “Application Preferences”: “Graphics View: Navigation”: “Mouse wheel/ two finger swipe”: “Scroll” allow user to assign scroll up/down to wheel mouse instead of Zoom. But there is mistake Ctrl+Wheel didn’t change to Zoom. Ctrl+Wheel continues to scroll up/down, as the wheel.
Wheel = Scroll up/down; Ctrl+Wheel = Scroll up/down; Shift+Wheel = Scroll left/right. No zoom!

Draw manipulation at this mode like a hell: you need to use wheel in conjunction with Ctrl/Shift to point draw in desired position, than move your hand to +(-) for make desired zoom.

 20 QCAD (main)Bug ReportMedium Changing drawing unit makes QCAD hangs Closed
Task Description

Changing the unit of a drawing can make QCAD hangs

  • Mile: QCAD hangs in endless loop
  • Nanometer, Microinch: view turns white, at some levels of zoom, it turns gray
  • Foot, Yard: GraphicsView grid too small meshed
 389 QCAD (main)Bug ReportMedium Changes in "Shortcuts and Commands" are not storable... Closed
Task Description

You can’t save changes in “Application Preferences > Shortcuts and Commands”!
It works only for the current session - after a restart the settings are back on default

1282QCAD (main)Feature RequestLowChangeable color of the selection bar in layer list. Assigned
1 Task Description

Changeable color of the selection bar in the layer list.
Now the color of the bar is darkblue and the underlaid icons are black and are not readable.

1651QCAD (main)Feature RequestLowChange thickness of arch tick for dimensioningAssigned
Task Description

An option in the drawing preferences to change the line thicknesses for arch ticks would be a huge plus, at the moment I am having to insert ‘arch tick’ blocks for this.

525QCAD (main)Feature RequestLowchange the printed symbol of pointsAssigned
Task Description


in QCAD3 RC2 points were printed as crosses, in QCAD3 RC4 they are printed as (very little) points. I think this isn’t a bug but a feature. ;-)

It would be nice if one could change this behaviour / select the symbol of points.

Best regards - Stefan

This is a double post of http://www.ribbonsoft.com/rsforum/viewtopic.php?p=5870#5870 as suggested there.

1810QCAD (main)Feature RequestLowChange icons from black on white to white on black depe...Assigned
1 Task Description

Automatic change of icons in the Library Browser from black on white to white on black or vice versa depending on the background (white or black; light or dark) in QCAD main window.
See also https://www.qcad.org/rsforum/viewtopic.php?f=31&p=21970#p21970

1255QCAD (main)Feature RequestLowChange a quote value modify the drawing + link quotes w...Assigned
Task Description

Change a quote value modify the drawing + link quotes with entities

In other words, makes quotes editable AND linked to entities.

  • Today in the properties, the value is read only. Being able to edit the value would modify the linked entity properties to fit the new quote.
  • Changing a property would change the linked quotes accordingly. Today, if I change a circle diameter which is quoted, the quote remain where it was and is no more relevant.
 259 QCAD (main)Feature RequestMedium Chain dimensions Closed
11 Task Description

Chain dimensions

 1077 QCAD (main)Bug ReportLow Centreline Cross using wrong Coordinate Format Closed
Task Description

My Coordinate Format/Decimal Point is adjusted to Dot’.’ but the “Centreline Cross (C,S)” will only accept Comma for Angel. X/Y works fine!

BTW: Is the spelling correct in the Menu? Should it be spelled “Centerline Cross” instead of “Centreline Cross” ...?

 1377 QCAD (main)Bug ReportVery Low CE - is asking to save an untouched drawing Closed
Task Description

If I launch the CE edition / do nothing with the empty default drawing and then try to terminate QCAD an unexpected warning pops up:

Do you want to save the changes you made in ‘Untitled 1’ ...

Hey - I haven’t change anything and there is nothing what needs to be saved ... ;-)

1469QCAD (main)SuggestionLowCartouche automatiqueAssigned
1 Task Description

Would not it be possible to create a kind of template for printing?
We draw our room without cartridge. The cartridge will automatically appear when printed. The scaling could be automatic so that it goes in the A4 and therefore also will post the scale automatically. The name of the play could be the file name, date last saved after it the rest of the information that would be to add somehow (material index, designer, ...).

Original suggestion:


Ne serait il pas possible de créer une sorte de template lors de l’impression ?
On dessine notre pièce sans cartouche. Le cartouche s’affiche automatiquement lors de son impression. La mise à l’échelle pourrais être automatique pour que ca rentre dans le A4 et donc l’échelle s’afficherai aussi en automatique. Le nom de la pièce pourrais être le nom du fichier, la date du dernier enregistrement après c’est le reste des infos qui serait à ajouter je ne sais comment (matière, indice, dessinateur, ...).

1838QCAD (main)Feature RequestLowCarbide Create importAssigned
Task Description

Add support for importing Carbide Create files (.c2d).

Format is JSON based, human readable.

 1286 QCAD (main)Bug ReportHigh Canvas flickers/flashes white when scrolling. Closed
Task Description

When scrolling quickly, the entire canvas flashes white (some kind of video buffer issue?). This includes the rulers, but excludes the scroll bars and the corner fillet at the top-left between the two rulers. Frequency of flicker is linked to speed too - the more you scroll the fast the flicker.

I’ve marked the severity high - obviously this is not a functional problem, but the strobe effect is causing headaches and may have negative affects for people with illnesses triggered by flashing light. Even with the background set to white, the flashing is still severe - when the background is set to black, it’s unbearable.

Using a Mac Pro (10.10.3) with AMD FirePro D300 2048 MB graphics and dual displays. Happens on either of the displays. Was using an August 2013 build with the issue - just upgraded to latest build and have same issue. Didn’t experience this on previous/older Mac Pro (running 10.8), so suspect it’s an issue with hardware or OS version?

 308 QCAD (main)Bug ReportHigh Cant start V3 beta 2 on debian linux 64bit Closed
Task Description

Tried the Beta on Debian 64 bit with the tarball, .. I didn’t want to use installer as I have a working qcad-

[email protected]:~/Downloads/qcad-3.0.0-beta2-trial-linux$ uname -a
Linux dolphin 2.6.39-2-amd64 #1 SMP Tue Jul 5 02:51:22 UTC 2011 x86_64 GNU/Linux


[email protected]:~/Downloads/qcad-3.0.0-beta2-trial-linux$ ./qcad-trial
#1 SMP Tue Jul 5 02:51:22 UTC 2011
./qcad-trial-bin: error while loading shared libraries: libgthread-2.0.so.0: wrong ELF class: ELFCLASS64
[email protected]:~/Downloads/qcad-3.0.0-beta2-trial-linux$

2021QCAD (main)Performance IssueVery LowCannot work with big dwg filesAssigned
Task Description

Openning a big file or doing any action in it, takes minutes to load.
Even dragging the scrollbar slightly left or right, takes mintues to redraw the canvas again, which makes QCAD un-usable for professional use.
Is there a way to make QCAD usable, after loading completed:
- Like suppressing edit until user says so,
- or taking snapshots of rendered canvases to another file and use it, as windows uses thumb.db ( for negative latency :P )

PS: I wish I could help a bit, but my hand are tied. I am just a java freak, I am opt to any idea of porting it to java, if she is still alive.

Tuğalsan Karabacak
EEE, MSc Mobile Comp & App, IWE

 2030 QCAD (main)Bug ReportLow Cannot snap to points of mirrored blocks Closed
1 Task Description

Wenn ich selbst erstellte Blocks Spiegle, funtionieren gewisse Fangpunkte nicht mehr.

In der angehängten Datei, ist der gespiegelte Block und deren inaktive Fangpunkte mit Roten Kreisen markiert.

Ich arbeite mit macOS Catalina 10.15.2

Vielen Dank für das Beheben dieses Bugs, der mich gerade sehr viel Zeit kostet ;-(

 2038 QCAD (main)Bug ReportLow Cannot snap arc / circle reference points inside blocks Closed
Task Description

- Create block with arc or circle
- Auto snap / reference snap does not snap to reference points at circle / arc max / min coordinates

 1124 QCAD (main)Bug ReportLow Cannot save linetypes with names with leading spaces Closed
Task Description

If third party files are loaded with linetype names with leading or trailing spaces, they cannot be saved.

“Invalid Symbol Table name”

 903 QCAD (main)Bug ReportLow Cannot read POLYLINE / VERTEX entities from DXF Closed
Task Description

Polylines that are stored with vertices as separate entities in DXF are not read by QCAD.

 2049 QCAD (main)Bug ReportLow Cannot print one particular file Closed
Task Description

no task description

 349 QCAD (main)Bug ReportMedium Cannot open saved files Closed
Task Description

Hi Andrew

Using Beta 3 v3 saving files to DXf 2010, DWG 2010, or even 2007 only saves succesfully some times. Most of the time I get a warning dialog stating that “Cannot open file” - no suitable importer found?

Please help


 1433 QCAD (main)Bug ReportLow Cannot open file with erased layout Closed
Task Description

See also:

 463 QCAD (main)Bug ReportLow Cannot edit drawing open with doubleclick Closed
Task Description

The buttons and menues greyed when i open a drawing with doubleclick from windows-explorer (viewer-mode?).
When qcad opened manually and doubleclick a other drawing qcad open this in edit-mode.

 1822 QCAD (main)Bug ReportCritical Cannot download old purchased QCAD due to expired link  ...Closed
Task Description


I logged in to my account, and checked my order. The link does not work anymore for the purchased item QCAD Pro.
Please help me ow can I download my Pro version QCAD.


 2212 QCAD (main)Bug ReportVery Low Cannot change f5 shortcut in preferences. Closed
Task Description

I’d like to change the f5 shortcut from rotate counter-clockwise to move/copy.

I started with a fresh QCAD3.conf

In the preferences window: general: tool settings

First time I remove f5 from rotate counter-clockwise qcad crashes.
Second run it seems to work.
I add the shortcut f5 to move/copy and restart.
The shortcut doesn’t work. And tool settings has a notice that there are conflicts.
When I change it to f3 it works.

btw the shortcut column don’t show any shortcuts. See screenshot.

 370 QCAD (main)Bug ReportLow Canceling quit leaves windows in half-closed state Closed
Task Description
  1. File - New
  2. File - New
  3. Draw line
  4. Quit
  5. Cancel
  6. Switch to first tab
 843 QCAD (main)Bug ReportLow Can't snap to reference point of a block reference Closed
Task Description

If I need to move etc. a block regarding to his reference point - I’m not able to snap to the reference point :-( All other snap points are appear as just fine working ...

 1410 QCAD (main)Bug ReportLow Can't see Layer drop down list - Property Editor > Gene ...Closed
Task Description

Version (3.14.0) 64bit

I have become used to selecting a line or shape, looking at the Property Editor, selecting the layer list and if appropriate changing the layer.

However since at least 3.13.1 The list shown is not wide enough to read the name of the layer although the colour block can be seen.

 996 QCAD (main)Bug ReportLow Can't scale controlled "Rich Text" multi Lines ... Closed
Task Description

If I have multi lines with different heights in a Rich Text the scale tool works not at all or the scale factor works different on each lines.

This example is scaled with factor 2. First line works - second line keeps the proportions.

 2095 QCAD (main)Bug ReportLow Can't Print from Q-cad in Win 10  Closed
Task Description

I can’t print from Q-cad in Win 10 latest update. Q-cad says it has sent it to the printer but does not print.
To make it work I print to a PDF file then send it to the printer. I was able to print prior to the update.

I have checked and rechecked the settings in Q-cad as well as my Firewall and printer. All other programs print ok.

I tried printing from my Win 7 computer and all works fine.

Please advise.

 1357 QCAD (main)Bug ReportMedium Can't open files with special characters in their names Closed
Task Description

When opening a .dxf file saved by QCAD with a name containing a special characters (tested with diacritics), it fails with the following message:

Cannot open file
Import failed.

How to reproduce:
1 - Save a file (content doesn’t matter, it’s the same with an empty file and a file containing data) using the name “tèst1.dxf” 2 - Try to open the file
3 - Error message

What is expected:
The file open.

Note that the problem doesn’t lie in the “save” step: the same file, once renamed to “test1.dxf” opens fine.

Showing tasks 1901 - 1950 of 2263 Page 39 of 46<<First - 37 - 38 - 39 - 40 - 41 - Last >>

Available keyboard shortcuts


Task Details

Task Editing