QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategoryTask Type  ascSeveritySummaryStatusProgress
 269 QCAD (main)Bug ReportLow Info: area: display result in dimension display format Closed
Task Description

Info: area: display result in dimension display format

See also:

 270 QCAD (main)Bug ReportLow Line type scaling Closed
Task Description

Line type scaling


 271 QCAD (main)Bug ReportLow Print Preview problem with an imported drawing Closed
Task Description

Frozen window in print preview.
Message QT Script Debugger:

Error Log: So 18. Sep 13:31:25 2011 Uncaught exception at C:/Programme/QCAD 3 Beta2/scripts/Snap/RestrictHorizontal/../..\WidgetFactory.js:441: Error: cannot access member `objectName’ of deleted QObject

Console: Welcome to the Qt Script debugger.
Debugger commands start with a . (period).
Any other input will be evaluated by the script interpreter.
Type “.help” for help.

Uncaught exception at C:/Programme/QCAD 3 Beta2/scripts/Snap/RestrictHorizontal/../..\WidgetFactory.js:441: Error: cannot access member `objectName’ of deleted QObject
441 if (isNull(c.objectName) || c.objectName==”“) {

To exit only possible with the Windows Task Manager!

 272 QCAD (main)Bug ReportLow Exception Linux Closed
Task Description

Welcome to the Qt Script debugger.
Debugger commands start with a . (period).
Any other input will be evaluated by the script interpreter.
Type “.help” for help.

Uncaught exception at C:/Programme/QCAD 3 Beta2/scripts/File/PrintPreview/../..\library.js:635: Error: cannot access member `objectName’ of deleted QObject
635 if (!isNull(child.objectName) && child.objectName != ““) {

 273 QCAD (main)Bug ReportLow Opening files drawn in previous versions, with layers t ...Closed
Task Description

When opening a multi layered file, which has been saved in a previous version with some layers turned off, the following happens:

The file is loaded, all layers are shown as switched on.
The view contains only those layers that were switched on when previously saved.


If the file is loaded with all layers turned on, then saved (all within beta3-2)
then upon reopening:-

The file is loaded and the layers are shown with status as saved.
The view is as expected showing just the ‘on’ layers.

If all the layers are then switched on, the view is unchanged.

 274 QCAD (main)Bug ReportLow previous tab is renamed by the new opened file Closed
Task Description

When opening a new tab, previous tab is renamed by the new opened file.

Tested on Ubuntu Natty amd64

 276 QCAD (main)Bug ReportLow Hatch not working if 'island' is a block Closed
Task Description

If a simple polygon is drawn and a rectangle created within it; the whole then selected and hatch applied; hatching works as expected. The hatching is within the polygon but not within the rectangle.

If the rectangle is made into a block, then hatching does not work at all when the block is included in the selection. If the block is not selected and the polygon is, then all within the polygon is hatched, including the block.

 278 QCAD (main)Bug ReportLow ECMAScript: all scripts should be read as UTF-8 Closed
Task Description

Scripts that are included through the ECMAScript include function are read with a default constructed QTextStream. UTF-8 should be forced.

 280 QCAD (main)Bug ReportLow dxf import: vertical text position Closed
Task Description

see 404011_0310_001.dxf

 281 QCAD (main)Bug ReportLow dxf import: show paper space by default Closed
Task Description

dxf import: show paper space by default if whole drawing is constructed on paper space or read ‘current block’ from sxf if available.

 282 QCAD (main)Bug ReportLow dxf import: single line text: diameter, plus minus, ... Closed
Task Description

dxf import: single line text: diameter, plus minus, degree shown as c, p, %%d

 283 QCAD (main)Bug ReportLow property editor: shift - left arrow to select broken Closed
Task Description

property editor: shift - left / right arrow to select in line edit broken (hot key for next / prev tab)

 289 QCAD (main)Bug ReportLow Extra (superfluous) reference points show with text fro ...Closed
Task Description

Dear Andrew,

When I open a dxf file created by QCad2 in QCad3 I see extra reference points to the right when selecting the text. I assume that these reference points have no function. Refer to attached dxf file.

Regards, Rutger

 290 QCAD (main)Bug ReportLow Arrow on Leaders do not scale  Closed
Task Description

I consider this a bug or at least poor software design.

When I edit the drawing preferences and change the arrow size (under the Dimensions tab), the arrows of my dimensions change as expected, but those of the leaders to not change.

No drawing preference exists to adjust the leaders separately, and scaling a leader does not scale its arrow. I currently must delete my leaders and redraw them completely to change the arrow size. Very inconvenient.

P.S. I’m using QCad (Community Edition) and didn’t see that version in your list. Does it have another name?

 291 QCAD (main)Bug ReportLow Tangent Point - Circle Closed
Task Description


 294 QCAD (main)Bug ReportLow Printing: Exception: page tags Closed
Task Description

Uncaught exception at C:/DISEGNO/QCAD Professional/scripts/File/PrintPreview\Print.js:345: Error: QFont::QFont(): could not find a function match; candidates are: QFont() QFont(QFont arg1) QFont(QFont arg1, QPaintDevice pd) QFont(String family, int pointSize, int weight, bool italic)

 295 QCAD (main)Bug ReportLow SEGFAULT in Plugin.prototype.initDoc() Closed
Task Description


 * \internal Called once on startup.
 */// TODO crashes under OpenSUSE 11.4


Thread [1] 31002 (Suspended : Signal : SIGSEGV:Segmentation fault)	
	strncmp() at 0xb505089a	
	__xmlParserInputBufferCreateFilename() at xmlIO.c:2,525 0x92c27b9	
	xmlParserInputBufferCreateFilename() at xmlIO.c:2,559 0x92c284a	
	xmlNewInputFromFile() at parserInternals.c:1,549 0x9285697	
	xmlDefaultExternalEntityLoader() at xmlIO.c:3,881 0x92c45fd	
	xmlLoadExternalEntity() at xmlIO.c:3,941 0x92c46f6	
	xsltDocDefaultLoaderFunc() at documents.c:85 0x922b0d9	
	xsltParseStylesheetFile() at xslt.c:6,726 0x9224da3	
	RXslt::parseStylesheet() at RXslt.cpp:14 0x9212ce7	
	REcmaXslt::parseStylesheet() at REcmaXslt.cpp:196 0x8dff0e4	
	QScriptEngine::evaluate() at 0xb6bba46f	
	RScriptHandlerEcma::eval() at RScriptHandlerEcma.cpp:775 0x87d1bf4	
	RScriptHandlerEcma::doScript() at RScriptHandlerEcma.cpp:771 0x87d1ad8	
	RScriptHandler::init() at RScriptHandler.cpp:31 0x8f9bf9e	
	main() at main.cpp:218 0x87cb5bf	


#ifdef HAVE_ZLIB_H
	if ((xmlInputCallbackTable[i].opencallback == xmlGzfileOpen) &&
		(strcmp(URI, "-") != 0)) {
	    if (((z_stream *)context)->avail_in > 4) {
	        char *cptr, buff4[4];
		cptr = (char *) ((z_stream *)context)->next_in;
		if (gzread(context, buff4, 4) == 4) {
		    if (strncmp(buff4, cptr, 4) == 0)
===>		        ret->compressed = 0;
		        ret->compressed = 1;

 296 QCAD (main)Bug ReportLow Segmentation Fault: Mac OS X: Print Preview Closed
Task Description

Thread 0 Crashed: Dispatch queue: com.apple.main-thread
0 libobjc.A.dylib 0x9392df87 objc_msgSend + 23
1 QtGui 0x05006ceb -[QCocoaWindow sendEvent:] + 267
2 com.apple.AppKit 0x902b760b -[NSApplication sendEvent:] + 6431
3 QtGui 0x0500a3ed -[QNSApplication sendEvent:] + 93
4 com.apple.AppKit 0x9024b253 -[NSApplication run] + 917
5 QtGui 0×05014481 QEventDispatcherMac::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) + 1505
6 QtCore 0x04d60941 QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) + 65
7 QtCore 0x04d60c8a QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) + 170
8 QtCore 0x04d620e6 QCoreApplication::exec() + 182
9 ...ript_core_debug.1.0.0.dylib 0x1dec391e qtscript_QCoreApplication_static_call(QScriptContext*, QScriptEngine*) + 1316 (qtscript_QCoreApplication.cpp:314)
10 QtScript 0x04af8318 QScript::FunctionWrapper::proxyCall(QTJSC::ExecState*, QTJSC::JSObject*, QTJSC::JSValue, QTJSC::ArgList const&) + 136
11 QtScript 0x04a10871 QTJSC::NativeFuncWrapper::operator()(QTJSC::ExecState*, QTJSC::JSObject*, QTJSC::JSValue, QTJSC::ArgList const&) const + 113
12 QtScript 0x049e5ac9 cti_op_call_NotJSFunction + 489
13 ??? 0x202e626f 0 + 539910767
14 QtScript 0x0499d057 QTJSC::Interpreter::execute(QTJSC::EvalExecutable*, QTJSC::ExecState*, QTJSC::JSObject*, int, QTJSC::ScopeChainNode*, QTJSC::JSValue*) + 1031
15 QtScript 0x0499d351 QTJSC::Interpreter::execute(QTJSC::EvalExecutable*, QTJSC::ExecState*, QTJSC::JSObject*, QTJSC::ScopeChainNode*, QTJSC::JSValue*) + 97
16 QtScript 0x04aca7b6 QScriptEnginePrivate::evaluateHelper(QTJSC::ExecState*, long, QTJSC::EvalExecutable*, bool&) + 582
17 QtScript 0x04acb011 QScriptEngine::evaluate(QString const&, QString const&, int) + 801
18 com.ribbonsoft.qcad 0x0003868b RScriptHandlerEcma::eval(QString const&, QString const&) + 57
19 com.ribbonsoft.qcad 0x00037c6f RScriptHandlerEcma::doScript(QString const&, QStringList const&) + 805
20 com.ribbonsoft.qcad 0x009c3b8d RScriptHandler::init(QString const&, QStringList const&) + 641
21 com.ribbonsoft.qcad 0x0002f4b8 main + 3878 (main.cpp:218)
22 com.ribbonsoft.qcad 0x0002e289 _start + 208
23 com.ribbonsoft.qcad 0x0002e1b8 start + 40

 299 QCAD (main)Bug ReportLow Text of rotated dimensions in SVG PG export Closed
Task Description

Sometimes the text of a dimension (that is in a block - just a suspicion of mine) will not get rotated. I do not know why this.text.getAngle() sometimes returns a wrong value, but there is a simple workaround: always rotate the text with the dimension:

--- SvgExporterPG-orig.js	2011-09-15 23:11:40.000000000 +0200
+++ SvgExporterPG.js	2011-10-07 13:07:03.715374911 +0200

@@ -428,9 +427,7 @@
         // dimension entity: export text:
         this.text = entity.getTextData();
-//        var angle = this.text.getAngle();
-//        var offset = RVector.createPolar(this.text.getHeight()/2, angle + Math.PI/2);
-//        this.text.move(offset);
+        this.text.setAngle(entity.getAngle());
         this.textColor = entity.getColor();
         this.text = undefined;
 300 QCAD (main)Bug ReportLow Dashed lines in SVG PG export Closed
Task Description

Chat from  FS#194  singled out, so that can be closed.

Dash patterns in BETA2 are very much out of proportion. BETA2 always PG exports 1:1 and only scales strokes so that in the final rendering they match what a technical drawing would show. As dash patterns depend on stroke, both current stroke and final scale have to be brought in accord.

The patch below also restores the alignment of dashes, so that dashed lines do not end in a gap, at least in most occasions.

--- SvgExporterPG-orig.js	2011-09-15 23:11:40.000000000 +0200
+++ SvgExporterPG.js	2011-10-07 13:28:04.085376719 +0200
@@ -384,32 +384,29 @@
         continuous = true;
     if (!continuous) {
-        //p.scale(this.getPatternFactor());
-        p.scale(1/this.scale);
+        // dash and gap lengths are to be proportional to line weight
+        // beware: line weight unit is 100 times millimeters, convert to current unit
+        // beware: the viewer scales lengths differently from weight
+        p.scale(RUnit.convert(this.weight / 100.0, RS.Millimeter, this.svgUnit) / this.scale);
         var num = p.getNumDashes();
-        var str = "";
+        var str = [];
         for ( var i = 0; i < num; ++i) {
             var len = Math.abs(p.getDashLengthAt(i));
-            // see FS#192:
-            //len = this.convert(len);
-            str += "" + len;
-            if (i < num - 1) {
-                str += ",";
-            }
-        }
-        additionalStyles += "stroke-dasharray:" + str;
-        // does more harm than good
-//        if (isShape(this.shape)) {
-//            var length = this.shape.getLength();
-//            if (isNaN(this.offset)) {
-//                this.offset = this.getPatternOffset(length, p);
-//            } else {
-//                var num = Math.ceil(this.offset / p.getPatternLength());
-        //                this.offset -= num * p.getPatternLength();
-        //            }
-        //            additionalStyles += ";stroke-dashoffset:" + this.offset;
-        //        }
+            str.push(len);
+        }
+        additionalStyles += "stroke-dasharray:" + str.join(",");
+        // center dash-array
+        if (isShape(this.shape) && isFinite(this.shape.getLength())) {
+            var length = this.shape.getLength();
+            if (isNaN(this.offset)) {
+                this.offset = -this.getPatternOffset(length, p);
+            } else {
+                var num = Math.ceil(this.offset / p.getPatternLength());
+                this.offset -= num * p.getPatternLength();
+            }
+            additionalStyles += ";stroke-dashoffset:" + this.offset;
+        }
 303 QCAD (main)Bug ReportLow Hatch with spline boundary Closed
Task Description

If spline boundary has fit points, hatch is loaded with visible inaccuracy.

 307 QCAD (main)Bug ReportLow Library Browser DB File Locked Closed
Task Description

Handle situation in which DB file is locked (from previous crash, ...).

Currently, the debugger is shown repeatedly.

 314 QCAD (main)Bug ReportLow Polyline from segments puts result in layer 0 Closed
Task Description

A polyline or polygon created from segments always ends up in layer 0, shouldn’t it stay in the same layer as the segments have been?

 317 QCAD (main)Bug ReportLow Debugger with -always-load-scripts Closed
Task Description

Starting qcad Beta 3 with command line argument -always-load-scripts will bring up debugger:

Uncaught exception at /opt/qcad-3.0.0-beta3-prof-linux/scripts/library.js:2: RangeError: Maximum call stack size exceeded.
2 include(”sprintf.js”);

 318 QCAD (main)Bug ReportLow Text of dimensions label in SVG PG export  Closed
Task Description

The labels of dimensions in PG exporter are moved half text-height. Thats a bit much, and actually, no such movement looks more true to the display of same in QCAD itself.

--- SvgExporterPG.js.orig	2011-10-15 18:57:29.994666881 +0200
+++ SvgExporterPG.js	2011-10-15 18:57:39.284666834 +0200
@@ -434,7 +434,7 @@
         var angle = this.text.getAngle();
-        var offset = RVector.createPolar(this.text.getHeight()/2, angle + Math.PI/2);
+        var offset = RVector.createPolar(0, angle + Math.PI/2);
         this.textColor = entity.getColor();
 322 QCAD (main)Bug ReportLow Line type scaling with print scale factor Closed
Task Description

In QCAD 2, line type patterns are scaled according to the print preview drawing scale, also in model space.
This is not the case in QCAD 3 and possibly needs a different solution.

Possible solutions:

  • two different LTSCALEs for model space and print preview
  • same behavior as QCAD 2
 325 QCAD (main)Bug ReportLow Layer renaming: changing name from lower case to upper  ...Closed
Task Description

Layer renaming: changing name from lower case to upper case

 328 QCAD (main)Bug ReportLow Persistent selections Closed
Task Description

Preference for persistent selections

 330 QCAD (main)Bug ReportLow Text Edit command replaces \U+00B0 with %%[dD] Closed
Task Description

when editing text which contains the degree symbol the proper escape sequence is \U+00B0
Qcad 3Beta3 replaces \U+00B0 with %%[dD]

 331 QCAD (main)Bug ReportLow Snap buttons doubled Closed
Task Description

1. For some reason on the Window machine, the snap toolbar buttons are doubled for all functions. I therefore have two buttons for each type of snap and cannot access the bottom snaps unless I undoc the toolbar.

For some reason, this is still fine in the Linux Beta 3. Single buttons like always.

Reported by: koosjr

 333 QCAD (main)Bug ReportLow Add layer: new layer should be active one Closed
Task Description

Add layer: new layer should be active one

 336 QCAD (main)Bug ReportLow Tool bars with tools without icon Closed
Task Description

Some tool bars (e.g. ‘Block’ tool bar) contain tools without an icon (empty button).
Not all tools are available in tool bars.

 345 QCAD (main)Bug ReportLow unit foot: no dotted line Closed
Task Description

can’t make a dotted line on a drawing with unit foot.

  • drawing unit: foot (length taken from a actual architecture plan)
  • layer settings: as shown in the screen shot
  • selected line is on layer “dotted”
  • line types is shown as continues for almost everything
 350 QCAD (main)Bug ReportLow Strech function of version 3.0.0 Beta does not work (ha ...Closed
Task Description

The stretch function does not work at all. I tried it in the old version 2.2.2 where it worked.

 351 QCAD (main)Bug ReportLow Simple text: position, simple text flag Closed
Task Description

Simple text tool does not create simple text but mtext.
When changed to simple in property editor, position does not work

 352 QCAD (main)Bug ReportLow Info Tool, Polygonal Area shows decimal units instead o ...Closed
Task Description

Drawing preferences / dimension = Fraction

Info Tool, Polygonal Area shows decimal units instead of fractions.

 353 QCAD (main)Bug ReportLow Relative Angle / Line Orthogonal caused malfunction in  ...Closed
Task Description

After using Line “Relative Angle” or “Line Orthogonal” the Toolbar is in a loop without showing all the Cad tools such as “Modify” “Hatch” etc..
Escape switch only between the “Lines Menu” and the “Select Menu”. To get all Cad Tools back you have to restart QCad.

 354 QCAD (main)Bug ReportLow Property Editor / Select Layer Malfunction Closed
Task Description

To change the postfix for dimension.
Situation: New drawing, Dimension in Drawing, Dimension on one Layer. Menu > Select > Select Layer and click on a dimension. Went to Property Editor > Geometry > Label and change the Label in <>”. Nothing happens.

The same procedure with a other kind of selection works and it works also in the

 357 ECMAScriptBug ReportLow include should raise exception if file not found Closed
Task Description

include() should raise exception if file not found.

This is actually the case but does not seem to work properly.

 361 QCAD (main)Bug ReportLow New from template: save saves template Closed
Task Description

- New from template
- Choose template
- File - Save

→ Template is overwritten instead of the “Save As” dialog being shown.

 362 QCAD (main)Bug ReportLow Regression in SvgExporterPG.prototype.exportEntity Closed
Task Description

In RC1 text in PG SVG will be in the wrong location. The position passed from native code to the SvgExporterPG.prototype.exportEntity is wrong:

Instead of the actual place of the text it gets the position of the surrounding block entity, or, for text that is not in a block, “0,0,0”.

Dimension labels are not affected by this. Also HAlign and VAlign are not passed correctly for text in the model-view block.

 363 QCAD (main)Bug ReportLow Modify tool "Stretch" only one time ... Closed
Task Description

3.0 RC1

The Stretch Tool works only for one task and than you have to reselect it again for the next task.
Who really works with the stretch tool has to use it (often) a couple times consecutively to get the job done.

It was nice working in

 364 QCAD (main)Bug ReportLow Default paper with default unit inch Closed
Task Description

Default paper might be configured as 210×297 inches if inch is chosen as default unit.

 365 QCAD (main)Bug ReportLow Auto fit to paper fails with some drawings in inches Closed
Task Description

Auto fit to paper fails with some drawings in inches

e.g. Bathroom mod 2.dxf

 368 QCAD (main)Bug ReportLow Appearance preference Closed
Task Description

RC1 is lazy in saving appearance to config. I noticed, because it always started with default window size. Maximizing was not carried over, also the panels were consistently reset.

Only when eg. dragging the handle to change cad-toolbar width not from preferences it would write an “appearance” section to the config file.

The appearance section should be written rather sooner than later.

 370 QCAD (main)Bug ReportLow Canceling quit leaves windows in half-closed state Closed
Task Description
  1. File - New
  2. File - New
  3. Draw line
  4. Quit
  5. Cancel
  6. Switch to first tab
 371 QCAD (main)Bug ReportLow Ctrl-P not working in print preview Closed
Task Description

Ctrl-P not working in print preview

Linux only.

 372 QCAD (main)Bug ReportLow Loading QCAD 3 layer names with international character ...Closed
Task Description

Loading QCAD 3 layer names with international characters fails in QCAD 2.

e.g. æøå

 374 QCAD (main)Bug ReportLow Text: spaces at beginning of line does not indent Closed
Task Description

Text: non-breaking spaces (\~) at beginning of line does not indent.

See aeg_koe_1_H0_A.dxf

 375 QCAD (main)Bug ReportLow Text: white text shown as white on white in text dialog Closed
Task Description

Text: white text shown as white on white in text dialog

See: aeg_koe_1_H0_A.dxf

Showing tasks 201 - 250 of 2228 Page 5 of 45<<First - 3 - 4 - 5 - 6 - 7 - Last >>

Available keyboard shortcuts


Task Details

Task Editing