QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategoryTask TypeSeveritySummaryStatusProgress  desc
 2015 QCAD (main)Bug ReportLow Hatch from segments cannot be saved to DXF/DWG using Op ...Closed
100%
Task Description

I have an example of a figure that I can solid-fill, but if I save and exit, and reload, it disappears.

 2017 QCAD (main)Bug ReportLow Rendering of arcs in blocks with scale factor > 1 Closed
100%
Task Description

Arcs in blocks are not rendered smoothly if the block is inserted with a scale factor > 1.

 2019 QCAD (main)Bug ReportLow Polyline with segment widths: uneven arc segments Closed
100%
Task Description

Example shows the effect on a ring (Menu → Draw → Ring)

 2020 QCAD (main)Bug ReportLow Edit > Paste: Wrong position for block references with  ...Closed
100%
Task Description

Open the example drawing,
selected all,
copy to clipboard,
open new drawing,
paste clipboard content with a scale of 1:1, check preview = everything ok,
change scale to 1/10 etc., check preview = block references way of.

QCAD Pro Version 3.24.0.1

 2022 QCAD (main)Bug ReportLow File > SVG Export: polyline arc segments and hatches in ...Closed
100%
Task Description

Block scales are not applied to the radius of arc segments of polylines and arc boundary segments of hatches.

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=32&t=6854

 2023 QCAD (main)Bug ReportLow Polyline with segment widths: error with clockwise arcs ...Closed
100%
Task Description

- Create clockwise arc
- Convert to polyline
- Assign segment end width > 0

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=33&t=6853

 2024 QCAD/CAMBug ReportLow CAM > Nesting: Nesting blocks with multiple parts fails Closed
100%
Task Description

Case:
Nesting quantity all test: 3

Nesting block2 = works
Nesting block1 = fails (placed outside sheet),
Nesting both blocks = fails (placed partly outside sheet),

 2025 QCAD/CAMBug ReportLow Set Nesting Quantity shows wrong quantity Closed
100%
Task Description

If I set “Set Nesting Quantity” to e.g. 5 it will remember this number within the session.
If I need to check which number I’ve used last time there is no way to find the actual used value - it will show me always 1.
If I restart QCAD/CAM the value is completely lost and the nesting tool tries to fit in as much as possible into the sheet - regardless that the quantity number still shows one.

It would be nice to have a remember function even after restarting QCAD/CAM and have some kind of possibility to see the last used value.

 2026 QCAD (main)Bug ReportLow Modify > Clip to Rectangle: fails on blocks Closed
100%
Task Description

Clip to Area = deletes whole blocks
Clear Area = deletes whole blocks
Cut at Area Boundary = deletes whole blocks

It was working before e.g. in QCAD Version 3.18.0 ;-)

 2027 QCAD (main)Bug ReportLow File > Print: Minimum line weight for printing is 0.01  ...Closed
100%
Task Description

Create drawing in Meters.
Create line with line weight 0.25mm.
Line prints as 1cm wide as minimum line weight is forced as 0.01 drawing units (i.e. 0.01m) for printing.

 2028 QCAD/CAMBug ReportLow CAM > CAM Export: Fails for new document created Closed
100%
Task Description

1. Load drawing
2. Create new drawing
3. Add toolpath / tool
4. CAM > CAM Export

Fails to identify current config (post processor).

 2029 QCAD (main)Bug ReportVery Low Block order issue within drawing exchange between CE an ...Closed
100%
Task Description

If I create a dxf in Pro and open it in CE (or vice versa) the block order can change strange and a new Layout Block is occasionally added. Looks like dxf version (R15 etc.) doesn’t matters.

Versions:
QCAD Pro 3.24.2.0
QCAD CE 3.24.0.0

 2031 QCAD (main)Bug ReportLow Ordinate Dimensions don't act as expected Closed
100%
Task Description

Hi Andrew

I wasn’t sure if this was a bug or feature request, when I’m drawing part sets that only change in lengths I dimension them
to save time then I stretch and save as whatever filename... I was surprised when Qcad reacted the way it did when stretching ordinate
dimensions on a part, the 1st thing I did was window select over the dimensions which didn’t work ( this is the typical way for
stretching ordinate dimensions in AutoCAD,IntelliCad,Draftsight etc )... anyway Husky and I had a fairly long debate and he told me
I had to select the object and only parts of the ordinate dimensions which when stretched leaves a bit of tidying up to do..
Please let me know if I’m going about this the wrong way.. do i really have to do multiple stretches and move all the jogged dimensions?

See Topic https://www.qcad.org/rsforum/viewtopic.php?f=32&t=6901&start=15 It started off with negative values for ordinate dimensions then turned into problems stretching ordinate dimensions..
I also posted dropbox links to quite a few videos..

Attached is a zip file containing some screenshots plus the original dxf file..

Best Regards
John Hyslop

 2032 QCAD (main)Bug ReportLow Draw > Circle > Three Tangents: Cannot select third tan ...Closed
100%
Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=33&t=6915

 2033 QCAD/CAMBug ReportLow Repeated warning message while updating toolpath Closed
100%
Task Description

While updating or regenerating toolpath on the attached dxf file I repeatedly get the warning message in the attached jpg file. If I keep clicking OK then the toolpath is successfully generated. This did not happen in version 3.23.0 with the same file.

 2035 QCAD (main)Bug ReportLow Linetype scale in viewports Closed
100%
Task Description

The preference

Edit > Drawing Preferences > General > Linetype > Scale of linetypes matches the scale of each viewport

should take the individual line type scale of entities into account.

 2036 QCAD (main)Bug ReportLow Arc rendering in block context Closed
100%
Task Description

Arcs in nested scaled and rotated blocks are not always rendered properly (too rough, too fine).

 2038 QCAD (main)Bug ReportLow Cannot snap arc / circle reference points inside blocks Closed
100%
Task Description

- Create block with arc or circle
- Auto snap / reference snap does not snap to reference points at circle / arc max / min coordinates

 2040 QCAD (main)Feature RequestLow Parallel and Offset tool - digit limit for Number to s ...Closed
100%
Task Description

LP - Number limit:
2 digits (max. 99)

LG - Number limit:
2 digits (max. 99)

OF - Number limit:
3 digits (max. 999)

OH - Number limit:
2 digits (max. 99)

Yes I know - it’s also a performance question but compared to ...

... Copy/Move (MV)
next to infinite digits (max. ???)

... Paste Along Entity (PE)
next to infinite digits (max. ???)

 2042 QCAD (main)Bug ReportLow linetangent can't draw a tangent to arc through a point ...Closed
100%
Task Description

Very often I need to draw a tangent line through a point on the arc or circle. Currently I solve this by drawing the perpendicular in that point and then the perpendicular to that perpendicular. As this problem is solvable I set the severity to “Low”.

But I think linetangent should be able to draw such tangents. And I think this tool should firstly ask for arc or circle and only then for a point. Currently linetangent firstly asks for a point.

 2043 QCAD Community EditionBug ReportLow library browser's menu not consistent with empty namesp ...Closed
100%
Task Description

The library browser’s accordion menu is not consistent when browsing back and forth through empty namespaces (directory).

In the image attached (top to bottom, left to right), I’m trying to open the empty namespace “Hydraulics”. If I close & open the “default” namespace, the empty namespace’s open arrow disappears.

 2044 QCAD (main)Feature RequestLow Filter selection entities according to more than one cr ...Closed
100%
Task Description

At the moment there is no way to select all entities that match more than one criterion (i.e. layers, colours, object types, ..).

 2045 QCAD (main)Bug ReportLow The whole block disappear when one of its layer is hidd ...Closed
100%
Task Description

If a block is created with entities from different layers and then one of these layers is hidden, the block disappears. I would expect that only that specific entity disappears.

 2047 QCAD (main)Bug ReportLow QCAD quits when inserting a library item, Ubuntu 19.10  ...Closed
100%
Task Description

Description:
QCAD quits when trying to insert a library item (PC_1kW.dxf) from the library browser. Both by dragging it or clicking on insert.
Joined a copy of the terminal and dmesg (Linux) and what I found on the windows logs.

- Tested with other libraries elements of the same origin with the same result.
- The file opens normally in QCAD. When you create a block from it, you can re-insert it and it works as expected, try with PC_1kWblock.dxf...
- If you re-create a library item from the file with another name it fails also to insert.
- Tested with a new empty file or with a file containing same blocks...

Now the strange part:

-On a brand new HP Zbook 14u G6 it works flawlessly on Windows but fails on Linux... That was the first computer I tried (with Windows) when I decided that it will replace Draftsight... I was lucky...
-On a 4 years old Lenovo Yoga 14 it fails both on Linux & Windows... This computer has only 8Gb of RAM, but dedicated graphics...
-On a customer’s HP Pavillon 17’’ it fails... He bought a licence & Book of QCAD because of me...
-On my Dell 7720 it fails both on Windows and Linux. This workstation has everything to run any CAD software (64Gb RAM, Xeon 1535M v6, Quadro P5000)
-Reinstallation of the software doesn’t solve the problem. 2 independent sources tested (my download and my customer’s download)

These blocks have a lot of attributes on different layers, needed for the intended usage. I’m developping a script to extract them to a CSV file based on a template file... As on Draftsight.

Looks a lot like  FS#1938 ... But now you have files to test...

I made further testings and this bug is definitely related to the fact that the attributes definitions are on different layers...

If the layer definition exists before the library items is inserted, it works as expected.

If one layer existing in the item definition is missing from the layer list before the item is inserted it fails.

If you create a block from an instance of the library item, and create a new library item with the block, then it can be inserted without problems and the layers are created... But you must explode it first to access the attributes which is not the idea behind the block attributes that should be editable when a block with attributes is inserted.

So at the moment the only way to work is to start with a template document with all the possible layers on which attributes definitions are defined...

Can’t go further in debugging as block attributes are one of the feature of the ‘professional’ version I paid for and are not open source...

Ready and willing to sign a NDA to get access to the sources and make this work if nobody else takes care of this.

 2049 QCAD (main)Bug ReportLow Cannot print one particular file Closed
100%
Task Description

no task description

 2050 QCAD Community EditionBug ReportVery Low FlexPainter dosen't work Closed
100%
Task Description

FlexPainter works in the Pro version of QCad but not in the Comunity one.
If it’s not supposed to works in the latter, maybe, it would be better to remove it from the menu (Misc > Script Examples > Mathematics).

 2051 QCAD (main)Bug ReportLow Window selection of rotated and aligned dimensions with ...Closed
100%
Task Description

Please see item 1) in topic https://www.qcad.org/rsforum/viewtopic.php?f=33&t=7037 item 2) I can’t reproduce at present

Issue is about left→right selection of dimensions.

Thank you.

 2052 QCAD Community EditionBug ReportCritical QCAD Crash when try to save file Closed
100%
Task Description

I have tried to use QCAD on arch linux and installed the latest version via

pacman -S qcad

Steps to reproduce the bug:

  • create a rectangular box and 2 lines (See attached *.dxf file)
  • mirror those 2 lines to the opposite side
  • qcad crashes on save

i also added a coredump file from the crash if it does help to locate the problem..

kind regards,
stif

 2053 QCAD (main)Bug ReportLow Dots in line patterns not visible at extreme coordinate ...Closed
100%
Task Description

Dots in line patterns are not displayed / printed at extreme coordinates.

See also:
https://qcad.org/rsforum/viewtopic.php?f=89&t=7053

 2054 QCAD (main)Bug ReportMedium Misc > Modify > Flatten Drawing to 2D Closed
100%
Task Description

Crash when drawing contains viewports.

 2055 QCAD/CAMBug ReportLow RTF text formatting not supported Closed
100%
Task Description

If any text in a dxf file use RTF formatting for their fonts, the RTF code is not decoded and the text ends up showing the entire RTF code instead of just the intended text.
Most other editors (Draftsight, Autocad, Powerdraft) support the RTF codes which makes importing files from those editors problematic. See attached file for an example.

 2058 QCAD (main)Bug ReportLow Modify > Move, Rotate, ...: "Use current layer and attr ...Closed
100%
Task Description

If I use the mentioned option and do an undo all entities will stay on the previously chosen target (current) Layer - the layer restoration fails.

Example:
entities on layer x,
current Layer y,
select entities,
Move/Copy MV,
reference,
drag to new position,
Dialog option “Use current Layer and attributes” checked,
OK,
Undo

 2059 QCAD (main)Bug ReportLow Modify > Explode: Error with hatch in block with positi ...Closed
100%
Task Description

See Forum Topic:
https://www.qcad.org/rsforum/viewtopic.php?f=33&t=7093

Isolated in Reply:
https://www.qcad.org/rsforum/viewtopic.php?f=33&t=7093#p27329

Sorry forgot to mention.
Reported by User 2CV375 qcad/cam version 3.24.2.0 (3.24.2) on Windows 10.
Reproduced in Qcad pro 3.24.2 on Windows 7/32.

 2061 QCAD (main)Bug ReportLow Insert Library items fails to update relative zero poin ...Closed
100%
Task Description

To reproduce the issue: Insert a Library item from the Library browser and the RZ point will stay where it is.

 2062 QCAD (main)Bug ReportLow Electronic symbols not shown correctly in library Closed
100%
Task Description

I bought the QCAD Professional and tried the Electronics library which was linked to the qcad.org website. When loading symbolms, the symbols are not shown correctly.

Please have a look at the screenshot.

 2064 QCAD (main)Bug ReportLow XLines in blocks appear shortened Closed
100%
Task Description

Coming from https://www.qcad.org/rsforum/viewtopic.php?f=76&t=7148 ...

I create help lines of infinite length inside a block, layer is “helplines”, red, 0,25mm, DOT(2x). Inside the block I can see the lines at any zoom level. Leaving the block editor, the lines are getting shorter when zooming closer. Zooming far away the lines look like infinite length, zooming closer, the lines look like cut shorter, and zooming very close, the lines disappear completely.

As Husky confirmed:

Infinitive lines in blocks are displayed shortened in Model_Space. I would consider that a bug which pertains the QCAD Pro version too.
 2065 QCAD (main)Bug ReportLow Viewport: three dimensional entities not rendered Closed
100%
Task Description

Viewports only display entities on the zero plane.

 2066 QCAD (main)Bug ReportLow Text/Dim rendering issue for size and contrast Closed
100%
Task Description

Sorry - can’t give you a proper way to reproduce it .... it just happens.

Dimension Arrows shown with reduced contrast, zoom in/out can trigger it but not always,
text hight jumps from “correct” to way to small to a kind of mixed size display,
DIM preview fails often in size - probably depending on zoom factor ...

Snapshot Version: 3.24.3.4
Edit: Issue occurred first with version: 3.24.3.2

 2067 QCAD (main)Bug ReportLow Attributes with fixed color Closed
100%
Task Description

Attributes with fixed color take on color of block if preference Edit > Application Preferences > Layer > Compatibility > Layer 0 behaves differently is activated.

 2069 QCAD (main)Bug ReportLow Text with sub/super script is not saved in the label di ...Closed
100%
Task Description

How to reproduce the issue:

  1. create a dimension
  2. in it’s “label” field enter any string with sub/super script, for example: t\Sc^;
  3. save and reopen the file
  4. the dimension shows correctly the string but its label only the normal text, for example: t

Note that if the button “Use auto measurement” (next to the “label” field) is pressed, the real measurement is showed along with the sub/super script, which now can’t be removed.

 2071 QCAD (main)Feature RequestLow Solid hatch fade Closed
100%
Task Description

It may be useful to implement the fade function in solid hatches, as present in the image options

 2073 QCAD (main)Bug ReportLow Property Editor: Imperial Area info incorrect Closed
100%
Task Description

Drawing Unit: Inch
Label Format: Architectural and Engineering

Note: Info tool calculation is correct.

 2074 QCAD Community EditionBug ReportMedium No tile print option Closed
100%
Task Description

I’m trying to print a large cad drawing at 1:1 scale. However, when I go into preview to select tile button, it doesn’t exit. First image is my screeen capture, the 2nd is from the online tutorial regarding printing and the button that is missing.

 2075 QCAD (main)SuggestionLow Draw order bug after insert bit map Closed
100%
Task Description

First post, so please excuse if I missed some forum rules etc...

I insert bit maps and trace over them to create DXF files for laser cutting burnout templates. If the edge of the bit map is coincident with a line I have drawn, it is not possible to select the line for offsetting, trimming etc. This is regardless of the draw order or handle number. It seems to happen most if the edge of the image and line are coincident with the X or Y origin. I also use fairly fat lines to make it easy to see. My default line width is 1mm. Not sure if that affects selection or not, but fatter lines don’t help the issue at hand.

Steps to reproduce...
insert bitmap at 0,0
draw horizontal and vertical lines starting at 0,0. (my lines are usually longer than the edges of the bitmap.
try to select one of the lines for offsetting. (Select the line in the area of the bitmap. There is no problem selecting the line where it extends past the edge of the bitmap.)

It does not matter if I insert the bitmap first and then draw lines, or draw lines first, insert bitmap and then change the draw order so the lines are on top. It is also not consistent on which axis is affected. It is usually both X & Y, but sometimes just one or the other.

Workaround is select the bitmap, then move it by 0.001 in any direction. Now the edges are no longer coincident and you can select your lines. The alternate workaround is to insert the image on another layer and then turn that layer off when you need to select a line on the edge of the bitmap.

 2076 QCAD (main)Bug ReportLow File > SVG Export: circles in mirrored blocks Closed
100%
Task Description

Circles in mirrored blocks are not exported or exported with negative radius (not shown in SVG).

See also:
https://qcad.org/rsforum/viewtopic.php?f=33&t=7232

 2077 QCAD (main)Bug ReportLow Property Editor / Fixed Extension Line fails in certain ...Closed
100%
Task Description

If I edit a DIM regarding the fixed Extension Line Length it will fail if it has to be extended to meet the new length. Even it has failed - the Property Editor will provide from now on the new length as the “correct” value for the Extension Line Length.

Example drawing: Try to adjust the Extension Line Length to 50 ...

 2078 QCAD (main)Bug ReportLow Draw > Hatch: Small gap tolerated by QCAD, not by DXF/D ...Closed
100%
Task Description

https://qcad.org/rsforum/viewtopic.php?f=33&t=7254

It seems to be an accuracy problem.
The original hatch boundaries are defined from 732 single entities.
These interconnect with an accuracy better then 1e-10 except for a gap of 0.000814 in two places.

Creating a Hatch of these entities with TA-HA is rather slow but succesfull.
After Save-Close-Open the Hatch may look different or may even be missing (=Null).

Suspected is that:
The recreation off the Hatch on load uses some other accuracy setting.
The outer boundary is not found and only some inner ones are considered as outer.

But that explains not why it looks fine after initial creation.
Nor that the outcome of a retry may vary.

Regards,
CVH

 2079 QCAD/CAMBug ReportLow Full screen mode (F11) - Menu / drop down menus not wor ...Closed
100%
Task Description

https://www.qcad.org/rsforum/viewtopic.php?f=33&t=7269

 2080 QCAD (main)Bug ReportLow Modify > Stretch: Hatch moves instead of stretching Closed
100%
Task Description

A hatch might move instead of being stretched if the hatch is partially inside the stretch area but the visible hatch pattern does not intersect with the stretch area or only contains points.

 2081 QCAD (main)Bug ReportLow Dimension label color at existing files will change to  ...Closed
100%
Task Description

The new QCAD feature “dimension label color” will change the label color at existing drawings to “Custom”.
In my opinion it should be by default “by Layer” until the user decide to change the color by him/herself. ;-)

Showing tasks 1851 - 1900 of 2190 Page 38 of 44<<First - 36 - 37 - 38 - 39 - 40 - Last >>

Available keyboard shortcuts

Tasklist

Task Details

Task Editing