QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

IDCategoryTask TypeSeveritySummaryStatusProgress  desc
 2045 QCAD (main)Bug ReportLow The whole block disappear when one of its layer is hidd ...Closed
100%
Task Description

If a block is created with entities from different layers and then one of these layers is hidden, the block disappears. I would expect that only that specific entity disappears.

 2047 QCAD (main)Bug ReportLow QCAD quits when inserting a library item, Ubuntu 19.10  ...Closed
100%
Task Description

Description:
QCAD quits when trying to insert a library item (PC_1kW.dxf) from the library browser. Both by dragging it or clicking on insert.
Joined a copy of the terminal and dmesg (Linux) and what I found on the windows logs.

- Tested with other libraries elements of the same origin with the same result.
- The file opens normally in QCAD. When you create a block from it, you can re-insert it and it works as expected, try with PC_1kWblock.dxf...
- If you re-create a library item from the file with another name it fails also to insert.
- Tested with a new empty file or with a file containing same blocks...

Now the strange part:

-On a brand new HP Zbook 14u G6 it works flawlessly on Windows but fails on Linux... That was the first computer I tried (with Windows) when I decided that it will replace Draftsight... I was lucky...
-On a 4 years old Lenovo Yoga 14 it fails both on Linux & Windows... This computer has only 8Gb of RAM, but dedicated graphics...
-On a customer’s HP Pavillon 17’’ it fails... He bought a licence & Book of QCAD because of me...
-On my Dell 7720 it fails both on Windows and Linux. This workstation has everything to run any CAD software (64Gb RAM, Xeon 1535M v6, Quadro P5000)
-Reinstallation of the software doesn’t solve the problem. 2 independent sources tested (my download and my customer’s download)

These blocks have a lot of attributes on different layers, needed for the intended usage. I’m developping a script to extract them to a CSV file based on a template file... As on Draftsight.

Looks a lot like  FS#1938 ... But now you have files to test...

I made further testings and this bug is definitely related to the fact that the attributes definitions are on different layers...

If the layer definition exists before the library items is inserted, it works as expected.

If one layer existing in the item definition is missing from the layer list before the item is inserted it fails.

If you create a block from an instance of the library item, and create a new library item with the block, then it can be inserted without problems and the layers are created... But you must explode it first to access the attributes which is not the idea behind the block attributes that should be editable when a block with attributes is inserted.

So at the moment the only way to work is to start with a template document with all the possible layers on which attributes definitions are defined...

Can’t go further in debugging as block attributes are one of the feature of the ‘professional’ version I paid for and are not open source...

Ready and willing to sign a NDA to get access to the sources and make this work if nobody else takes care of this.

 2049 QCAD (main)Bug ReportLow Cannot print one particular file Closed
100%
Task Description

no task description

 2050 QCAD Community EditionBug ReportVery Low FlexPainter dosen't work Closed
100%
Task Description

FlexPainter works in the Pro version of QCad but not in the Comunity one.
If it’s not supposed to works in the latter, maybe, it would be better to remove it from the menu (Misc > Script Examples > Mathematics).

 2051 QCAD (main)Bug ReportLow Window selection of rotated and aligned dimensions with ...Closed
100%
Task Description

Please see item 1) in topic https://www.qcad.org/rsforum/viewtopic.php?f=33&t=7037 item 2) I can’t reproduce at present

Issue is about left→right selection of dimensions.

Thank you.

 2052 QCAD Community EditionBug ReportCritical QCAD Crash when try to save file Closed
100%
Task Description

I have tried to use QCAD on arch linux and installed the latest version via

pacman -S qcad

Steps to reproduce the bug:

  • create a rectangular box and 2 lines (See attached *.dxf file)
  • mirror those 2 lines to the opposite side
  • qcad crashes on save

i also added a coredump file from the crash if it does help to locate the problem..

kind regards,
stif

 2053 QCAD (main)Bug ReportLow Dots in line patterns not visible at extreme coordinate ...Closed
100%
Task Description

Dots in line patterns are not displayed / printed at extreme coordinates.

See also:
https://qcad.org/rsforum/viewtopic.php?f=89&t=7053

 2054 QCAD (main)Bug ReportMedium Misc > Modify > Flatten Drawing to 2D Closed
100%
Task Description

Crash when drawing contains viewports.

 2055 QCAD/CAMBug ReportLow RTF text formatting not supported Closed
100%
Task Description

If any text in a dxf file use RTF formatting for their fonts, the RTF code is not decoded and the text ends up showing the entire RTF code instead of just the intended text.
Most other editors (Draftsight, Autocad, Powerdraft) support the RTF codes which makes importing files from those editors problematic. See attached file for an example.

 2058 QCAD (main)Bug ReportLow Modify > Move, Rotate, ...: "Use current layer and attr ...Closed
100%
Task Description

If I use the mentioned option and do an undo all entities will stay on the previously chosen target (current) Layer - the layer restoration fails.

Example:
entities on layer x,
current Layer y,
select entities,
Move/Copy MV,
reference,
drag to new position,
Dialog option “Use current Layer and attributes” checked,
OK,
Undo

 2059 QCAD (main)Bug ReportLow Modify > Explode: Error with hatch in block with positi ...Closed
100%
Task Description

See Forum Topic:
https://www.qcad.org/rsforum/viewtopic.php?f=33&t=7093

Isolated in Reply:
https://www.qcad.org/rsforum/viewtopic.php?f=33&t=7093#p27329

Sorry forgot to mention.
Reported by User 2CV375 qcad/cam version 3.24.2.0 (3.24.2) on Windows 10.
Reproduced in Qcad pro 3.24.2 on Windows 7/32.

 2061 QCAD (main)Bug ReportLow Insert Library items fails to update relative zero poin ...Closed
100%
Task Description

To reproduce the issue: Insert a Library item from the Library browser and the RZ point will stay where it is.

 2062 QCAD (main)Bug ReportLow Electronic symbols not shown correctly in library Closed
100%
Task Description

I bought the QCAD Professional and tried the Electronics library which was linked to the qcad.org website. When loading symbolms, the symbols are not shown correctly.

Please have a look at the screenshot.

 2064 QCAD (main)Bug ReportLow XLines in blocks appear shortened Closed
100%
Task Description

Coming from https://www.qcad.org/rsforum/viewtopic.php?f=76&t=7148 ...

I create help lines of infinite length inside a block, layer is “helplines”, red, 0,25mm, DOT(2x). Inside the block I can see the lines at any zoom level. Leaving the block editor, the lines are getting shorter when zooming closer. Zooming far away the lines look like infinite length, zooming closer, the lines look like cut shorter, and zooming very close, the lines disappear completely.

As Husky confirmed:

Infinitive lines in blocks are displayed shortened in Model_Space. I would consider that a bug which pertains the QCAD Pro version too.
 2065 QCAD (main)Bug ReportLow Viewport: three dimensional entities not rendered Closed
100%
Task Description

Viewports only display entities on the zero plane.

 2066 QCAD (main)Bug ReportLow Text/Dim rendering issue for size and contrast Closed
100%
Task Description

Sorry - can’t give you a proper way to reproduce it .... it just happens.

Dimension Arrows shown with reduced contrast, zoom in/out can trigger it but not always,
text hight jumps from “correct” to way to small to a kind of mixed size display,
DIM preview fails often in size - probably depending on zoom factor ...

Snapshot Version: 3.24.3.4
Edit: Issue occurred first with version: 3.24.3.2

 2067 QCAD (main)Bug ReportLow Attributes with fixed color Closed
100%
Task Description

Attributes with fixed color take on color of block if preference Edit > Application Preferences > Layer > Compatibility > Layer 0 behaves differently is activated.

 2069 QCAD (main)Bug ReportLow Text with sub/super script is not saved in the label di ...Closed
100%
Task Description

How to reproduce the issue:

  1. create a dimension
  2. in it’s “label” field enter any string with sub/super script, for example: t\Sc^;
  3. save and reopen the file
  4. the dimension shows correctly the string but its label only the normal text, for example: t

Note that if the button “Use auto measurement” (next to the “label” field) is pressed, the real measurement is showed along with the sub/super script, which now can’t be removed.

 2071 QCAD (main)Feature RequestLow Solid hatch fade Closed
100%
Task Description

It may be useful to implement the fade function in solid hatches, as present in the image options

 2073 QCAD (main)Bug ReportLow Property Editor: Imperial Area info incorrect Closed
100%
Task Description

Drawing Unit: Inch
Label Format: Architectural and Engineering

Note: Info tool calculation is correct.

 2074 QCAD Community EditionBug ReportMedium No tile print option Closed
100%
Task Description

I’m trying to print a large cad drawing at 1:1 scale. However, when I go into preview to select tile button, it doesn’t exit. First image is my screeen capture, the 2nd is from the online tutorial regarding printing and the button that is missing.

 2075 QCAD (main)SuggestionLow Draw order bug after insert bit map Closed
100%
Task Description

First post, so please excuse if I missed some forum rules etc...

I insert bit maps and trace over them to create DXF files for laser cutting burnout templates. If the edge of the bit map is coincident with a line I have drawn, it is not possible to select the line for offsetting, trimming etc. This is regardless of the draw order or handle number. It seems to happen most if the edge of the image and line are coincident with the X or Y origin. I also use fairly fat lines to make it easy to see. My default line width is 1mm. Not sure if that affects selection or not, but fatter lines don’t help the issue at hand.

Steps to reproduce...
insert bitmap at 0,0
draw horizontal and vertical lines starting at 0,0. (my lines are usually longer than the edges of the bitmap.
try to select one of the lines for offsetting. (Select the line in the area of the bitmap. There is no problem selecting the line where it extends past the edge of the bitmap.)

It does not matter if I insert the bitmap first and then draw lines, or draw lines first, insert bitmap and then change the draw order so the lines are on top. It is also not consistent on which axis is affected. It is usually both X & Y, but sometimes just one or the other.

Workaround is select the bitmap, then move it by 0.001 in any direction. Now the edges are no longer coincident and you can select your lines. The alternate workaround is to insert the image on another layer and then turn that layer off when you need to select a line on the edge of the bitmap.

 2076 QCAD (main)Bug ReportLow File > SVG Export: circles in mirrored blocks Closed
100%
Task Description

Circles in mirrored blocks are not exported or exported with negative radius (not shown in SVG).

See also:
https://qcad.org/rsforum/viewtopic.php?f=33&t=7232

 2077 QCAD (main)Bug ReportLow Property Editor / Fixed Extension Line fails in certain ...Closed
100%
Task Description

If I edit a DIM regarding the fixed Extension Line Length it will fail if it has to be extended to meet the new length. Even it has failed - the Property Editor will provide from now on the new length as the “correct” value for the Extension Line Length.

Example drawing: Try to adjust the Extension Line Length to 50 ...

 2078 QCAD (main)Bug ReportLow Draw > Hatch: Small gap tolerated by QCAD, not by DXF/D ...Closed
100%
Task Description

https://qcad.org/rsforum/viewtopic.php?f=33&t=7254

It seems to be an accuracy problem.
The original hatch boundaries are defined from 732 single entities.
These interconnect with an accuracy better then 1e-10 except for a gap of 0.000814 in two places.

Creating a Hatch of these entities with TA-HA is rather slow but succesfull.
After Save-Close-Open the Hatch may look different or may even be missing (=Null).

Suspected is that:
The recreation off the Hatch on load uses some other accuracy setting.
The outer boundary is not found and only some inner ones are considered as outer.

But that explains not why it looks fine after initial creation.
Nor that the outcome of a retry may vary.

Regards,
CVH

 2079 QCAD/CAMBug ReportLow Full screen mode (F11) - Menu / drop down menus not wor ...Closed
100%
Task Description

https://www.qcad.org/rsforum/viewtopic.php?f=33&t=7269

 2080 QCAD (main)Bug ReportLow Modify > Stretch: Hatch moves instead of stretching Closed
100%
Task Description

A hatch might move instead of being stretched if the hatch is partially inside the stretch area but the visible hatch pattern does not intersect with the stretch area or only contains points.

 2081 QCAD (main)Bug ReportLow Dimension label color at existing files will change to  ...Closed
100%
Task Description

The new QCAD feature “dimension label color” will change the label color at existing drawings to “Custom”.
In my opinion it should be by default “by Layer” until the user decide to change the color by him/herself. ;-)

 2082 QCAD (main)Bug ReportLow File > Print / PDF Export: Handling of block references ...Closed
100%
Task Description

QCadPro - MacOS Mojave (10.14.6)

Version: 3.24.3.0 (3.24.3)
Build Date: Mar 16 2020
Revision: 6e718a8
Qt Version: 5.13.2
Architecture: x86_64
Compiler: Clang 10.0.0

In the attached .dxf file is a simple drawing (a wooden deck). In the layout space (of A3 size) there are two viewports (one of the frames and one with the decking).

In the left viewport a spurious enlarged part of the block “stolpe” (eng. column) has appeared in the exported PDF (not visible in either the layout nor the model space). See attached .PDF where it is clearly visible.

So it seems that the interaction of blocks with viewport triggers a bug.

 2083 QCAD (main)Bug ReportLow Viewport: Fixed extension line length of dimensions not ...Closed
100%
Task Description

See:
https://qcad.org/rsforum/viewtopic.php?f=89&t=7313

 2084 QCAD (main)Bug ReportLow File > Save: Fixed extension line length of dimensions  ...Closed
100%
Task Description

Create dimension with fixed extension line length.
Set scale to 2.
Save / Load or Reload.

→ Extension line length no longer fixed.

 2085 QCAD (main)Bug ReportVery Low Drag and drop: moving single polyline vertex moves also ...Closed
100%
Task Description

See the steps to reproduce in the attached drawing.

 2086 QCAD (main)Bug ReportLow Font formatting in text dialog Closed
100%
Task Description

QCadPro (snapshot, but can be reproduced with 3.24.3 as well)

OS: MacOS 10.14.6
Version: 3.24.3.8 (3.24.3.8)
Build Date: Jun 3 2020
Revision: 828df3a
Qt Version: 5.13.2
Architecture: x86_64
Compiler: Clang 10.0.0

To reproduce:
1. Add some text to a drawing
2. Double click on the text to open the text-edit dialogue
3. Select all text, change font, press OK

Expected behavior: The font has been updated

Actual behavior: The font seems to visually change in the edit box but as soon as you press OK to close the dialogue the text on the drawing is not changed. Viewing the text with the font information (via properties) it can be seen that the embedded font information has not been updated.

Workaround:
- Select text and edit the properties

 2089 QCAD (main)Bug ReportLow Property Editor: Linetype Scale and Draw Order wrongly  ...Closed
100%
Task Description

Case:

Drawing unit = inch,

Dimension Label Format set to Engineering or Architectural,

 2090 QCAD (main)Bug ReportLow Snap > Auto Snap: intersections of pattern with other e ...Closed
100%
Task Description

- Create hatch with pattern “ANSI31” (or other).
- Move cursor along boundary with auto snap
- Auto snap finds intersections between hatch pattern and boundary or other entities close to the hatch boundary

 2093 QCAD (main)Bug ReportLow Datum tool, option bar, missing icon for "Undo Last Seg ...Closed
100%
Task Description

no task description

 2094 TranslationBug ReportLow Leader and Datum - Tool tip for "Undo Last Segment" Closed
100%
Task Description

Tools: Leader and Datum
Tool tip for “Undo Last Segment” - Segment instead of Segement

 2095 QCAD (main)Bug ReportLow Can't Print from Q-cad in Win 10  Closed
100%
Task Description

I can’t print from Q-cad in Win 10 latest update. Q-cad says it has sent it to the printer but does not print.
To make it work I print to a PDF file then send it to the printer. I was able to print prior to the update.

I have checked and rechecked the settings in Q-cad as well as my Firewall and printer. All other programs print ok.

I tried printing from my Win 7 computer and all works fine.

Please advise.

 2096 QCAD (main)Bug ReportLow trim fail between line and arc Closed
100%
Task Description

Trim, or round do not work between the green line and the magenta arc. The line properties do not report the length correctly.

Info - distance reports the distance between the end point of the magenta arc and the start point of the red arc as .1534. the Property editor reports the green line length as .257.

If the length of the green line is edited to .5 inches then trim and round work properly, and the green line length is reported properly. The other line/arc intersections have been edited in this manner.

 2101 QCAD (main)Bug ReportLow File > SVG Export: Double hyphen in text leads to inval ...Closed
100%
Task Description

Double hyphens in text entities lead to double hyphens in SVG comments which is not valid.

 2102 QCAD (main)Bug ReportLow Angular Dimension - fixed extension line option incompl ...Closed
100%
Task Description

The property editor offers for an Angular Dimension the option to make a fixed extension (yes/no) but the input field for a length is missing.

 2104 ECMAScriptRefactoringLow Dublicate functions in scripts/simple.js and scripts/li ...Closed
100%
Task Description

Both of these files (scripts/simple.js and scripts/library.js) contain a function named sleep() that duplicate each other. There is probably a need to delete one of them.

Permalinks to this definitions on Github:

 2105 QCAD (main)Bug ReportLow File > Print / PDF export: Selected entities are printe ...Closed
100%
Task Description

QCAD community 3.25.0.0, Qt 5.15.0, FreeBSD 12.1p8

Take any random drawing (as far as I can tell), select (at least) one object, then export to PDF. The “highlight attribute” (for lack of a better word) of the object will unexpectedly be exported.

 2108 ECMAScriptReleaseLow FlexPainter update Beta 0.42e Closed
100%
Task Description

https://qcad.org/rsforum/viewtopic.php?f=30&t=6547&p=29307#p29307

FlexPainter is updated.

Should not load while PROTOOLS are absent.

Regards,
CVH

 2109 QCAD (main)Bug ReportLow Dimension > Arc Length: Tool non-responsive Closed
100%
Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=33&t=7542

 2114 QCAD (main)Bug ReportLow File > Print: Printout offset under Windows Closed
100%
Task Description

See Qt bug 5363:
https://bugreports.qt.io/browse/QTBUG-5363

 2118 QCAD (main)Bug ReportLow Dark mode: disabled menu text distorted Closed
100%
Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=33&t=7596

Windows / Linux

 2119 QCAD (main)Bug ReportLow QCAD/CAM 3.25.2 locks up during startup on lubuntu 18.0 ...Closed
100%
Task Description

Upgraded from 3.24.3 to 3.25.2 on lubuntu 18.04
QCAD/CAM hangs during startup, but managed to get it running by renaming libqcadgles3d.so to libqcadgles3d.so.orig.
Don’t understand why 3.24.3 still works ok without having to do this.
Any suggestions please?
Thanks.

 2120 QCAD (main)SuggestionLow SH - Restrictions for orientation are not working Closed
100%
Task Description

Case:
launch LI,
launch for the first point SH, set to 5 distance,
snap to a point,
activate Auto snap, (which would work with SD for EH and EV but not for Alt)
try to restrict orientation for second point with ALT, EH, EV - it won’t work in this scenario ... :-(

Edit: Playing around ... could it be that RZ is not propperly set within those tools?

 2122 QCAD (main)Bug ReportLow View > Property Editor: Formatting of Negative Values i ...Closed
100%
Task Description

See also:
https://www.qcad.org/rsforum/viewtopic.php?f=31&t=7633

Showing tasks 2101 - 2150 of 2179 Page 43 of 44<<First - 40 - 41 - 42 - 43 - 44 -

Available keyboard shortcuts

Tasklist

Task Details

Task Editing