QCAD Bugtracker

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

ID  descCategoryTask TypeSeveritySummaryStatusProgress
1864QCAD (main)Bug ReportLowPrint current view doesn't shows the actual quantity of...Assigned
0%
Task Description

Case: My last “Print preview” setting was “Multiple Pages” = 4
QCAD will remember this setting until I change it.

If I then - maybe days later - start a “Print current view” out of my drawing then QCAD will show me the current view on ONE page. Exactly what I expected. If I start the print QCAD will print on FOUR pages regarding to the last “Print preview” setting. Not what I was looking for .... :-(

Now knowing what will happen I launch “Print current view”, see my current view on ONE page, launch the “Drawing preferences”, see that FOUR is the number for pages, doesn’t change anything and cancel the dialog. NOW I can see that FOUR pages are used for the current view print.

That is confusing and it would be nice to have somehow more control over this behavior. ;-)

1863ECMAScriptFeature RequestLowWidgetFactory.saveState: save state of checkable QGroup...Assigned
0%
Task Description

QGroupBox widgets with <property name=”checkable”> are not saved in Qcad3.conf

 1862 ECMAScriptBug ReportLow (Groups of) Radio Button does not remember its state. Closed
100%
Task Description

Also, the way the state of radioButtons is saved on Qcad3.conf is rather confusing.

Exemple :
Two radioButtons _cr_i and _cr_x are in the same QWidget.
- check _cr_i
- validate the form with OK
- reopen the form, check _cr_x
- validate the form with OK

the config file reads

[_myPlenum2]
VisibleInMenu=true
...
_cr_i=_cr_i
_cr_x=_cr_x
...

On next form run, even if I select _cr_i, the radiobutton QWidget always takes the value of _cr_x.

 1861 QCAD (main)Bug ReportLow Modify > Stretch: block references inside stretch box a ...Closed
100%
Task Description

I know that I can’t stretch a block in Model space but a block completely inside a Blocks should move. It doesn’t works that way in 3.22.0.3

 1860 QCAD (main)Bug ReportLow Rendering of nested blocks / use of negative scale fact ...Closed
100%
Task Description

I received an ACAD file for a cinema we’re working on and the handicapped toilets were rotated 180-degrees referenced to everything (so the toilet appears to be in the hallway rather than the restroom. The handicapped toilet is part of a block with the handrails and those are in their proper place, just the toilet is rotated.

I have verified the problem on both MAC and PC versions.

The drawing appears correct in AutoCAD as well as TrueView and other programs that can read AutoCAD (that I’ve checked). This problem seems to be QCAD specific.

 1859 QCAD (main)Bug ReportLow Modify > Stretch: dimension completely inside area not  ...Closed
100%
Task Description

Dimension entities that lay completely within the stretch area are not moved.

See also:
http://www.qcad.org/rsforum/viewtopic.php?f=89&t=6118

1858QCAD (main)Feature RequestLowEnter measurements from drawing into line inputsAssigned
0%
Task Description

Add option to line input context menu to enter a distance from the drawing, measured from two points.
Perhaps existing measuring tools can be re-used to feedback values into line edits to avoid duplication.

See also:
http://www.qcad.org/rsforum/viewtopic.php?f=31&t=6111

 1857 QCAD (main)Bug ReportLow Layer List: current layer not highlighted after collaps ...Closed
100%
Task Description

Hi. This is a layers confusion..

I have layers:

0
v Layer 1
Layer 1a
v Layer 2
Layer 2a

I select (highlight) “Layer 1a” add an entity on “Layer 1a”
I select (highlight) “Layer 2a” add an entity on “Layer 2a”

I then collapse “Layer 2” and then collapse “Layer1” - in that order:

0
> Layer 1
> Layer 2

No layers shown highlighted.

I immediately add a 3rd entity.

I then open “Layer 2” and see that “Layer 2a” is still highlighted.

I then hide “Layer 1”

That third entity that I added is now hidden (as is the first entity that I added in “Layer 1a”) and properties show it is part of “Layer 1”, not “Layer 2a”. Seems like the third entity is added to the top layer that was last collapsed.

Even happens if I collapse “Layer 2” and then immediately expand it. Add an entity and that entity is placed in “Layer 2” even though “Layer 2a” is still highlighted.

I hope this makes sense. Not a huge issue, just a strange UI peculiarity.

Best regards
Hugh
3.21.3.19 and 3.21.3 Windows 10 as updated as possible

 1856 QCAD (main)Feature RequestLow SVG import: add support for rotate transformations with ...Closed
100%
Task Description

QCAD seems either to mishandle or ignore svg group transformations altogether.

Importing the attached file into QCAD renders the largest polygon (polygon18) to be rotated and misplaced. This is shown in actual.png. The expected result (original Inkscape renedering) is shown in expected.png.

Looking at the code of the original drawing it can be observed there is a transformation applied to the group which polygon18 is in:

 <g
   style="stroke-width:0.35433099;stroke-miterlimit:4;stroke-dasharray:none"
   id="g20"
   transform="rotate(-90,316.66796,298.95141)" >
   <path
      inkscape:connector-curvature="0"
      id="polygon18"
      d="..." />

Removing the ‘transform’ attribute produces virtually identical (erroneous) rendering in Inkscape as well.

 1855 QCAD (main)Bug ReportLow I cannot print Closed
100%
Task Description

when printing only a white page is generated. Also when pdf generation, a corrupted file is generated. I enclose my dwg file.
Also It takes more than 20 seconds for most of the task, like selecting, zoom in or out, and I own a 16Gb RAM and i7 8Gen processor....
It sucks...

 1854 QCAD (main)Bug ReportLow Build failure due to missing RZip.h Closed
100%
Task Description

Linux, gcc:

make[4]: Entering directory '/home/ice/w/qcad/qcad/src/scripting/ecmaapi'
g++ -c -include release/qcadecmaapi -pipe -O2 -w -D_REENTRANT -fPIC -DQT_DISABLE_DEPRECATED_BEFORE=0x000000 -DQCAD_DLL -DQCADECMAAPI_LIBRARY -DQT_NO_DEBUG -DQT_PLUGIN -DQT_PRINTSUPPORT_LIB -DQT_SVG_LIB -DQT_OPENGL_LIB -DQT_HELP_LIB -DQT_UITOOLS_LIB -DQT_DESIGNER_LIB -DQT_UIPLUGIN_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_SCRIPT_LIB -DQT_SCRIPTTOOLS_LIB -DQT_SQL_LIB -DQT_XMLPATTERNS_LIB -DQT_NETWORK_LIB -DQT_XML_LIB -DQT_CORE_LIB -DQDESIGNER_EXPORT_WIDGETS -I. -I../../core -I../../core/math -I../../grid -I../../snap -I../../gui -I../../entity -I../../operations -I../../scripting -I../../stemmer -I. -Igenerated -Iadapters -I../../io/dxf -I../../spatialindex -I../../3rdparty -I/home/ice/w/qcad/qcad/src/zip -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtPrintSupport -isystem /usr/include/x86_64-linux-gnu/qt5/QtSvg -isystem /usr/include/x86_64-linux-gnu/qt5/QtOpenGL -isystem /usr/include/x86_64-linux-gnu/qt5/QtHelp -isystem /usr/include/x86_64-linux-gnu/qt5/QtUiTools -isystem /usr/include/x86_64-linux-gnu/qt5/QtDesigner -isystem /usr/include/x86_64-linux-gnu/qt5/QtUiPlugin -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtScript -isystem /usr/include/x86_64-linux-gnu/qt5/QtScriptTools -isystem /usr/include/x86_64-linux-gnu/qt5/QtSql -isystem /usr/include/x86_64-linux-gnu/qt5/QtXmlPatterns -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtXml -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -Irelease -isystem /usr/include/libdrm -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++ -o release/RScriptHandlerEcma.o RScriptHandlerEcma.cpp
In file included from RScriptHandlerEcma.cpp:372:0:
generated/REcmaZip.h:15:26: fatal error: RZip.h: No such file or directory
                 #include "RZip.h"
                          ^~~~~~~~
compilation terminated.
Makefile.Release:3622: recipe for target 'release/RScriptHandlerEcma.o' failed
make[4]: *** [release/RScriptHandlerEcma.o] Error 1

Seems to have been introduced in 854baacb, it seems.

 1853 QCAD (main)Bug ReportLow Duplication of input fields in Property Editor 3.21.3.1 ...Closed
100%
Task Description

look at
https://www.qcad.org/rsforum/viewtopic.php?f=89&p=22762&sid=26fade8dcfd514372faaf98834df4413#p22762

 1852 QCAD (main)Feature RequestLow Layer state management Closed
100%
Task Description

- Store layer states under a name
- Restore layer states
- Remove layer states object
- Update layer states object

1851QCAD (main)SuggestionLowLateral surface of a coneAssigned
0%
Task Description

Module mise à plat d’un cone

Bonjour,

Serait il possible dans un futur d’ajouter un module de mise en plan de cone.

Une petite fenêtre sur lequel on donne par exemple :
1- Ø haut
2- angle de coupe du haut
3- hauteur du cône
4- Ø bas
5- angle du bas
6- épaisseur matière

Ce qui permettrai de sortir une mise en plan a plat de la forme

 1850 QCAD/CAMBug ReportLow Toolpath error Closed
100%
Task Description

Hi Andrew,

While generating a toolpath I stumbled upon an odd error.

 1849 QCAD (main)Bug ReportMedium paste of spline with scaling of 0 crashes application Closed
100%
Task Description

Application crashes when entering 0 in the scale option while pasting a spline.

This is an issue also when entering scale factors of less than 1, as the application immediately crashes when entering the 0 digit.
As a workaround for a scale factor of e.g. 0.5, one can enter 1.5 and then edit the 1 digit to 0.

 1848 QCAD/CAMFeature RequestMedium PWM Laser Closed
100%
Task Description

Hi Andrew,

I have added a PWM Laser post processor.

You can add it to QCAD’s post processor directory

1847QCAD/CAMBug ReportLowBUG MEMORYAssigned
0%
Task Description

Hi Andrew,

Still working on creating HPGL.PLT toolpaths for the HP7580 pen plotter. QCAD has some trouble creating toolpaths. Too often it shuts itself down, or the PC gets stalled.

Recreating the same error however is possible

1846QCAD/CAMFeature RequestLowToolpath preset offsetsAssigned
0%
Task Description

Hi Andrew

A request for adding some fields to the toolpath

 1845 QCAD (main)Bug ReportLow Block reference points cannot be supressed in printer o ...Closed
100%
Task Description

Drawing preferences have no effect on point type when printed or in print-preview for block reference points.
Notice in “print output”, the “Dot” (Block reference point) is displayed (drawing preferences are ignored).

See attached photos.

1844QCAD/CAMFeature RequestLowHP/GL (PLT) importAssigned
0%
Task Description

Hi Andrew

QCAD/CAM misses a hpgl.plt import. If gerber and G-code can, so should plt.

1843QCAD/CAMBug ReportLowCreating ToolPath StallsAssigned
0%
Task Description

Hi Andrew,

Still working with and on CAM HPGL for the HP7580 pen plotter.

I have added a penplotter test drawing, that might be used for testing en callibrating plotter and pens. You may add it to the Examples-directory.

QCAD has a lot of trouble creating toolpaths and exports. Much too often it shuts itself down, or gets stalled. Why? I am not sure.

 1842 QCAD (main)Bug ReportLow svg export shows texts in different place Closed
100%
Task Description

Hi,

when I export a dxf draw to svg the text objects shows in a bit different place.

QCAD version is 3.21.3.14

1841QCAD/CAMFeature RequestLowQCAD/CAM Postprocessor "Hpgl": Add pen colors to HP/GL ...Assigned
0%
Task Description

Add SPx; with x being pen number from 1-8.

TODO:
- Which color corresponds to which pen number?
- What if there are more than 8 colors in a DXF files?

 1840 QCAD (main)Bug ReportMedium Edit > Paste along entity: endless loop Closed
100%
Task Description

Ich habe im Snapshot 3.21.3.14 unter macOS einen Fehler gefunden, der QCAD in eine Endlosschleife führt, sodaß QCAD nicht mehr antwortet.
Details siehe unter https://www.qcad.org/rsforum/viewtopic.php?f=89&t=6011#p22435

 1839 QCAD (main)Bug ReportHigh Lost in migration Closed
100%
Task Description

Hi Andrew,

I am trying to ‘HP pen plotter’ a test file, created by AutoCAD 10.

Saving the in QCAD loaded file goes fine. However, the tool table is empty now.

Trying to make a new tool 1 Errors it exists already but does not show up in the tool table.

What do I miss?

1838QCAD (main)Feature RequestLowCarbide Create importAssigned
0%
Task Description

Add support for importing Carbide Create files (.c2d).

Format is JSON based, human readable.

1837QCAD (main)Feature RequestLowLine bisector toolAssigned
0%
Task Description

Hi,

we have already this nice tool “Angle bisector”.

I would really appreciate if we could get the same function for parallel lines to place a line exactly in the center of both lines.

Thanks.

1836QCAD (main)Feature RequestLowOffset for paste along entityAssigned
0%
Task Description

add a new parameter “offset” in the dialog “Paste along entity”

see https://www.qcad.org/rsforum/viewtopic.php?f=31&t=5929&p=22307#p22307

 1835 QCAD (main)Bug ReportLow QCAD Professional crashing when trying to open .dwg fil ...Closed
100%
Task Description

Hi I am having an issue with the attached DWG file, when I try to open the file qcad opens then immediately crashes and I am unable to do anything.

Here is the event viewer log:

Faulting application name: qcad.exe, version: 3.21.3.0, time stamp: 0x5b9fbdd3
Faulting module name: MSVCR120.dll, version: 12.0.21005.1, time stamp: 0x524f83ff
Exception code: 0xc0000409
Fault offset: 0x0000000000074a30
Faulting process id: 0x1ad8
Faulting application start time: 0x01d48bbf05480557
Faulting application path: C:\Program Files\QCAD\qcad.exe
Faulting module path: C:\Program Files\QCAD\MSVCR120.dll
Report Id: fa661b18-d0df-41a8-88e9-37c2ea345bcb
Faulting package full name:
Faulting package-relative application ID:

 1834 QCAD (main)Bug ReportLow Property Editor: Attributes of block reference not show ...Closed
100%
Task Description

- Create block with attributes
- Create block reference
- Select block reference
→ Property editor does not show attributes

1833QCAD (main)Feature RequestLowDeep synchronize attributes featureAssigned
0%
1 Task Description

There is the Synchronize attributes feature which works well. But It affects only block references in the active layout(modelspace, block layout). If I want to synchronize attributes of block references in in another blocks, i have to manually go through all blocks and run synchronize attributes feature. That is the reason I would like to modify Synchronize attributes feature to affect all block references in a drawing, or add new Deep synchronize attributes feature.

 1832 QCAD (main)Bug ReportLow Modify > Explode: attributes of block references are or ...Closed
100%
1 Task Description

In a the modelspace I have a block reference of a block(parent), which includes block references (with attributes) of another blocks(child). Than I select this parent block reference and choose Explode. The result is, that the child block references have visible attributes, but they are not connected to the block reference anymore (I can not see them in property editor when the child block is selected). Than when I choose synchronize attributes, new attributes with default values will appear.
I am not sure it his is a bug or expected behavior of the Explode feature.

If it is not a bug, I would like to have new Extract feature, which would copy the content of the selected block reference and immediately insert it exactly to the same place (attributes would be still connected to child references) Extracted block reference would be than removed. Optionally, it could delete the block definition if it is not used anymore in the drawing (but there is already Block Purge feature which will do this).

 1831 QCAD (main)Bug ReportLow Block > Copy Block: attributes of block references are  ...Closed
100%
1 Task Description

1) Open the attached dxf file
2) Right click on “vne_vent_odvod_ec_3f” block in Block list and select Copy block
3) Choose name
4) Insert reference of this Copy block to the modelspace
5) Save the file
6) Close and reopen the file

RESULT: Attributes of block references included in the original block are missing in the copied block.
Immediately after insertion of the copied block I can see in the property editor, that block reference attributes are not “conected” to the block reference, but they are still visible. They disappear when the file is reopen.

Alternative way I use to copy this kind of blocks without error: Open block I want to copy, Select all entities, reference copy of them, paste to modelspace, select them in modelspace and choose create block.

 1830 QCAD/CAMSuggestionLow HP7580 Penplotter Closed
100%
Task Description

Hi Andrew,

I was fiddeling around with a copy of the hpgl postprocessor, and has it adapted, up and running for a HP7580 penplotter. You may add this to QCAD if you like.

Poking and peeking in the other postprocessor files, I found enough information to generate a very acceptable hpgl.plt file now, including the required pen changes.

The purpose of a ‘bracket-field’ (as [S] ) is clear to me. Where are [S#] and [S!] used for?

 1829 QCAD (main)Bug ReportLow Incorrect font weights in macOS 10.14 Mojave Closed
100%
Task Description

See QTBUG-69955 which affects QCAD on Mojave:
https://bugreports.qt.io/browse/QTBUG-69955

 1828 QCAD (main)Bug ReportLow Chinese language not loading correctly Closed
100%
Task Description

Most of the Chinese items cannot be shown correctly. But when I check the qm files, the translation are there and the contents are correct.

I’m using the Pro version 3.21.3.0

1827QCAD (main)Feature RequestLowProperty Editor: Accept advanced scale expressions for ...Assigned
0%
Task Description

Hi,

Identical scale expression used in Print Preview like 5:1, 5/1, 5”=1”, 5 are working flawless like expected.
Same expression used in a Viewport scale leads to different outcomes.

The Property Editor used to fix that in Paper_Space does also not accept those standard expressions.

1826QCAD (main)Feature RequestLowguide lines when extending lines Assigned
0%
Task Description

When using the SHIFT key while dragging the end point a perpendicular guide line is displayed (see attached screenshot).
It would be very helpful if other guide lines with x=const. and y= const. are displayed when pressing SHIFT + ALT key together while dragging.

 1825 QCAD (main)Bug ReportLow File > Svg Export: text exported with wrong height Closed
100%
Task Description

If option “Preserve geometry” is activated, texts are exported at a wrong height if the drawing unit is not the same as the SVG output unit.

1824dwg2pdfFeature RequestLowdwg2pdf does not obey frozen layers in paper-space view...Assigned
0%
Task Description

We currently have a paper-space using two viewports with different layers from the model-space frozen. Unfortunately in the pdf output the layers which are frozen show up.
dwg2pdf should obey the specific frozen layer for each viewport

1823dwg2pdfFeature RequestLowplotting error to pdf a Dwg where the view port is not ...Assigned
0%
Task Description

When trying to plot a dwg or a dxf to pdf where the viewport is orientated to a different angle than north up
the data in the view port is plotted north up.
see attached DWG and pdf for clarification.

 1822 QCAD (main)Bug ReportCritical Cannot download old purchased QCAD due to expired link  ...Closed
100%
Task Description

Hi,

I logged in to my account, and checked my order. The link does not work anymore for the purchased item QCAD Pro.
Please help me ow can I download my Pro version QCAD.

Thanks,
Soma

 1821 QCAD (main)Feature RequestMedium Export svg with linetype parameter Closed
100%
Task Description

Hi,

as I saw in the svg file and tried it, the ‘stroke-dasharray’ parameter needed (with values) to show the line same as in the editor.

Example:
...

      <!-- Line -->
      <path d="M207452.1773,1518891.8208 L203034.0991,1518891.8208 " style="stroke:#808000;stroke-dasharray:200,300;stroke-width:25;" qs:layer="layer"/>

...

Thanks,
Soma

 1820 QCAD/CAMBug ReportMedium CAM Export: exporting text entities broken Closed
100%
Task Description

Hi Andrew,

Kubuntu, QCAD/CAM 3.21.3

Font Standard. Selected as ‘single line’ font for engraving with mill or laser.

While CAM Exporting as G-code Laser (Offset) MM, or as Linux CNC, Exporting gets trapped in a loop.

In Font Standard the glyph’s ? & $ @ s S Q and 2 contains unwanted Z-movements. It seems these glyphs entities are not alligned properly; endpoint last line does not meet startpoint next line; why else the Z-movements?

Could this misallignment also traps Exporting?

 1819 QCAD (main)Feature RequestLow  Additional Options for "Paste along Entity" Closed
100%
Task Description

Please see:

http://www.qcad.org/rsforum/viewtopic.php?f=31&t=5929&p=22098#p22098

 1818 DocumentationTaskLow QCAD Reference Manual / Paste along Entity ... Closed
100%
Task Description

... describes basically the “Paste” tool and not the “Paste along Entity” tool.

 1817 QCAD/CAMBug ReportLow CAM Export: offset fails for contours with arcs (tolera ...Closed
100%
Task Description

After regenerate selected toolpath OR regenerate all toolpath.

The result of the output is every time different.

When pushed for example 2 or 3 times this button.

See pictures

 1816 QCAD/CAMBug ReportLow TAB function in CAM module fails  Closed
100%
Task Description

When using (adding a TAB on a radius fails).

Example:

When length of the TAB is set to 1 mm.

After export to *.nc code the code is not ok.

And then check this is NC viewer or gcode sender the length is not set to 1 mm but is smaller.

On a line this function (TAB) is correct working.

1815QCAD/CAMFeature RequestLowAdd Laser tool optionAssigned
0%
Task Description

Hi Andrew,

Creating G-code for cnc-laser, the laser-tool can not be correctly set at all.

Attached a laser tool proposal

Showing tasks 1 - 50 of 1864 Page 1 of 381 - 2 - 3 - 4 - 5 - Last >>

Available keyboard shortcuts

Tasklist

Task Details

Task Editing