Opening Files with umlauts under Linux

Do you have a question you want to ask an existing QCAD user about QCAD and what you can do with it? Do you want to know if a particular feature exists? This is the place to ask.

Moderator: andrew

rainer
Registered Member
Posts: 2
Joined: Wed Oct 05, 2016 5:51 am

Opening Files with umlauts under Linux

Postby rainer » Wed Oct 05, 2016 6:26 am

Hello, I am currently running the trial version of QCAD.

Looks good, but I had difficulties with importing AutoCAD .dwg files. Finally I found out that this is caused by the filename!

I am running my system without UTF-8. I use ISO-8859-15, because this simplifies life a lot (I use German language).

The file "Spindelhülse.dwg" caused an error when I tried to open/import it. I noticed that a different file "40-50.dwg" could be opened/imported. So I renamed the German Umlaut "ü" -> "ue" and it worked.

So from my point of view, QCAD has a problem with ISO-8859-15 ! e_geek

User avatar
andrew
Site Admin
Posts: 4906
Joined: Fri Mar 30, 2007 6:07 am

Re: Import of AutoCAD files

Postby andrew » Wed Oct 05, 2016 7:30 am

Thanks for your report.

Please indicate what operating system (Windows, macOS, Linux) you are using and what version thereof, so we can try to reproduce the problem here. Thanks.

rainer
Registered Member
Posts: 2
Joined: Wed Oct 05, 2016 5:51 am

Re: Import of AutoCAD files

Postby rainer » Wed Oct 05, 2016 9:36 am

Hello.

I use openSUSE 13.1 x64 - LINUX - here.

Desktop is KDE

I have disabled UTF8 in YaST.
~> locale
LANG=de_DE@euro
LC_CTYPE="de_DE@euro"
LC_NUMERIC="de_DE@euro"
LC_TIME="de_DE@euro"
LC_COLLATE="de_DE@euro"
LC_MONETARY="de_DE@euro"
LC_MESSAGES="de_DE@euro"
LC_PAPER="de_DE@euro"
LC_NAME="de_DE@euro"
LC_ADDRESS="de_DE@euro"
LC_TELEPHONE="de_DE@euro"
LC_MEASUREMENT="de_DE@euro"
LC_IDENTIFICATION="de_DE@euro"
LC_ALL=

User avatar
andrew
Site Admin
Posts: 4906
Joined: Fri Mar 30, 2007 6:07 am

Re: Opening Files with umlauts under Linux

Postby andrew » Thu Oct 06, 2016 8:11 am

I've changed the title of this topic to better reflect the problem.

I don't think there is an easy solution. I cannot get umlauts in file names to display properly in the Qt file dialogs or even on a command line. At this point, I would suggest to avoid using umlauts in file names under Linux systems.

User avatar
hungerburg
Premier Member
Posts: 160
Joined: Fri May 28, 2010 7:35 pm

Re: Opening Files with umlauts under Linux

Postby hungerburg » Mon Oct 31, 2016 12:02 am

Hello there,

No problem at all with diacritics &c on this system here with qcad 3.15.2, even on fat-formatted drives. "locale" output below, nationality or currency seems to matter not much; Unicode is what system installers for some years now default to, admins who disable stock features are to know the consequences. The world has more than some 200 different characters… (Ellipsis intended)

Code: Select all

$ locale
LANG=de_DE.UTF-8
LANGUAGE=de_DE:en_GB:en
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC=de_AT.UTF-8
LC_TIME=de_AT.UTF-8
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY=de_AT.UTF-8
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER=de_AT.UTF-8
LC_NAME=de_AT.UTF-8
LC_ADDRESS=de_AT.UTF-8
LC_TELEPHONE=de_AT.UTF-8
LC_MEASUREMENT=de_AT.UTF-8
LC_IDENTIFICATION=de_AT.UTF-8
LC_ALL=


Return to “Pre-sales Questions”

Who is online

Users browsing this forum: No registered users and 2 guests