autocad 2018 errors using commandline conversion?

Use this forum to ask questions about how to do things in QCAD.

Moderator: andrew

Forum rules
Always indicate Operating system, QCAD version
Attach Drawing files, Screenshots
Post one question per topic.
Post Reply
mikinturin
Registered Member
Posts: 1
Joined: Fri Mar 16, 2018 7:35 pm

autocad 2018 errors using commandline conversion?

Post by mikinturin » Fri Mar 16, 2018 7:43 pm

Hi, we got errors converting autocad 2018 dwg's to any format (see below)
on ubuntu linux, qcad trial 3.19.2
(we wanted to buy, but have to be sure the software can convert our files using command line tools..)


QCAD version 3.19.2
Debug: RDwgPlugin::init: trial
Debug: RDxfPlugin::init
Debug: RPolygonPlugin::init: trial
Debug: RProScriptsPlugin::init: trial
Debug:

You are using a trial version of QCAD Professional.

Debug: If you would like to use this software productively,
Debug: please purchase the full version for a small license fee from our
Debug: Online Shop at:
Debug: http://www.ribbonsoft.com/shop

Debug: Thank you for trying this add-on!


Debug: Your script will start in 15 seconds...
Debug: RTriangulationPlugin::init: trial
Debug: calling odInitialize
Warning: RDwgImporter::importFile: reading: OdError:
Debug: "RDwgServices::printErrorStackTrace: Invalid file version"
Warning: RDwgImporter::importFile: trying to recover...
Warning: RDwgImporter::importFile: recovering: OdError:
Debug: "RDwgServices::printErrorStackTrace: Invalid file version"
Warning: "Import for file /FOLDERXXX/FILEXXX.dwg failed"
Cannot import file: /FOLDERXXX/FILEXXX.dwg

User avatar
andrew
Site Admin
Posts: 5702
Joined: Fri Mar 30, 2007 6:07 am

Re: autocad 2018 errors using commandline conversion?

Post by andrew » Fri Mar 16, 2018 10:02 pm

There are two different sets of packages for Linux:
- the Qt 5 based packages for all modern Linux distributions (qcad-3.19.2-trial-linux-x86_32.run / qcad-3.19.2-trial-linux-x86_64.run)
- the Qt 4 based legacy packages for older Linux distributions (qcad-3.19.2-trial-linux-qt4-x86_32.run, qcad-3.19.2-trial-linux-qt4-x86_64.run)

The Qt 5 based packages are recommended for most modern Linux distributions and support DXF/DWG <= 2018 (DXF/DWG R32).

The Qt 4 based packages are recommended only for older Linux distributions if the Qt 5 based version does not work due to incompatible gcc libraries. These packages only support DXF/DWG <= 2013 (DXF/DWG R27).

Post Reply

Return to “QCAD 'How Do I' Questions”