[Solved] Cannot resolve two versions of QtWebKit

If you are having problems with QCAD version 3, post here. Please report bugs through our Bug Tracker instead.

Always attach your original DXF or DWG file and mentions your QCAD version and the platform you are on.

Moderator: andrew

Forum rules
Always indicate Operating system, QCAD version
Attach Drawing files, Screenshots
wdebruyn
Registered Member
Posts: 2
Joined: Tue Mar 04, 2014 7:13 pm

[Solved] Cannot resolve two versions of QtWebKit

Postby wdebruyn » Tue Mar 04, 2014 7:41 pm

Attempting to print a drawing but produces empty results

Could the following be causing the problem? See below

Ran QCAD with script debugging turn on.

./qcad -enable-script-debugger

Attempted to print again and got the following log entry:

objc[20345]: Class WebCoreMovieObserver is implemented in both /Applications/QCAD-Pro.app/Contents/Frameworks/QtWebKit.framework/Versions/4/QtWebKit and /System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/WebCore.framework/Versions/A/WebCore. One of the two will be used. Which one is undefined.

My path variable: /usr/local/bin:/Applications/Xcode.app/Contents/Developer/usr/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/local/git/bin:/usr/local/mysql/bin

Running OS X 10.9.2

QCAD Professional
Version: 3.4.6.0 (3.4.6)
Build Date: Feb 6 2014
Qt Version: 4.8.4
Compiler: gcc 4.2.1

XCoder 5.0.2 installed.
QT Creator 3.0.1 (based on Qt 5.2.1 (Clang 5.0 (Apple), 64 bit) Built Jan 31 2014 installed.

User avatar
andrew
Site Admin
Posts: 4685
Joined: Fri Mar 30, 2007 6:07 am

Re: Cannot resolve two versions of QtWebKit

Postby andrew » Wed Mar 05, 2014 9:33 am

Printing problems are usually related to usage issues (paper size not adjusted, drawing scale too big / small, drawing not on paper, lineweight is zero, ...).

Please refer to this brief printing how-to:
viewtopic.php?f=32&t=2800

Let me know if that does not solve your problem.

wdebruyn
Registered Member
Posts: 2
Joined: Tue Mar 04, 2014 7:13 pm

Re: Cannot resolve two versions of QtWebKit

Postby wdebruyn » Wed Mar 05, 2014 11:33 pm

Resolved. We have printed copies. Thanks.


Return to “QCAD 3 Troubleshooting and Problems”

Who is online

Users browsing this forum: No registered users and 1 guest