upgraded 3.17.1 fails to start with glibc errors.

Post your question about installing or upgrading QCAD.

Moderator: andrew

Post Reply
jamby
Active Member
Posts: 26
Joined: Fri Jun 24, 2016 2:41 pm

upgraded 3.17.1 fails to start with glibc errors.

Post by jamby » Tue Jun 20, 2017 12:16 am

Hi
Running Centos 6.9 on Dell Desktop 3.15.3 running fine upgraded to 3.17.1 and now when trying to start I get following errors..

./qcad
./qcad-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/qcad-3.17.1-pro-linux-x86_64/libqcadecmaapi.so)
./qcad-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/qcad-3.17.1-pro-linux-x86_64/libqcadentity.so)
./qcad-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/qcad-3.17.1-pro-linux-x86_64/libqcadcore.so)
./qcad-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/qcad-3.17.1-pro-linux-x86_64/libQt5Core.so.5)
./qcad-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/qcad-3.17.1-pro-linux-x86_64/libqcadgui.so)
./qcad-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/qcad-3.17.1-pro-linux-x86_64/libqcadoperations.so)
./qcad-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/qcad-3.17.1-pro-linux-x86_64/libqcadsnap.so)
./qcad-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/qcad-3.17.1-pro-linux-x86_64/libQt5PrintSupport.so.5)
./qcad-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/qcad-3.17.1-pro-linux-x86_64/libQt5Widgets.so.5)
./qcad-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/qcad-3.17.1-pro-linux-x86_64/libQt5Gui.so.5)
./qcad-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/qcad-3.17.1-pro-linux-x86_64/libQt5Script.so.5)
./qcad-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/qcad-3.17.1-pro-linux-x86_64/libQt5ScriptTools.so.5)
./qcad-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/qcad-3.17.1-pro-linux-x86_64/libQt5Network.so.5)
./qcad-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/qcad-3.17.1-pro-linux-x86_64/libQt5Xml.so.5)
./qcad-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/qcad-3.17.1-pro-linux-x86_64/libQt5Svg.so.5)
./qcad-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by ./libicui18n.so.56)
./qcad-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by ./libicuuc.so.56)
./qcad-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/qcad-3.17.1-pro-linux-x86_64/libspatialindexnavel.so)
./qcad-bin: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /opt/qcad-3.17.1-pro-linux-x86_64/libspatialindexnavel.so)
./qcad-bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/qcad-3.17.1-pro-linux-x86_64/libquazip.so)

QCAD has failed to start.

Please use the offscreen platform plugin for headless systems
(without a running X11 server):
./qcad -platform offscreen

In addition, you might have to override the default Qt style
to prevent the loading of a native desktop style (such as GTK):
./qcad -style plastique


Check on glibc shows
rpm -qa | grep glibc
glibc-common-2.12-1.209.el6_9.1.x86_64
glibc-2.12-1.209.el6_9.1.i686
glibc-headers-2.12-1.209.el6_9.1.x86_64
glibc-devel-2.12-1.209.el6_9.1.x86_64
glibc-2.12-1.209.el6_9.1.x86_64

Don't know were to go from here

Any Help Appreciated
Jim

User avatar
andrew
Site Admin
Posts: 5557
Joined: Fri Mar 30, 2007 6:07 am

Re: upgraded 3.17.1 fails to start with glibc errors.

Post by andrew » Tue Jun 20, 2017 7:32 am

Unfortunately, your OS is too old to run the latest QCAD packages using Qt 5 (GLIBC < 2.14).

I will send you a link via private message for packages of the latest QCAD version linked against Qt 4 instead.

jamby
Active Member
Posts: 26
Joined: Fri Jun 24, 2016 2:41 pm

Re: upgraded 3.17.1 fails to start with glibc errors.

Post by jamby » Tue Jun 20, 2017 2:42 pm

Got it

Thanks Andrew

Jim

jamby
Active Member
Posts: 26
Joined: Fri Jun 24, 2016 2:41 pm

Re: upgraded 3.17.1 fails to start with glibc errors.

Post by jamby » Sat Jul 08, 2017 5:10 pm

Andrew

Is it possible to get version qcad3.17.2 pro and qcadcam compiled against Qt 4. ?

Thanks
Jim

User avatar
andrew
Site Admin
Posts: 5557
Joined: Fri Mar 30, 2007 6:07 am

Re: upgraded 3.17.1 fails to start with glibc errors.

Post by andrew » Mon Jul 10, 2017 9:27 am

jamby wrote:Is it possible to get version qcad3.17.2 pro and qcadcam compiled against Qt 4. ?
Yes, with the exception of the 3D simulation view which requires Qt 5. I'll send you a link to snapshot through PM.

jamby
Active Member
Posts: 26
Joined: Fri Jun 24, 2016 2:41 pm

Re: upgraded 3.17.1 fails to start with glibc errors.

Post by jamby » Mon Jul 10, 2017 8:44 pm

Thanks Andrew

Jim

Post Reply

Return to “QCAD Installation and Upgrades”