Page 1 of 1

dxf files are not visible in AutoCAD

Posted: Thu Jan 20, 2011 1:57 pm
by bluequad
Having created a file in QCAD in dxf format, it will not open in AutoCAD. There is something there, because the crosshairs pick up a dashed line for each component of the drawing but becomes invisible once the cursor moves away.

I was lead to believe that QCAD files were interchangable with AutoCAD. Do I have to save the file in another format?

Posted: Thu Jan 20, 2011 2:05 pm
by andrew
You might have to change the color of your entities (or layers) from black to something else. QCAD displays black lines on a black background in white, Autocad does not.

black/white

Posted: Fri Mar 04, 2011 9:36 am
by hungerburg
So in QCAD a black line gets rendered white, if the background of the drawing surface is pure black (zero, not one, two...255). I prefer drawing on a silver board (192). Background colour is an "application" preference, not a "drawing" or document preference and is not saved in the DXF file.

One could say, the DXFormat is underspecified for omitting such a preference. Or is it just QCAD? I rather draw draw black lines than those candy coloured lines I see so often. Still, other people have to look at my drawings with their software, and autocad is wide spread. Is there another way to help them, than writing with a white pencil a hint into the area, like:

"Please use a light background to view this drawing correctly."

Regards

--
peter

Posted: Fri Mar 04, 2011 2:05 pm
by bluequad
Thanks for that Peter. Actually, Andrews reply worked because I changed the drawing colour to Red in preferences and it opened in Red in AutoCAD.

I suppose one can then change the colour to what you want thereafter.

Someone posted a reply to a similar question a little while ago and made a series of changes in AutoCAD, but I haven't tried this.

Keith

Re: black/white

Posted: Fri Mar 04, 2011 3:36 pm
by andrew
hungerburg wrote:One could say, the DXFormat is underspecified for omitting such a preference. Or is it just QCAD?


The background color of the drawing area is definitely a user preference, not a drawing / document setting in CAD. The vast majority of people draws on a black background. A few people prefer a white background (matches the print).

QCAD automatically adjusts the display color of black and white entities, so they are never invisible. Autocad and other CAD systems might not do that.

Posted: Mon Mar 14, 2011 5:55 pm
by faber
reading your comment looks like the major problem is the setting of the color of the layer; didn't you experience huge differences when opening the same file in autocad and qcad?
Unfortunately I am not currently able to have the same results...
I "have" to use only the same software (qcad) if I want to handle the dxf file without problem; if I try to open it using autocad (lite version) is a little disaster.