library browser shows not all directories

Use this forum to ask questions about how to do things in QCAD 2.1/2.2.

Moderator: andrew

Active Member
Posts: 38
Joined: Sat Feb 13, 2010 12:01 pm

library browser shows not all directories

Postby LeoP » Sat Jan 22, 2011 5:53 pm


Running Pro on Windows 2kPro.

I was trying to arrange my own blocks into a more comprehensible structure (a.k.a. Library). Up till now, I just copied the blocks from one drawing into another...
After all shuffeling was done I restarted Qcad to point it to the new structure (edit - program prefs - paths), only to find that the new structure is not listed in the library browser. Not even after a restart.
FWIW, the 'startup directory' in the program shortcut points to c:\program files\qcad\; the path in the qcad program preferences points to the correct location (d:\my documents\cad\cad libraries\). Removing the last backslash did nothing.
When I start Qcad by double-clicking one of 'my' blocks from the explorer, all of my blocks show up correctly...

Searching my hard drive, I found several Qcad related library dirs:
    c:\documents and settings\leo\.qcad\libraries\, which seems to contain a .png file for every block ever listed in the library browser
    c:\program files\qcad\library\, which contains the Qcad supplied libraries (.dat and .dxf files)
    d:\my documents\cad\cad libraries\, which contains my own blocks (.dxf)

The directory under ....\.qcad still holds a .png for no longer existing blocks.
This brings me to my question: What files need to go in what directory and where do I point the 'paths' entry in the program preferences in order to let it work as intended/expected?

Full Member
Posts: 71
Joined: Tue Apr 15, 2008 5:42 pm
Location: Near Munich

Postby Ferdi » Sat Jan 22, 2011 8:44 pm

Try the following:

o Stop QCad
o Rename the directory ..\.qcad to lets say ..\.qcad_bak
o Start QCad
o Use the Library Browser to view your library
- QCad will create a new and updated ..\.qcad
o If all works as desired you may delete the dir ..\.qcad_bak


Active Member
Posts: 38
Joined: Sat Feb 13, 2010 12:01 pm

Postby LeoP » Sun Jan 23, 2011 4:13 pm

It works, although I am not entirely shure why: I thought I already tried something along those lines earlier.
Probably forgot a comma or something silly like that...

Oh well, it should all be solved in a couple of weeks with v3.
That is, unless the date mentioned in is moved... :wink:


Return to “QCAD 2.1/2.2 'How Do I' Questions”

Who is online

Users browsing this forum: No registered users and 6 guests