"Lengthen"-Bug / wrong dim?

If you are having problems with QCAD 2.1/2.2, post here. Please report bugs here.

Moderator: andrew

Newbie Member
Posts: 3
Joined: Thu Feb 17, 2011 10:27 am

"Lengthen"-Bug / wrong dim?

Post by CADdy » Thu Feb 17, 2011 10:46 am

Hi there,

I yesterday did my first steps with Qcad Prof. Most of the functions are very intuitive. I love that.

But one problem occured, when I tried to shorten some parallels I had drawn.
I clicked on the "Lengthen"-function and put the value on -200.
The line itself had a length of 390 (0° - horizontal).

Then I clicked on the left end of the line, so it should be 190 afterwards,
but it did not look right, so I measured: 200.

The HELP showed me I did everything right, as far as I can see.

Another try with a value of -100 worked very well.

Then I shortened a line 200 long with a value of -110, result: length 110.


This problem occured on my MacBook Pro - OS X Tiger.
Afterwards I tested it on MacMini - OS X SnowLeopard, to see if only my notebook had this problem, but it was all the same on both OS.

I would appreciate any help with this issue and would be very glad for short term solutions so I can finish my drawings asap.

Maybe some other users here could test on their systems with different OS if they have the same problem?

Thanks in advance

User avatar
Posts: 434
Joined: Tue Mar 24, 2009 9:48 pm

Post by J-J » Thu Feb 17, 2011 7:25 pm

I had never thought of shortening a line this way, but nevertheless I had a go and indeed I got the same results. (2.2 pro on Win XP3). It works as long as the shortening is less than half of the length of the line. I'm not sure how Qcad interprets the calculation in that case, a look at the algebra beneath that tool would be interesting.
JJ Win7 pro-64

Newbie Member
Posts: 3
Joined: Thu Feb 17, 2011 10:27 am

Post by CADdy » Thu Feb 17, 2011 8:50 pm

I helped myself with some construction lines for now. :)
So this issue is not THAT much important for me anymore.

One should just keep in mind, that this tool is a little "twisty" at the moment.

Thank you very much for testing.


Return to “QCAD 2.1/2.2 Troubleshooting and Problems”