help Manual

If you are having problems with QCAD 2.1/2.2, post here. Please report bugs here.

Moderator: andrew

Newbie Member
Posts: 4
Joined: Fri Jul 25, 2008 7:54 am
Location: warwick UK

help Manual

Postby merryjohn » Fri Jul 25, 2008 8:00 am

I'm new to Qcad but not new to Cad in General
Qcad looks Good but on the second time of using selsecting Help either with F1 or via the menu closes Qcad down??
Running Ubuntu 7?

Registered Member
Posts: 2
Joined: Wed Aug 20, 2008 12:31 pm
Location: Durham, UK

Same Problem in Ubuntu Hardy Heron

Postby quickstep » Wed Aug 20, 2008 12:36 pm

When selecting 'Help -> Manual (F1)' QCAD crashes with a segmentation fault (started from command line). No additional error messages are provided.

I am running QCAD Version: [Professional] on Kubuntu 8.04 with KDE 4. Thanks for any suggestions.

User avatar
Site Admin
Posts: 5126
Joined: Fri Mar 30, 2007 6:07 am

Postby andrew » Wed Aug 20, 2008 2:43 pm

There seems to be a problem with the help browser on certain installations.

Please note that you can also browse the manual with any regular Internet browser such as Firefox or Konqueror. Simply open the file index.html in the subfolder "doc" of your QCad installation.

Registered Member
Posts: 2
Joined: Wed Aug 20, 2008 12:31 pm
Location: Durham, UK


Postby quickstep » Wed Aug 20, 2008 2:49 pm

Thanks andrew. That works of course and I was aware of it. It would just be handy to access it right out of QCad. I also followed the advice in FAQ 16. and deleted the entry in ~/.assistant. That did not help though. My old QCad community version I removed as well.

I guess I have to hope for a fix of that in the next QCad version or hope that it is not a problem in the next (K)Ubuntu version anymore.

Registered Member
Posts: 2
Joined: Fri Mar 12, 2010 8:46 pm

Postby Lupus » Wed Jun 23, 2010 1:06 pm

Sorry for raising a dead thread, but i had the same problem and solved it. I've searched for "qcad help segmentation fault" and this was a hit.

Qcad needs his application directory as the current working directory. Say your installation is under /opt/qcad you can't link /opt/qcad/qcad to /usr/bin/qcad to get it in your path and you can't start /opt/qcad/qcad when you want to use F1-help.

Solution: build a simple quick'n'dirty wrapper script
cd /opt/qcad
exec ./qcad $@

Registered Member
Posts: 1
Joined: Sun Aug 15, 2010 4:01 am

Problem solved

Postby carvar » Sun Aug 15, 2010 4:46 am

To fix the problem it is necessary to decompress the file "qcaddoc.adp.gz" that is in the directory /usr/share/doc/qcad/html. Then create a link from the qcad directory and name it doc


sudo gunzip /usr/share/doc/qcad/html/qcaddoc.adp.gz
sudo ln -s /usr/share/doc/qcad/html /usr/share/qcad/doc

I did that on Ubuntu 10.04 and it works.

Registered Member
Posts: 1
Joined: Mon Dec 20, 2010 12:16 pm

Postby jimfleig » Mon Dec 20, 2010 12:39 pm

My thanks to carvar's post on Sat Aug 14, 2010 10:46 pm. I ran the command lines in carvar's post in terminal and this worked for me also.

Return to “QCAD 2.1/2.2 Troubleshooting and Problems”

Who is online

Users browsing this forum: No registered users and 1 guest