"Tool options" dissapeared after I did something w

If you are having problems with QCAD 2.1/2.2, post here. Please report bugs here.

Moderator: andrew

Registered Member
Posts: 2
Joined: Tue Mar 03, 2009 9:27 am

"Tool options" dissapeared after I did something w

Postby Justine » Tue Mar 03, 2009 8:58 pm

Hi everyone, this is my first post here.

I'm running the latest version of QCad Professional (, on Debian Linux.

So, everything was working wonderfully (I'm very happy with the program), and then just the other day, I clicked to open the program, but as I was doing it I changed desktops (on a multiple desktop linux environment with the 3D cube).

The has never caused a problem with any of my other programs. I'll open a program, and then switch to another side of the desktop. Fine.

But, in this case, when I opened QCad the program opened as normal on the desktop side I switched to, but some of the toolbars got left behind on the desktop I switched from! (I should say that I have all the tools undocked -- I'm working on a multiple monitor system and keep the toolbars on their on screen).

So here I had toolbars on one desktop, workspace on another. (The toolbars apparently can't be dragged from desktop to desktop like a normal window can). I restarted the program. This time I had all the toolbars open up with the program, all on the same desktop as they should. Great! Except for now the "tool options" bar has gone missing, lost in this process perhaps, and nothing will bring it back. I tried unchecking and rechecking in the view menu -- nothing. I tried using a tool that needs tool options thinking maybe that would initialize it -- nothing. I even tried reinstalling the program -- nothing! That, I don't understand. I deleted the old program folder (that should be all that's required in Linux), downloaded the installer again (a .tar.gz file), installed again, but the tools all behave in exactly the same way as before. They're even in the same places (undocked) that I left them before reinstalling the program. I'm thinking their must be some other place these files are being referenced, but I don't see how that's possible given that the .tar.gz is extracted by my package manager into one folder.

Any suggestions? Is there perhaps a better way I can reinstall the QCad? Is their some way to wipe the old install that I'm missing?

Thank you,

User avatar
Site Admin
Posts: 4957
Joined: Fri Mar 30, 2007 6:07 am

Postby andrew » Thu Mar 05, 2009 8:15 am

You might want to reset QCAD to its default configuration. See:

Registered Member
Posts: 2
Joined: Tue Mar 03, 2009 9:27 am

Postby Justine » Thu Mar 05, 2009 7:20 pm

Unix / Linux / Mac OS X:
- Quit QCAD
- Delete the file
(where '~' is your home directory)

That was it! I actually JUST came from another forum (a Linux forum) where I received this suggestion as well. Thank you!

Return to “QCAD 2.1/2.2 Troubleshooting and Problems”

Who is online

Users browsing this forum: No registered users and 0 guests