Exploding lettering into polylines not working for ampersand

If you are having problems with QCAD 2.1/2.2, post here. Please report bugs here.

Moderator: andrew

Newbie Member
Posts: 6
Joined: Tue Jul 27, 2010 10:32 pm

Exploding lettering into polylines not working for ampersand

Postby wootty2000 » Sat Jul 31, 2010 3:59 pm


I've hit a bit of a problem.
I am trying to use QCad with a laser engraving machine. I do the designs in QCad and then import them in to the laser software.

The laser software takes a DXF file and works on all entities as if there are polylines. When I want to engrave letters, I need to have an outline of the letter, as the laser software will fill between the lines

I have tried using the Kochigothic font. It looks ok in QCad, but as soon as I import the DXF in to the laser software, I only get a set of single vectors showing the inside of the letters

I decided to explode the letters in QCad and recreate them as a set of polylines. This works for all the letters I have tried except the ampersand symbol - I have not tried any other symbols.
It seems to be that the lines do not joint up properly when they were exploded, so when I try to create a polyline from segments, I have to make numerious polylines that make up the ampersand symbol.
This however, does not work inside the laser software, as the software looks for completed and joined up polyline to fill between

I can manually pull the indivdual segments out and then line them back up with the other segment ends but would not have expected to have to do this.
I would have expected QCad to have exploded the ampersand symbol so that the segments would have joined up correctly, as it did for the other letters.


User avatar
Site Admin
Posts: 5128
Joined: Fri Mar 30, 2007 6:07 am

Postby andrew » Mon Aug 02, 2010 4:17 pm

It could be that the ampersand in the font you are using is not constructed precisely.

Note that QCAD can load and edit fonts:
- File open, File type: QCAD Font
- Edit block with name starting with "&"
- Safe font

Return to “QCAD 2.1/2.2 Troubleshooting and Problems”

Who is online

Users browsing this forum: No registered users and 0 guests