main Qcad window oversized

If you are having problems with QCAD version 3, post here. Please report bugs through our Bug Tracker instead.

Always attach your original DXF or DWG file and mentions your QCAD version and the platform you are on.

Moderator: andrew

Forum rules
Always indicate Operating system, QCAD version
Attach Drawing files, Screenshots
terpic
Newbie Member
Posts: 4
Joined: Mon Jan 28, 2013 6:20 pm

main Qcad window oversized

Postby terpic » Mon Jan 28, 2013 6:52 pm

qcad3 window.jpg
qcad3 window.jpg (306.48 KiB) Viewed 3161 times
This is strange, for no apparent reason the main Qcad 3 trial window has become oversized and the programme is unusable because all of the controls are off the screen. The window can't be minimised or closed other than with ctl-alt-del and it can't be moved. I'm running it on linux and can't find a config file to see if there's anything to alter such as default window size.

Any help would be much appreciated.

User avatar
andrew
Site Admin
Posts: 4782
Joined: Fri Mar 30, 2007 6:07 am

Re: main Qcad window oversized

Postby andrew » Mon Jan 28, 2013 7:00 pm

First, please try to reset the configuration:

- Quit QCAD
- Delete the file ~/.config/RibbonSoft/QCAD3.ini

Start QCAD again.

Please let me know if that does not solve it.

terpic
Newbie Member
Posts: 4
Joined: Mon Jan 28, 2013 6:20 pm

Re: main Qcad window oversized

Postby terpic » Mon Jan 28, 2013 7:07 pm

Hello Andrew

I'm afraid that didn't fix it, is there anything to alter in /.config/RibbonSoft/QCAD3conf ?

terpic
Newbie Member
Posts: 4
Joined: Mon Jan 28, 2013 6:20 pm

Re: main Qcad window oversized

Postby terpic » Mon Jan 28, 2013 7:29 pm

I have deleted then reinstalled Qcad 3 after deleting the Ribbonsoft directory in /.config, it has improved the problem as Qcad now opens in a fixed window on the desktop. There isn't a windows bar at the top of the screen and no means of getting one that I can see, so I can't move the Qcad window with the mouse, I can switch to full screen mode using the full screen mode in the window button and can close Qcad using quit in the file button.

terpic
Newbie Member
Posts: 4
Joined: Mon Jan 28, 2013 6:20 pm

Re: main Qcad window oversized

Postby terpic » Wed Jan 30, 2013 3:07 am

Hi

I think I've solved this one. For some reason the window settings somehow got messed up, the only thing I can think that may have caused it was trying to open a .dwg file which came up with an error saying Qcad couldn't open it, the problem started after that (I won't try to recreate it)

I messed around in the KDE module "window rules" and set the "window class (application)" setting to; kwin_rules_dialog kwin_rules_dialog, highlighted "dialog window" and in "appearances and fixes" I ticked window type and set this to force and panel (dock).

Not entirely sure why this fixed it but it seems to work ok now.


Return to “QCAD 3 Troubleshooting and Problems”

Who is online

Users browsing this forum: No registered users and 0 guests