QCAD Bugtracker

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category QCAD (main)
  • Assigned To
    Andrew
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version 3.26.1
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: QCAD Bugtracker
Opened by CVH - 12.03.2021
Last edited by Andrew - 15.03.2021

FS#2204 - Modify > Break out Manual: point order matters with open polyline

QCAD Professional
Win7 32bit wininstaller
Version: 3.25.2.13 (3.25.2.13)
Internet: QCAD.org
Build Date: Feb 12 2021
Revision: cad2d36
Qt Version: 5.13.2
Architecture: i386
Compiler: Unknown

Andrew,

Break out Manual (B2) on Arc and open Polyline results
seems to depend on the breakpoint picking order.

A segment is broken out when the picking order is in the entity orientation.
The intended behavior.

That differs when the picking order is opposite the entity orientation.
One would expect that the picking order matters when removing
a segment between the picked points.

Example file included

Noticed while merging code to PolyLineBreakSymbol.js
https://github.com/qcad/qcad/blob/master/scripts/Misc/MiscDraw/PolyLineBreakSymbol/PolyLineBreakSymbol.js Line 300-312 orders cut points on distance from start.
Otherwise, the results where inconsistent.

Regards,
CVH

Closed by  Andrew
15.03.2021 09:35
Reason for closing:  Fixed
CVH commented on 13.03.2021 09:40

Sorry, that should read:
One would NOT expect that the picking order matters when removing...

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing